Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

/vt/ is now archived.Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 13 KB, 300x272, 1520477061609.jpg [View same] [iqdb] [saucenao] [google] [report]
71174025 No.71174025 [Reply] [Original] [archived.moe] [rbt]

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

!!! GUIX 1.0.1 is released https://gnu.org/software/guix/blog/2019/gnu-guix-1.0.1-released/ !!!

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: Please spend at least a minute to check a web search engine with your question.

$ man %command%
$ info %command%
$ %command% -h/--help
$ help %builtin/keyword%

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux:
https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux
>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page
>What are some cool terminal commands?
http://www.commandlinefu.com/
http://cheat.sh/
>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/
http://overthewire.org/wargames/bandit/
>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html
>Which web browser performs best on GNU/Linux?
https://linuxreviews.org/firefox-vs-chromium/

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

/t/'s GNU/Linux Games: >>>/t/861783

Previous thread: >>71157004

>> No.71174039

systemd sucks

>> No.71174055
File: 102 KB, 1023x576, takemymoneyfuture.jpg [View same] [iqdb] [saucenao] [google] [report]
71174055

>>71174025

Looks like Intel are being gay again. AMD take my money.

>> No.71174074

>>71174039
you don't have to make posts like this for upvotes here

>> No.71174079

This is the most impressive shit I've seen today. https://distrowatch.com/table.php?distribution=gentoo
What do you think?

>> No.71174081

>>71174039
fpbp, take my updoot-I mean (You)

>> No.71174085

I’m getting into Linux system administration after having used Linux for several years. I don’t have experience in professional environment with Linux to do certain tasks as my personal needs haven’t called for it but while I’m learning, is there any advice as to what I should study? Book to read? Maybe some practice projects that I could expect to do in a job that I could get the hang of at home? I’m switching my career from HVAC/R to this. I’ve seen job postings from quite a few companies asking for knowledge to create software for development tools for their engineers. Is that a normal thing to do as a Linux system administrator? It sounds like they are trying to get a mixed bag of a sys admin and a programmer for cheap.

>> No.71174090
File: 76 KB, 535x523, 1558004951074.png [View same] [iqdb] [saucenao] [google] [report]
71174090

>>71174055
>tfw FX idiot
>tfw green across the board in spectre-meltdown-checker and the performance degrading vulnerabilities are all "not affected"

>> No.71174096

>>71174074
stop projecting, chucklefuck

>> No.71174114

>>71174090
Id juzt lige to inderject for a momend :DD wat you’re referrign to az LinuxXDDiz in factXDD GNU/LinuxXDD or az I’ve recendly tagen to gallign idXDD GNU pluz Linux :-DDDDDD

>> No.71174115

>>71174085
Install Gentoo

>> No.71174148

> The Tragedy of systemd
https://www.youtube.com/watch?v=o_AIw9bGogo

>> No.71174170

>>71174148
thank you Lennart, very cool

>> No.71174195

>>71174170
it's not lennart but it is a guy whose apologetic to systemd because he wants to bring it to some *bsd variant

>> No.71174224

>>71174195
>he wants to bring it to some *bsd variant
I unironically embrace the idea
freebsd is the only bsd that'd adopt such crap and when it does, people will finally see it for what it truly is and flee to other bsd's

>> No.71174241

>>71174195
He didn't really say that, just seemed rather disappointed with the bsd community having a regressive mindset about new ideas and modern implementations.

>> No.71174256

>>71174241
>new ideas and modern implementations
you mean bad ideas and shitty implementations

>> No.71174286

>>71174241
been a while since I watched the talk, but isn't the crux of it that he likes a lot of ideas that systemd brings to the table but thinks poettering/rhel fucked it up in typical poettering/rhel fashion and it's a shame because (in his opinion) *bsds need something similar to systemd and they're going to reject it after looking at systemd as an example?

>> No.71174296

>>71174256
*awards you reddit gold for your witty comment*

>> No.71174303

>>71174195
>wanting to bring systemd to BSDs
That guy cannot be fucking serious.

>> No.71174321

>>71174303
something similar to systemd*
might be more accurate to say that he thinks shell scripts are outdated and have issues that need to be resolved

>> No.71174323

>xscreensaver has a BSOD screen saver
Jesus I nearly had a heart attack

>> No.71174402

Oh good. Another unfriendly systemd thread.

>> No.71174406

>>71174286
Yes, but that wouldn't fit into those losers' headcanon.

>> No.71174413

some people are just obsessed with things they dislike

>> No.71174457
File: 2.84 MB, 786x583, 1559151795335.webm [View same] [iqdb] [saucenao] [google] [report]
71174457

>>71174323
You can actually do some cool shit with xscreensaver. Have a retro terminal:
/usr/lib/xscreensaver/apple2 -text -fast -program /bin/bash

>> No.71174560
File: 213 KB, 1624x840, 2019-05-29-135140_1624x840_scrot.png [View same] [iqdb] [saucenao] [google] [report]
71174560

>>71174457
interesting

>> No.71174653

Flying toasters were the zenith of screensaver technology.

>> No.71174753

hey lad I am posting from a TinyCore live USB and I gotta say its pretty comfy

>> No.71174993

ا>>71174753 subscribed

>> No.71175043

anarchy vs arcolinux vs archlabs
which will become the new antergos?

>> No.71175069

>>71174993
thank you I subscribe back

I have read several forum posts on how to change resolution but I still cannot succeed. Hope you are having a good day, friend

>> No.71175076

>>71175043
Can't people just use plain Arch?

>> No.71175080

>>71175043
haven't used any of these but probably manjaro

>> No.71175091

>>71175076
no, it's the battle of arch installers
>>71175080
manjaro uses its own repos

>> No.71175109

Why everyone wants to use Arch?

>> No.71175193

>>71175109
Cool screenfetch ascii

>> No.71175198

>>71175091
A second set of eyes checking packages for breaking xorg is just what Arch needs.

>> No.71175270 [DELETED] 
File: 189 KB, 1200x800, Daily-Starch-1200x800.jpg [View same] [iqdb] [saucenao] [google] [report]
71175270

Arch? more like starch

>> No.71175321

>>71175198
cept they cant even manage an ssl cert, 4 years in a row, going invalid, and their offical "fix" was to turn your clock backwards an entire week
Or the time they didnt sanitize their forums and god drop table'd....

>> No.71175333

>>71175270

>> No.71175418

>>71175333
please don't quotelink my shitty jokes ty

>> No.71175642

>>71174025
are there any programs or whatnot ot help me display the brightness/volume? I'm using Openbox and while I can change both volume and brightness a display showing the level would be nice, especially volume which I would just have to guess.

>> No.71175654
File: 19 KB, 229x177, qemu_kvm.png [View same] [iqdb] [saucenao] [google] [report]
71175654

Can anyone with a Ryzen system tell me if AMD-v, aka SVM, can be used for two different type 2 hypervisors at the same time? For example, at least one hardware accelerated Virtualbox machine running alongside at least one hardware accelerated QEMU/KVM.
I'm using KVM for GPU passthrough, and Virtualbox for everything else on my current system.

Intel cannot run both at the same time with VT-x, and it is a huge problem for me on Skylake-X. I have to load and unload the kernel modules each time I want to switch between the two, so cannot run them at the same time.

After being locked in to the Intel ecosystem for so many years, it occurred to me that there might be another option with the latest Ryzen CPUs though.
I'm going to be using the 16 core or the new Threadripper when they come out if that matters.

>> No.71175698

Please give me a reason to use fedora over anything from the debian family.

>> No.71175715
File: 127 KB, 800x800, HTB1H2ook4PI8KJjSspoq6x6MFXay.jpg [View same] [iqdb] [saucenao] [google] [report]
71175715

>>71174025
is that shit just ready to work Anon ? I don't see the plugged card in lspci/lsusb

>> No.71175916

>>71175654
You should just use KVM for everything. virt-manager gives you a very similar interface.

>> No.71175955

How do I manage (mainly delete) all the stuff I installed and no longer need?
There's isn't really a centralized list. I got all these weird dependencies and programs now I needed for other programs.
Most from apt install but some from snaps and some from manual installation and what not. I lost all overview.

>> No.71175995

>>71175955
LPT: If you install *anything* manually, make sure it ends up in ~/software (or whereever, as long it's in your home) and edit your PATH.

>> No.71176038

>>71175069
>>71174993
>>71174753
I take it back
it's uncomfy as heck
I feel like the scrubbiest noob because I can't make shit work
I wish I never tried this

>> No.71176158

>>71175698
>rpm is superior to deb
>optionally have an immutable OSTree system
>up-to-date software in the stable channel
>is actually stable
>a systemd setup that actually works
>doesn't rely on sysv scripts
>not patched to death
>adheres to standards
>very secure by default
With OSTree this >>71175955 cannot happen

>> No.71176186

>>71176038
unsubscribed.

>> No.71176244

>>71176186
cold

>> No.71176320

>>71175916
Not an answer to my question. They are different hypervisors with different strengths, weaknesses, and bugs. Suggesting that all jobs can be done on just one or the other means you probably aren't using them for much.

The question still stands.

>> No.71176387

>>71176158
I am a Fedora user.
>up-to-date software
relative to Ubuntu or Debian yes, but some packages are really outdated. Mesa and Chromium, for example.
>is actually stable
somewhat. Upgrading between major releases always breaks for me, so I'm forced to reinstall every 6 months.
>very secure by default
sort of. It has SELinux and packages are usually compiled with sane flags, but then again, it has a much greater attack surface because all of the Poetteringware.
>OSTree
last time I tried Silverblue it sucked. I believe it uses shit tonnes of virtualisation/FUSE crap just to achieve and immutable base system. You also have to restart after installing each package, and unless you use purely flatpaks, you lose some of the benefits of OSTree anyway.

>> No.71176488

>>71172732
do your grep and store result in variable

then do what you wrote in an simple if-then

if grep $VAR then ....

read about grep command in if construct
(if I remember well, a successfull grep should activate the first part of if-then, if grep "something" in $VAR is unsuccessful, then the else-part should be activated)

>> No.71176987

>>71176244
>>71176186
I took a screenshot but if I try to upload it to 4chin, firefox crashes because no file manager, I guess

I can get the GUI to launch but I cant make the install permanent on the USB stick, everything that I install just goes to shite once I reboot. I have read several threads that mostly say /git gud read the FAQ philosophy/

shouldve installed gentoo

>> No.71177057

So, is there any way to get more out of Gnome Boxes - on one hand, it's very slick and simple. On another it's too simple where i can't see any way to configure the virtual machines?

>> No.71177073

>>71177057
playing command line qemu is not hard brah.

Look at a few example, you'll memorize the most common options in no time.

>> No.71177076

How hard would it be to get Arch running for a guy that's just patient and willing to spend an afternoon searching how to use the terminal and stuff? Should I just go with Debian instead?

I tried Mint for a few weeks and it was OK but I had to install windows so now I want to just make a partition and run both W10 and some Linux distro.

>> No.71177127

>>71176387
>Mesa and Chromium
I am on Mesa 19.0.5, the latest release, from May 21 2019. Chromium is 73, so not terribly outdated either (74 is current stable). If you want to use Chromium, you might as well use Chrome or ungoogled-chromium, both of which provide more up-to-date versions for Fedora.
>Upgrading between major releases always breaks for me
Use Silverblue
>Poetteringware
Seems like RHEL doesn't care about that.
>shit tonnes of virtualisation/FUSE crap
Huh? It uses fs namespaces, bind mounts and maybe overlayfs, nothing terribly complicated. Not a single FUSE driver. Also, why would it need virtualisation?
>have to restart after installing each package
You can do multiple packages in one go, even multiple different operations. Having to reboot is kind of necessary to achieve the immutable thing, although they are working to have a live-remount system for purely additive changes to the system (just installing packages), which can be used right now but is considered unstable. For throwaway package installs, you're supposed to use Fedora Toolbox, which is essentially a transparent unprivileged container with dnf.
>unless you use purely flatpaks, you lose some of the benefits of OSTree anyway
?

>> No.71177134

>>71176987
speaking of...

emerge: (175 of 193) dev-qt/qtwebengine-5.12.3 Compile


Good thing I can leave this running overnight.

>> No.71178240
File: 7 KB, 184x84, 1491950499654.gif [View same] [iqdb] [saucenao] [google] [report]
71178240

>> No.71178393

>>71178240
MooGNU has a cute story: https://archive.org/details/M00GNU

>> No.71178487
File: 240 KB, 1364x768, Screenshot_20190530_021524.png [View same] [iqdb] [saucenao] [google] [report]
71178487

>Manjaro KDE
I have this strange X cpu usage when plugging/unplugging any usb INPUT device, be it a keyboard, mouse and even my x360 controller and KDE freezes for like 30 seconds. Googled a lot but couldn't find a fix/workaround that worked for me for this annoying bug. Uninstalled xmodmap because I thought it was the problem but it didnt help. Lets hope some anon has met with this bug and knows if it can be fixed!
pic related - unplugged my $5 usb mouse

a logout and logging in again fixes it but as kde freezes even the app launcher doesn't open

>> No.71178536

>>71174025
Lately, my xorg has been completely fucked up. Sometimes it just completely locks up and I can't do anything, not even switch to a different tty. Sometimes it happens right when I startx, sometimes when opening a program (has happened with both termimal and firefox in the past) or when shutting down.
The only thing I can do is a hard reset via power button.

It started about a month ago, and I've since reinstalled trying to fix it, but to no avail. Then, earlier today I finally realized I should look at dmesg, and foud out the cause is a kernel paging error caused by the amdgpu module.
This is on Arch Linux (btw), and no, pacman didn't fuck up my xorg.conf. That is still tthe way it should be.

Does anyone have any tips, or similar experiences?

>> No.71178544

Does CloverOS even work. The installation process stalls at Xorg

>> No.71178607

>>71177076
Anyone having trouble installing Arch is just too stupid to rmfollow instructions. When I first installed it I just followed the video of this one bald goateed youtuber, confirming every step on the wiki to see if anything had changed, and only running each command after I understood what it did.
I had no real experience with Linux, and I only knew the command line from messing around with Dosbox and a raspi.

The whole thing took one afternoon, and another one to get X running.

>> No.71178988

Why are people massive dick on irc ? like is there an actual reason ?

>> No.71179005

Redpill me on Void. Give me the
>Pros
>Cons
>Other interesting things

>> No.71179015

>>71179005
Install gentoo

>> No.71179036

>>71179005
Pros: No systems
Cons: No systemd, Luke Smith uses it

>> No.71179078

What is the QRD on Pantheon? Any glaring problems (actual problems, not the fact it's a macOS clone)? I know the UI will be considered haram here, but I'm interested in trying something new for a little bit. Also how much of a macOS clone is it? I've never used it.

>> No.71179111

>>71178988
No offense, but in my experience the answer is overwhelmingly because you did something to deserve it.
Unless you're talking about something like 4chans IRC, but if you're talking about technology IRC channels then it's like I said.

I have never once been treated poorly in any tech communities, or IRC channels, and I only ever see someone being mistreated when they're acting like they're entitled to something. They'll show up practically demanding that their problem be given attention, or if someone doesn't respond immediately they start dropping passive aggressive threats like
>hmmm, guess nobody knows maybe I'll use <alternative_software> instead
crap like that doesn't deserve to be shown any respect.

>> No.71179117

>>71178988
that probably depends on the channel

>>71179005
it's like arch if simplicity still meant something
runit boots fast and xbps installs packages fast
everything is on github so it's very easy to contribute to (if shit's broken/missing/outdated you get to fix it for others too)

cons: it's not gentoo and the most active contributor quit recently

>> No.71179143

>>71179117
>>71179111

If your question is not perfectly formed and totally on point they just dismiss me has a retard and totally ignore me generally

>> No.71179168

>>71179143
That what i like with discord and sending quick screenshot and video and people are generally nicer

>> No.71179175
File: 146 KB, 1280x720, 1555119083612.jpg [View same] [iqdb] [saucenao] [google] [report]
71179175

Ubuntu Mate 19.04

How to make screen split for 2x2 for fullscreen apps, so I can place fullscreen apps (like mpv) to each of them?

>> No.71179210

>>71179143
I'm still skeptical.
I mean, I've been using communities like that for over 20yrs and for the longest time I always would hear stories about these legendary "jerky communities" and I just believed them. But it was really always like some mythical beast to me because I'd never seen one.

Either you just keep getting unlucky and running into "that one troll" who hangs around certain channels (and has probably been banned multiple times) and you're mistaking that for the attitude of the whole community, or you're being unfair/disrespectful to the people who frequent the channel without realizing it.

>> No.71179318

>>71174025
Anyone have I guideline for what settings I should have checked on my Gentoo kernel config if I have an NVIDIA GPU. Last time I installed Gentoo, I encountered a ton of problems and I couldn't even reboot without holding the power button.

>> No.71179338

>>71179168
Discord is IRC for beta retards.
>>71179175
>>>/a/ weeb

>> No.71179395

>>71179168
>installing spyware

>> No.71179406

>>71179338
anime website

>> No.71179428

>>71179406
Containment boards.

>> No.71179438

>>71179428
You need to go back.

>> No.71179710

ok, I understand GNU's point, but I just don't like the aesthetic side of it all
Is there a free software distro that's not nerdy and is hip?
please no trisquel or parabola or guix

>> No.71179732

>>71179710
Check out https://distrowatch.com/table.php?distribution=gentoo

>> No.71179746

>>71179710
>aesthetic
In what way? It's not like there's some default GNU desktop

>> No.71179769

tried this lutris thing out its pretty cool, got the game i wanted to get running doing so painlessly.

>> No.71179828

hi frens,
can I remote into a windows PC usinga citrix client on void linux?
THANKS!

>> No.71179874

>>71179828
Neck yourself contrarian.

>> No.71179895

>>71179874
I need to in order to remote in for work!

>> No.71179986

>>71179769
Good to hear man!
I use it for all of my old cd installer games.

>> No.71180107

>>71179746
What I mean is, all I see is a kind of political activist distros, purity cult preaching distros, scientific research distros, which are either hostile or indifferent to artists, their vision, their sensibilities and their needs.
as an artistic type, I simply can't fucking stand all these approaches and people associated with them and consider them one-dimensional, no matter how true they may be in the end. I see that there is some truth, but I think their truth can't spread further because of their idiotic, narrow monastic mentality that fails to recognize subjective needs of people and is unaware of their psychological subtleties.

>> No.71180173

>>71179732
I said free, as in no proprietary software included

>> No.71180189

>>71180107
Sounds more like you've just been listening to too many memes from kiddies talking about this stuff and not getting a lot of information straight from the horses mouth.
Also you may be mistaking a simple lack of accommodation for your needs (due to most contributors being very tech oriented types) as confirmation of those memes and that they're somehow "hostile" to it when that's not the case.

>> No.71180210

>>71180107
>which are either hostile or indifferent to artists, their vision, their sensibilities and their needs.
Because, on average, software developers are not artists. They have no clue about artists' needs and they personally don't really care either. They, on average, care even less about art than most non-software-developers. Also you're not paying them to care and you certainly don't seem to be contributing code.
You're demanding shit to be done for you for free, which is not how it works.

>> No.71180220

>>71174224
>people will finally see it for what it truly is
and what it truly is?

>> No.71180270

>>71180210
>Also you're not paying them to care and you certainly don't seem to be contributing code.
I don't think your attitude reflects the overall developer attitude at all, and that sentence I quoted makes you sound a bit like the average edgy 4chan elitist.

Most developers would be happy to have more users, even artists and any other non-tech oriented types.
Just because they don't go out of their way to accommodate them doesn't mean they agree with your elitist attitude, it just might mean they don't think it's their job (e.g. following the Unix way might mean they want to build the bare bones CLI software only and then let someone who's more understanding of an artists needs build a GUI for it).
Often that just doesn't happen though, but it's not because nobody cares.

>> No.71180280

Will removing Win 7 from my old ass laptop and replacing it with a distro improve performance?

>> No.71180314

>>71180280
Install GuixSD

>> No.71180324

>>71180270
>Most developers would be happy to have more users, even artists and any other non-tech oriented types.
The developers who would be happy to have more users are those who make the distros. And they have their hands full actually maintaining the distro. The other group who would be happy to have more users are those who make desktop environments. But they have their hands full maintaining their desktop environment. Everyone else who wrote software did it because it solved a problem they personally had and wanted to be fixed. You're not getting anywhere demanding unpaid software developers rewrite all the stuff to fit your personal needs. You need to actually start contributing.

>> No.71180348

>>71180280
run xubuntu from a live usb and find out
linux doesn't magically make old computers faster so there might not be a huge difference unless the windows install is bloated with background programs

>> No.71180422

>>71180348
>usb
>performance
>linux
Dude

>> No.71180430

>>71180107
Also you should understand what it's like for us when someone like you shows up asking questions.

75% of the time because they don't understand the technical issues they're very impatient with US first.
So for example, if we try to explain "sorry we just don't have a way to do it like that, but you can do it this other way instead which is a bit more complicated"
usually what happens is that "artist" type gets angry, starts implying the software other have worked so hard on is garbage and that they're going to go use something else instead.

I'm sure you can imagine that after seeing that day in and day out for years on end many of those developers end up becoming a bit harsh to non-tech savvy users preemptively without realizing it. Because they see them ask a question they can't really give the expected answer to and they just see the conversation going down that bad path like it has so many times before.

>>71180324
>You're not getting anywhere demanding unpaid software developers rewrite all the stuff to fit your personal needs
I agree. But there's a big difference between demanding and requesting.

It's not that I'm saying you're wrong, it's just the way you're making the mentality of the developers seem is wrong.
They aren't sitting there thinking
>Not my problem bub, you write your own code if you want that feature. Oh you don't know how to program? lol too bad
It's really more like
>I just don't want to do it. Sure it would be great if someone else could help you, or write the code to accommodate users like you, but it's either just not my specialty or just not something I feel comfortable adding.

They're technically the same thing but the attitude behind it is totally different.

>> No.71180473

>>71180430
ok

>> No.71180683

Why can I never get UEFI boot to work properly. I set up the boot partition, made it FAT32, made sure I had the uefivarfs module, did grub-install with no errors, and grub-mkconfig with no errors. I double checked the fstab file and the disks are definitely listed correctly and the kernel definitely supports UEFI, when whenever I go to boot it just gives me the UEFI shell. I've never had any problems with a BIOS install but for some reason UEFI never seems to work.

>> No.71180767

>>71180683
Because UEFI is a massive clusterfuck with every hardware vendor doing their own thing. Think ACPI except worse.

>> No.71180871
File: 604 KB, 810x556, 1525911221970.png [View same] [iqdb] [saucenao] [google] [report]
71180871

Budgie or KDE

>> No.71180905

>>71180871
dwm

>> No.71180917

>>71180871
KDE is pretty comfy.

>> No.71180953

I was looking in /usr/bin and /usr/sbin and I found mpv in both of those folders. From my googling on the difference between /bin /sbin /usr/bin and /usr/sbin I thought they would only be in one. What's the deal?

>> No.71180974

>>71180953
your /usr/sbin is probably a symlink to /usr/bin

>> No.71181134
File: 1.41 MB, 3120x4160, IMG_20190530_120454.jpg [View same] [iqdb] [saucenao] [google] [report]
71181134

How do I change the text that says to input my passphrase on luks? Man I am wording this like a retard. I want to change what it says instead of "Please unlock disk sdax_crypt" to bamboozle fellow retards. Like maybe it will say "no bootable drive" to temporarily confuse others or seomeothing. Is this even possible?

>> No.71181258

>>71180953
Please use a search engine that respects your privacy.

>> No.71181272

is there a way to temporarily rebind keys?
For example I want the t key to register as F1 when I'm running a certain game.

>> No.71181282
File: 1.92 MB, 230x306, 1540285321524.gif [View same] [iqdb] [saucenao] [google] [report]
71181282

So I'm ready to dive back in to Linux. I'm used to Debian based distros like Linux Mint, so I was thinking about trying out Devuan, but I keep hearing good things about Manjaro. How hard would it be for me to relearn terminal commands for something Arch based considering what I do know about Debian? Also, is it really worth it?
Sorry for being dumb and shit.

>> No.71181293

>>71181134
Its open source faggot of course you can change it.

>> No.71181301

>>71181282
>Manjaro
Just install arch and be done with it

>> No.71181324

>>71181293
Your mother is open source retard

>> No.71181337

>>71181301
But what interests me about Manjaro is the preconfigured software and the power user stuff being behind a UI

>> No.71181338

>>71181301
>I use Arch (have no sex) btw

>> No.71181348

>>71181293
That's not very friendly of you anon.

>> No.71181877

Do any distros enable SSD trim by default?
I've distro jumped a ton of times on a relatively new SSD and it's at 47% health now according to HDSentinel.

>> No.71181966
File: 781 KB, 1920x1080, a-victorian-dark-fairytale-004_full.jpg [View same] [iqdb] [saucenao] [google] [report]
71181966

Are there any sites to find random desktop screenshots of linux desktops?
I used to sometimes see some on wallpaper scraping sites like wallbase.
There are often desktop threads here but it would be nice to have some larger database to scroll through.

>> No.71181987

>>71179828
Pls frens. This is a serious question. I do not like dual booting.

>> No.71181994

>>71181877

Trim is enabled by default on Ubuntu 18.04 & newer. If you're on a derivative, run the following -

> systemctl status fstrim.timer

Default is weekly, but you can modify it if you so choose. Read the following article -

> https://askubuntu.com/questions/1034169/is-trim-enabled-on-my-ubuntu-18-04-installation

>> No.71182036

>>71181994
Neat, any idea on Manjaro?

>> No.71182056

>>71181994
>>71182036
nm, first result in google. I'll give 'er a shot!

>> No.71182066

can someone clear this for me??

so basically, vim is like, editing and just coding right?
and emacs is for plugins and shit? i have been reading that i can fucking make a music player and note taking on emacs

>> No.71182099
File: 1.37 MB, 430x360, prideful magus can't figure out how to record Carnival Phatasm.gif [View same] [iqdb] [saucenao] [google] [report]
71182099

Alright you fucks, is kdenlive the only option for video editing on Linux? I want to start learning it, but would like any recommendations(or alternatives) before I go balls deep.

>> No.71182110
File: 662 KB, 1280x1022, smug Lancer.png [View same] [iqdb] [saucenao] [google] [report]
71182110

>>71179338

>> No.71182120

>>71179338
its easier to setup dude... why you so mad

>> No.71182126

>>71180220
corporate cock sleeve

>> No.71182160

>>71180422
sometimes when i try live usb when distrohopping... perfomance on usb is much faster rather than having it installed.

>> No.71182179

>>71182099
there's da vinci resolve which is commercial software. It's very good.

If you are going with kdenlive, my suggestion would be to make it as much like adobe in terms of interface, shortcuts, etc. This way you can easily somewhat transfer your skills to adobe.

>> No.71182573

I'm trying to get the number of unread messages in my inbox from a shell script. Is there a simple way to read email via IMAP from the command line?

>> No.71182644

>>71182099
kdenlive isn't the only option but it is the best free software option.

Shotcut isn't a bad alternative if you're using 1080p. They hard-coded icon sizes in their .xml files so it's unusable at 4K.

I spent some time comparing the alternatives some weeks ago and wrote this,
https://linuxreviews.org/Linux_Video_Editor_Comparison

>>71182179
>there's da vinci resolve which is commercial software. It's very good.
Too bad they didn't make it an AppImage because it simply doesn't work on Fedora 30. And I really tried to make it work.

>> No.71183216

>>71182573
I figured out how to do this with curl.

>> No.71183267

>>71182644
You didn't mention OpenShot.
But I think it falls in the "joke" category considering how often it fucking crashes.

>> No.71183688
File: 597 KB, 1721x1470, openshot.jpg [View same] [iqdb] [saucenao] [google] [report]
71183688

>>71183267
yeah I should probably look into what happens to be the problem with just _launching_ the thing on Fedora 30. Or try it in a VM. Not that video editing in a VM is ideal but ... I guess I could take a screenshot of it, at minimum.

Kind of hard to write a short review when you have to start with "and if you're using distribution X you have to do Y and Z to get it to _start_ and on distribution A you have to do B and C.

I'm not generally a fan of Appimages but in some cases it's preferable to have a compressed file with everything so it actually .. runs.

>> No.71183729

Is there a way to have drag and drop functionality from ranger?

I don't like it, but it's used by so much web pages/applications these days....

>> No.71183841

>>71183688
Also last time I checked you needed to add/edit some files somewhere in /usr just so you could have additional encoding profiles.
The whole thing is just a mess.

>> No.71183957

Went to install Ubuntu on my gf's piece of shit laptop computer using a flash drive. Didn't work. Was embarrassing. When it starts up, it says that it can't boot from the other installation. Will trying to install from a disk fix this? What did I do wrong? I'm literally crying and shaking.

>> No.71183991

>>71183957
>Didn't work. Was embarrassing.
Good, time to give her up to a chad who can install guix system on it.

>> No.71184108

Sorry to bother you, but i need help.
I'm trying to make my rpi zero w to work in Access point mode. I followed official guide to configuring stuff. My wifi network from RPI shows up, but i have issue connecting to it: device seems to be in process of connecting, but in the end it fails to do so.
First of all: what is possible location of this issue? Since i just need to connect only to raspberry via wifi it creates, i assume problem lies somewhere in stuff hostapd does, but i'm unsure of that.

Log that i got from running "sudo hostapd -d /etc/hostapd/hostapd.conf" https://pastebin.com/EFkKSFHz

There are a certain points of interest like
>nl80211: Register frame command failed (type=208): ret=-22 (Invalid argument)
>nl80211: Failed to subscribe for mgmt frames from SME driver - trying to run without it
>nl80211: Failed to enable Probe Request frame reporting in AP mode
>nl80211: set_key failed; err=-22 Invalid argument)
>Failed to clear default encryption keys (ifname=wlan0 keyidx=0)
However i'm not even sure this kind of messages is relevant to the this issue

Guide i followed: https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md

>> No.71184298

>>71183991
Cringe

>> No.71184458

>>71184298
>Cringe
You have to go back.

>> No.71184865

>>71182066
Both are text editors, but emacs is by design more extensible and as a result less lightweight.

If you want a lightweight terminal text editir that is controlled with things like Ctrl-x, Ctrl-m, Alt-t, etc., go for nano.
If you want a leightweight terminal text editor with a bit of a different approach to commands (multiple modes. a key does different things in different modes, for example: in insert mode, "d" writes a d, but in normal mode, "d" deletes an amount of text dependent on what key you press next (dd deletes the line, de deletes to the end of the word, d2j deletes 2 lines down, etc.)) choose vim.
If you want a lightweight graphical text editor and don't care about all those hotkey shenanigans, choose meousepad.
If you want a not so lightweight terminal text editor, that actually is an interpreter for a scripting language called elisp, choose emacs. Emacs may be shit by default, but because it is so customizable you can do a lot of shit with it. Want to make it control like vim? There's a plugin for that! Want to have an integrated web browser, music player, tetris, digital fingerbox...? There's probably a plugin for that. Only problem with emacs is that the defaults are so shit, so everyone changes their config so much that one person's emacs becomes unusable to any other emacs user.

>> No.71184888

>>71183957
You probably need to enable usb boot in the bios.

>> No.71184899

>>71184458
cringe and bluepilled

>> No.71184975

>>71184298
Cringe is the new cool
deal with it faggot

>> No.71185256

>>71174025
Is there any program I could use to automatically remove whitespace from every page of .pdf book? I don't really care if it will be converted to images.

>> No.71185334
File: 97 KB, 750x530, HTB1ZyPaSpXXXXXRXpXXq6xXFXXXn.jpg [View same] [iqdb] [saucenao] [google] [report]
71185334

>Bought that think
>plugged it into comp
>put 2 cards to check for validity
>no sign

recieving that within lspci
...
...
=== trie on-disk ===
tool version: 3
file size: 7620445 bytes
header size 80 bytes
strings 1919821 bytes
nodes 5700544 bytes
...
...


and the same within lsusb
=== trie on-disk ===
tool version: 3
file size: 7620445 bytes
header size 80 bytes
strings 1919821 bytes
nodes 5700544 bytes
no db file to read /run/udev/data/+usb:1-9.1.4:1.0: No such file or directory
...
...



Do I missed something in my kernel ?

>> No.71185562
File: 357 KB, 397x402, 1551745347605.png [View same] [iqdb] [saucenao] [google] [report]
71185562

Does using Gentoo actually make your computer run any faster? Does configuring a minimal kernel and compiling all your packages with optimization flags make a big difference? Woulnd't a binary distribution just keep a repository of binary files depending on your architecture?

>> No.71185605

>>71185562
if you like 3 seconds faster

>> No.71185608

>>71185562
idk, but it is actually more stable believe it or not.

>> No.71185652

>>71185562
The difference is minimal. Customization is the main selling point nowadays. It used to an wiki on par with that of Arch but the dumb admin deleted it without ever having made a backup.

Distributions usually keep binaries for each architecture. Wtf you on about?

>> No.71185655

>>71185562
it's actually massively slower
you spend hours compiling stuff and thinking about use flags and kernel options only to shave off like a few percents of execution time compared to a normal binary

>> No.71185664

>>71185334
Install gentoo.

>> No.71185692

>>71182099
Cinelerra.

>> No.71185716

>>71181966
Unironically /r/unixporn.

>> No.71185735

>>71181282
The commands are except for apt and pacman. Arch and friends are a meme.

>> No.71185759

>>71185562
portuga viado

>> No.71185854

>>71182644
What about >>71185692 ?

>> No.71185906

>>71185334
did you plug in the sata power connector?
you didn't plug it into a usb port, did you?

>> No.71185917

I just got an X61 tablet. Are there any Linux compatible equivalents to onenote that have drawing support? Everything I've found so far doesn't.

>> No.71186020
File: 175 KB, 1280x800, 2019-05-30-200851_1280x800_scrot.png [View same] [iqdb] [saucenao] [google] [report]
71186020

what is wrong with the font on my urxvt? im currently using terminator but the start up time takes around 1.5~ second and urxvt just instantly shows up

>> No.71186096

>>71186020
nevermind, i mistyped the font

>> No.71186106

>>71186020
Try putting something like
URxvt.font: -xos4-terminus-medium-r-normal--16-160-72-72-c-80-iso10646-1

In your .Xresources file if nothing else works.

>> No.71186479

>>71185854
Looks like it's worth a try. Looks like there's a bunch of versions and the -gg is the most updated one?
https://www.cinelerra-gg.org/about-cinelerra-gg/

ofc there's no FC30 package at
https://cinelerra-gg.org/download/pkgs/
but there is a src.rpm at https://cinelerra-gg.org/download/pkgs/src/
I'll see if I can build it.

It looks pretty neat in the screenshots, I'll give it that.

>> No.71186577

i am thinking of moving to arch since i have some free time now but im afraid it will fail me on critical times, should i just install manjaro?

my reason is i want to try the package manager, i've been using only ubuntu for a few years and wanted to change to something else, something better

>> No.71186623

>>71186577
>tfw unintended reddit spacing
sorry for that, my reason is also i dont want to reset my setup every few months or when new releases come out

>> No.71186655

My VPN daemon always needs to restart after I log in/startup to work properly.
I've set a auto restart option up with xfce autostart but it always asks for a password which is not ideal, I'd like everything to just be ready to go when I log in.
Is the best way to get it to not ask for a password to edit the sudoers file?
And if so what line would I add to the file?
I have been reading up on "man sudoers" but I'm fairly new to Linux and I feel in over my head at this point.

Tldr: how to restart a service without password prompt

>> No.71186760

>>71186577
Manjato is just Arch with stuff added on top. If Arch fails, Manjato fails too. But when Manjato fails, it could be Manjaro's fault, having no effect on Arch.
If can into command line, or are capable of following instructions, go for Arch

>> No.71186767
File: 85 KB, 1000x935, flat,1000x1000,075,f.jpg [View same] [iqdb] [saucenao] [google] [report]
71186767

When I apt-get upgrade a running service (say, apache or docker-ce, for example). Does apt apply the update automatically? Or do I have to restart my docker containers?

>> No.71186776

>>71186767
it stops the service, upgrades its files and starts the service again.

>> No.71186792

>>71186767
apt simply overwrites the files, you gotta restart all the running programs

>> No.71186798

>>71186020
>>71186096
What name did you end up using? I don't know why but I can never make urxvt look normal with a lot of fonts (including noto)
In other terminals like st it looks natural, but in urxvt there's always that huge spacing between characters (settiing a negative letter spacing doesn't look quite right either)

>> No.71186821

>>71186798
the ttf name was Hack-Regular and i typed it as HackRegular, i dont know why it showed up as noto sans there even in the terminator

>> No.71186830

>>71186577
Arch is not unstable, it's not going to just randomly break one day. Most of the talk about Arch breaking come from a few years back when Xorg configs were a mess and system updates would sometimes write over files the user added manually.

>> No.71186899

>>71186821
Oh, but fuck I hate urxvt's font rendering sometimes. I'd switch to st if it didn't have such dumb issues with the delete/home/end keys.

>> No.71186932

>>71186655
You need to be more clear anon.
How are you starting the service, through
systemd or through your DE?

Read up on visudo, I have this set
%wheel ALL=(ALL) NOPASSWD: /usr/bin/ip
so anyone on group wheel can use openvpn without sudo.

>> No.71187089

>>71186830
Arch actually broke for me recently in a very strange way. I couldn't update xorg-server because for some reason pacman that the files belonging to xorg-server belonged to anybody.
So I had to manually delete the files and reinstall xorg-server quite the classic meme way of pacman breaking xorg, but funny either way.

I think ultimately it wasn't pacman's fault, but rather linux-frmware's. One update broke the amdgpu module, which would freeze my X, so I had to hard reset a few times.

>> No.71187196

URxvt*letterSpace: -1

>> No.71187273

>>71187196
That's really no substitute for proper font rendering. The kerning is still off, and some characters even end up with pixels cut off or look squished

>> No.71187362

>>71187196
Not directly related, but are there any terminal emulators besides urxvt that have a daemon mode? I quite like the concept, especially since I'm prone to having several terminals open at a time, and I'm wondering if anything else does it.

>> No.71187372

>>71187362
Does Emacs count?

>> No.71187400

>>71187372
No, though you are technically correct I guess.

>> No.71187517

>>71187362
Use a terminal multiplexer lol
Screen or Tmux

>> No.71187623

>>71186479
I used it in 2009. Didn’t have any problems. Please repost back with updates.

>> No.71187629

>>71186479
>>71187623
of course the src.rpm doesn't build.

Trying the usual ./configure && make of cin_5.1.20190430-src.tgz
but ./configure gives configure: error: required for SHUTTLE_USB support.

I can probably figure that one out. But..

it already fails the basic "Can I recommend this?" test. it needs to be a whole lot better than kdenlive for me to recommend going through hoops to get the source compiled when kdenlive's in all the distributions repositories.

>> No.71187645

>>71186577
Guix is the supreme package manager.
Dnf and the open suse (zypper I think) one are on par with it.

>> No.71187647 [DELETED] 

>>71180189
not quite, I've been trying many distributions like AV Linux that are specifically made for multimedia, but they're incredibly makeshift and shoddy, even developers admit it. I wanted to support libre distros, but realized that they're even rawer, it's simply impossible to work with multimedia on them.

>> No.71187684

>>71187362
Terminator maybe.

>> No.71187685
File: 746 KB, 1834x2091, not-going-so-well.jpg [View same] [iqdb] [saucenao] [google] [report]
71187685

>>71187629
./configure only needed libusbx-devel to be happy.

but I didn't get much further..

>> No.71187687

>>71184865

thanks mate !

>> No.71187714

>>71180189
not quite, I've been trying many distributions like AV Linux that are specifically made for multimedia, but they're incredibly makeshift and shoddy, even developers admit it. I wanted to support libre distros, but realized that they're even rawer, it's simply impossible to work with multimedia on them.
So, I'm left with two choices again - either use Windows, or use MacOS. I don't like them one bit. And people will be saying, look, these artistic guys are all Macfags. Yep, when there's virtually no choice and Mac has at least half decent software interface design.

>> No.71187735

Should I be using podman over docker? Will I run into any limitations if I do? im really only going to be grabbing stuff off of dockerhub like plex/rutorrent for my nas

>> No.71187776

>>71187685
make clean and try again
isn’t there a flatpak or app image?
maybe use guix

>> No.71187793

>>71187685
It says right there that you have to add the thing to your path.

>> No.71187813

>>71187714
That's all true. The post you replied to wasn't about GNU/Linux not having poor support for stuff like that, it's just saying that the reasons for the poor support aren't due to any ideals, "minimalism", or elitism.
Writing good software for things like that is one of the hardest things to do. Probably even harder than making your own freaking window manager or something. And then considering that most programming nerds don't even know what you'd expect anyway even if they were capable of making such a program and it becomes even more challenging.

>> No.71187868

>>71187714
>>71187813
Also, take this with a grain of salt, but I've heard there's actually really decent software for things like AV on GNU/Linux, but it's all just kept proprietary and never sold or made public, like stuff used in industry or hollywood.
https://www.youtube.com/watch?v=x9ikzGQW0ys

>> No.71187892

>>71187776
>isn’t there a flatpak or app image?
no. But there are some packages for other distributions though it's mostly packages for older versions of distributions.
https://www.cinelerra-gg.org/downloads/

The documentation has a lot of references to something called "Arch". I believe that's what they are testing it against.

I personally don't like the idea of Appimages, I'd hate to have a system full of those things. But in cases where there's no choice but to compile... it would be a god-send. Like when Krita was released, I could just download the appimage, chmod a+x and run it easy as pie. Not so with Cinelerra.

>>71187793
libsndfile isn't in /usr/local so I have no idea why the script would even propose that.

>> No.71187963

>>71180871
xfce

>> No.71188082

I have a Dell PowerEdge T110 II running Debian 9 stable which has a Matrox MGA G200eW WPCM450 (rev 0a) (got that through lspci) video board, and I'm not sure if I have drivers installed for it. Everything is werking, but my max resolution is 1024*768 in xfce settings, while I know it's possible, and at maximum, 1280*720 as specified here http://i.dell.com/sites/content/shared-content/data-sheets/en/Documents/PowerEdge-T110-II-Technical-Guide.pdf.

Now, I have tried setting the resolution in /etc/X11/xorg.conf, but the file didn't exist. So I changed to terminal (not terminal emulator with CTRL+ALT+6), stopped lightdm service through systemctl, ran Xorg -configure, and copied the file /root/xorg.conf.new to /etc/X11/xorg.conf, then tried to start lightdm, and it changes to tty7 or whatever but nothing happens, and when I check the status for lightdm again in tty6 it results in this https://pastebin.com/f0MF2vm2

If I delete the file /etc/X11/xorg.conf and then try to start lightdm it starts the GUI normally so I can login. The generated file in Xorg -configure is https://pastebin.com/hkuWrmxr

Any help?

>> No.71188159

>>71187892
The link you posted has a pre compiled binary and fedora and Centos packages.

>> No.71188256

>>71180430
>Also you should understand what it's like for us when someone like you shows up asking questions.
I seldom ask anything, I usually assist developers where I can, especially with music software, and contribute to its development. The problem with linux distros as I see it is that they're created by programmers/IT guys, managed via programmers/IT guys, distributed to programmers/IT guys. If they were user-oriented companies they would have departments that would assure distro's accessibility and ease of use for the general public, good GUI implementation, out-of-the-box convenience, good driver support and availability of the newest and best software, i.e. all these "superficial" things that are very important according to me and most other non-tech people who don't care about tinkering with console. Distros are community projects, but their community can be a bit parochial.

>> No.71188261

>>71188159
the packages at https://cinelerra-gg.org/download/tars/ are just the same as the RPMs and there's no FC30 package there. Yes, there is packages for FC27-29. There's nothing current. Of course, I do have the option of running one of those in a VM just to try it.

>> No.71188289

>>71188082
I have a dell server next to me with a similar Matrox card. Xorg uses a driver called "MGA".
https://packages.debian.org/stretch/x11/xserver-xorg-video-mga
The server has a 1280x1024 monitor which it doesn't detect correctly, so I run script that adds this resolution and sets the monitor to it using xrandr. That being said 1280x1024 is a VESA resolution.

Also your generate xorg.conf is pure shit: it uses an ultra generic fbdev driver, it doesn't specify resolutions etc.

>> No.71188306

>>71188256
So you have contributed zero code implementing your suggested changes so far?

>> No.71188324

>>71188261
Just install them on 30 anyways.

>> No.71188414

>>71188261
>There's nothing current.
It's all the same.

>> No.71188438
File: 128 KB, 1280x800, 2019-05-30-233910_1280x800_scrot.png [View same] [iqdb] [saucenao] [google] [report]
71188438

whats the info thing on the top right called?

>> No.71188464

>>71188438
conky

>> No.71188492
File: 77 KB, 1366x741, fucking macfag.png [View same] [iqdb] [saucenao] [google] [report]
71188492

>>71188261
>literally just download and double click
>macfag can't do it and complain about devs
HOLY SHIT FUCK OFF YOU FUCKING RETARDED LITTLE SHIT I DIND'T WANT TO GET INTO THIS BUT YOU MADE ME GET OUT OF MY BAD AND FUCKING DO IT
HOPE YOU ARE HAPPY
YES I'M UPSET

>> No.71188504

>>71188289
The result of lshw -C display is
*-display
description: VGA compatible controller
product: MGA G200eW WPCM450
vendor: Matrox Electronics Systems Ltd.
physical id: 3
bus info: [email protected]:05:03.0
version: 0a
width: 32 bits
clock: 33MHz
capabilities: pm vga_controller bus_master cap_list rom
configuration: driver=mgag200 latency=0 maxlatency=32 mingnt=16
resources: irq:19 memory:c0000000-c07fffff memory:c1000000-c1003fff memory:c0800000-c0ffffff memory:c0000-dffff

So I think the driver is correctly installed.

>The server has a 1280x1024 monitor which it doesn't detect correctly, so I run script that adds this resolution and sets the monitor to it using xrandr.
May I have a look in your script?

I imagined, but I don't really know anything at all about Linux, so I don't have a clue about how a xorg.conf file should look like. Maybe this shit from 2011 can help me out? https://answers.launchpad.net/ubuntu/+source/xserver-xorg-video-mga/+question/141544

>> No.71188551

>>71188464
thanks anon

>> No.71188654

>>71188492
complains*
bed*

>> No.71188673
File: 3.56 MB, 150x175, 1546324752123.gif [View same] [iqdb] [saucenao] [google] [report]
71188673

>>71182179
>>71182644
>>71185692
Thanks faggots, I'll go look into all of them. I think a tutorial video of just seeing someone working on it should be fine for now.

>> No.71188695

>>71187868
wasn't Debian's project leader in the 90s a guy from Pixar

>> No.71188712

>>71188306
Code? I don't know how to write code. I did testing, GUI elements, general advice etc.

>> No.71188714
File: 145 KB, 1280x720, Mobile_Suit_Gundam_Unicorn_Ep5_The_Black_Unicorn_[720p,BluRay,x264,DTS]_-_THORA_0001_00:15:16_[2018_12_05_15].jpg [View same] [iqdb] [saucenao] [google] [report]
71188714

Running Ubuntu these last two months has been a pleasure compared to running debian Sid for two years. Don't fall for the testing/Sid memes, debian is only good stable and stable shouldn't be used on anything that isn't server or shitty *books.

>> No.71188776

>>71188714
>Don't fall for the testing/Sid memes, debian is only good stable
Correct.
>stable shouldn't be used on anything that isn't server or shitty *books.
Wrong. Dumb anime fag.

>> No.71188863

>>71188776
>Correct.
this is what fags who never used sid/testing for more than 5 minutes actually believe.

>> No.71188872

>>71188776
Have fun using ancient packages on the desktop then. I can still compile them, sure, but even some of the libs are ancient.

>> No.71188913
File: 90 KB, 1000x699, 14.jpg [View same] [iqdb] [saucenao] [google] [report]
71188913

I copied my private key id_rsa to id_rsa.bak
When I open them with Thunar's "view file" I'm asked for unlock, and I can see fingerprint and sha256 are the same.
But when I sha256 from CLI, the output differs... how possible ??

>> No.71188925

>>71188872
>Have fun using ancient packages on the desktop then.
I'm.
>I can still compile them, sure, but even some of the libs are ancient.
https://wiki.debian.org/DontBreakDebian

Stop being a consumerist fag that obsesses over every new shiny little shit.

>> No.71188955

>>71188925
>new mesa updates don't matter
>new kernel images don't matter
>new hardware doesn't matter

>> No.71188964

Give me a shell script question. I love these puzzles.

>> No.71188976

>>71188955
>Stop being a consumerist fag that obsesses over every new shiny little shit.
They don't.

>> No.71188991

>>71188964
will u b my gf?

>> No.71189035
File: 128 KB, 1079x1080, 15546353859830.jpg [View same] [iqdb] [saucenao] [google] [report]
71189035

>>71188991
Can you handle small surprises?

>> No.71189079
File: 655 KB, 640x800, (female).webm [View same] [iqdb] [saucenao] [google] [report]
71189079

>>71189035
i love them

>> No.71189099
File: 1.87 MB, 750x750, 1559123963539.gif [View same] [iqdb] [saucenao] [google] [report]
71189099

Why is there no dating platform for the free software community?

>> No.71189124

>>71189099

idk, maybe you can make an open-source dating program. (Its going to be 90% dudes tho)

>> No.71189143

>>71189099
Don't question. Why don't you make one? Remember to make it federated.
>>71189124
It's 2019, we have trannies now.

>> No.71189183

>>71189143

True, but.... Well damn... you got me there buddy. I will still date girls tho.. trannies... maybe. If shit goes to worse

>> No.71189198

>>71189183
trans girls often have higher standards by the way

>> No.71189209

>>71189198

I'm amusing you are referring to M-2-F

>> No.71189255

>>71182126
and linux is not a corporate cock sleeve, of course.
How many corporations were involved in FreeBSD? 2 (two).
How many corporations are involved in Linux? Dozens.

>> No.71189269
File: 105 KB, 640x640, bailey jay married.jpg [View same] [iqdb] [saucenao] [google] [report]
71189269

>>71189209
>>71189198
She does JOI now too.

>> No.71189283

>>71189143
> Remember to make it federated.
And here is the big problem. Look at all the "federated" platforms. How do they look like in reality? Yrs, it's just like Twitter; people connect to the most crowded server.

We have to solve this problem first, before going further.

>> No.71189308

>>71189099
Because FSF are all volcels.

>> No.71189322

>>71189283
This is not true. There are many small and very active communities. I follow one or two people from the main mastodon instance and there is plenty of content on my timeline.

>> No.71189339

>>71189308
Stallman has date two chicks at once at one time.

>> No.71189359

>>71189143
>>71189124
>tfw the free software community hacked open source boys to solve the girl problem

>> No.71189391
File: 65 KB, 480x411, 1516135391738.jpg [View same] [iqdb] [saucenao] [google] [report]
71189391

>>71189359
Based

>> No.71189654

How do I get nouvea to work properly on debian? Everytime I install debian the resolution is shit and there is no sound from HDMI. The only way to fix it has been to install the proprietary NVIDIA drivers.

>> No.71189706

>>71189654
If the problem is debian specific you can try getting a newer kernel and nouveau xorg drivers from backports.
If it exists for other distros, then that's it. nvidia gives 0 shit about nouveau and provides zero support to its development.

>> No.71189734

Is it possible systemd could be causing my computer to completely freeze?

Also what's the best systemd-free distro?

How is GuixSD? Can I install the real nvidia drivers on there?

>> No.71189738

>>71189734
probably not
gentoo
no

>> No.71189757
File: 6 KB, 299x169, nvidia-fuck-you.jpg [View same] [iqdb] [saucenao] [google] [report]
71189757

>>71189654
>>71189706

>> No.71189769

>>71189734
>How is GuixSD? Can I install the real nvidia drivers on there?
yes. they arent on the repos tho

>> No.71189794

>>71189706
pretty sure it worked out of the box on void, manjaro, mint, ubuntu etc.

>> No.71189893
File: 157 KB, 713x1000, 01.jpg [View same] [iqdb] [saucenao] [google] [report]
71189893

>>71188913
Also when I cat them in encrypted form content is different. But when I open them with openssl, content is the same

>> No.71189921
File: 257 KB, 1200x798, 1517833235061.jpg [View same] [iqdb] [saucenao] [google] [report]
71189921

>xterm does't work on hurd because of missing devpts implementation
>vte terminals do (did)
>cannot isntall new vte terminal because no new libvte
>cannot build new libvte because libglade-dev is not installable
>cannot install libglade-dev because libglade-2-6 is not installable
>cannot install libglade-2-6 because it fucking depends on libwebkitgtk2
>no webkitgtk2 ever for hurd, so no working X terminals

>> No.71189953

>>71175043
I used Arcolinux and it was very good.

>> No.71189954

>>71189893
You sound dumb. Explain better.

>> No.71189976

>>71188261
Did it work o or not fag?

>> No.71190025

is uBlock still usable in the newest chromium?

>> No.71190161

>>71190025
I'm on GNU Icecat myself.

>> No.71190171

>>71187813
>Writing good software for things like that is one of the hardest things to do.
there's plenty of such software and plenty of good ideas, it simply doesn't have nice-looking polished interfaces and resembles skeletons of software, not full-fledged programs.

>> No.71190191

>>71190161
I'm on seamonkey :)

>> No.71190197
File: 115 KB, 568x743, gentoo.png [View same] [iqdb] [saucenao] [google] [report]
71190197

What's the best distro to install Gentoo from? Gentoo LiveDVD is kinda outdated (last update was in 2016). I want to use localmodconfig and start from there, so kernel is not so bloated. I wonder if systemd distro would cause a problem when doing that. So, what would you recommend, or maybe the official LiveDVD is still fine?

>> No.71190205

Reporting from Debian Stable + Xfce.
Everything is still very /comfy/.
Over.

>> No.71190226

>>71190191
good post
>>71190197
Just use their lvedvd autist. It's not hard to make a livedvd, if they didn't release a new one is because there is no need for it.

>> No.71190228

>>71190197
>What's the best distro to install Gentoo from?
Crux

>> No.71190240

>>71190197
Use the minimal cd,

>> No.71190242

new to linux just installed Linux from scratch
any tips

>> No.71190251

>>71190025
grabbed 76.0.3809.0 from the build servers

ubO works just fine.

>>71190242
gentoo
e
n
t
o
o

>> No.71190281

>>71190242
install the guix package manager

>> No.71190285

>>71190240
I kinda want to have a graphical environment, so I can read the wiki comfortably, copy links and shitpost.

>>71190226
>Just use their lvedvd autist. It's not hard to make a livedvd, if they didn't release a new one is because there is no need for it.
You're meanie.

>> No.71190307

>>71190281
>package manager
I am my package manager

>> No.71190320

>>71190251
>ubO works just fine.
so, who said that new chromium dropped uBlock support?

>> No.71190346
File: 1.67 MB, 202x360, gay british chads.webm [View same] [iqdb] [saucenao] [google] [report]
71190346

>>71190285
You can install a graphical system on a live minimal but there is no problem in using the old iso.
>You're meanie.
Sorry. Have a rare webm.

>> No.71190369

>>71190346
Alright, I'll use LiveDVD. Thank you, anon.

>> No.71190428

>>71190320
its a proposition.

They will make their own adblocker (lawsuits inc.) but fuck up APIs that ublock will use -- is what I assume from the news. Corporate users will be excluded from the change.

Since it looks like the change is kinda an option there is a possibility that only consumer grade chrome will be kek'd, chromium and derivs might not be. We will see.

>> No.71190436
File: 1.70 MB, 4608x2304, IMG_20190530_204040.jpg [View same] [iqdb] [saucenao] [google] [report]
71190436

So I tried installing cdm as my display manager and when I try to log in as a regular user it throws an error saying something like in pic related. However when I try to login as an admin it works just fine. What do anons?

>> No.71190477

>>71190369
Oh, one more thing. It will be easier to download the new stages and not use the ones that come with the iso.

>> No.71190542

>>71185906
>did you plug in the sata power connector?
I'm so dumb I haven't even had an eye there :D
Thank you glad.

>> No.71190591

Is there any way to make mupdf fit documents to the window's height by default? I'm tired of pressing H every single time.
Using -r works, but it's monitor-dependent and requires trial-and-error to find the sweet spot.

>> No.71190707

>>71190591
Kinda autism, but reading my own post gave me the idea of adding this part to my script.
mupdf "$1" & disown
sleep 0.1
xdotool getactivewindow key H

Let me know if you have any better ideas.

>> No.71190733
File: 317 KB, 1536x2048, c02252e1323d0daaffb114fe35792bb0a4ef6269.jpg [View same] [iqdb] [saucenao] [google] [report]
71190733

>>71174025
>really old laptop, ubuntu vivid (I guess), lubuntu splash screen, kubuntu background image.. oh god
>/root partition almost full, 30 GB (wtf? yes, have a /home partition too)
>between disc-upgrades, use gparted to maximize size /root partition
>use help.ubuntu.com/community/EOLUpgrades to upgrade from 15.04 -> 15.10 -> 16.04 LTS to 18.04 LTS
>all good
>(this updates lxde to lxqt)
>upgrade from 18.04 LTS to 19.04
>s-some errors
>more than 4 hours all this
How can I know if "ubuntu" or "lubuntu" is installed?
then, How can I keep the default "ubuntu/lubuntu distro" applications and uninstall the rest?

>> No.71190773

didn't know that TrueOS was swallowed by ixsystems

>> No.71190801

>>71190733
"ubuntu" is the "ubuntu-desktop" metapackage. lubuntu is the "lubuntu-desktop".

run tasksel to see which one is installed. if you deselect one the packages pulled in just by that should be easy to remove using apt autoremove

>> No.71190885

Why --pid search doesn't work?
$ pgrep -u $USER mupdf
8466
$ xdotool search --pid 8466
$ xdotool search --class mupdf
125829231

>> No.71190947

>>71189757
who's that?

>> No.71190963

>>71190025
Stop using ublock. Use ublock origin instead.
Stop using chromium. Use IceCat instead.

>> No.71190987

>>71190947
Linus Tech Tips

>> No.71190997

>>71190963
>Stop using ublock. Use ublock origin instead.
there's ublock that's not ublock origin? didn't know. I only use origin

>> No.71191008

>>71190242
Everybody can install linux from scratch. All you need to do is executing a simple command which tells your package manager to install linux. Even grandma can do it.

>> No.71191016

new to linux just installed Crux
any tips

>> No.71191068

>>71191016
>any tips
yes, stop posting the same garbage in every thread.

>> No.71191078

>>71191016
You won't believe if you don't see it yourself: https://distrowatch.com/table.php?distribution=gentoo

>> No.71191088

>>71191078
botnet tracking link, don't click

>> No.71191093

new to linux just installed OpenBSD
any tips

>> No.71191125

>>71191093
install netbsd

>> No.71191371

>>71190801
thanks bro <3

>> No.71191450

Is it possible to send vim commands from the terminal? I'm writing a quick script to set up a fresh install with all my configs, and I want to know if this script can run ":PluginInstall" for a new vim installation

>> No.71191781
File: 223 KB, 1000x707, 13.jpg [View same] [iqdb] [saucenao] [google] [report]
71191781

>>71189954
I have 2 private keys : rsa_1 and rsa_2.
Now "cat rsa_1" and "cat rsa_2" give different outputs
But "openssl rsa -in rsa_1" and "openssl rsa -in rsa_2" give the same output
So basically it is the same private key but encrypted differently ? How can it be possible (both are AES 128 CBC) ?

>> No.71191794 [DELETED] 

#!/bin/bash
clearcache=true
ls ~/ | while read line; do
clearcache=false
echo $clearcache
done
echo $clearcache

...
false
false
false
true



#!/bin/bash
clearcache=true
for file in *; do
clearcache=false
echo $clearcache
done
echo $clearcache
...
false
false
false
false

why the abnormal behavior in the first version?

>> No.71191812

#!/bin/bash
clearcache=true
ls ~/ | while read line; do
clearcache=false
echo $clearcache
done
echo $clearcache

...
false
false
false
true

#!/bin/bash
clearcache=true
for file in *; do
clearcache=false
echo $clearcache
done
echo $clearcache

...
false
false
false
false

why the abnormal behavior in the first version?

>> No.71192164

>>71179078
It's gnome 3 but good.

>> No.71192231

anyone got gwent running on wine?
furthest I've gone was the loading screen, and it seems no one has added it to lutris.

>> No.71192323

>>71191781
Your key is used to encrypt the actual encryption key. That’s why you can have many keys for a single thing.
If it was not like this and you used the same key for different things, guessing it with plain text attacks or some kind of comparison would be much easier.

>> No.71192416
File: 137 KB, 1000x707, 12.jpg [View same] [iqdb] [saucenao] [google] [report]
71192416

>>71192323
>Your key is used to encrypt the actual encryption key.
I don't understand.
As far as I remember, I just copied rsa_1 from ssh folder to keepass and renamed it rsa_2.
>That’s why you can have many keys for a single thing
So, how do I create these variations ? Personally I always generate new keys with ssh-keygen

>> No.71192517

hey, i'm fairly new to linux and was wondering if it was possible to turn off anti-aliasing across the system in XFCE, if that makes any sense? i disabled font anti-aliasing in the appearance tab yet it's not entirely what i was looking for yet

>> No.71192665

>>71192416
By key I meant password.

>> No.71192692

>>71192416
I really like cryptography but I’m super tired and depressed sorry

>> No.71192711

>>71192517
Install gentoo

>> No.71192777

>>71192711
thanks, will do!

>> No.71192837

>>71191450
man vim
$ vim -c 'exit'
$ vim +'exit'
>>71191812
Stop using ls in scripts.
Quote your variables.
Always read with -r.

>> No.71192883

-> >>71192874

>> No.71193323

Guys i cant dualboot my windows and arch together. Grub wont install :( halp pls.

>> No.71193952

>>71193323
Delete Archlinux partition, check that windows boots properly. Retry archlinux install.

Trial and error.

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action