Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

If you can see this message, the SSL certificate expiration has been fixed.
Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 274 KB, 962x908, compile-kernel.jpg [View same] [iqdb] [saucenao] [google] [report]
71135482 No.71135482 [Reply] [Original] [archived.moe] [rbt]

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

!!! GUIX 1.0.1 is released https://gnu.org/software/guix/blog/2019/gnu-guix-1.0.1-released/ !!!

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: Please spend at least a minute to check a web search engine with your question.

$ man %command%
$ info %command%
$ %command% -h/--help
$ help %builtin/keyword%

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux:
https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux
>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page
>What are some cool terminal commands?
http://www.commandlinefu.com/
http://cheat.sh/
>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/
http://overthewire.org/wargames/bandit/
>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html
>Which web browser performs best on GNU/Linux?
https://linuxreviews.org/firefox-vs-chromium/

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

/t/'s GNU/Linux Games: >>>/t/861783

Previous thread: >>71104852

>> No.71135592

Despite Antergos being discontinued, is there any reason it can't be installed for the forseeable future using the last iso? six months from now it'll still install, then you can just update everything and it would be exactly the same. maybe I'm not understanding the point of "iso refreshes" for rolling distros

>> No.71135946

>>71135592
Antergos was just Arch Linux with some packages on top. The last update to Antergos is a meta package which removes those and turns it into plain Arch Linux. And you can always just uninstall the Antergos-specific package if that last update (or all updates) becomes unavailable 2 years from now. I see no reason why that installer can't be used to install Arch.

>> No.71136030

Does the old radeon driver still get performance upgrades/fixes or is AMD only focusing on the amdgpu/amdgpu-pro driver?

>> No.71136540

sup /g/entoomen

looking to move away from arch to something else rolling release/bleeding edge. I don't mind systemd, have to use it at work anyway.
what would you guys recommend?

>> No.71136637

How do I make the clock on my computer make a *ding* sound every hour?

>> No.71136852

>>71136637
User-level systemd timer with OnCalendar=hourly, the corresponding oneshot service could be something like ffplay -nodisp ~/.local/share/ding.wav.

>> No.71136953 [DELETED] 

Does Red Hat plan to add support for encrypted partitions to their upgrade tool? I'm thinking of installing the free version.

>> No.71137067

Also, is it correct that the free version of RHEL is free for its entire lifespan or is there a 30 day trial limit? According to distrowatch's recent review, they say it's 30 days but it might not be the free version.

>> No.71137080

>>71137067
>distrowatch's
Stopped reading there.

>> No.71137103

>>71136953
Deleted this because fuck it I'll do fresh installs.

>>71137080
Since you read that far into the post, what is the answer to the question?

>> No.71137297

>>71135592
>maybe I'm not understanding the point of "iso refreshes" for rolling distros
support for newer hardware is a major point, especially disk and network drivers which may be necessary for installation

>> No.71137348

>>71137103
Don't know. Don't think ibm will be knocking down your door if it were just a 30 day trial regardless.

>> No.71137502

I had to do some work on binary files (save files for a game) yesterday.
The situation with hex editing on GNU/Linux is major fucked. Bless fucking crashed. Ghex was shit.
hexedit (the terminal thing) sucked ass (but mostly worked)
diff'ing is annoying and shit af. vbindiff has another ass interface.

>> No.71137579

new to linux just installed arch. so firefox is super slow so im building chrome from the aur. how can i remove firefox and other files?

>> No.71137605

>>71136852
lol never thought I would need this.

>> No.71137624

>>71137579
pacman -Rsc firefox
if you also want to get rid of your profiles;
rm ~/.mozilla -rf

>> No.71137643

>>71137579
I have to ask, did you install any graphics drivers?

>> No.71137693

>yay -Syu
>5.1.5-1 is out
>spend 30 minutes compiling it
>5.1.5-2 is out
ffff

>> No.71137719

>>71137643
no i should probbaly look into that before assuming the problem is firefox.

>> No.71137734

Pop! OS vs Fedora Gnome Wayland
Tried both Fedora seems more bleeding edge and Wayland is the future which works better with every month.
This is for laptops only mind you.
What is your take?

>> No.71137754

>>71137734
I'm using Ubuntu 18.04 with Wayland, and the session dies/crashes repeatedly sending me back to GDM.
It's getting there, I remember earlier Wayland versions were even worse.
I also tried 19.04 briefly and it was good. 19.10 should be perfect.

>> No.71137756

>>71137734
Arch, Debian or Gentoo

>> No.71137787

>>71137579
>new to linux just installed arch.
Every damn time.

>> No.71137791

what's the best portage gui? I already know how to completely use portage but I miss using graphical package managers

>> No.71137792

>>71137754
I didn't have any problems like that with Fedora, they put more work into Wayland since it's their flagship. You should give it a go. Right now I'm testing Pop but I will probably go back to Fedora.

>> No.71137798

>>71137643
okay im installing intel graphics video package. another thing is two touch scrolling on touchpad makes it where hte mouse delays occasional when trying to move horizontally. do you know how disable this in the libinput?

>> No.71137847

>>71136852
I've been trying to figure out how to implement this for 2 hours now, all the links I'm finding say to do different things. Mind helping out? I got hourlyding.timer and hourlyding.service.

timer is
[Unit]
Description=Hourly ding timer

[Timer]
OnCalendar=hourly
Persistent=true

[Install]
WantedBy=timers.target

service is
[Unit]
Description=Prints the date every minute

[Service]
ExecStart=ffplay -nodisp /usr/share/sounds/freedesktop/stereo/service-login.oga

>> No.71137856

Ubuntu, openSUSE, Manjaro or you aew autistic

>> No.71137857

>>71137847
woops, desription on service is supposed to be: ding every hour

>> No.71137867

>>71137856
how ironic

>> No.71137868

>>71137756
What's that supposed to mean? The question was very simple.

>> No.71137968

Is there some simple command line program which would allow me to convert pdf file into text?
something like
cat poop.pdf

>> No.71138008

>>71137968
pdftotext

>> No.71138013

>>71137968
pandoc

>> No.71138025

>>71137968
pdftotext (part of poppler)

>> No.71138051

>>71138008
>>71138013
>>71138025
thanks, turns out pdftotext is already present on my distro and it works great

>> No.71138148

I'd like to make a script to auto concante using ffmpeg,videos that were recorded that day. But due to not having this script i have a sizable backlog of videos that need to be merged.
They all share the following filename format
%ID_%Y-%m-%d_%H:%M:%S_%3N where id is a generated name.
How can i have a fire and forget it script that will find the videos based on id and then date, and then create a concat file and have ffmpeg concatenate the list?
I've got the ffmpeg down, but struggling on how to do an entire folder at once

>> No.71138167

>>71137798
okay i figured this out i linked the xf86 synaptics conf file because i was actually able to disable vertical and horizontal two finger scrolling using that so the mouse dont stick anymore. no longer using libinput one.

>> No.71138192

>Users may receive an error citing circular dependencies due to gpm and ncurses. If this is the case, add -gpm to sys-libs/ncurses and update the @world set once more.
>add -gpm to sys-libs/ncurses
what does this mean? add a file -gpm to the folder?

>> No.71138201

>>71138192
install gentoo

>> No.71138293

>>71138192
disable it by adding -gpm to your global flags in your make.conf

>> No.71138315

>>71138201
too late
>>71138293
thank you

>> No.71138353

when i build a pkg i put directory in /usr/local/bin then it put the binary in /usr/bin for me.

where does normally store directorys for working binary files? if you build a package from say arch linux aur how do i update that package or find out if its up to date in future?

>> No.71138372

Noob question.

I have bagina.txt and .benis.txt, rm *.txt will only delete bagina.txt. How to include the hidden benis.txt?

>> No.71138382

>>71138315
I forgot to mention, I don't usually make small changes like that global but I'm pretty sure I will never use gpm and I'm sure you won't either unless you're always using a tty

>> No.71138385

>>71138372
>crouching bagina, hidden benis

>> No.71138463

>>71138382
yeah if it solves my issue and I'm never using it anyway I don't see why not. only time I use tty is when changing/borking my DE/WM. I'm still very new to linux, let alone gentoo, but learning a lot atm. thanks for the help

>> No.71138467
File: 50 KB, 524x700, 1537714068460_0.jpg [View same] [iqdb] [saucenao] [google] [report]
71138467

>>71138372
RM {.,}*.txt

>> No.71138494

>>71138467
It's "rm" actually, sorry for phoneposting

>> No.71138495

>>71138372
if you need to delete everything in a directory, it's usually a better idea to just delete the directory (and recreate it id necessary)
be careful not to force rm to delete '.' or '..'

>> No.71138570

>>71138495
That's why i'm asking.
>>71138467
Is this safe, also when using -rf?

>> No.71138604

>>71138570
considering "ls -a {.,}*" (gnu ls) doesn't list the . or .. entries, it's probably file

>> No.71138627

Are copy/paste file transfers more reliable than on windows? Like doing multiple TB in thunar from one drive to another.

>> No.71138742

>>71138570
It is. Moreover ".*.txt" doesn't match "."

>> No.71138749

>>71138627
rsync baby. learn it, love it.

>> No.71138751

>>71138627
i don't think thunar does anything special but rsync automatically resumes where it left off if it gets interrupted and you run the command again
https://linux.die.net/man/1/rsync

>> No.71138771

>>71138604
>>71138742
Thanks!

>> No.71138800

>>71138749
>>71138751

I use it, I'm just curious. Also rsync still takes foreba when I sync the 10TB I use with my various backups.

>> No.71138802

>>71138627
>>71138749
>>71138751
this, definately use rsync for huge transfers
or at least use rsync if you use another method, but it gets interrupted
thing about rsync is that it syncs plain folders, doesn't require anything special about them or the transfer, so you can 'resume' a broken copy with rsync, even if you didn't use rsync in the first place

>> No.71138812
File: 12 KB, 837x348, Screenshot_2019-05-27_20-56-53.png [View same] [iqdb] [saucenao] [google] [report]
71138812

Trying to change the trackpoint and touchpad settings on my X230, which of these files am I meant to edit?
I'm noob as fuck when it comes to linux, never really had to make changes to settings that didn't involve a GUI menu.

>> No.71138822

>>71138802
-- oh, it's also good to get the hang of it for it's more unique uses, like updating a backup, or doing network transfers

>> No.71138827
File: 122 KB, 1280x720, [HorribleSubs] Senryuu Shoujo - 08 [720p]_00:04:35_02.jpg [View same] [iqdb] [saucenao] [google] [report]
71138827

>>71138627
Not in thunar, ouch.
Run rsync inside screen.

>> No.71138830

How much data can a variable hold?
Is something like x="$(curl http://site.domain/file.ext)" reliable or should i use a temp file?

>> No.71138882
File: 277 KB, 593x745, Kd8yxNZ.jpg [View same] [iqdb] [saucenao] [google] [report]
71138882

yes | pv > /dev/null

post em

4.25GiB/s on my laptop with anime playing PM me for stats when not playing anime.

>> No.71138928

>>71138882
% dd if=/dev/zero of=/dev/null status=progress
13303889920 bytes (13 GB, 12 GiB) copied, 10 s, 1.3 GB/s^C

i have an emerge -j2 running in the background

>> No.71138942

>>71138882
3.09GiB/s
compiling something atm

>> No.71138943

>>71138882
$ yes | pv > /dev/null
^C77GiB 0:00:10 [ 281MiB/s] [ <=> ]
$ busybox yes | pv > /dev/null
^C.5MiB 0:00:10 [4.14MiB/s] [ <=> ]

>> No.71138997

Quick, someone compile this https://github.com/dspinellis/unix-history-repo/blob/4c37048d6dd7b8f65481c8c86ef8cede2e782bb3/usr/src/cmd/yes.c and do >>71138882 it's the 1979 original unix yes

>> No.71139012
File: 15 KB, 480x270, painthuff.jpg [View same] [iqdb] [saucenao] [google] [report]
71139012

>>71138928
>emerge -j2
>using dd with 512 byte blocks

jesus christ

>> No.71139052

>>71138997
https://github.com/dspinellis/unix-history-repo/blob/Research-PDP7-Snapshot-Development/LICENSE

>> No.71139084

>>71138997
114MiB/s versus gnu yes on my machine atm's 3.11GiB/s

>> No.71139107

>>71138997
> gcc -o yes yes.c 2>/dev/null
> ./yes | pv > /dev/null
^C48MiB 0:00:06 [ 124MiB/s] [ <=> ]
> yes | pv > /dev/null
^C.5GiB 0:00:07 [3.22GiB/s] [ <=> ]

>> No.71139235

>>71138812
hey i had this issue i posted up here >>71138167

remove the libinput one and use the 70 synaptics conf. make sure its linked to original file in /etc/X11/xorg.conf.d then edit it using https://wiki.archlinux.org/index.php/Touchpad_Synaptics all the options here.

>> No.71139257
File: 609 KB, 962x908, 1558937198848.jpg [View same] [iqdb] [saucenao] [google] [report]
71139257

>>71135482
Fixed that for you.

>> No.71139276

>>71139257
would unironically use that terminal but it crashes constantly for me

>> No.71139338

is btrfs raid56 safe yet?
friend wants to make a nas sometime in the not too far off future, and i'm not really sure what the best option is atm
zfs? inflexible, can't just add a new disk
btrfs? raid56 has been questionable
btrfs over mdadm? can this handle bitrot?
bcachefs? not mainlined yet, is this stable/usable?

>> No.71139574

>>71136540
unironically install gentoo

>> No.71139703

I've got a spreadsheet in Libre Office Calc to keep track of my TV shows. Is there any way to have it automatically sort by column B first, then column A? So far I've been doing it manually every time before I save it.

>> No.71139741

>>71139235
Thanks anon, but how do I check if the files are linked?

>> No.71139846

>>71139338
No.
Use ext4(alot of small files) or xfs(alot of large files)
btrfs is a persistent ALPHA status software. The devs have publicly stated that they dont know how things work and why things didnt work in their own code

>> No.71139861
File: 378 KB, 500x333, Mentok the mind reader.gif [View same] [iqdb] [saucenao] [google] [report]
71139861

---> INSTALL GUIX <---
I PLANT A COMMAND TO INSTALL IT IN YOUR MIND

>> No.71139869

>>71139846
xfs looks nice, but can it be shrunk?
why are there so many nice filesystems for linux that all have one thing which ruins them?

>> No.71139880

>>71139846
>The devs have publicly stated that they dont know how things work and why things didnt work in their own code
there are better options like ZFS.

>> No.71139913

>>71139338
>add a new disk
I don't think you understand how it works, there are no disks.

>> No.71139919

>>71139869
No it cannot.Read the xfs docs

>>71139880
zfr is solaris meme bullshit

>> No.71139946

>>71139913
>I don't think you understand how it works, there are no disks.
exactly, i can't say, make a 4 disk raidz1 and add a disk to make it a 5 disk raidz1, since you can't add disks to vdevs, only vdevs to pools, so afaik, the minimum upgrade to a 4 disk raidz1 is to add another 3 disk raidz1 vdev

>> No.71139985

>>71139919
>zfr is solaris meme bullshit
wow, zfs = destroed.
great attitude, you'll have a great understanding of computing with it.
And by the way, it's not a solaris project for more than a decade.

>> No.71139995

>>71139741
well it should show up as a different color in your terminal then just a plain text file.

you can link it like

# ln -s /usr/share/X11/xorg.conf.d/70-synaptics.conf /etc/X11/xorg.conf.d/70-synaptics.conf
[/code

>> No.71140007

>>71139985
>not a solaris project
When what niggas created it then faggot?
Dont mean shit if 90% of the code base is solaris garbage
Fucking retard
There is no reason to use zfs, even in enterprise applications, ext4/xfs cover eveything you need

>> No.71140012

>>71139703
pandas

>> No.71140033

>>71139107
>>71139084
Thanks

>> No.71140065

>>71140007
take that dick out of your mouth and repeat what you tried to say.

>> No.71140073
File: 103 KB, 376x341, 1545158320523.png [View same] [iqdb] [saucenao] [google] [report]
71140073

>>71139257
Amber! Now that was a terminal color!

>> No.71140122

Eben Moglen more like EBIN Moglen

>> No.71140133
File: 38 KB, 499x338, 1557975342130.png [View same] [iqdb] [saucenao] [google] [report]
71140133

>>71140065

>> No.71140149

>>71140133
better hide behind your anime pics

>> No.71140217

>>71140073
Terminals went pretty much downhill compared to the possibilities back in the day. https://www.youtube.com/watch?v=jOYqXlsgo78

>> No.71140309
File: 2.47 MB, 200x200, 1517646189482.gif [View same] [iqdb] [saucenao] [google] [report]
71140309

>>71140217
>that ghosting

>> No.71140409

>reading forums from 8 years ago where people are optimistically talking about btrfs no longer being a testing fs

>> No.71140589

Can anyone help me out with Wine? I'm running Linux Mint x64 19.1 Tessa.
I'm on staging and today upgraded from 4.8 to 4.9, and some of my games broke. I have found instructions on uninstalling to downgrade wine, but i am unable to locate a wine staging 4.8 install to i can use.

please help? i think i saw source on wine's github but i know nothing of building from source.

>> No.71140739
File: 265 KB, 711x1024, Wildebeest.jpg [View same] [iqdb] [saucenao] [google] [report]
71140739

INSTALL PARABOLA

>> No.71140750

lads my 7 year old macbook pro has been crashing regularly to the point of being unusable and sometimes not booting up at all.

I installed Manjaro on my old XP Machine running a Phenom II and 4 jiggerbytes of ram.

It runs smooth and I wish I made the jump to Linux earlier, gonna mess around in Manjaro and hopefully after I get the jist ill switch to Arch.

Anyway my issues is that whilst I had my macbook I had most my data on a external HDD 2TB formatted in HSF+ for Mac. Now I would like to read and ideally write and edit files that I have on that HDD. I removed the password protection bullshit it had, so now it shows when I connect it to Manjaro but it wont open when is shows in the file manager.

Any help chads?

>> No.71140887

so, after 10 years can you tell whether systemd is ok and convenient or bad, harmful etc?

>> No.71140922
File: 1.77 MB, 4608x2592, 20190527_103942_024.jpg [View same] [iqdb] [saucenao] [google] [report]
71140922

Anyone know what this is?

>> No.71140964

>>71135482
Trying to get the linux native version of Tribes 2 running, but it uses a very old glibc - 2.1. The wine version runs ok for a few minutes but constantly crashes with exception errors. Great game, but I can't play it very long without it shitting the bed. I suppose I could run a really old VM of a contemporary linux version?

>> No.71141341

>>71140964
I patched it with the vendor and TribesNext patches, in that order, from here - https://www.myabandonware.com/game/tribes-2-bhu

Then applied this fix for a ruby issue with Wine - https://www.tribesnext.com/forum/index.php/topic,2095.0.html

Hasn't crashed yet! Having an all day LAN party atm

>> No.71141602

>>71140887
It really doesn't matter. All arguments against systemd could be used against Linux itself as well. Use what your distro provides. If you don't like it, there's nothing preventing you from using a distro without systemd.

>> No.71141651

>>71141602
can't wait to get rid of linux and with it all the linux foundation shilling and their payed meme devs adding shit into the kernel

>> No.71142141

>>71140887
>10 years?
Since 2015, the majority of Linux distributions have adopted systemd,[9] and it is considered a de facto standard.[1]

>> No.71142160

>>71142141
Linux doesn't distribute systemd.

>> No.71142218

>>71142160
"Linux distributions" interjections now, too?

>> No.71142243

>>71142160
>Linux (/ˈlJnəks/ (About this soundlisten) LIN-əks)[9][10] is a family of open source Unix-like operating systems based on the Linux kernel,[11] an operating system kernel first released on September 17, 1991 by Linus Torvalds.[12][13][14]
https://en.m.wikipedia.org/wiki/Linux

>> No.71142276

>>71142243
> operating systems based on the Linux kernel
Yoi mean, like Android?

>> No.71142287

>>71142276
Exactly. No GNUshit needed :^)

>> No.71142305

>>71142287
But Anon, Android isn't distributed with systemd.

>> No.71142334

>>71142243
>m.

>> No.71142403

>>71142287
your answer should have been: no, no androidshit needed; it's just linux.
git gud

>> No.71142445

I have ubuntu right now and want to switch to arch, what's the best way to do this without losing most of my files? My Ubuntu is on a 500GB ssd, partitions are 16gb swap, 300mb etf , and the rest(~450GB) is /, the root. I didnt separate root and home, they are on the same partition. Anyway what's the best way to make the transition to arch while saving my files? The ssd is technically an internal one, but I use a sata+power to USB adapter, if that makes any difference.

>> No.71142482

>>71142287
>>>/flt/

>> No.71142553

cp
dd
rsync

I want to backup my entire home directory onto an external hdd before making some possibly system-erasing experiments
which of these programs do I use?

>> No.71142574
File: 4 KB, 403x104, 1549391717640.png [View same] [iqdb] [saucenao] [google] [report]
71142574

Why are my fonts like this?

>> No.71142602

now that antergos is dead, what is the alternative when looking for arch with an installer? Does Anarchy/Arcolinux use the arch repos like antergos did?

>> No.71142678

I just setup debian netinst with i3 and disk encryption. How do I put my laptop to sleep and ask my user password on wake, without having anything easily accessible to a malicious person with physical access?

>> No.71143144

I've installed Guix and set up the same graphics packages and mpv config as on my previous distro, but I've been noticing some video tearing. Is this an Intel firmware issue, a Wayland issue, or something else?

>> No.71143195

>>71142602
Just use arch.
Takes 5 minutes to read

>> No.71143377

>>71142602
try Archlabs

>> No.71143677

Yo wtf, does Ubuntu's Startup Disk creator only work with Ubuntu distros? Trying to figure out what's the best way to create a bootable Manjaro USB flash drive.

>> No.71143766
File: 213 KB, 1125x1252, 1556819573976.jpg [View same] [iqdb] [saucenao] [google] [report]
71143766

Something is going on with my Manjaro install, it just stopped automounting my USB drives, Thunar doesn't show them at all.
They show up in gparted when connected and they can be mounted manually.
Tried reinstalling gvfs and udisks2 but to no avail. (also tried reinstalling their old versions)
Downgrading the kernel didn't work also.

Any tips?

>> No.71143902

>>71143677
You're already using some flavor of linux. Just use dd.

>> No.71143918

>>71143677
> Download the live iso from Manjaro
> dd it to the USB
>???
>PRoFiT!1!

>> No.71144047

>>71142678
Which DE?

>> No.71144058

>>71144047
None

>> No.71144123

Ok, I feel like an idiot for not being able to figure this out. I want to manipulate images on a script with imagemagick. The command in particular looks like this:

convert image.png -fill black -draw "rectangle 263,465 265,467" image.png

I want to use a variable instead of the string between quotes, but no matter what I try I get an error. What the fuck is going on?

>> No.71144182

>>71144123
thing="rectangle 263,465 265,467"
convert image.png -fill black -draw $thing image.png

>> No.71144196

>>71142678
>>71144058
Get a standalone screen locker program (e.g i3lock) and set up a service to run it on suspend.

https://wiki.archlinux.org/index.php/Power_management#Sleep_hooks is a good reference if you're using systemd.

>> No.71144242

>>71144182
Already tried that many times...

convert: non-conforming drawing primitive definition `rectangle' @ error/draw.c/DrawImage/3190.
convert: unable to open image `263,465': No such file or directory @ error/blob.c/OpenBlob/2712.
convert: unable to open image `263,465': No such file or directory @ error/blob.c/OpenBlob/2712.
convert: no decode delegate for this image format `' @ error/constitute.c/ReadImage/501.
convert: unable to open image `265,467': No such file or directory @ error/blob.c/OpenBlob/2712.
convert: unable to open image `265,467': No such file or directory @ error/blob.c/OpenBlob/2712.
convert: no decode delegate for this image format `' @ error/constitute.c/ReadImage/501.
convert: non-conforming drawing primitive definition `rectangle' @ error/draw.c/DrawImage/3190.

>> No.71144279

>>71144242
oh wait
thing="rectangle 263,465 265,467"
convert image.png -fill black -draw "$thing" image.png

>> No.71144315

>>71144242
try putting the double quotes within single quotes in the variable, i.e. var = ' " value " '
Im not at home so cant test

>> No.71144330

>>71142553
any ideas, fellas?

>> No.71144341

>>71144315
if you want literal quotes, then do this;
\"value\"

>> No.71144357

>>71141602
>All arguments against systemd could be used against Linux itself as well.
so, better use BSD as the last bastion of Unix philosophy

>> No.71144410
File: 205 KB, 659x525, 1488786437953.png [View same] [iqdb] [saucenao] [google] [report]
71144410

>make a diff to un-apply the glibc commit that broke flash in chromium
>it actually applies, builds and runs without problems
thank you gnu/gentoo

>> No.71144439
File: 1.97 MB, 1920x1040, District 9 yellow prawn.png [View same] [iqdb] [saucenao] [google] [report]
71144439

>>71142553
>>71144330
rsync. It's the shit. I keep twin 10 TB drives in sync with it, and a run takes seconds. You can even simulate RAID functionality by having renames and no-longer-present data on the source mirrored on the destination on the next run with the --delete flag. Just cron:

rsync -aPq --delete-before /$src/ /$dest/ >/dev/null 2>&1

-a preserves time metadata and stuff. -P is worthless but there anyway. -q for quiet.

>> No.71144463

>>71144196
Thanks

>> No.71144469

>>71144439
thank you for the help my man

>> No.71144679

>>71144469
alternatively you could create a new user with a home directory for testing.
>unless you plan on accidentally the entire /home partition.

>> No.71144841

>>71144679
I might just about do!lmao. just want to fuck with things a bit, see what happens

>> No.71144973

Just installed Manjaro with KDE. How do I rice this fucking thing?

>> No.71145075

>>71144973
KDE is literally perfect. It's just a matter of picking a wallpaper and a theme.

>> No.71145093

GNOME is literally perfect. It's simply a matter of picking a wallpaper.

>> No.71145110

>>71145075
I was using Ubuntu with Gnome and then Budgie previously. Don't know what took me so long to come around. Would still like to tweak it a bit, I think digging around in the appearance settings should be sufficient.

>> No.71145114

>>71145093
pls don't theme our apps

>> No.71145313

What's the newest laptop coreboot or libreboot can work on? Because I'll buy it based on that alone.

>> No.71145329

>>71144123
eval

>> No.71145362

>>71143902
GNU/Linux*

>> No.71145376
File: 61 KB, 609x887, 1556618539885.jpg [View same] [iqdb] [saucenao] [google] [report]
71145376

>>71143766
Anyone?

>> No.71145386

>>71142574
Bad kerning, fix hinting.

>> No.71145421

>>71145313
Just buy an already librebooted one off minifree or something.

>> No.71145433

>>71135482
for being an artificial phosphor screen the fading effect is quite accurate.

>> No.71145434

>>71145114
Stop this meme, you know it's false.

>> No.71145554
File: 35 KB, 600x450, 1476772673265.jpg [View same] [iqdb] [saucenao] [google] [report]
71145554

>>71145376
https://help.ubuntu.com/community/Autofs
Check if this thing's config is fucked.
Also nice garlic bread meme.

>> No.71145558

>>71145434
https://stopthemingmy.app/

>> No.71145565

>>71145093
>literally perfect
>have rx580
>gnome shell lags at 1080 like it was shot in both legs
fuck gnome and fuck gnome shitters.

>> No.71145904
File: 42 KB, 432x447, don't know dumb.jpg [View same] [iqdb] [saucenao] [google] [report]
71145904

I installed Debian on my spare PC but everything is confusing as hell. Why do I need to remember a dozen commands just to install something from a tar ball?
Are things any easier on Ubuntu?

>> No.71145974

Is Guix manual install a pain like Gentoo (don't have much time rn so I don't want to deal with compiling and USE flag setup etc.) or can it be done in a few hours? I'm not big on letting a graphical installer add shit that I don't know about

>> No.71145995 [DELETED] 

>>71145904
pls tell me you searched for x in your package manager before you downloaded x.tar.gz

>> No.71146057

>>71145995
Yes. Veracrypt isn't in the package manager as far as I can tell.

>> No.71146330

>>71145974
The graphical installer doesn't force you to install a DE, so you could go the Debian netinst route easily enough

>> No.71146371

>>71138882
8,67GiB/s

>> No.71146571

>>71145904
>dozen commands
it's pretty much just
extract
cd
make
make install

isn't it? and it's like that on pretty much everything to install from source

>> No.71146592
File: 39 KB, 1209x658, Oomox-1-1.png [View same] [iqdb] [saucenao] [google] [report]
71146592

Has anyone used oomox? Is it worth trying it? Are there other helpers for creating your own themes?

>> No.71146606
File: 94 KB, 720x432, neadhdyqsn031.png [View same] [iqdb] [saucenao] [google] [report]
71146606

New Cmatrix out
https://github.com/M4444/TMatrix

>> No.71146666

>>71143144
>https://www.gnu.org/software/guix/manual/en/html_node/Desktop-Services.html
>The desktop environments in Guix use the Xorg display server by default. If you’d like to use the newer display server protocol called Wayland, you need to use the sddm-service instead of GDM as the graphical login manager. You should then select the “GNOME (Wayland)” session in SDDM.
Okay. I suppose this explains it. I'll to try to set up SDDM later, after another five hours of compiling dependencies for program called electrum. (I'm at 46%.)

While I'm at it:
-In Guix, you have to reboot to use a newly installed program.
-I think I have three identical copies of Python 3.7.0. I installed an emacs package and had to download a 45MB package called emcas-minimal which I'm guessing is a complete copy of my current version of emacs. I understand support for multiple versions, but there's some serious redundancy going on here.

>> No.71146696

>>71146592
Apparently pywal can integrate with oomox.

>> No.71146942

Is there a way to use termux to disable the camera?
There is an app, Cameraless, thats bloated as fuck and i dont see why i need an entire app to disable the camera. I cant seem to find how it disables it but apps that try to access the camera when using the app stats the security policy prevents it.

Can i not just find this command that the app uses and add this to a sh script in termux?
How would i find what command it is using to disable the camera?

>> No.71146944

>>71146592
I actually have it right now but I can't generate anything since I don't have inkscape installed. I don't need it anyway since I found a theme I'm very comfortable with

>> No.71146959

>>71146942
install coreutils

>> No.71146977

>>71146959
That does not solve anything, and busybox negates the need for gnu coreutils

>> No.71147037

>>71146666
>I installed an emacs package and had to download a 45MB package called emcas-minimal which I'm guessing is a complete copy of my current version of emacs

Witness the GNU virus replicating

>> No.71147049

>>71146696
It takes forever to install, it's literally downloading themes I already have on my machine.
>>71146944
I need Inkscape too?!

>> No.71147137

>>71147049
everytime I tried to export a theme it gave me an error telling me I needed inkscape

>> No.71147204

Henlo frens. Recommended distro and de for old parents. They hate windows 10. Was thinking manjaro bc I’m familiar with it and arch, but idk what desktop. Or gentoo.

>> No.71147307

>>71147204
Debian Stable with KDE.

>> No.71147323

>>71146666
No you don't have to reboot to use a new program. It should function immediately.
However, in some cases they want to add new environment variables (perhaps this is why you find it doesn't work) but all you should have to do is re-source the profile.
You should have this line somewhere in your bashrc or profile:
>source ${HOME}/.guix-profile/etc/profile

Also, you're running Guix on top of another distro right? If so, then expect a bit of inefficiency. Guix cannot do what it does best (reproducible builds) if it keeps relying on shit built from your host distro. It builds the entire chain of dependencies it needs.
In this sense, using Guix on a different distro is a bit like using flatpacks or something. You're going to get a lot of additional stuff that you already have on the host distro.
Obviously it becomes more efficient if you just use Guix System as your distro.

>> No.71147372

>>71147204
just put linux mint cinnamon on there. xfce if it's slow. I seriously don't know why you're avoiding the obvious

>> No.71147393

>>71147323
I'm using GuixSD. I thought I may as well go in head first.

>> No.71147448

>>71147393
Nice. Well in that case I'm not sure about your redundancies. Perhaps you just need to run garbage collection. It's a source based distro so you tend to accumulate a lot of build tools that aren't needed to run the system later.

Also I wonder if there's still some things that need polishing.
Rust is a great example of redundancy. It looks like you need several versions of rust to compile the newest versions of rust. I'm not sure if that's just a flaw in Guix that needs to be ironed out, or if that's something inherent to rust.

>> No.71147738
File: 36 KB, 678x309, 1558997189106.png [View same] [iqdb] [saucenao] [google] [report]
71147738

>>71145558
Retard.

>> No.71147771

>>71146977
Good luck.

>> No.71147801

>>71146942
Either you rip the camera out, or you deal with having a camera. There is no reliable software solution, unless you have hardware killswitches.

>> No.71147902

>>71147738
Not that anon, but I don't care who they're targeting. That mentality is pretty shitty.

Their theming system has always been fucking garbage, and of course, right on schedule here they are blaming everyone else for their broken shit instead of taking responsibility and making a system that actually works.
They've literally broken their own theming system _multiple_ fucking times just within 3.x. I could understand it breaking across major version updates, but not minor versions.

I honestly think we'd all be better off if every last gnome/redhat developer never touched a computer again.
Their philosophy toward development and attitudes are about the most cancerous thing to the whole system we're creating, and like a cancer, it's starting to spread. And new users are coming to accept their ideals as standards.
Absolute cancer that needs to be cut.

>> No.71147931

Anyone able to recommend a good way to get your external IP? I want to run it on my i3bar every second or two so I don't want to hammer some external site. I have the capability to host a webpage but I've not fucked with that kind of stuff since literally the 1990s with Geocities pages so I'd prefer not to spend the next week learning html and php all over again.

>> No.71147936

>>71146977
>busybox negates the need for gnu coreutils
Busybox is a small multicall binary that provides very basic, trimmed down coreutils-like utilities, aiming for small filesize. It is not a full coreutils replacement. That said, for use in Termux, busybox is fine, but when some script doesn't work, you now know how to fix it.

>> No.71147979

>>71147931
Fastest way as always: dig +short myip.opendns.com @resolver1.opendns.com

>> No.71148028

>>71147801
>There is no reliable software solution
I am using a reliable software solution. "Cameraless"
I open the app and click a button, it sets some security policy and now the camera dosent load anywhere.
The app has "pro" features that it nags about after X amount of on/offs.

What i am after is what command that app is using to turn off the camera so that i may create a termux script that does exactly that and have a script on my home screen for faster access then waiting for the app to start, show me ads, check for what number off/on it is and nag about pro features
There has to be a way to execute that command within a rooted system

>> No.71148048

>>71147979
Ah yeah, I know about running dig on dns servers and wget or curling a few webpages. I was hoping their was a built in tool for grabbing your IP.

>> No.71148223

>>71148028
termux would need to be a device administrator and from what I see, that's not really the point of it so don't think they built that in.
probably can be done with root somehow.
how much is it, that you don't want to buy it?

>> No.71148271

>>71147738
You clearly don't get it, perhaps you can't. I'll try to help you comprehend anyway: They are saying that if you run a GNOME program and a KDE program and some GTK program in Xfce they want the GNOME program to use it's default theme and the KDE program to use it's default theme and the GTK program should also look differently. That's just stupid. Further, they are saying that it's fine to use special quirks for GNOME and it's stock theme and not care about anything else.

This is a big fuck you to everyone, specially anyone who's ever made a GTK theme (I have) or an icon theme (I have).

>> No.71148374

>>71148223
>probably can be done with root somehow
Back on one of the old nexus devices back on v3 or v4 a decade ago, i was able to create a widget and give it two commands, a ON and OFF commands, i did this for gps,lte,flashlight etc etc(what we call quick settings now), i also had a widget to turn the camera off cause there were no advanced permissions back then and every app opened the camera on start and it slowed everything down, so i clicked that widget that i gave some string/command and it turned the camera off.
I cant find anything about that anywhere, but i cant imagine that there isnt some way to do this

>how much is it, that you don't want to buy it?
The turn off turn on functionality is free, but every X times you click it, it pops open a dialog screen that steals focus and you cant side click, you have to click ":remind me later".This causes excess load time that isnt necessary.

What is it that this app does that i cant replicate with a widget of some sort within the rooted os?

>> No.71148391

>>71147902
You are right on all points. There is a reason I bothered to spend some time writing a whole page about it,
https://linuxreviews.org/GNOME_Developers_have_Made_Their_Moves_against_Themes

because it's really apparent that they would like to ideally remove theme support from their GNOME Toolkit (not what GTK was intended to be but that's what it is now).

The partially censored github tracker for the subject is laughable, there's Michael Murphy from system76 trying to spoon-feed basic concepts to incompetent whining children.

btw, The biggest personal issue I have with GNOME: I've always used a mix of software in whatever WM I have been using, fluxbox or iceWM or Xfce and KDE for a while too - never GNOME though. Running kate or kdenlive or firefox has always worked just fine in any wm. GNOME children call their desktop a "platform" and confuse it with an OS and make it very clear that they are fine with their shit not working with other desktops - or other themes than the GNOME default one. When they removed the window titlebar and menus they basically restricted all the GNOME crap to GNOME. It's mostly crap, so it's not the end of the world. But it is generally sad that they have managed to remove a large amount of software from the non-GNOME Linux desktop.

>> No.71148462

>>71148374
keyword in your reply is a decade ago.
android has been locked down quite a bit more than back in those wild west days in case you missed it.

>> No.71148485

>>71148462
And yet this app is able to rape the system and is on the play store for years now, and this app is using the system api that google gave to the android system
So your argument is moot.
There is some command being used when you click that gui element, and another when you click it a second time.
That command can be processed somehow within the system without an app.

>> No.71148501

>>71147738
Would it make sense to you if I say "Everyone must wear gray clothes, coloring clothes is bad and we want to forbid anyone from doing it. We do not like that government officials wear colored clothes. This is just targeting government officials"?

>> No.71148612

>>71148485
It isn't moot, because the app is getting device administrator access before it can even touch the camera. your little widget would have to get that same access too.
you are better off just investing in some electrical tape.
you could probably do it with tasker actually,

>> No.71148644

Is irqbalance worth it if I only have 2 cores

>> No.71148647

>>71148612
>your little widget would have to get that same access too.
I own the bootloader and the device is rooted. I can give anything on the system any permissions i want. You act like this is some unfathomable task when its the most trivial.

>tasker
Tasker requires Cameraless.It has 3 intents..but this is in the pro version and still requires an extra app vs a command line.There is no camera management intents in tasker

>> No.71149162

What is the correct way of storing conf files for packages installed with guix?
Right now i'm storing them under /gnu/store/package/... but when there is a new release for the package, will I need to setup the files in the new directory?
Then there is also $HOME/.guix-profile but I guess my question ultimately is where am I supposed to store these files when all these directories are owned by root, think just changing the permissions might not be the right way of doing things.

>> No.71149247

>>71148271
>>71148501
>>71147902
you either enjoy drama more than software, or you unironically are whiny pussies
did you feel personally attacked by the linux coc too?
nothing of this shit hits the users

>> No.71149272

>>71148028
You don't turn off a piece of hardware using software. Malicious software will flip it back on. Get it?

>> No.71149295

I'm using Manjaro KDE.
I wanted to remove some screen tearing that still happens when I browse some site (mostly on non-video site like manga sites). I followed the archlinux wiki to create a conf file in /etc/X11/xorg.conf/ named 20-radeon.conf which content is:
Section "Device"
Identifier "Radeon"
Driver "radeon"
Option "TearFree" "on"
EndSection

But then it couldn't boot. It stuck after bios screen with error with something along this line: failed to start simple desktop display manager.

What do? Can I just use liveusb and delete said conf file?

>> No.71149307

>>71149272
When the camera is denied a security policy, you do.
I dont care about malicious software i care about common mainstream apps that are required to be used to maintain a real job, instead of being a neckbeard collecting neetbux

>> No.71149323

>>71149247
you don't get it, it's gnu software, that means you don't get to tell anyone jack shit about what to do with it

>> No.71149337

>>71149307
>claims to not be neckbear
>refuses to pay for program that does exactly what he wants
suuuure pal

>> No.71149352

>>71149307
>real job
Oh, you're that kind of guy.

>> No.71149378

>>71149337
So you buy literally everything you put your eyes on cause "LOL IT WOKRS"?

Not guna pay for bloated shit when a simple command does its job

>>71149352
Yeah tell your ne boss that you dont want to use programs X,Y,Z that their entire system is built upon.Tell them that they have to RESEPCT MUAH FREEDUMBS. And see how quickly you dont have a job

>> No.71149415

>>71149378
Enjoy you're botnet.

>> No.71149417

>>71149378
when said software does what you want, and you can't figure out how it does it and no one else offers a free alternative then yes you buy it fuckface. also no 'real' job requires the use of an app, or for that matter even the possession of a cell phone

>> No.71149449

>>71149417
>>71149337
Are you one of these retards who believe that payed apps don't spy?

>> No.71149478
File: 91 KB, 734x729, 1558773013002.jpg [View same] [iqdb] [saucenao] [google] [report]
71149478

Get that Android shit outta here

>> No.71149533

>>71148028
>using a spying privacy app
https://reports.exodus-privacy.eu.org/en/reports/23060/

>> No.71149537

>>71149417
>also no 'real' job requires the use of an app, or for that matter even the possession of a cell phone
Any job you will have various social media platforms that you are required to join and be part of because your literal job is managed via these apps.
Starting with shitty cashier jobs at walmart to your high level it jobs that schedule required work events via facebook, to telegram groups to stay in constant contact with your co-workers and boss

Kill your self you neetbux faggot

>> No.71149639

>>71148048

>a built in tool for grabbing your IP.

How would your external IP to the outside world be determined completely internally within your computer, without a DNS?

>> No.71149657

ok guys need a hand please. installed gentoo a month ago. going great. so i go to reboot because my audio was acting funny (fucking PA) froze on reboot with audio repeating. ok, hit the power. now i reboot and my HD is not recognized. put in my livecd usb and go to lsblk, the hd is there but there are partitions recognized on it?
where do i even start? i'm searching right now but i don't even know whats going on really? i don't see how it could just 'disappear'
thanks in advance...

>> No.71149706

>>71149657
install gentoo

>> No.71149776

>>71145386
Turning off autohint to native seems to have solved the problem.

>> No.71149806

>>71149706
thx m8. heres to hoping i dont have to again. says no NTFS signature found so i'm hoping the filesystem is only corrupted and can be recovered. working with systemrescuecd now but ive no experience in linux with this.

>> No.71150394

My keyboard stopped working randomly
I tried grepping to find it and i think i see 2 keyboards (the one thats isnt working and the one im using to test)
Is hiddev96 mean its being turned-off ? Is there any way i can turn it on again ?
To clarify I tried connecting the keyboard on my win10 laptop and it found the device but couldnt startit (error 43)

>> No.71150410

>>71149657
>the hd is there but there are partitions recognized

You may be retarded.

>> No.71150412
File: 106 KB, 1920x1080, screen.png [View same] [iqdb] [saucenao] [google] [report]
71150412

>>71150394
forgot the terminal output

>> No.71150425

>>71150410
/no/ partitions. thanks man. running testdisk but i am too retarded right now.

>> No.71150441

>>71150425
smartctl -a /dev/whatever

>> No.71150502

>>71150441
it passes, testdisk can't recover all the partitions. looks like i can get to some of my files but some appear deleted. depressed. the only thing i can think right now is to put it in my other box and save what i can. funny cause i was just about to clone my dotfiles later tonite. #[email protected]#@HDKSA. i'll keep fighting the good fight here thanks

>> No.71150633

what does a "base install" of linux distro usually have, other than the kernel image?
for instance, what does debootstrap --variant=minbase installs?

>> No.71150677

>>71150633
libc, the coreutils (things like ls, cat, etc.), the init system (systemd in debian's case), a few libraries needed by the previous things.

>> No.71150703
File: 45 KB, 464x213, 1559007511063.png [View same] [iqdb] [saucenao] [google] [report]
71150703

Im getting an error on linux where it doesnt detect my keyboard over (doesnt even come up on the lsusb or anything), But in windows 10 the keyboard comes up as a USB device and error 43
What do ?

>> No.71150746
File: 45 KB, 1366x768, 2019-05-27-232520_1366x768_scrot.png [View same] [iqdb] [saucenao] [google] [report]
71150746

>>71135482
Why do I see two "streams" of audio and how do I get rid of one? I had both of these on at one points and it sounded really weird as there was the same sound playing twice. Should I just have one muted or is there a way to get rid of one?

>> No.71150765

anybody know how long does it usually take for a stable kernel take to go from testing to core repo on arch?

>> No.71150778

>>71150765
Usually a few weeks, I think.

>> No.71150821

>>71150778
weeks? damn. so it's not the same as the git changes (below)?
should I just enable the testing repos then (not many packages)?
I think the new kernel has a bugfix I need :(
index : svntogit/packages.git

Age Commit message (Expand) Author
23 hours 5.1.5.arch1-2 heftig
2 days 5.1.5.arch1-1 heftig
6 days 5.1.4.arch1-1 heftig
6 days 5.1.3.arch2-1 heftig
11 days 5.1.3.arch1-1 heftig
13 days 5.1.2.arch1-1

>> No.71150857

>>71149162
>Right now i'm storing them under /gnu/store/package/...
I don't get it. If you're storing them with the package itself inside the store then that means you've already defined the config programmatically within the guix package. That's the only possible way I'm aware of for you to get your custom config in there.
And if that's the case then your problem is already solved isn't it?

>> No.71150871

>>71150746
idk, but I'd guess you have mpd misconfigured. If I'm not mistaken mpd is capable of outputing multiple streams which is used for broadcasting your music over the network and such

>> No.71151159

I just installed Arch with linux-lts. its causing problems with drivers do i just want to switch to the standard linux kernel because t works when I manually switch to it on boot. is there any way to remove linux-lts, or at least change the default bootable linux kernel? i have GRUB, if that helps.

>> No.71151189

>>71149295
I suspect the reason is that you are using the amdgpu kernel driver. If that is indeed the case then you'll need to use Driver "amdgpu" instead.

Section "Device"
Identifier "AMD"
Driver "amdgpu"
Option "TearFree" "1"
EndSection


The reason is simply that this section will change what X tries to load and if you are using amdgpu then X won't start when you ask it to use radeon.

As for not booting, I'm sure it boots and just doesn't load your display manager? you can still ctrl+alt+f2 to get to a console and change the configuration file.

>>71149247
>you either enjoy drama
no, I don't. I enjoy having working software. I do not enjoy having to explain fundamentals of good software design to immature children. It's quite annoying that I sometimes have to do that.

>> No.71151231

>>71151159
see the "tip" here:

https://wiki.archlinux.org/index.php/GRUB#Configuration

or go here:

https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks#Multiple_entries

>> No.71151250

>>71151159
what is a linux lts?

>> No.71151275

>>71151250
Long Term Support, i.e. lts

>> No.71151295

>>71151231
thank you, i got it

>> No.71151296

>>71151189
Isn't amdgpu for the newer cards? This is an old PC which is still using X1300/X1550 card. When I typed lspci it's still using RV505 driver which is indeed radeon.
>it boots and just doesn't load your display manager
Perhaps? So at that error I should just press ctrl+alt+F2 and delete the conf file? Cause currently I'm not having any usb drive available.

>> No.71151312

>>71151250
linux-lts is a more stable version of linux, but its older. in my case it didn't work with my nvidia drivers

>> No.71151345

>>71151296
I think it might be time for you to get a new GPU. You can get things like the R5 230 for next to nothing.
Your current GPU probably would still work, but I don't think what you have is going to have the required OpenGL features that a lot of programs are expecting.

It would be better to look into whatever SDDM's output is to see why it's failing.

>>71151312
>>71151250
It's not like it's magically more stable than different releases, but they backport bugfixes and security updates to it for much longer.

>> No.71151425

>>71151345
Yeah, I know. But this PC isn't for that. I do posses a laptop which is much more powerful, I usually use this one for linux learning/testing.
>look into whatever SDDM's output
How do I do that? I assume I just press ctrl+alt+F2 on error screen and navigate into whatever log file?

>> No.71151487

>>71151425
>I assume I just press ctrl+alt+F2 on error screen and navigate into whatever log file?
Probably.

>> No.71152174

>>71150821
just download and install that package by itself if you need it ahead of time
i wouldn't recommend enabling the arch testing repo

>> No.71152579

>>71135482
>Try to install system wide paramatic eq
>break almost everything in the process
>too dumb to know how to fix it
>reinstall

I can't count how many times I've done this.

>> No.71152590

>>71151487
Thanks, ctrl+alt+F2 and deleting the conf worked. I didn't get to see the sddm log though. But it's okay since it's working again without having to use liveusb.

>> No.71152597

>>71152579
that'll happen when you're new
it's easy to break the fuck out of things, but it's also easy to fix anything as well
once you learn how to fix things, you'll never have to reinstall your OS ever again

>> No.71152625

>>71152597
I've been using linux for about 2 and half years and I still fuck up like this. There's so many variables and even after hours of research I sometimes can't fix something because it's such a niche issue.

>> No.71152641

>>71152625
i don't know exactly when i got to the point where there wasn't anything i couldn't fix without reinstalling, but it was probably about that long, if not a little longer
you have to actually mess with and break things in order to learn to fix them though, if you play it safe all the time, it'll take forever to learn anything

>> No.71152720

>>71137067
It will keep working but you’ll lose the ability to update packages if you don’t pay for it.

Use CENTOS instead in that case or Fedora if you want red hat but bleeding edge

>> No.71153628

>>71149478
this sperglord uses Windows, by the way.

>> No.71153647

>>71141651
SUPPORT HURD

>> No.71153675
File: 13 KB, 300x300, 2795415-9653374716-king..jpg [View same] [iqdb] [saucenao] [google] [report]
71153675

guix package -i guix

>> No.71153774

>>71150703
It probably comes up in dmesg as an error/unknow device

Your kb or its cable is kill.

>> No.71153794

>>71146666
normally on Guix you would run Garbage Collector in order to get rid of unneeded stuff

>> No.71153835

>>71152174
>just download and install that package by itself
yeah well it's the kernel itself, so I'd have to also get it's dependencies
it's OK though, they actually moved it (5.1.5.arch1-2) to core shortly after I asked lol

>> No.71153905

>>71149537
wow watch out we have a professional in our midst
what are you even doing in our dregs of society hobo hacker thread?

>> No.71153916

>>71149537
kill yourself u idiot

>> No.71153941

>>71149537
>Starting with shitty cashier jobs at walmart to your high level it jobs that schedule required work events via facebook, to telegram groups to stay in constant contact with your co-workers and boss
Here is your (You) faggot don't spend it all once at your companies Söylent vending machine all once.

>> No.71153951

https://www.youtube.com/watch?v=KMs-g5ILaIo
Adding GNU/Hurd support to GNU Guix

>> No.71154093

>>71153941
>telegram
>co-workers
Is telegram actually a thing? I thought it was a thing for low-level privacy autists.

>> No.71154095
File: 36 KB, 741x486, yodawg.jpg [View same] [iqdb] [saucenao] [google] [report]
71154095

>>71153675

>> No.71154139

>>71145974
>Is Guix manual install a pain like Gentoo
No, it's like manually installing some major distro, there's nothing outstanding or unusual. You should know that Guix's complexity is usually exaggerated. Its point is not complexity or inconvenience a la gentoo, its point is having a different operating system architecture, which is not hard per se, but simply different.

>> No.71154187

>>71154139
To be fair it can be difficult to do some things you want to do without programming knowledge. For instance, I don't like bash smart completion which comes in the default %base-packages and I just replaced it with: (delete (@@ (gnu packages bash) bash-completion) %base-packages)
worked like a charm, but that's not something everyone would know how to do.
A lot of people installing from the "graphical" installer don't even know where their system config file is located.

I suppose it's possible to just live without any of these small customizations in the first place, and then maybe you don't need to know anything. But I like to tweak things to be exactly the way I like them.

>> No.71154211

Hi /g/
What is the most stable distro at the moment? I've been using Ubuntu 18.04 for about 3 months now and while its good (for a norm like me), i've noticed it tends to break a lot and I spend half of my time trying to fix it. Should I persist or try something else?

>> No.71154225

what are your favorite non-mainstream and amateur file managers? I think that Xfe and Worker are pretty cool

>> No.71154230

>>71154211
Try debian stable or centos.

>> No.71154238

>>71154187
>without programming knowledge
Well, it's still pretty basic programming knowledge.

>> No.71154243

>>71154225
vifm

>> No.71154247

>>71154230
these are distros for servers, not humans. centos is dinosaur-like, I don't know how anyone can use it as a modern desktop

>> No.71154261

>>71154211
what do you mean "stable"? with few package conflicts? try something like NixOS that eliminates the very problem of package conflicts instead of remaining severely outdated.

>> No.71154292

>>71154095
it actually says this command in manual:
https://guix-hpc.bordeaux.inria.fr/package/guix

>> No.71154334

>>71154292
What's the problem?
If you want to install guix, you just fire up your guix and install guix

>> No.71154350

>>71154334
I have 5 generations of Guix on my Guix

>> No.71154364

Also, on Guix one doesn't install programs, but deploys them.

>> No.71154393
File: 3 KB, 332x152, dwm.jpg [View same] [iqdb] [saucenao] [google] [report]
71154393

'Ello friends I installed dwm on Ubuntu but it won't show up at login. What do?

>> No.71154397

Sorry, I've never Hurd of Linux.

>> No.71154403

>>71154397
cat /usr/share/pasta/jp/whatafuckman.txt > /dev/4chan/thread/current

>> No.71154415

>>71154403
Go write a FUSE driver that does that.

>> No.71154423

>>71154415
I unironically considering writing a hurd translator for 4chan threads.

>> No.71154427

>>71154403
This is my dream
but I refuse to buy a pass to make it a reality

>> No.71154439

>>71154423
So, is Hurd like Plan9 then?

>> No.71154444

>>71147204
Gentoo

>> No.71154735

>>71137787
I started with installing Gentoo after anon told me to

>> No.71155376

>>71154393
How did you install it? I think you need to actually create a .desktop file for the executable if you are using a dm

>> No.71155396

new to linux just installed Crux.

>> No.71155722

What in the fucking fuck. Why does RHEL and Fedora have SSH access enables by default?

>> No.71155738

>>71155722
when would you ever not want ssh?

>> No.71155747

>>71155722
Enjoy your NSA botnet.

>> No.71155761

>>71155722
Most distros do that. And I'm glad they do, it's super useful.
It's not like you actually have your port 22 forwarded to the open internet in your router right anon?

>> No.71155765

>>71155738
When I'm on a hostile network or one with just shit security.

>> No.71155809

>>71155761
Some dumb fuck network admin at a library could have set it up wrong. Or maybe I have to use some shitty McDonald's wifi in a city for an emergency and it's a hostile network. Even visiting my relatives is risky. I have to ask why it would be on by default but the user doesn't know.

>> No.71155821

>>71155765
i think ssh on default is sensible. most people will want to use it, so let the few who don't turn it off

>> No.71155841
File: 170 KB, 1213x928, 1553598355899.png [View same] [iqdb] [saucenao] [google] [report]
71155841

What will happen if I remove /opt/cuda?
It takes too much space.

>> No.71155855

>>71155809
I'll be honest here, I'm actually just taking the fact that it's default on so many distros and using that to assume it's safe.
Maybe it's not wise to assume such things, but I can't help it. I really believe if it's the default (and I've never seen the slightest hint of it even being a controversial descision) then I simply trust that it's secure enough. I trust that people who do know more about the topic would have made a ruckus if it wasn't.

>> No.71155873

>>71155841
Your Cuda programs won't work? Why do you even have the proprietary garbage installed anyway?

>> No.71155900

>>71155873
>Your Cuda programs won't work
Eh ? I don't even know what programs requires cuda on my machine...

>> No.71156126

>>71155841
what disk space viewer is that?

>> No.71156146

>>71155900
then uninstall cuda

>> No.71156164

>>71156126
baobab (aka gnome disk usage analyzer)

>> No.71156190

>>71156164
cool. i never used gnome

>> No.71156212

>>71155722
they also automatically install windows 10 when you're not watching

>> No.71156218

>>71156146
It feels risky to do that if something requires cuda
>>71156190
You can use it in whatever DE you use

>> No.71156241

>>71156218
>DE
i never used de

>> No.71156264

>>71156241
ok

>> No.71156268

>>71156190
neither, but i've used baobab, it doesn't require gnome
i use ncdu nowadays though

>>71156218
>It feels risky to do that if something requires cuda
review the list of the programs that will be removed when removing cuda, it will list anything that requires cuda
this isn't windows where you will be left with broken things you aren't aware about

>> No.71156297

>>71156264
im such an ancient piece of shit that window maker looks too modern to me

>> No.71156346

>>71156268
>review the list of the programs that will be removed when removing cuda
It only removes cuda...
5.5go
I will now remove /opt/cuda (7go)
> -12.5go
Done

>> No.71156473

>>71156346
>It only removes cuda...
probably an orphaned requirement of something you already removed
don't manually delete things outside your home folder unless you really know what you're doing. find out what package owns them and remove that package if you want to remove it

>> No.71156599

>>71140589
>i know nothing of building from source.
it literally involves a couple of simple commands - ./configure, make, make install

>> No.71157010

New memes: >>71157004

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action