Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 80 KB, 620x434, 1538831549787.png [View same] [iqdb] [saucenao] [google] [report]
68252292 No.68252292 [Reply] [Original] [archived.moe] [rbt]

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: Please spend at least a minute to check a web search engine with your question.
*Many free software projects have active mailing lists.

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux:
https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux
>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page
>What are some cool terminal commands?
http://www.commandlinefu.com/
http://cheat.sh/
>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://linuxcommand.org/tlcl.php
http://www.grymoire.com/Unix/
>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html
>How to break out of the botnet?
https://prism-break.org/en/categories/gnu-linux

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

/t/'s GNU/Linux Games: >>>/t/825628

Previous thread: >>68235506

>> No.68252340

1st for clang is overtaking gcc and there is nothing you can do to stop it
Whats wrong gcc? Cant handle he competition?

>> No.68252380

>>68252340
There's no "overtaking". It's a healthy competition. Clang may be end up more widespread, but that's for licensing reasons, not quality.

>> No.68252382

I think the biggest turn off if I was learning Linux would be all of this emphasis on distros.

Install Debian and CentOS minimal on VMs and instead of spending time ricing then out learn bash and all of the tools installed by default. I believe neither enables the network card by default so that’s an important one to figure out. From there you can install some packages I use every day like Vim, tree, htop, etc. Then learn to compile software using Cmake, make, etc.

Also basic admin shit, useradd usermod chmod are things you actually use a lot if you’re in an environment tearing down and rebuilding machines constantly. SSH obviously is important and takes 20 mins to figure out.

Then get into writing scripts using bash and learning regex with grep then sed then awk.

Then learn about systemd.

>> No.68252384
File: 70 KB, 180x399, 180px-Tumblrraid.png [View same] [iqdb] [saucenao] [google] [report]
68252384

Might I please ask for counsel upon what would be the best distro to use for someone who really, really liked Mandriva Linux?
What I liked : it came with everything working out the box in terms of media codecs and such like (I believe it even offered you the ability to purchase a license to play mp3 files), and the desktop environment was by the far the most pleasingly designed of any distro I've ever used. It used KDE, and had a really awaesome desktop background that changed once every 30 mins or so to reflect the time of day.
Anyhoo, what's the reckoning on a good replacement please? Noob friendly with a stunning desktop UI either natively or easily installed. Thank you.

>> No.68252391

Devuan with SysV or OpenRC?
Or should i just stay on Debian?

>> No.68252401

just purged my twitter to refocus, what's some good gnu/linux news twitters?

>> No.68252444

>>68252380
1.Faster binaries
2.Smaller binaries
3.Better debug messages
4,No shitty plugins that are kernel dependent.
>Chromium defaults to clang
>Mozilla defaults to clang
>Apple defaults to clang
>Google defaults to clang
>Nvidia defaults to clang
>AMD defaults to clang
Yes, it is only popular because of the license and not the astounding performance gains. Once Linus gets rid of those shitty gcc plugins Linux will be built with clang

>> No.68252449

>>68252401
Mastadon?

>> No.68252457
File: 359 KB, 1622x970, 1495312724343.png [View same] [iqdb] [saucenao] [google] [report]
68252457

>>68252292

>> No.68252472

>>68252444
>>68252340
1st for braindead GNU haters, corporate cocsuckers and suckmore retards can hit the fucking road.

>> No.68252476
File: 29 KB, 601x500, 1540099340626.jpg [View same] [iqdb] [saucenao] [google] [report]
68252476

>>68252444
A reasonable and great future.

>> No.68252479

>>68252472
Not an argument

>> No.68252480

>>68252391
Both work just fine.
openRC supports parallel startup to speed up the booting process however it might not be fully supported on non-gentoo.

>> No.68252778

>>68252480
>openRC supports parallel startup
I dont know how to even use that so it probably doesn't matter

>> No.68252783

>>68252778
literally setting a variable in its config file to 1. Try it once.

>> No.68252953

Which runit compatible distro would you guys recommend? I'm looking to get back into Linux but want to avoid systemd cancer.

>> No.68253090

How the fuck do you get a python script to load with systemd service files? I just want it to start on system boot and kill it when told tooand when the system ends.

>> No.68253103

>>68252953
Linux

>> No.68253130

>>68253090
guess you have to create a systemd service and for the command to run you specify the python script directly or using "python /path/to/scrip"

>> No.68253249

>>68253130
I have that. It says it cannot find it.
~/.config/systemd/user
LITERALLY WHERE IT WANTS IT
Doesnt do shit

>> No.68253267

>>68253249
Try it will a proper full path, not with ~.

>> No.68253298

>>68253267
It is the absolute path in the script.
ExecStart=/usr/bin/python /home/user/.bin/script.py

>> No.68253309

What do people here use to read comics?
I have Viewnior, I like it but what kills it for me is that the arrow keys do not scroll smoothly.

>> No.68253358
File: 95 KB, 820x440, 1533301016035.png [View same] [iqdb] [saucenao] [google] [report]
68253358

>>68252292
>>68252382
>>68252391
>>68252401
>>68252444
>>68252449
>>68252457
>>68252472
>>68253103
Manjaro

>> No.68253427

>>68253309
mcomix

>> No.68253481
File: 15 KB, 320x320, 42802192.jpg [View same] [iqdb] [saucenao] [google] [report]
68253481

alright gucci gang
installed devuan but no super key
its set as multi-key and i dunno how to change
pls halp

>> No.68253510

>>68253481
dpkg-reconfigure keyboard-configuration

>> No.68253518

>>68253481
>gucci gang
are you 12?

>> No.68253543

What web browser are you using?

>> No.68253608
File: 914 KB, 302x500, tofubo.gif [View same] [iqdb] [saucenao] [google] [report]
68253608

>>68253510
worked
now i can use my shortcuts
thank you very much

>> No.68253616
File: 97 KB, 1366x768, 1540737765103.png [View same] [iqdb] [saucenao] [google] [report]
68253616

>>68253358
Did we forget about this meme already?

>> No.68253626

>>68253616
Don't care virgin

>> No.68253878

Is there an image tagging program that dosent duplicate your images? I've tried hydrus but having a duplicate file the same size as your collection makes little sense.

>> No.68253883

What's the current best method to encrypt DNS traffic? dnscrypt-proxy or something else? I haven't done this for a while and barely remember what I did last time but I did use dnscrypt-proxy but it was really clunky.
I'm on Ubuntu.
Also does this completely hide the URLs of the websites you're visiting from your ISP/the glowniggers.?

>> No.68253902

Why isn't the Disks application in Mintbuntu integrated with the file managers (Thunar, Caja, etc)? I'm talking about being able to see disk properties like the device location (/dev/sda), UUID, partition type, and most of all the ability to power off the drive. Unmounting a drive, especially an external, does not power it off.

>inb4 just fork it and do it yourself

>> No.68253908

>>68253883
unbound+dnssec+dnscrypt-proxy.
Archwiki has detailed instructions for various dns servers options

>> No.68253933

>>68253908
From what I remember, DNSSEC is the standard used by dnscrypt-proxy so that makes sense, but how does unbound fit into this?

>> No.68253967

>>68253933
It depends on what server you use, some dnscrypt-proxies dont have dnssec enabled, most do but its not mutually exclusive.
>unbound
Local caching dns server that enables dnssec if its enabled on the server,dnscrypt-proxy alone does not enable dnssec, you need a resolving dns server to enable it

>> No.68253974

>>68252953
The only popular runit distro i know of would be void linux.

>> No.68254024 [DELETED] 

https://m.tiktok.com/v/6609304017161948422.html

is she one of us?

>> No.68254063 [DELETED] 

>>68254024
Fucking incel. Cyka

>> No.68254113

what's the best virtualization software you'd recommend?
virtualbox is a nigger in the ass in dual boot because of secure boot
what's the best alternative (i want my VMs to be able to communicate with each others)

>> No.68254176

>>68254113
Turn off secure boot

>> No.68254203

>>68254176
problem is it's a GNU/Linux - winshit dual boot so that's gonna be a no

>> No.68254601

I have a chromebook and I'm planning on installing Mint on it. How do I go about uninstalling Chrome os and replacing it with MInt? I've looked and haven't found a solution.

>> No.68254615

>>68254601
Look up Gallium OS

>> No.68254916

>>68252384
Mageia is the new Mandriva. From my personal experience I think you will prefer OpenSuse though.

>> No.68255026

>>68253298
What does `journalctl -e` say after you try to launch it?

>> No.68255060

Anyone using Icecat here?

It seems slower than Firefox ESR, and it has preinstalled extensions you can't remove (normally).

>> No.68255074

>>68254203
You dont need secure boot for anything, specially not linux.

>> No.68255097

>>68254203
qemu and possibly some qemu front-end. virt-manager is bloated as fuck but gets things done.

>> No.68255128

>>68255060
you can disable the integrated addons.
>seems slower than FF esr
that's true sadly. Literally one guy working on it, regardless of its being a priority FSF project.

>> No.68255190

>>68255060
>>68255128
I haven't noticed any difference in speed between icecat and normal ff. How could it be slower when all they are doing is changing some permissions/tracking shit and enabling/disabling some addons?
Granted I have most of the addons disabled. I don't think it matters if they're fully removed or not, speed should only be effected by whether they are disabled or not.

Which version of icecat are you using?

>> No.68255241

>>68255190
IIRC it has some webgl/canvas related shit (which can accelerate things btw) disabled because they can be used to track the user.

I use this:
https://alpha.gnu.org/gnu/gnuzilla/60.2.0/

>> No.68255257

>>68255241
I guess that could make sense then since I always had webgl disabled on normal ff too.

>> No.68255258

>>68255128
Always sad to hear things like that.
>>68255190
52, because it showed as the lastest. But now I see >>68255241 and am curious why is wasn't in the options.

>> No.68255270

>>68255258
60 is considered alpha, that's why it is not in the main mirrors.
https://savannah.gnu.org/forum/forum.php?forum_id=9240

>> No.68255288

>>68255258
>52
That's what I was wondering because icecat quantum is fairly new and might not be adopted by some distros yet.
As you probably know (despite all the hate ff quantum gets over the plugin engine) quantum represented a totally new engine for ff and has _huge_ performance increases with increased parallelism.

So if you're comparing pre-quantum icecat to post quantum ff then yeah, that'll definitely explain the speed differences.

>> No.68255527

>>68252472
this

>> No.68255583

>>68254615
Are you able to rice Gallium OS? What about Steam games?

>> No.68255644

>>68255288
>>68255270
Thanks! 60 runs A LOT better!

>> No.68255667

>>68255074
what about winshit?
i know that it is not a big deal with Linux, but winshit doesn't work the way GNU/Linux does
>>68255097
what about xen?
is there no way to make virtualbox work with secure boot? it's fucking annoying, i'm used to it

>> No.68255777

Would UDF be a good choice for an OS agnostic FS that can hold >4GB files?

>> No.68255807

Can you set a default directory for scrot to save to, other than with a bash script?

>> No.68255821

>>68255667
Xen is a type 1 hypervisor that uses qemu. Why would you want secure boot in a VM?

>> No.68255840

how to list moutable drives and devices for example phone or windows partitions in terminal?

>> No.68255844

I use Xubuntu and installed i3wm.
I like it but I notice that after a while I seem to get disconnected from the router and I have to click the applet to connect again.
This never happened before so I think it might be related to the change, does anyone know what it could be?

>> No.68255887

>>68254113
KVM with linux bridges. And fuck secure boot, there's no reason to complicate things with that, your home server isn't a kiosk or laptop.

>> No.68255926

>>68255777
Not as broadly supported as NTFS or exFAT, but it would work for Vista and later. NTFS is really the best. UDF and exFAT can't support asynchronous writes safely, or at least UDF can't outside of BSD.

>> No.68255929

>>68255821
you misunderstood, i have a dual boot PC (winshit and GNU/Linux) with secure boot and can't use virtualbox (on GNU/L) because it has to install drivers to the kernel, which changes its signature.
problem is i don't want to disable SB because of the winshit OS

>> No.68255933

I can't do netinstalls, what are the most bleeding edge distros available to me, is void netinst?

>> No.68255960

>>68255929
virtualization without VT-X/AMD-V will be subpar anyway, just disable secure boot

>> No.68256011

>>68255929
There's something severely fucktarded going on with how you're handling the Linux side, but just disable secure boot and you won't have to think about it.

>> No.68256088

>>68255583
pls respond

>> No.68256091

>>68255583
Gallium OS is just Xubuntu for chromebooks

>> No.68256116

>>68256091
So... yes? Sorry I am a complete brainlet when it comes to Linux, but I'm making an effort to learn.

>> No.68256157

>>68256116
aren't chromebooks arm-based? steam is x86-only

>> No.68256192

>>68256157
I have the Samsung Chromebook 3 which has an intel processor. So no, I don't think so.

>> No.68256249

Simplest way to create a single color image of any size?

>> No.68256256

Installing arch linux and trying to set up grub:
mount /dev/sda2 /mnt/efi
grub-install --target=x86_64-efi --efi-directory=/dev/sda2 --bootloader-id=GRUB
grub-mkconfig -o /boot/grub/grub.cfg


After rebooting, I get kicked straight to GRUB shell, no error messages, no boot menu. Where did I fuck up?

>> No.68256263

>>68256249
>>>/sqt/
fuck off

>> No.68256269

>>68256256
oops, --efi-directory was set to /mnt/efi not /dev/sda2, so that wasn't the problem I don't think

>> No.68256341

>>68256263
Not a simple question.

>> No.68256423

>>68255840
lsblk

>> No.68256431

>>68255840
fdisk -l

>> No.68256510

>>68256431
i have just tried that and it lists only partitions on my one and only HDD which it does correctly nonetheless
however it wont prompt me with my phone being connected although thunar can properly detect it and browse files on my phone

>> No.68256520

Third time returning to linux.

Going to dualboot it with windows 7 for application compatibility on an old HP Touchsmart 600 AIO.

Originally circa 2001-2003 I started on Suse. 2009-2013 I ran Ubuntu before it was completely botnet and then at last try in 2016 I was using mint linux. Is mint still a decent choice for productivity? I would use a more advanced distro for my particular hardware, but I'm really just trying to have something that would work as a daily driver with minimal setup.

Any gaming is likely going to occur on the Windows 7 side with how dated the hardware is becoming.

>> No.68256523

>even getting shilled for Manjaro on youtube recommended videos
the hebrews are behind this, without a doubt

>> No.68256524

>>68256510
maybe because the phone is accessed via mtp and not via traditional block devices?

>> No.68256529

>>68256116
XFCE is easy to rice/theme
Steam will most likely work

>> No.68256570

https://repology.org

>> No.68256574

>>68256524
silly me, it actually is. can you give me a quick rundown of what mtp ie exactly before i dig into that?

>> No.68256575

>>68256249
If your intention is to use it as a wallpaper then just use "xsetroot --solid #cc0000".
Otherwise look up how to do it with imagemagick. Should be a simple 1 line command.

>> No.68256583

>>68256574
no, go on fucking wikipedia and read about it.

>> No.68256593

>>68256520
Mint or one of the Ubuntu spins should be fine.
KDE Neon/Kubuntu might work nicely with a touchscreen if you want to rice things up

>> No.68256617

>>68256523
Why do you people even care so much? There is _always_ going to be a distro being pushed to new users.
It's not the distros fault, it's just how things are, and I suspect it's only going to happen more and more as GNU/Linux becomes more popular. What do you get out of pointing this out anyway? Do you like bashing on the flavor of the year distro for new users? Does it make you feel more elite?
Get the fuck over it.

>> No.68256645

>>68256510
Is it just the one phone you need? After you open it with thunar, you can list mounted devices with mount -l
It'll probably be in the same place next time.
ls /dev will also list all your devices, though it doesn't explain what anything is.
Googling for "mtp mount" will probably give you more broad resources on what's going on.

>> No.68256682
File: 506 B, 1337x1337, out.png [View same] [iqdb] [saucenao] [google] [report]
68256682

>>68256249
convert -size 1337x1337 xc:\#00ff00 out.png

>> No.68256711

>>68256593
Thanks. Will check out KDE Neon.

>> No.68256767

>>68256645
I recommend searXing instead.

>> No.68256792

Do not use Manjaro.

>> No.68256805

Bout to move to Linux again on my main rig. I'll have an SSD mounted with /, and a hard drive mounted with /home. However, for some programs and games that thrash the hard drive with lots of random reads, I want to put them on the SSD.

Is there a way to do that? Maybe make a folder called /extra in the root system and give myself permissions to it?

>> No.68256888

>>68256805
All your programs will be installed to /usr/bin and /etc or /opt or /usr/share with your package manager. You dont need to fuck around with the fs hierarchy for that. For games just make /games and point everything there, including steam as a secondary library

>> No.68257063

>>68256682
> File: out.png (506.00 Byte
Damn, not even 1 KB.

>> No.68257065
File: 152 KB, 466x492, 1419739124772.png [View same] [iqdb] [saucenao] [google] [report]
68257065

>ibm has acquired redhat

>> No.68257087

>>68257065
how this will affect systemd?

>> No.68257124

>>68257065
YO WTF!

>> No.68257187

clinfo says my device is compatible and ready but when i use opencv programs, they all state t hat their is no card.
Is there another way to expose the card to these programs?

>> No.68257190

whats a good DE thats touch screen friendly? is it only gnome?

>> No.68257200

>>68257065
fuck its real. days without jewish tricks: 404 not found

>> No.68257232

>>68257065
lmao you weren't lying

>> No.68257242

>>68257065
i can finally see it

>buy ibm server
>read manual
>supported operating system: windows server , red hat enterprise

>> No.68257260

someone post their ubuntu 18.10 ram usage

>> No.68257262

Don't worry, Fedora will still be shit and a runner-up to Ubuntu in every possible way.

>> No.68257265

>>68257065
implying redhat could get worse than it already is

>> No.68257332

>>68257242
Nah, HP does the same. Can't get debs for their drivers.

>> No.68257377

>>68257262
Spotted the /v/ermin.

>> No.68257601

I am giving a presentation on software freedom to a class of normies. What do you think would be most interesting or relevant to them? NSA? Facebook/Twitter spying (particularly keeping records on people who don't use Facebook/Twitter)? Or just general pragmatic ideas they might like?

>> No.68257651

>>68256792
Why?

>> No.68257753

Using Windows 7 and want to try out Linux, is Devuan a good OS for beginners?

>> No.68257768

>>68257601
talk about stuff they have at and and can scare them. Like spyware and tracking their phones, facebook data collection and abuse, dangers of the vulernabilities of internet of shit, similar.

>> No.68257778

>>68257753
Devuan is for existing debian users who dislike systemd. Beginners should start with ubuntu, opensuse, mint, similar.

>> No.68257779

>>68257601
show them this page https://prism-break.org/en/categories/windows/ and ramble on like a crazy conspiracy lunatic .... which is what anyone sounds explaining freedom to normies.

>>68257753
why not try it out? download virtualbox and mess around, it's how I got started using linux

>> No.68257923

Is Fedora now compromised by effective IBM ownership?

>> No.68257940

>>68257779
No, the retards are getting on board 10 years late. Something like 50% of young people deleted Facebook from their phone in the past year due to the Zuck trial. Almost everyone has stories about talking about something aloud and getting ads for it minutes later too. Will they ever do something about it? No, of course not, they are born and bred slaves. However, I can show some people that there is an option. I'm not gonna talk about crypto or dark web or other schizo stuff.

>> No.68258012

>>68257778
>mint
Is not appropriate for anyone.
>suse
Because I want to be IBM and Merkel's bitch at the same time.

>>68257753
Xubuntu 18.10

>> No.68258027

>>68258012
>>suse
>Because I want to be IBM and Merkel's bitch at the same time.
see a doctor, you need professional help or euthanasia.

>> No.68258056

>>68252292
Why when I start Eve Online after using CrossOver to install it, it stops downloading and I have no fonts? Ubuntu 18.04.1
Thanks

>> No.68258097

>>68258056
>it stops downloading and I have no fonts?
How are we supposed to know?

>> No.68258129

>>68257242
>>buy ibm server
>implying
the only servers they still sell use POWER and support AIX, Linux, and some mainframe monstrosity IBM decided to keep alive for some reason (no, not z/OS)
their x86 shitboxes were sold years ago to Lenovo

>> No.68258195
File: 15 KB, 800x600, wew.png [View same] [iqdb] [saucenao] [google] [report]
68258195

>>68257779
on it my man

>> No.68258262

>>68257923
Red Hat had contracts with most of the intelligence agencies IBM does. The only good reason to use Fedora in the first place is dogfooding with RHEL / CentOS.

I just hope someone from IBM takes a hammer to GNOME and the Poettering Pals Network. Those assholes have been in need of adult supervision for years.

>> No.68258274

>>68257601
Personally I think Windows 10 is pretty scary, and should be relevant to them. If I'm not mistaken it literally even uploads some of your files to MS without your permission.
Not only are things like that horrible privacy violations, but they're also using your own bandwidth that you're paying for to spy on you so that they can learn how to better advertise to you.

I also think people horribly underestimate the danger of "more relevant advertising". We're not talking about conveniently being aware of new products or something, we're talking about outright manipulation. You should look up statistics on how effective some of these "targeted ads" can actually be at swaying opinions.
This profiling is also used to change prices on things. For example, I've talked to a bunch of people who've noticed that they'll get a higher price for flights than their friends, and if they try to buy tickets on a different browser the price goes down.

Smart phones would also be a good area to discuss. For instance I think an average simple flashlight application on a smart phone contacts about 100 different servers sending them data on how you use your phone, who you talk to, what files you have or download.

There's another example I like which is hard to find much information on. But there was a leak of AOL data a long time ago and that was made available in some archive that you could browse. You could literally look up someone's IP and the date and see exactly what websites they went to and every link they would click on.
And that was before "big data" was the huge giant it is today. Imagine how fucking dangerous it would be if the massive quantities of information google or facebook have on you ever got leaked.

>> No.68258326

>>68258129
POWER RHEL is a good possibility then.

>> No.68258356

>>68258326
fucking NEETS
RHEL on POWER has existed for years

>> No.68258370
File: 878 KB, 1358x5170, boot_analysis.png [View same] [iqdb] [saucenao] [google] [report]
68258370

systemd-analyze
Startup finished in 5.576s (firmware) + 88ms (loader) + 3.678s (kernel) + 3.439s (userspace) = 12.782s
graphical.target reached after 2.919s in userspace


I basically can't do any more to get lower boot times unless I disable more services possible for my distribution and stop using a graphical environment, right? I am already using EFIboot and deferring or disabling what I don't need, but afterwards, snapd seems to be on the list but it will break a ton of dependencies.

>> No.68258374

>>68258027
> imagine being this upset
> this platinum mad
> at another country's technical prowess
> that you beg your own government to fuck you in the ass
> because you think it'll somehow spite them

>> No.68258434
File: 37 KB, 960x540, what is the source for what you say.jpg [View same] [iqdb] [saucenao] [google] [report]
68258434

>>68258274
>I think an average simple flashlight application on a smart phone contacts about 100 different servers
And I trust you have the Wireshark captures or router logs or whatever that show this?

>> No.68258449

OpenSUSE seemed to have a very convoluted setup compared to others... only distro. I never got working in a VM, I never tried again, so I'll give it another go maybe before I choose the distro to go with.

>> No.68258498

>>68258356
project a bit harder nigger. No truth exists without shouting gay/weeb/neet.

>> No.68258530

>>68258370
What is swapfile.swap?
Does that create a "temporary" swap file on every boot?
In that case, just make your own permanent one and add it to fstab, and disable the service.
Might shave off a bit of the time.

>> No.68258595

Is there a way to completely sandbox an application on linux? I'm mostly talking wine stuff (like photoshop) and steam games. Currently running it all in a VM, but maybe there's a better approach. I don't feel like running proprietary software "as is".

>> No.68258728

watchdog is detecting "hard lockups" on all my cpu cores, some list the "interrupt took too long" others are "BUG: soft lockup - cpu# stuck for Xs" while others are segfaults all over the logs the past few hours.

Is my cpu dying?

>> No.68258892

>>68258595
>completely
The VM is probably the best approach, assuming the software runs fine.
There's also the chroot jail, for restricting a program to only a certain part of the file system, but it's designed more for utility than security.
It does have some security, but if a program can escalate its privileges to root within the jail, it can get out.

You might look into it, but if your reason you're doing this is that you think the software you're running is specifically designed to fuck your shit up (or you want to assume that, on principle) you probably don't want to rely on it. A virtual machine is more secure.

>> No.68258960

>>68258530

No, it allocates the swapfile if you don't have a swap partition, I think. I could get rid of it via using a swap partition instead but it's not on the critical path and a lot of hassle for not much gain. I should also post the systemd-analyze critical-chain output.

$ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @2.919s
└─multi-user.target @2.919s
└─snapd.seeded.service @2.898s +21ms
└─snapd.service @1.957s +939ms
└─basic.target @1.834s
└─sockets.target @1.834s
└─snapd.socket @1.833s +790us
└─sysinit.target @1.827s
└─systemd-timesyncd.service @1.681s +145ms
└─systemd-tmpfiles-setup.service @1.655s +24ms
└─local-fs.target @1.650s
└─boot-efi.mount @1.638s +11ms
└─[email protected]\x2duuid-CB53\x2dD1EE.service @1.609s +28ms
└─dev-disk-by\x2duuid-CB53\x2dD1EE.device @1.608s


But yeah, I think at this point, it's trying to see how I can remove snapd without breaking KDE Neon. I know you probably would need to remove the Discover(Application Store) at a minimum but I think there's more stuff than that, there seems to be a framework snap installed and whatnot, and I don't have much more time to go over the installation until next weekend. Still, without optimization, it took roughly 28-30 seconds to boot, and getting it to less than half that is already a pretty good accomplishment in my books.

>> No.68259038

I'm on KDE neon and my Vega 56 stays at 800 MHz memory clock (stock max). The core can and will properly downclock, but I was unable to get any info on how to get the memory to downclock too. I can't change its power profile away from 'performance', either. Is this normal behavior, and if not, how can I solve both?

>> No.68259092

>>68258892
Good to know, so vm stays as it is. Is there anything better than barrier (synergy fork) for sharing mouse and keyboard? It's a vm with dedicated gpu.

>> No.68259257

How do i setup python virtenv so i dont have to do any extra shit?

>> No.68259260

>>68258960

Well, I did a leap of faith and removed it along with a bunch of KDE dependencies but it seems like KDE Neon kept trucking along fine without snap installed, which is great. My final stats:

$systemd-analyze
Startup finished in 5.465s (firmware) + 87ms (loader) + 3.954s (kernel) + 2.302s (userspace) = 11.809s
graphical.target reached after 1.756s in userspace

$ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @1.756s
└─upower.service @1.342s +413ms
└─basic.target @1.252s
└─paths.target @1.252s
└─cups.path @1.252s
└─sysinit.target @1.247s
└─systemd-timesyncd.service @1.096s +150ms
└─systemd-tmpfiles-setup.service @1.044s +48ms
└─systemd-journal-flush.service @327ms +714ms
└─systemd-journald.service @250ms +74ms
└─systemd-journald-dev-log.socket @248ms
└─system.slice @244ms
└─-.slice @242ms


That's probably it as removing upower and other systemd stuff is on the territory of using Void Linux or other init systems. Still, satisfied on a almost 3x reduction in boot times.

>>68259038

Performance for some AMD cards on Linux, but I think you might need to force dpm performance to solve the issue. Try the following:

sudo echo low > /sys/class/drm/card0/device/power_dpm_force_performance_level

Echo it back to auto when you need to use it to play games or something.

>> No.68259303

>>68253358
>tfw im on riced manjaro
Comfy.

>> No.68259378

>>68259260
It says permission denied when I run that command. I can change from auto to the alternatives in radeon-profile, but setting it to low doesn't help. Setting it to high clocks the core to max.

>> No.68259385

>>68254601
>step 1: boot into the usb drive that has mint mounted to it
>step 2: started installing mint
>step 3: during the installation setup process, choose to wipe whole hard drive then install mint

>> No.68259404

Are there any good wayland tiling/dynamic window managers that work with proprietary nvidia drivers?

>> No.68259500

>>68259378

Yeah then that sucks, because it won't fix it. What kernel are you using? You might want to try using the latest kernel and see if that fixes it, because it looks like a powerplay issue.

>> No.68259605

>>68259500
I am using the latest kernel, 4.19. I'm also running Oibaf's ppa.

>> No.68259647

>>68256520
Im back. I was able to get Mint 19 installed and had an adventure with Nouveau display drivers for half an hour.

Now when I was able to use nomodeset and then install Nvidia drivers it has gone into a test pattern loop and google has not helped me out.

Any ideas what is causing the system to lock onto a test pattern loop?

>> No.68259750

How do I a job with Linux? I have installed Gentoo but I want to be paid for it? Do I get certs or what?

>> No.68259769
File: 59 KB, 680x680, 9d5.png [View same] [iqdb] [saucenao] [google] [report]
68259769

Is there a distro that is actually the worst, while still functional?

People always fight over which is the best, but we never talk about which is the worst.

>> No.68259819

>>68259769
Slackware

>> No.68259825

>>68259750
Linux certs for Linux users provide Linux know-how for use with Linux.

>> No.68259865
File: 489 KB, 604x464, 1484718873521.png [View same] [iqdb] [saucenao] [google] [report]
68259865

>load liveusb
>smooth as fuck
>install and update
>restart
>everything is choppy as fuck, think its the gpu driver
>install it with the provided manual
>restart
>DE is broken

>> No.68259879

>>68259404
The proprietary nvidia drivers don't support Wayland compositors.
Go write an angrily worded letter to nvidia, sell your GPU, and buy a sensible GPU (AMD).

>> No.68259961

>>68259605

Yeah I dunno then. You should probably file a bug on it or wait for 4.20 Linux fixes. They did a lot of powerplay fixing there but not sure if anything there is relevant ti the issue you have.

>> No.68260040

I have an i7-2640M and 8GB RAM, why is Ubuntu no longer usable after the upgrade? Is GNOME getting shittier with memory usage or is my computer getting old?

>> No.68260046

Any shell script heros ITT can explain what is going on here? https://github.com/Bhai4You/SmS-BomB/

>> No.68260272

>>68252292
So I just used trash-cli to send a big ass directory to the Trash. And then I realized I trashed the wrong directory, so now I want to restore it.

Apparently trash-cli doesn't have a "Restore All" or "Restore this range" command.

When I looked it up, the solution people offered on the issues tab of their git was
while ( echo '0' | trash-restore ) ; do true; done;

Please tell me there's a faster way to do this and that I'm not gonna have to wait a year for this thing to finish restoring those files.

>> No.68260298

>>68260040
Lol.
GNOME's fault. Your hardware is waaaaaay more than sufficient.

>> No.68260304

>>68259385
Whats this I've been reading about firmware and having to unscrew something off my laptop mobo .

>> No.68260363

>>68260040
Stop using Gnome. You need at least 16GB and even that's barely enough. xfce and terminals are more than sufficient. If you crave eye candy, go back to Windows.

>> No.68260380

>>68259647
I'm now reinstalling Mint as I have spent over an hour trying to fix this problem.

I'm going to try and install an older set of Nvidia drivers and see if that corrects the issue. This is incredibly frustrating and now the third time I have attempted to get out of driver hell.

>> No.68260504

>>68260363
What's with people telling newbies to go back to W*ndows?

That's seriously your advice?

>> No.68260516

>>68260504
He still uses Xfeces post-2010, ignore him.

>> No.68260522

https://github.com/MasterOfWebM/WebM-Converter
how to run this on lignux?

>> No.68260536

>>68260516
Hey! Me too... I just started using Gn001337ux

>> No.68260539
File: 1.05 MB, 1920x1080, 1509829034338.png [View same] [iqdb] [saucenao] [google] [report]
68260539

>>68260298
I'm using an i7 with 8GB of ram and GNOME runs flawlessly for me

>> No.68260561

>>68260539
>that little activity
>that CPU and RAM usage
>flawlessly
>still uses Manjaro and hasn't even installed Arch yet let alone realized that it was shit and went back to Ubuntu
did all the good users leave these threads leaving only the memelords?

>> No.68260585

>>68260561
I've been using for 8 years. You're just a moron.

>> No.68260592

>>68260522
alternatively is there another script that just converts to webm automatically calculating the bitrate to fit into 4chan size limit?

>> No.68260598

>>68260380
only nvidia has this problem
if you want linux as a regular desktop, you really want an AMD card. the nvidia driver may be a bit faster, but amdgpu is far more pleasant to use

>> No.68260607

>>68260585
Using a kiddie pool distro for 8 years and calling other people morons? Have you been outside in that period of time?

>> No.68260641

>>68260539
Why the hell is it using so much of your CPU? haha

>> No.68260696
File: 315 KB, 2000x2000, 444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444444.jpg [View same] [iqdb] [saucenao] [google] [report]
68260696

>>68260607
>>68260641
>>>r/gatekeeping

>> No.68260728

>>68260598
I'm using an old AIO pc that I have laying around for productivity.

I need to do homework now so I'm just going to leave this be until I have some more time.

>> No.68260742

>>68260592
-b:v $((1024 * 8 * 3 / 60))k
For a 60 seconds and 3 megabytes webm.

>> No.68260777

>>68260696
Dunno hacker man, that's some odd spikes and high Cpu average readings there, have you got a ton of stuff open other than those 3 tabs?
what i7?

>> No.68260816

>>68260777
Doesn't matter. I could be rendering 4k video on my third monitor and you retards would still say dumb shit.

>> No.68260832

>>68260816
But you're not, you're using Manjaro and you're calling other people retards.

>> No.68260887

>>68260832
I used Arch for a few years. It has major breaks every once in a while and Manjaro avoids that issue entirely. Go fuck off to another thread.

>> No.68260911

How hard is it to set up a working active switch between Intel and Nvidia graphics using Bumblebee on Arch?
I've installed both drivers, (erroneously) believing I could then just go for LightDM and straight to i3, but I'm getting a black screen. I am guessing it's because it is confused whcih graphics ard to use.

>> No.68260921

>>68260742
trying to automate this, what's wrong with this script?
#!/bin/bash
LENGTH=$(ffprobe -i "$0" -show_entries format=duration -v quiet -of csv="p=0")
ffmpeg -i "$0" -c:v libvpx-b:v $((1024 * 8 * 3 / $LENGTH))k output.webm

>> No.68260933

>>68260887
How do you manage to break Arch?

>> No.68260934

>>68260911
Throw the nvidia card out. Buy AMD.

>> No.68260939

>>68260921
You need $1.

>> No.68261009

>>68260934
I have an XPS 15. But thanks for the advice.

>> No.68261032

Why doesnt this recurse subdirectories in the folder its executed from and execute the command?
#! /bin/bash
for f in *;
do
file="$(realpath "$f")"
script -o $file
done

>> No.68261046

Does linux have any problems with media playback, online or offline? I'm talking about FHD and UHD videos at 60fps from youtube or my storage and lossless music. Does linux have anything as good as foobar?
Are USB DACs plug and play on linux as well like they are on windows?
I want to buy a thinkpad to exclusively use Linux on. If Linux won't limit my productivity (uni stuff) or entertainment (movies, music, a little youtube, no games), I'll buy a decent used thinkpad and turn that into my main computer so i can force myself to get good at Linux.

>> No.68261075

Redpill me on IBM guise. Is RedHat doomed?

>> No.68261098

>>68261009
Dude just reinstall windows and buy an x220 for like $50 or something kek.

>> No.68261107

>>68261075
> govt it contractor buys govt it contractor
Clearly both are doomed.

>> No.68261135

>>68259865
What distro?

>> No.68261191

>>68261046
no loonex browsers support hardware-accelerated video playback, so even 720p videos will increase temperature and waste battery, alongside stuttery playback

>> No.68261197

>>68260696
I don't understand what you're saying here. I can get it from the context, but I have no idea what that subreddit has to do with anything you were talking about.

>> No.68261216

>>68260046
Regular 14 year old skiddy stuff.

requirements.sh uses apt to install a few packages(curl, php, figlet) and downloads

https://github.com/Bhai4You/bhai4you/blob/master/smsbomb.php

And start.sh runs it with gay colored text and a bunch of "sleep 3" command to make it look more l33t.

That kind of "obfuscation" is retarded, if you just replace eval with echo it will print the regular code.

>> No.68261217

>>68261046
>>68261191
Bullshit.
Chromium and firefox have gpu hardware rendering.

>> No.68261238

>>68260911
Install Ubuntu 18.10, it's the only distro that just werks with optimus hardware, and right now there's ongoing development (novidia prime) to make its usage even more seamless
Bumblebee is alright, but there's a noticeable performance loss.

>> No.68261261

>>68261217
Keep closing your ears to any loonex problem, but when the normie sees that freetardation only leads to lower battery usage they'd just bounce back to Windows.

>> No.68261262

>>68261238
Thank you, anon. That's really helpful.

>> No.68261283

>>68261238
>>68260911
This. I hate Ubuntu (because I am a more experienced autist and know how to manage without bloatshit) but I agree with this. Ubuntu isn't bad for beginners. Install minimal Ubuntu 18.10 and you'll be set for a long time man, you might not even have to switch from Ubuntu unless you end up falling for the /g/ memes like the rest of us. Go grab the Ubuntu 18.10 netinstall .iso

>> No.68261357

does a gentoo auto installing shell script exist? its definitely possible. there has to be at least one floating around out there.

>> No.68261367

>>68261357
That defeats the point of using Gentoo.

>> No.68261372

What’s the best distro for a new Linux user?

>> No.68261373

>>68261216
>of "obfuscation" is retarded, if you just replace eval with echo it will print the regular code.
Now i see., thanks. Not interested in this program anyway, but the obfuscation made me curious (forwhatpurpose.jpg).

>> No.68261404

>>68261357
Isn't that literally what CloverOS is?

>> No.68261407

>>68261372
Justin Bieber Linux

>> No.68261425

>>68261372
Hanna Montana Linux

>> No.68261428

>>68261372
Rebecca Black OS

>> No.68261431

>>68261372
Apartheid Linux

(I started with Lubuntu because it is nice and light on your machine, but I found Xubuntu suits me better. Now I'm running Debian with xfce (what xubuntu uses as well) and I am pretty happy with it.)

>> No.68261432

r8
#!/bin/bash
name=$(basename "$1" | cut -d. -f1)
LENGTH=$(ffprobe -i "$1" -show_entries format=duration -v quiet -of csv="p=0")
LENGTH=${LENGTH%.*}
ffmpeg -y -i "$1" -c:v libvpx -pass 1 -b:v $((1024 * 8 * 3 / $LENGTH))k -f webm /dev/null && \
ffmpeg -i "$1" -c:v libvpx -pass 2 -b:v $((1024 * 8 * 3 / $LENGTH))k -f webm $name.webm

>> No.68261435

>>68261367
eh, in a way, but no one on /g/ uses gentoo for the purposes its meant for, its just a status symbol here. as long as you run a deblobbed gentoo install you are cool. im sure at least one of these retards here has created a script that automates the process of installing deblobbed gentoo
>>68261372
debian netinstall if you arent into bloat, want a clean experience, want a good distro, and want to dedicate yourself to learning linux
debian xfce if you want a windows-like experience for your first linux install, a clean experience, dont mind bloat, and just want to get rid of botnet operating systems
ubuntu netinstall if you arent ready to dive that far in but plan to keep linux
ubuntu if you are just testing the waters
>>68261404
correct with im wrong, but i dont think cloveros is c o m p l e t e l y deblobbled, i think it just auto installs gentoo without systemd

>> No.68261436

>>68261372
Linux for Niggers

>> No.68261445
File: 366 KB, 2048x1365, DaveoL7VMAA6vci.jpg_orig.jpg [View same] [iqdb] [saucenao] [google] [report]
68261445

>>68261262
Been bouncing around various distros, only 18.10 (and soon 18.04) actually works well with optimus setup.
Fedora works ok with bumblebee, but there's that performance loss (20-30% IIRC) and I can't get it to work with only dedicated card in the BIOS - all route leads to X failing.
Manjaro sets up bumblebee during installation automatically; didn't have to do anything. Nice. But the forum has a thread by a developer to attempt what Ubuntu did (nvidia prime) due to that performance loss.
MX Linux is the same as Manjaro. Nice too.
OpenSUSE has instructions to use bumblebee in their wiki but it's still bumblebee.
But only Ubuntu handles it properly, as of now, the nvidia prime setup allows full performance/usage from the dGPU, with the only gotcha being that the iGPU is still turned on so (a bit of) power is still wasted. Doesn't matter much really, what I want is full power, and in launchpad right now devs are testing new code to really turn off the iGPU.

It's kinda like switching those cards fully from the BIOS, but instead of a full reboot it's just a simple logout/login.

>> No.68261447

>>68261372
I started with Xubuntu and switched to Arch after a month.

>> No.68261454

Is there any course i can read/follow in order to have useful knowledge about Linux Distros?

I know some commands and how to solve some minor problems like updating apt sources or running/starting services but i would like to learn stuff so that i dont have to depend that much on googling.

>> No.68261466

redpill me on base64

>> No.68261469

>>68261432
Install shellcheck for high quality rating.
https://www.shellcheck.net/

>> No.68261477

>>68261466
It's one number higher than base63.
Unrelated to Area 51 (so they say)

>> No.68261490

>>68261466
Crypographically better than rot13.

>> No.68261496

>>68261372
Dont fall for a distro with systemd. if you want a fairly simple to install distro that youll be able to stick with for a while that doesnt use systemd, try out void. Devuan (systemdless debian) and parabola (systemdless libre arch) are okay but not that beginner friendly.

>> No.68261501

>>68261432
$name needs to be quoted at the end.

>> No.68261503

>>68261466
It's useful when you need to store anything in plain text.

>> No.68261505

>>68261466
it's a stream coding that uses 64 possible values per character, rather than say, 256 for a byte
the 64 values are picked for being printable. base64 is often used to convey binary data over media which only support printable characters, such as email

>> No.68261514

>>68261469
>>68261501
nice site
#!/bin/bash
name=$(basename "$1" | cut -d. -f1)
LENGTH=$(ffprobe -i "$1" -show_entries format=duration -v quiet -of csv="p=0")
LENGTH=${LENGTH%.*}
ffmpeg -y -i "$1" -c:v libvpx -pass 1 -b:v $((1024 * 8 * 3 / LENGTH))k -f webm /dev/null && \
ffmpeg -i "$1" -c:v libvpx -pass 2 -b:v $((1024 * 8 * 3 / LENGTH))k -f webm "$name".webm

>> No.68261541

whats the difference between uniq -u and just uniq?
Doesnt uniq already remove anything thats not a unique string?

>> No.68261581

>>68261238
It does NOT work well with optimus.

It has been 8 years and it does not work well in any implementation because it is a driver issue that Nvidia has forgotten about and Nouveau will not fix

>> No.68261611

>>68261541
-u causes uniq to not print numbers that are not unique
for example, "1, 1, 2, 3" becomes just "2, 3", rather than "1, 2, 3"

>> No.68261639

Are AMD Ryzen APUs compatible with linux? Like a 2700u. Google says you need to have a modern kernel, but other than that it should be fine, right?

>> No.68261644

>>68261541
uniq prints the unique lines
uniq -u prints the unique unique lines
$ printf 'foo\nfoo\nbar' | uniq
foo
bar
$ printf 'foo\nfoo\nbar' | uniq -u
bar

>> No.68261656

>>68261581
Learn to read.

>> No.68261680
File: 5 KB, 199x250, 617.jpg [View same] [iqdb] [saucenao] [google] [report]
68261680

Hearing about the interesting news from earlier, should we continue to use Fedora or move on to another distro?

>> No.68261691

>>68261680
>he uses fedora

>> No.68261716

>>68261680
I mean, Fedora is an okay distro and all, but it's repositories are bare and it's literally just feature testing for Red Hat Enterprise, so it was never fit for use as a daily distro. You should definitely move on. Give installing Gentoo a spin (uniroically), and then settle for Debian if you can't.

>> No.68261740

>>68261445
I understand. I've read some articles now on both the Arch Wiki and several other sites and most of them say that it only works seamlessly with the nouveau driver. But this driver seems to be suboptimal when it comes to power according to this https://wiki.freedesktop.org/nouveau/Optimus/

Does Ubuntu solve this somehow? Is this the same power drop that can be expected from Bumblebee?

I apologise for the additional questions. I am already very grateful for the information you provided. It helped me start to really understand the problems.

>> No.68261748

Is using PPAs, Flatpaks and Snaps the best way to get up-to-date software while keeping the base stable?

I still want the latest updates for applications Inkscape, LibreOffice, etc but I want a stable system.

>> No.68261755

>>68255060
Just disable the libreJS plugins and you are fine.
Posting from IceCat Myself.

>> No.68261777

>>68261748
New software isn't stable software.

>> No.68261800
File: 23 KB, 360x270, 1435738240590.jpg [View same] [iqdb] [saucenao] [google] [report]
68261800

>>68257065

>> No.68261810

>>68261716
What about Opensuse? Is that a good alternative?

>> No.68261819
File: 3.95 MB, 320x320, 1488481711384.gif [View same] [iqdb] [saucenao] [google] [report]
68261819

>finally understanding certain things
I've got a long way to go, but I never knew learning the command line could be such fun bros.

>> No.68261837

>>68256570
Thanks my man

>> No.68261848

>>68261819
Welcome fellow hackerman.

>> No.68261870

>>68256570
Why does nix package so much stuff?

>> No.68261888

>>68261810
OpenSUSE is pretty good, I suggest it, be weary that installation times can be pretty wicked though (in my experience). If you want something simple and customizable like OpenSUSE that doesn't take so long to install, try Arch.

>> No.68261894

yo guys.

i intall ubuntu(18.04 lts) and i was trying to install the drivers of my graphic card (readeon hd 6770).

i did everything that is listed in the amd website. but when i reboot my pc after installing the drivers, it stay stuck on the boot screen, and theres nothing i can do about it.

i re-install ubuntu after that, so im at point 0 again.

how can i know if i already have installed the graphic drivers? and if i need to install them, how can i do it without fucking up?

>> No.68261909

>>68261894
Just install them and install the free version of your drivers just in-case. If it fails again, hop to another distro.

>> No.68261941
File: 3.60 MB, 2660x3167, 1532415918198.jpg [View same] [iqdb] [saucenao] [google] [report]
68261941

>>68261740
Yes, nouveau works seamlessly, and with gnome/gnome-unity/budgie installed, right-clicking icons in the launcher will start the program using the nouveau driver. However it only runs the card at lowest frequency, you'd get subpar performance eitherway. Still it's the closest there is to how optimus runs in Windows - iGPU all the time, dGPU for chosen programs.
Ubuntu 18.10 through its own in-house nvidia-prime package, by a toggle in the nvidia-settings, allows you to choose either the iGPU or dGPU system-wide, and makes this change after a logout/login. It gives full power by the way, not at a loss like bumblebee/nouveau.
In 18.04 you'd need to fully reboot due to X fuckery, but in 18.10 it's far easier as described above. Just install the driver from the software updater settings, reboot and done. Only caveat is that the iGPU is actually turned on all the time, but shouldn't take much energy since it's not used.
Ubuntu devs are working to fix this right now, and a backport to 18.04 is expected soon so no more reboots to switch cards.

>> No.68261972

>>68261909
ok, ill try it.

is there any way to start the desktop in a "safe mode" and "restore" the system?

>> No.68261980

>>68261972
You should be able to restore the system with the bootable drive you installed it with.

>> No.68261986
File: 167 KB, 899x1199, lim.jpg [View same] [iqdb] [saucenao] [google] [report]
68261986

What is the best ease-of-use program to back up my files to later restore. I suspect my system may be compromised

>> No.68261990

is there something like VNC that uses x264 instead? not for games, so doesn't need to be super low latency, i just think it'd be more efficient than sending low quality jpeg's

>> No.68262018

>>68261980
okay

>> No.68262026

>>68261972
>>68261980
Oh, also, if Ubuntu fails again try switching to Arch, Arch has a lot of community support for this type of thing.

>> No.68262117
File: 32 KB, 480x206, akbar.webm [View same] [iqdb] [saucenao] [google] [report]
68262117

>>68262026
>switching to Arch

>> No.68262135

>>68262117
it isnt a trap in the year 2018 if you arent retarded

>> No.68262167

>>68262135
Dude, I am using an obscure distro, I could guide noobs through installing it and using it daily with no problem, that doesn't mean I want to recommend it to them.

>> No.68262181

>>68262167
Then you sir, are an idiot..
Also
>Dude

>> No.68262214

>>68262167
only brainlets think arch is bad

>> No.68262231

>>68262181
>'sir'
>>>reddit

>> No.68262300

>Look up problem
>Links to forum topic 6 pages long
I fucking hate this so much.

>> No.68262323

>>68252292
Brainlet here, how can I Install this on Ubuntu?
https://github.com/ahodesuka/ahoviewer
running ./bootstrap doesn't work and gives some error like this:
configure.ac:63: error: possibly undefined macro: AC_MSG_ERROR
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.

>> No.68262343

>>68262300
Problem?

>> No.68262359

>>68262343
An item in whisker menu is broken but still in the menu. If I try and delete it with menulibre (which usually doesn't fucking work) it doesn't show up there, neither is it in the applications folder.

>> No.68262363

>>68262323
Do you satisfy all the dependencies?

>> No.68262377

>>68262363
How am I able to do that? Do I just sudo apt install (all the dependencies the github uploader put)?

>> No.68262384

>>68262359
Distro?

>> No.68262390

>>68262323
Ask the developer to stop using such a shitty build system.
Anyway, you need to install the appropriate development tools. e.g. on Debian you install the 'build-essential' group.
You also need to go through and install the development version of the dependencies if your distro does that.

>> No.68262391

>>68262384
Debian

>> No.68262395

>>68262377
Yes

>> No.68262396

>>68262377
Yes.

>> No.68262403

>>68261075
More like finally not full of commie shit software

>> No.68262412

>>68262391
Try this:
sudo apt-get install i3wm i3-bar

>> No.68262433

>>68262412
Computer says no.
Can't locate i3wm and i3-bar

>> No.68262449

>>68262433
Try this:
sudo apt-get install i3 suckless-tools

>> No.68262493

>>68262433
>>68262449
Any luck?

>> No.68262500

>>68262493
Wait, why did I have to install i3 for a lost menu icon?

>> No.68262509

>>68262500
There's a library repair tool built into i3. It'll repair libraries that are fucked. This could solve your problem.

>> No.68262524

>>68262509
I'm first gonna restart the computer, and maybe even dump XFCE, because it's constantly shit like this.

>> No.68262535

>>68262412
>>68262433
>>68262449
>>68262493
>>68262500
>>68262509
He fucking with you.

>>68262359
Just check your .desktop files in the usual places and make sure there isn't anything there that isn't obviously fucked up
- ~/.local/share/applications
- /usr/share/applications
- /usr/local/share/applications

>> No.68262564

>>68262535
Shut the fuck up, no one asked you to post.
>>68262524
Yeah, sudo apt-get remove xfce4
git clone https://github.com/Airblader/i3 and git clone https://github.com/jaagr/polybar for maximum comfort.

>> No.68262634
File: 86 KB, 600x388, 1540162548787.png [View same] [iqdb] [saucenao] [google] [report]
68262634

>>68262564
This is unforgivable. I can't believe you've done this.
>>68262535
There were a couple of ghost files in .local, deleted them and now it's fixed. Thanks!

>> No.68262660

>>68262634
Post desktop. Now.

>> No.68262664
File: 128 KB, 1013x760, 1540527685145.jpg [View same] [iqdb] [saucenao] [google] [report]
68262664

>>68262660

>> No.68262673

>>68262664
Post desktop or get the fuck out of here, stupid frogposter.
Could've had a comfy i3 rice but no, you chose ratDE.

>> No.68262702
File: 215 KB, 480x605, unlimitedpower.jpg [View same] [iqdb] [saucenao] [google] [report]
68262702

>>68262673
I'm not ready yet to put my big boy pants on and start using i3. Give it a week, and then I will probably be fed up xfce.

>> No.68262708

>>68262702
How long have you been using XFCE?

>> No.68262720

>>68262708
two weeks

>> No.68262745

>>68262720
Well, I'd suggest you get all your shit setup now.
Make sure you have git installed and then git clone https://github.com/Airblader/i3 to install a fork of i3 called i3-gaps, which adds modifiable gaps between windows. Then git clone https://github.com/jaagr/polybar to get Polybar, an alternative to i3bar that (in my opinion) looks better. Finally, to finish off your new fresh Debian rice, sudo apt-get install i3blocks.
A lot better than XFCE.

>> No.68262775

>>68262745
lemme bookmarks these, because I probably will switch sometime soon.

>> No.68262862

>>68262775
Lemme run through all the processes of installation for them, and then run you through misc. packages to add to the rice.
git clone https://github.com/Airblader/i3
cd i3-gaps
autoreconf --force --install
rm -rf build/
mkdir -p build && cd build/
../configure --prefix=/usr --sysconfdir=/etc --disable-sanitizers
make
sudo make install
cd polybar
./build.sh
cd
sudo apt-get install i3blocks

That's the whole installation process for the necessary stuff.
Misc. -
Cmus - a terminal based music player.
git clone https://github.com/cmus/cmus
cd cmus
./configure prefix=$HOME/cmus
make install
cd

Neofetch - I'm sure you already know what this is if you use /g/.
sudo apt-get install neofetch

Ranger - terminal based file manager.
sudo apt-get install ranger

That's pretty much it.

>> No.68262875

>>68262862
*git clone https://github.com/Airblader/i3
cd i3-gaps
autoreconf --force --install
rm -rf build/
mkdir -p build && cd build/
../configure --prefix=/usr --sysconfdir=/etc --disable-sanitizers
make
sudo make install
cd
git clone git clone https://github.com/jaagr/polybar
cd polybar
./build.sh
cd
sudo apt-get install i3blocks
[code][/code]

>> No.68262913

>>68262862
Dayum, Ranger looks comfy as fuck.

>> No.68262932

>>68262913
it be

>> No.68262973
File: 13 KB, 447x61, Screenshot_2018-10-28_22-23-19.png [View same] [iqdb] [saucenao] [google] [report]
68262973

Henlo fren, rec me a distro + WM for this hardware

>> No.68262984

>>68262973
devuan/parabola/void + i3
take your pick of the three

>> No.68263040

>>68262984
IS the Beowulf release of Devuan the equivalent of Debian testing?

>> No.68263129

>>68262984
Wait i am looking through the devuan website and all i see are downloads for ascii, or debain stable, is there no testing or do i have to upgrade??

>> No.68263227

>>68263040
>>68263129
Here, official mirror:
https://devuan.c3l.lu/devuan_jessie/installer-iso/devuan_jessie_1.0.0_amd64_NETINST.iso

>> No.68263303

>>68261870
Yeah there's no way it's that large. That's 4/3rds the size of Debian's repos which is insane for a non-mainstream distro.
My guess is they're counting hashes, not actual packages. It's the same reason why if you don't run garbage collection on nix/guix and run screenfetch it'll show a larger than normal number of packages installed because it doesn't delete old stuff until you ask it to and they get counted as packages.

So if they're doing the same thing on the build farm "hydra" then they're probably counting packages multiple times just because it has different versions available in the repo.
They need a better way to count packages in those distros.

>> No.68264146

How to I tell MPV to replay certain files, like a webm for example.

>> No.68264261

What's the most polished polished spin of Manjaro?

Been running Deepin and I like it but it's got a few annoying bugs.

Don't want XFCE or KDE. Trying to get off the i3 meme. Don't feel like configuring a lot but I guess I could do the OpenBox version?

>> No.68264303

>>68264261
Budgie or Mate

>> No.68264375

>>68264146
man mpv /loop

>> No.68264607

new linus tech tips interview.
https://www.youtube.com/watch?v=pQWj2Fgxdrc

>> No.68264609

>>68255933
I just download the live non-free iso, and just install it at the boot. No issues, just do Debian testing or really Arch is a real bleeding edge distro

>> No.68264820

>>68264146
Add this to your mpv.conf to specifically loop webm's
[extension.webm]
loop-file=yes

To make all media loop in MPV, just add this line to your general settings :
loop-file

>> No.68265819

Memes:
>>68265814
>>68265814
>>68265814

>> No.68265972

>>68252384
Install gentoo

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action