Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

If you can see this message, the SSL certificate expiration has been fixed.
Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 363 KB, 700x506, Ted_Blanchett.png [View same] [iqdb] [saucenao] [google] [report]
66847028 No.66847028 [Reply] [Original] [archived.moe] [rbt]

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: just like in /sqt/ spend at least a minute to check a web search engine with your question.
*Search: qwant, searx, ixquick or startpage.
*Many free software have active mailing lists.
*Many free software has an active bugzilla where you can check and report errors

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux: https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux
>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page
>What are some cool terminal commands?
http://www.commandlinefu.com/
http://cheat.sh/
>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/
>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html
>How to break out of the botnet?
https://prism-break.org/en/categories/gnu-linux

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

Previous thread: >>66834657

>> No.66847051

nth for just installed i3
it's all uphill from here lads.

>> No.66847065

Install GuixSD

>> No.66847083
File: 64 KB, 736x448, adventure_mc-fileviewer.png [View same] [iqdb] [saucenao] [google] [report]
66847083

please identify the font being used to edit GNU Bash conf with GNU MC on GNU/Linux

>> No.66847128

>>66847028
Which is better?

Anarchy, Antergos or Manjaro?

>> No.66847158

>>66847128
Anarchy.

>> No.66847223

>>66847028
>linux politics
>>66847083
consolas?

>> No.66847248

>>66847083
Hack and source code pro look similar. Dotted 0 are degenarate though.

>> No.66847286 [DELETED] 
File: 182 KB, 1366x768, Screenshot from 2018-07-22 23-57-00.png [View same] [iqdb] [saucenao] [google] [report]
66847286

Alright, I tried for like two hours to resize this shit and all I succeeded in doing breaking everything and having to dd from the original drive again.
Clearly my IQ isn't high enough to understand luks.
help
>dd'd a 128GB SSD to a 256GB one and want to resize my / and /home in the lvm
I'm already in a live environment, here's the setup

>> No.66847328

>>66847286
https://wiki.archlinux.org/index.php/Resizing_LVM-on-LUKS

>> No.66847360

>>66847328
>>66847286

more specifically https://wiki.archlinux.org/index.php/Resizing_LVM-on-LUKS#Enlarge_LVM_on_LUKS
cryptsetup open /dev/sda5 CryptDisk
pvresize /dev/mapper/CryptDisk
lvresize -l 100%FREE #assuming this works idk
resize2fs -p /dev/CryptVolumeGroup/Home $size

also, don't use DD use cp or cat to copy your disk. dd is too dumb

>> No.66847375
File: 59 KB, 1080x1080, 1532244498384.jpg [View same] [iqdb] [saucenao] [google] [report]
66847375

I'm relapsing back into an arch ricing phase again

>> No.66847391
File: 188 KB, 640x360, moo3.png [View same] [iqdb] [saucenao] [google] [report]
66847391

>>66847375
install gentoo
stop ricing, start compiling!

>> No.66847407

linus is a carnal

>> No.66847413

How to reinstall boot loader from localhost?

>> No.66847439

>>66847413
>How to reinstall boot loader from localhost?
which bootloader?
gpt/efi or mbr?
what is localhost? you mean current machine? how can you boot the current machine if the bootloader doesn't work? do you need to mount it with a live environment and run the commands?

>> No.66847442

>>66847413
Laptop won't recognize or boot into USBs.
Good luck with this one

>> No.66847451

>>66847442
you need to go into boot settings of your device's firmware or BIOS to change boot order or select which device to boot from. you may need to disable features like secure boot

>> No.66847469

>>66847128
Manjaro. Manjaro is better than Arch itself.

>> No.66847470

im writing a linux kernel module for an undocumented USB device.
problem is, the usbhid(hid-generic) keeps claiming the device for me before my kernel module gets to register it.

even when i edit udev rules to stop it, hid-generic keeps claiming it.

how do i write my kernel module in such a way to stop usbhid from claiming or how do i stop it from claiming this particular device's vendor:device id

>> No.66847481

>>66847470
use a kernel parameter to assign your module to it

>> No.66847484

>>66847451
I have only USB selected and it says "No bootable devices found."

>> No.66847489
File: 503 KB, 1366x768, Screenshot.png [View same] [iqdb] [saucenao] [google] [report]
66847489

Do you guys like my desktop? Look at my custom pepe start menu icon. Haha!! So cute.

>> No.66847493

>>66847470
Nobody itt has any idea about linux, sorry.

>> No.66847495

>>66847469
no

>> No.66847498

>>66847481
this can't just be what everyone does.

if someone wants to use my driver i cant just ask everyone to add a kernel parameter.
something that scales would be better as i am writing a kernel module not just for myself.

>> No.66847502

>>66847489
>two lines for PS1
>hostname in PS1 on GUI
why

>> No.66847515

>>66847502
I don't have a PS1 emulator installed, what are you talking about? I'm new here.

>> No.66847522

How do I set the priority order of my sound cards?

[[email protected] ~]$ cat /proc/asound/cards
0 [HDMI ]: HDA-Intel - HDA Intel HDMI
HDA Intel HDMI at 0xf0630000 irq 50
1 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf0634000 irq 49
2 [v12 ]: USB-Audio - SABAJ DA3 v1.2
SABAJ SABAJ DA3 v1.2 at usb-0000:00:14.0-1.1, high speed
3 [AK5370 ]: USB-Audio - AK5370
AKM AK5370 at usb-0000:00:14.0-1.3, full speed
[[email protected] ~]$ cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel
2 snd_usb_audio
3 snd_usb_audio


On the arch wiki (https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture#Set_the_default_sound_card) and stackexchange (https://superuser.com/questions/626606/how-to-make-alsa-pick-a-preferred-sound-device-automatically#630048) it says to add:


options snd_hda_intel enable=1 index=0

options snd_hda_intel enable=0 index=1


From my output I have two cards that are snd_hda_intel and two cards that are snd_usb_audio. I want the default to be the Sabaj then the laptop speakers (I'm guessing HDA Intel PCH) and then HDMI last (AKM is usb mic).

in options snd_hda_intel enable=1 index=0

options snd_hda_intel enable=0 index=1
what differentiates each sound card?

>> No.66847526

>>66847498
look at how other modules, ones not included in the linux kernel, are written? zfs?

>> No.66847563
File: 45 KB, 850x400, 1532320793041.jpg [View same] [iqdb] [saucenao] [google] [report]
66847563

What are some cool terminal commands?

>> No.66847567

>>66847484
How do you reinstall a Windows boot loader from localhost when the computer is disconnected and it cannot sense USB's?

>> No.66847574

>>66847567
>>>/g/sqt

>> No.66847590
File: 177 KB, 500x280, 1531863301818.png [View same] [iqdb] [saucenao] [google] [report]
66847590

I installed Gentoo a few weeks back and it's gone pretty well, but every time I use emerge I feel I'm fucking everything up.
>emerge -a foo
>has a fuck ton of use flags disabled
>want some of them enabled but not permanently
>sometimes modify make.conf to set the use flags per package
>sometimes set them temporarily inside the shell
>hit confirm to install the package
>2 billion .zz-autounmask files to be updated in /etc/portage
>just overwrite them all to get things going
>package compiles and runs with no issues
Am I making a huge fucking mess for myself? Will the temporary use flags I set get unset when the package is updated? Does clobbering the autounmask files result in side effects?

>> No.66847597

>>66847574
I blame it on post-Windows 8 hardware, even though the computer came with Windows 7 Pro.

>> No.66847607

>>66847248
>Dotted 0 are degenarate though.
how tf you differentiate between 0 and O?

>> No.66847626

>>66847360
lvresize gets stuck on Insufficient free space: 3840 extents needed, but only 0 available
even though I ran pvresize and it said 1 volume expanded
I'm at a loss here

>> No.66847638

>>66847607
Slashed ofc.

>> No.66847640

>>66847563
:(){ :|:& };:

>> No.66847652

>>66847640
You(){ You|You & };You

>> No.66847659

>>66847563
More like
>I wrote a fucking kernel. Stallman has not finished his kernel yet and suffers humiliation from Linus.

>> No.66847676

>>66847659
>he doesn't know terry quotes
Found the atheist.

>> No.66847696

>>66847590
>ohshitniggerwhatareyoudoing.jpg
make.conf is ONLY for global use flags. You set per-package use flags in /etc/portage/package.use
custom masks go in /etc/portage/package.mask
and keyword overrides in /etc/portage/package.accept_keywords

Yes all the current use flags you've set will get reverted the next time they're updated because portage thinks you're changing the global setting, and that's probably also why you've been needing so much autounmask shit.
Just start doing it correctly from now on.

>> No.66847700
File: 605 KB, 500x589, yaya.gif [View same] [iqdb] [saucenao] [google] [report]
66847700

>>66847375
>tfw spent 2 years memeing around with meme distros constantly troubleshooting meme problems I was creating for myself
>finally just stopped giving a fuck and went with debian testing + stock i3 about 6 months ago
>zero issues ever since
>can focus completely on my anime backlog instead

feels good

>> No.66847706

>>66847700
memes are relative

>> No.66847714
File: 107 KB, 1920x1080, 1480663043631.jpg [View same] [iqdb] [saucenao] [google] [report]
66847714

>>66847590
yes, yes, yes

>> No.66847750

>>66847676
https://www.youtube.com/watch?v=EK-KOGh4cOI

>> No.66847769
File: 1.97 MB, 615x413, 1410201835970.gif [View same] [iqdb] [saucenao] [google] [report]
66847769

>>66847750
>and their gaylord leader Mr. Torvald's
every time

>> No.66847800

XFCE and KDE seem to be the only DEs that make it easy to adjust volume increments (I prefer to raise/lower by 1%). I can't figure out how to do it on Gnome, Mate or Cinnamon.

>> No.66847847

>>66847800
Just make some amixer keybinds.

>> No.66847896

>>66847800
If you use pulseaudio

>pactl set-sink-volume 0 +1%
>pactl set-sink-volume 0 -1%

Bind those two commands to keyboard shortcuts. Also for a mute toggle

>pactl set-sink-mute 0 toggle

>> No.66848076

Didnt know if this should be in SQT, DPT, or FGLT but Im guessing here because I think you all might be able to help more so sorry if it is wrong.

I am trying to connect a mouse and keyboard to a teensy lc (arduino type board) for as little money as possible. Getting a usb host adapter for it is around $25 and not made for the teensy's form factor so I looked for another solution. I thought I could fairly easily write up a java program to capture mouse and keyboard stuff and send it over a serial adapter to the teensy but that would be a pain needing to have a computer and serial adapter in the middle. Finally I came to another solution. I have a RPi Zero W that I dont use that I could use with an otg hub to connect the mouse and keyboard and it can be wired to send the data directly to the teensy over serial.

Where should I go to get started with such a project? I assume it will have to be some sort of graphical program since I need to capture mouse as well but I wish thats not the case. What language will it have to be? Id prefer to shell script over making a full blown program or something.

Mostly looking for someone to point me in the right direction.

>> No.66848192

>>66848076
>I assume it will have to be some sort of graphical program since I need to capture mouse as well
that's cute

>> No.66848211

>>66848076
to avoid a potential X/Y problem, can you explain why you need a keyboard and mouse on a teensy?
because mouse+kb > rpi zero > teensy sounds like it's probably not the best solution
for example, what are you using the teensy for that the zero can't?

>> No.66848467
File: 84 KB, 720x960, DidWu-IVAAEFIbO.jpg [View same] [iqdb] [saucenao] [google] [report]
66848467

>>66847028
How can I take my Debian to default? (in term of packages and services)
I have an old laptop with Debian (lxde) and I want to leave it as a server, but have bots running and other services (I don't remember how many things and services I installed).
I just want a Debian, with a lxde enviroment... just that, like a new flesh install (of course, without crash my wifi driver...installing that thing was hard.. I don't remember how I did it)

>> No.66848481

>>66848467
just install stretch?
or a headless BSD

>> No.66848609

>>66848211
USB emulation. Essentially as a project to get better at programming and electronics my friend had the idea to try to make an adapter to use mouse and keyboard on xbox as a controller. Teensy can emulate a controller nicely so I thought itd be a fun hobby type thing to do.
>to avoid a potential X/Y problem
What to you mean by this? If it is pointer location that isnt really what I am trying to get from the mouse, more like movement. I know how to handle the data if I can just get the mouse movement data (as well as clicks and maybe scroll) to the teensy. I already got it kinda got it working by hard wiring a shit old ps2 mouse to it and all I was able to get was mouse movement and clicks. I want to be able to use usb ports tho so I can use any mouse and keyboard and not just the shit ps2 ones I have collecting dust.

>>66848192
Care to explain? Id prefer if it was just a script I could run in terminal but from the little Ive googled (dont know where to start) you have to have x running to be able to get mouse movements.

>> No.66848635
File: 48 KB, 750x750, zft2hxztop111.jpg [View same] [iqdb] [saucenao] [google] [report]
66848635

Recommend me a PDF viewer, please.
I'm currently using Zathura-mupdf, but it lacks the ability to change fonts in the document.
I'd like something similar (meaning that I can recolor the document, control it from the keyboard and have two-page view), but in which I can change the main document font.

>> No.66848710

How do i add git integration in to zsh without using that cancer oh-my-zsh bloat?

>> No.66848767

Great tool for monday mornings
https://github.com/nvbn/thefuck

>> No.66848803

I have created an lvm snapshot some time ago and when i now tried to remove it with lvremove, it fails with
>Logical volume main/Poop in use.
I checked and the volume is not mounted, so what the shit is going on?

>> No.66848824

>>66848635
>it lacks the ability to change fonts in the document.
that would defeat the purpose of PDF though

>> No.66848849

>>66848824
>that would defeat the purpose of PDF though
Partially, yeah. But there is one fuck whose research papers use some obscure fonts that he didn't embed. I need to set my own ones instead.

>> No.66848858

>>66848849
fair enough, specifying a font and not embedding it also defeats the purpose of PDF, so they're already broken

>> No.66848937

>>66848767
zsh correction is less cancer than that

>> No.66849119

What is the best distro for gayming on ryzen 2400g

>> No.66849226

Doesn't using a backup of / cause issues when switching distro and/or upgrading to a newer version? When talking about Windows you would never just copy system files or personal settings to a new OS yet under GNU/Linux it is always recommended and seems to be standard. Why?

I guess it's a bit less prone to errors if you skip customizations (hidden .folders?) but I still worry about it messing stuff up due to compatibility issues. As you probably notice I've never been on a single distro long enough for me to have gone through the update procedure and the answer might be obvious to more experienced users but I would really appreciate a simple explanation as to why it doesn't cause breakage and how it differs from a Windows perspective.

Thanks

>> No.66849233

>>66849119
debian, arch or something minimal like them.
arch wiki has a really good GPU passthrough guide as well.

>> No.66849445

>>66847083
Nigga, that font is set by your terminal.
Anyway, it's Ubuntu Mono.

>> No.66849460

anyone try Liri OS?

>> No.66849488

Trying to use antigen or zplug.
I have the .zsh file sourced in .zshrc but when i go to use it, it dosent return anything to stdout.No switches function either. Even sourcing it in the terminal direction does not allow for the programs to be run.
What could cause this? I've checked the permissions and they are fine.

>> No.66849538

why is gnome shit so fucking bloated?
>want to try out one program
>have to pull in 500MB of shit just to run it
jesus christ.

>> No.66849568

I can't SSH/ping my server unless it has a keyboard plugged in, how to fix?
boot with kb: ssh works, can ping machine
boot without kb: ssh gives "Resource temporary unavailable", cannot ping
Ubuntu 18.04

>> No.66849581

>Using Arch as daily driver since 2012
>New pc, need something less time consuming and that gets the job done for my freelancing (full stack dev, and virtual machines)
>Cannot be too stable/outdated cause it's a ryzen 2600x and a gtx 1080 (yeah gaymen windows partition aswell)
>3 monitor configuration
I was thinking kde would be the best bet, not requiring hours and hours of config. Could you guys give me tips on the distro (and DE eventually)? I also have old dotfiles of i3 with multimonitor scripts but I'd prefer something more standard, I won't use it to fuck around.

>> No.66849598

>>66849445
that's the one

>>66847248
no u

>> No.66849629
File: 356 KB, 3600x2056, iosevka.png [View same] [iqdb] [saucenao] [google] [report]
66849629

$ cat ~/.Xdefaults |grep font
URxvt*font: xft:iosevka:pixelsize=26


u mad?

>> No.66849691

>>66849581
I also would like a DE that can actually fucking do multi-monitors without shitting out.

>> No.66849710

>>66849629
& could do with more distinction from 8, and capital M looks too squeezed, but otherwise it's good
I especially like the Slab variant

>> No.66849736

I have a bluetooth audio reciever that goes into standby after 10 minutes. Is there a way for me to somehow change that?
It's just a simple device with only 1 button to turn it on. Here's what bluetoothctl says about it:

Device 00:75:58:BC:8B:08 (public)
Name: RT-B6
Alias: RT-B6
Class: 0x00240404
Icon: audio-card
Paired: yes
Trusted: yes
Blocked: no
Connected: yes
LegacyPairing: no
UUID: Audio Sink (0000110b-0000-1000-8000-00805f9b34fb)
UUID: Advanced Audio Distribu.. (0000110d-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb)
UUID: Handsfree (0000111e-0000-1000-8000-00805f9b34fb)


Can I somehow toggle it on remotely, so I don't have to always stand up and turn it on when I want to listen to music?

>> No.66849866

which variant of ubuntu is the nicest in terms of aesthetics?

>> No.66849875

>>66849866

What a fucking retarded subjective question. Not even going to mention that there are a handful of Ubuntu flavors which you could look at and decide for yourself.

>> No.66849918

>>66849866
ubuntu server

>> No.66849929 [DELETED] 

How do I add a line to rifle so it opens images with irfanview from ranger?
mime ^image, has wine, X, flag f = "wine /path/to/program.exe" -Z "[email protected]"

>> No.66850196

>>66848710
Go the the oh-my-zsh github site, check source -> plugins -> and look how it's done.

Most stuff also works on bash, so if anyone is bored and wants to steal some more or less useful aliases, just copy paste from om-my-zsh.

>> No.66850221

>>66849929

Install Windows again, you pretentious retard.

>> No.66850371

Well, this was a depressing read. https://www.devever.net/~hl/intelme

>> No.66850396

>>66850371
>The ME firmware includes functionality relating to the system boot process, but also things like DRM functionality. It also supports remote management functionality (including an HTTP server, even) targeted at enterprise IT;
ggnore botnet

>> No.66850427

>>66850396
That's just the tip of the iceberg. These chip systems are much more powerful. Read this for full nightmare mode:
https://libreboot.org/faq.html#amd
https://libreboot.org/faq.html#intel

>> No.66850453

>>66850371
>>66850427
So it doesn't matter if you buy Intel or AMD, right?
Are thee any computers without that crap? I don't care about ultra hd bluray memes.

>> No.66850464

>>66850453
maybe arm, since it's a little better about freedumbs, but have fun running anything well.

>> No.66850503

How shit are the closed source Nvidia drivers these days? I've been a AMD fag for years and last time I checked the drivers were very buggy.

>> No.66850512

>>66850503
About three fiddy.

>> No.66850523

>>66850503
theyre bretty gud these days.
they're a must if you want to do any tiny amount of gaymen as well since nouveau is awful.

>> No.66850570

>>66850503
pig disgusting

>> No.66850614

>>66850570
Nice brainlet fanboi response. Upboated.

>> No.66850680

>>66850614
Please go back to the reddit.

>> No.66850691

>>66850680
no u

>> No.66850733

why the fuck do i keep getting this error:
E: Unable to locate package openfoam5
?

>> No.66850774
File: 2.85 MB, 200x234, 1532327195360.gif [View same] [iqdb] [saucenao] [google] [report]
66850774

>>66847563
vrms -s | xargs sudo apt-get purge

>> No.66850887

>>66850733

It means you're retarded. You whole post proves that. Consider dropping all computers.

>> No.66850891

>>66847128
Just install Arch.

>> No.66850923

>>66850887
no u

>> No.66850933

>>66850891
No.

>> No.66851248
File: 1.93 MB, 420x298, 1531146742319.gif [View same] [iqdb] [saucenao] [google] [report]
66851248

>> No.66851256

>>66850891
Why doesn't it have a graphical installer?

>> No.66851338
File: 2.50 MB, 1920x1080, chinpo.png [View same] [iqdb] [saucenao] [google] [report]
66851338

I have an SSD and a HDD.
The SSD holds Windows and the HDD all my media.
I'm installing Linux to the SSD, but I don't know what to do with the HDD.

Are all file permissions fucked or should an NTFS drive work fine on Xubuntu?
Would it make sense to copy the files to another drive, format the internal one in EXT4 and then copy the files back?

>> No.66851354

>>66851338
you'll want to switch to a native filesystem eventually, if you intend to use the disk only in linux from now on
but for temporary or sharing purposes ntfs does work fine (as in, it's safe, but it has limited features and performance under linux)

>> No.66851372

>>66851354
OK, thanks.
If switching permanently to Linux does
> copy the files to another drive, format the internal one in EXT4 and then copy the files back?
make sense?

>> No.66851387

>>66851372
yea that makes sense

>> No.66851428

>>66851387
Thanks.
Now I just have to working out why Firefox keeps freezing...

>> No.66851444
File: 72 KB, 545x615, 1517185631067.jpg [View same] [iqdb] [saucenao] [google] [report]
66851444

What is the absolute comfiest ganoo/loonicks distro to install on a Thinkpad?

>> No.66851477

Why is scrolling with a mousewheel so slow on Chromium?

>> No.66851541

>>66851444
the one I use (debian testing)

>> No.66851549

>>66851477
it has smooth scrolling on by default

>> No.66851581

>>66851477
xinput lets you change scroll speed if your mouse allows it

>> No.66851686

>>66847028
how to rice GNOME???
Like changing some colors or something
Is gnome-look still useful?

>> No.66851743

Opening chromium from the xubuntu menu causes a "busy" cursor to appear when hovering over the title bar.
Is there a reason why?

Launching it from terminal or default web browser menu never does this.

>> No.66851786
File: 57 KB, 720x544, 1420708141_scr1.jpg [View same] [iqdb] [saucenao] [google] [report]
66851786

>>66847028
PLS PLS PLS
At whom ubunt, you can see your /var/log/apt/term.log
and say, is there a mention of the chroot?
In my term.log, the line "Running into chroot, ignoring the query: daemon-reload" often appears, and is it normal that it is mentioned there chroot? I'm a Nob, I only know that chroot is used, for example, to get root privileges without a password. So, the mention of him in term.log bothers me!

>> No.66851791

on fedora how can I make traffic from one piece of software not go through a VPN?

>> No.66851878
File: 1.36 MB, 1081x869, it crowd.png [View same] [iqdb] [saucenao] [google] [report]
66851878

Is this a gentoo reference?

>> No.66852119

>>66847128
Antergos is the slimmest version of Arch that doesn't require you to be terminally autistic to install
Manjaro is bloated as all hell

>> No.66852212

So, I tried to install latest LTS Ubuntu on laptop and it stuck on purple screen, without even starting live version.

After that I downloaded Debian 9.5 with KDE and that too failed to start.

(I used YUMI to mount isos on USB.)

>> No.66852435

>>66847028
Don't ever post Bors cartoons you fucking queer.

>> No.66852495

>>66850891
This.

>> No.66852508

>>66851686
bump

>> No.66852561

>>66847028
What program should I use to monitor disk activity and CPU usage on xubuntu?

>> No.66852578

>>66850503
AND drivers>Nvidia
Nvidia props aren’t that bad these days, they’re honestly pretty close but it depends on your card. AMD is as good as it always was. Only thing I notice is ~5 degree higher temps at idle than in windows but I might just be dreaming it.
It is a pain to have so many different drivers available looking for the right one instead of a catch-all like fglrx.
>t. GTX 1060 owner

>> No.66852606

do you know a filtering command that can use regex patterns in this form?
>/\d\s/gm
I tried reading grep and sed mans but they don't accept patterns tested with regexr dot com

>> No.66852781

>>66852606
that's in javascript form
it's just '\d\s' with global and multiline flags set

>> No.66852863

>>66852606
>filtering command that can use regex patterns in this form
Perl probably has the most powerful regex engine out there and can be used for filtering very easily

$ ls|perl -nle 'print if /\s/'
prints files with spaces in their names for example

you can learn about Perl regexes via the perldoc command:
$ perldoc perlre

>> No.66852897
File: 88 KB, 720x640, 1511362266991.jpg [View same] [iqdb] [saucenao] [google] [report]
66852897

I need help with mounting a network drive that's connected to my pc via ethernet via a switch which isn't connected to the internet.

I use an arch based system

>> No.66852967

I want to open a port for TransmissionQT client in Ubuntu, what's the simplest GUI way to do this? I've never needed to do this before. I'd rather not mess around with the router config unless there's no other way.

>> No.66853036
File: 92 KB, 500x750, varg-vikernes.jpg [View same] [iqdb] [saucenao] [google] [report]
66853036

>>66852897
>uses arch
>cannot fucking mount a network drive

>> No.66853037

>>66852967
upnp

>> No.66853041

>>66852967
bashing the UPnP button in transmission.

>> No.66853084

>>66853037
>>66853041
Its already active, think it was the default option.

>> No.66853092

>>66853084
They you should be set. If the port is still not open, enable UPnP in the router.

>> No.66853093

>>66853036
I had mounted it when I assinged an IP to it, however I don't want the drive to be connected to the internet anymore.
like I said it's on a switch and neither the drive or the switch are connected to the internet

>> No.66853137

>decide to install gentoo in a vm
>at one point, the tutorial tells me to run emerge --info
>run emerge info instead
>it starts installing a bunch of shit

>> No.66853184

>>66851686
Get a GTK theme.

>> No.66853227

>>66852561
htop

>>66852606
Try GNU grep with the -P option

>>66853137
It's all over

>> No.66853257

Install GNU/GuixSD

>> No.66853277

>>66853257
No slash needed.

>> No.66853292

>>66853277
Install GNUGuixSD

>> No.66853294

>>66853227
>GNU grep with the -P option
just a note: this uses so called PCRE (Perl compatible regular expressions), but they are not the same as Perl regexes, see
https://en.wikipedia.org/wiki/Perl_Compatible_Regular_Expressions#Differences_from_Perl

>> No.66853309

>>66853294
Thanks, always been curious about the actual differences.

>> No.66853355

>>66853292
GNUPLUSGuixSD, you dingus

>> No.66853413

>Kubuntu 16.04 LTS RAM usage on startup: 683 MB
>Xubuntu 16.04 LTS: 249 MB
>Slackware w/ XFCE: 183 MB
Systemd wasn't the bloat. KDE was.

>> No.66853588

I want to have a nice web dashboard with my linux server stats (CPU and memory usage, temperature, processes etc). Accessed via SSH tunnel (so actually a localhost http).
Which tools could you recommend?

>> No.66853608

>>66847028
is there a method to move all directories containing a specific keyword to another directory?

I got a folder full of flac and mp3 music, and i need to seperate it.
I want to move all the folders containing the keyword "flac" to a folder called lossless.

>> No.66853632

>>66853588
http://linfo.sourceforge.net/

>> No.66853989

>linux newfag
>try installing debian
>"your computer is using nonfree software for [what I assume to be network drivers]."
>tells me I can retrieve them and put them on removable media
>only have a single flash drive which was currently installing debian in the first place
>continue without the drivers
>fails network connection
>venture on anyway
>installing debian right now
how fucked am i?

>> No.66854070

>>66853989
can you plug in a network cable?
you can install the non-free wifi drivers etc afterwards.

https://wiki.debian.org/WiFi

>> No.66854084

lads

I type set -o vi on the terminal and nothing changes

>> No.66854325

Is hardware compatibility dependent solely on kernel version? I installed Ubuntu 18.04 on a MacBook Pro from 2014 and it works mostly well, but I've heard Fedora 28 has better hw support

>> No.66854384

>>66853989
Use the nonfree installer instead
https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/

>> No.66854482

>>66854325
The kernel is the part that talks to your hardware, so yeah, basically. Newer kernel versions may include newer drivers that don't even exist in older kernels adding support for more hardware, or improvements on older ones.

Although I'll be honest I'm not sure if they retroactively update drivers in older kernels. My guess is that they do, but they don't add new support.
In general on GNU/Linux versioning is usually done with major and minor version numbers. The major numbers introduce new functionality while the minor numbers indicate bug fixes or updates on existing functionality.

>> No.66854533

>>66854084
>nothing changes
type some command, press escape and dd

>> No.66854609

https://www.gnu.org/software/gtypist/index.html
>Tux Typing is a graphical, educational typing tutorial game starring Tux, the GNU/Linux Penguin.
>the GNU/Linux Penguin

>> No.66854636

>>66854609
It's all just gray area at this point. Blame Torvald's.

>> No.66854647

>>66853413
Yeah, it WAS! They fixed ram bloat with 5.13. Pretty good now.

>> No.66854944

>>66853632
Thing seems nice, but may I also see alternatives?

>> No.66854978

How would you go about adding trackpad gestures to Debian on a Dell XPS?
i.e. two fingers and swipe to go back/forward, two fingers to right-click etc.

Also whatever driver I'm using for the trackpad at the moment is shit. Anyone recommend another?

>> No.66855159

>>66854978
I use https://github.com/bulletmark/libinput-gestures
Works without issue, have only used it with GNOME though

>> No.66855165

>>66854384
Stop shilling that crap. He needs exactly one module, not a whole collection.
>>66854070
Good reply.

>> No.66855188

>>66854084
# > bash: vi mode

# You can set Vi editing mode for bash in .bashrc like so
bind 'set editing-mode vi'

# And then this to get the indicator:
bind 'set show-mode-in-prompt on'

# And to change the indicator strings:
bind 'set vi-ins-mode-string └[\1\e[34;1m\2ins\1\e[0m\2]'
bind 'set vi-cmd-mode-string └[\1\e[35;1m\2cmd\1\e[0m\2]'

# If you want to use those, then try this PS1:
PS1="┌─╼ \[\e[0;34m\]\u\[\e[1;35m\]::\[\e[0;34m\]\h \[\e[1;34m\]\w\[\e[0m\]\n──╼ "

>> No.66855288

>>66855165
What are you on about? This ISO just has extra non-free firmware so you can actually use your hardware during and post install. It only installs firmware for detected devices, which you'd end up having to do manually post-install anyway.

>> No.66855374

what's a good book to learn about networking in the linux environment? I'm reading How Linux Works and then after that Linux Firewalls, both by Starch Press. Any other good stuff? If it's python-related, even better.

>> No.66855379

>>66855165
>adding a repo means you have to install the whole thing
are you fucking serious m8?

>> No.66855462

>>66855379
>cd
>repo

>> No.66855571

>>66855374
A weekend with iptables and nmap should suffice

>> No.66855714

What's the recommended free software solution for Android rooting?

>> No.66855735
File: 196 KB, 661x768, servers-wat.jpg [View same] [iqdb] [saucenao] [google] [report]
66855735

Hey guys, I tried to compile the VMWare workstation kernel modules on Ubuntu 18.04 but got so many errors I gave up (and it's not about dependencies)
Couldn't find much help on the official forums.
Is there a guide or something for this?

>> No.66855764

>>66855714
I've read good things about Magisk

>> No.66855765

>>66855735
install debian or arch if you're trying gpu passthrough.

>> No.66855812

>>66855765
I'm not trying to GPU passthrough, I don't have a second GPU and I want to use Vmware for more VMs than just Windows

>> No.66855844

>>66855812
well get rid of ubuntu anyway and you won't have to compile anything.
wmplayer just werks on stretch.

>> No.66855868
File: 49 KB, 500x385, 1531944592703.jpg [View same] [iqdb] [saucenao] [google] [report]
66855868

>>66850887
>You whole post proves that

That's not very friendly

>> No.66855892

>>66855188
worked, thank you

>> No.66855918

>>66855764
Thanks

>> No.66855933

Is there something similar to xfce4-whiskermenu-plugin that will fit nicely with i3 status bar?

>> No.66856185

>>66855933
i3status doesn't support scripts, so no.

>> No.66856255
File: 25 KB, 400x400, 1520121729_Sad pepe.jpg [View same] [iqdb] [saucenao] [google] [report]
66856255

Anybody know of a nice simple GUI file manager? Only requirement is that it's open source so I can compile it for my OS, and that it uses Motif or GTK.

I've tried a couple of them but they're all too busy and too modern. I want something that looks like the old Mac OS 9 file manager almost. Just a very simple window that displays files and directories, maybe with a file system path bar on top. Nothing more. The closest I found is Rox-FM but it's sorta shitty and hard to customized. I tried Xfe which I used around 2008 but for whatever reason on modern Linux and BSD it's really buggy and froze my whole desktop making me force terminate the X server on Debian. Thunar is what I've been using but it's still too busy. Gnome and KDE file managers are out of the question.

>> No.66856295

>>66856255
people shit on it, but thunar does what in needs to.

>> No.66856313

>>66856295
oops
but how is thunar too busy?
do you not want file-help menus or something?

>> No.66856319

>>66855933
>>66856185
I think you can do it with i3bar by itself without using i3status.
I think all i3 status does is print out a string that i3bar uses (it may be formatted as JSON). But I read somewhere that you can just make your own script to output the string for i3bar, using python or whatever.
Not sure exactly how though.

>> No.66856322

>>66856255
M-x dired

>> No.66856338

>>66856319
i3bar only supports text and basic coloring. If you want to see just how feature-devoid it is, look up how to get icons to work with it. Just adding small images is a ton of work.

If you really want a start-menu style thing, just replace i3bar with xfce-panel entirely a la AwesomeWM.

>> No.66856357

>>66856255
spacefm and pcmanfm are very simple by default. They have sidebar options too but you can toggle them off, and you can right click any element and remove it from the interface (including the toggle buttons if you're sure you just want to disable things permanently)
There very lightweight too and have decent thumbnail support.

>> No.66856406

I'm the retard that couldn't resize his Debian luks partition.
I gave up and am currently installing arch

>> No.66856432

>>66856406
unsubscribe

>> No.66856476

>>66856406
you should stop and try out Liri OS for me, it's arch based with a nice wayland-based desktop.

>> No.66856640

>>66856295
>>66856313
Thunar just feels really clunky. It works, but it lacks the elegance of other file managers I've used in the past. Stuff like the side pane can't be toggled off. I can't hide that top bar with the directory path. It's just a waste of space, especially on my laptop which is 1366x768. I keep comparing my simple modern Linux experience to my old G3 Macintosh with OS 9.2 and 8.6 on it. The display was 1024x768 and it was more than enough for basic tasks. Even my old Windows XP PC had a 1024x768 display briefly and it was good enough, despite every XP UI element being thick as fuck. Now every UI element takes up so much space and things are crammed together and it's just bad.

>>66856357
>spacefm
I tried this and couldn't configure it how I wanted so I removed it.
>pcmanfm
This one is pretty good. I might tinker with it a bit, or just fork the Rox-FM source and remove the stuff that bugs me. Thanks for the suggestions.

>> No.66856814
File: 37 KB, 690x706, 2018-07-23-181328_1024x768_scrot.png [View same] [iqdb] [saucenao] [google] [report]
66856814

>>66856357
Thanks again Anon. I think I'll use pcmanfm for a while. It's pretty comfy.

>> No.66856891

>>66856814
you might as well install puppy linux or something.

>> No.66856905

>>66852212
use either rufus with bios setting on windows and default installer startup disk creator on *buntus which is pretty fast.
look if there are bios or cmr options to make the iso bootable in that option.

>> No.66856918

Whats going on here? Why does it say NTFS when all my other drives that are ext4 show up as "Linux"

fdisk
Device Boot Start End Sectors Size Id Type
/dev/sdj1 2048 625139711 625137664 298.1G 7 HPFS/NTFS/exFAT


lsblk
sdj 8:144 0 298.1G 0
└─sdj1 8:145 0 298.1G 0 ext4 /media/Nonna

>> No.66856952

>>66856814
what themes/fonts/etc are you using? how did you get it to look like that?

>> No.66856988

>>66856814
Seconding this >>66856952
also the icons?

>> No.66857018

>>66853092
>>66853084
You shouldn't use upnp
enabling upnp allows any program to open ports on your router automatically including malware
manually forward your ports its not really hard if you have any router that's not a toy

>> No.66857028

So, sometimes when I log out from i3 using mod+shift+e, the X session is unable to end and totally locks up the computer. I am not even able to switch to another TTY and I have to hard reset. It brings me to the screen saying it's trying to kill X and that it refuses to die or something.
Other times I'm about to log out successfully.
It can't be a DM issue because I don't have one installed, I just have it so X autostarts from login.
What could be the problem?

>> No.66857048

I have a USB network adapter that has no support for Linux and I wanna get rid of Windows 10 in replace of Slackware or Manjaro (help me decide between the too, also). How can I make it work with Linux?

>> No.66857064

>>66857028
>Other times I'm about to log out successfully.

able*

>> No.66857097

>>66847700
don't you miss aur?

>> No.66857103

>>66857048
There's a big difference between
>my hardware has no support for Linux
and
>Linux has no support for my hardware
Are you sure you meant the former? Because that's usually nothing to worry about. Manufacturers always say that and it just means they didn't put any thought into it, but it still may have drivers in the kernel that work.

>> No.66857129

>>66857048
generic drivers will most likely work fine.
but if not
>find model name
>find drivers
it's really not hard.
slackware has no developers and no formal bug tracking. and manjaro still has install-breaking bugs.
install debian or arch.
if you can't be fucked with arch installing, there's antergos or liri or the billion other arch wrapper distros.

>> No.66857149

>>66857048
>Slackware vs Manjaro
Wat
They are not even slightly similar, Slackware is not beginner friendly.

>> No.66857169

>>66857149
I am not a beginner. I have been using Linux on a laptop for a while, but I wanna get rid of Win10 on my main machine.
On one hand, I love Manjaro and have been using it for as long as i've been using Linux, on the other hand Slackware is cool and systemdless.

>> No.66857192

>>66857103
My hardware has no support for Linux. I checked, only macOS 10 and Windows 7 - 10.
I am sure Linux could support it. It's generic as fuck, only $15 on Amazon. Cheap adapter.
>>66857129
I know how to install Arch, but it has issues these days (and I dislike Debian).
I don't know the model, but it's an Anewkodi brand USB adapter. If you can find me some drivers that'll work, i'll love you forever.

>> No.66857223

>>66857192
You're most likely going to get a liveCD or liveUSB before installing anyway. Just try out your adapter at that stage. If it works there then it'll work after you install it. If not then you can worry about it.

>> No.66857235

>>66857223
My issue is, I can't install it if it can't connect to the internet. Slackware as an install CD ISO that I can use.
I'mma try out a live bootable to see if my adapter works at that stage and then install Slackware with the install CD ISO.

>> No.66857256

>>66857192
having the exact model would help but theres this
https://robtranquillo.wordpress.com/2017/08/27/linux-driver-for-anewkodi-usb-wifi-dongle/
https://github.com/gnab/rtl8812au
will probably work if the generic drivers don't.

>> No.66857262

>>66856952
>>66856988
Pretty sure his theme is this one
https://www.opendesktop.org/p/1230293/

As for the font I don't know but it looks bitmapped, and if you go that route you'll definitely want a normal font with "embedded bitmaps" not a bitmap format font. For example IPAMonaPGothic.

Not sure about the icons.

>> No.66857273

>>66856918
Type is just a numerical field in the partition table. It doesn't get changed if you format the partition to a different FS.

>> No.66857283

>>66857235
>My issue is, I can't install it if it can't connect to the internet.
plenty of distro's have full images with everything you need. I'd really stay away from slackware unless you only care about basic 4chan and youtube.

>> No.66857299

>>66857273
ok thanks

>> No.66857311
File: 7 KB, 250x223, 1509618560050.jpg [View same] [iqdb] [saucenao] [google] [report]
66857311

>>66856952
>>66856988
https://www.gnome-look.org/p/998527/
https://www.gnome-look.org/p/1015906/
https://www.gnome-look.org/p/1006689/
https://www.gnome-look.org/p/999497/
https://github.com/n-kremeris/irix-icons-linux

>>66857262
Not a CDE theme, but rather an IRIX themed XFCE. Files linked above. For the fonts you need to be sure to run dpkg-reconfigure fontconfig-config as sudo or root on Debian based systems. Then you can enable bitmapped fonts. Otherwise the SGI fonts look blurry.

>> No.66857323

>>66857283
>>66857256
Thanks for the help. I'll report back later with the results. Hopefully i'll be running GNU/Linux.

>> No.66857383

>>66857311
Also, to add to this, you guys should go into /SGI-IMD/gtk-2.0/gtkrc and search for "font" and change the style menufont to the following:
style "menufont"
{
font_name = "medium 11"
}

This makes the fonts a lot smaller and easier on the eyes.

>> No.66857426

>>66847522
Personally got tired of fiddling with arcane command one liners.
Now I just use either alsamixer or pulsmixer to enable/disable the sound card I'm using.
>if using USB just disable all on board and make it your preferred card

>> No.66857436

>>66847640
Is this the fork bomb thingy?

>> No.66857559 [DELETED] 

What is (GNU) m4 useful for? I learned how to use it for the most part but haven't come up with a neat use case. Also, the following concerns me:
define(`a',`b')

a()
b
a()a()
ba()
ba()b

>> No.66857567
File: 7 KB, 870x367, file.png [View same] [iqdb] [saucenao] [google] [report]
66857567

>>66853137
>have trouble installing genkernel (needed for generating the initial ramdisk)
>fix it after about 10 minutes of fucking around
>forget to actually generate the initial ramdisk
...
>finish installing gentoo about 4 hours later (went for a run and did other things in the meantime)
>reboot
>presented with a grub prompt because no initrd
Luckily it was a 2 minute fix and everything seems to just werk now.

>> No.66857571

>>66855188
what would that do?
enable Vi-like functionality on your shell?

>> No.66857574 [DELETED] 

What is (GNU) m4 useful for? I learned how to use it for the most part, including some advanced things with "eval", but I haven't come up with my own neat use case. Also, the following concerns me:
define(`a',`b')

a()
b
a()a()
ba()
a()a()a()
ba()b

>> No.66857582

>>66847028
I want to learn about Linux. I saw a book called learn Linux programming. Is this about the operating system? What’s Linux programming. I never heard of Windows programming or macOS programming

>> No.66857622

Has anybody done anything cool in (GNU) m4 that they would mind sharing?

>> No.66857666
File: 1.23 MB, 3412x1920, 4F7200BC-4741-4FC1-8244-A2888CB1CA8A.jpg [View same] [iqdb] [saucenao] [google] [report]
66857666

I’ve had these annoying error messages on start up and I was wondering how you got rid of them. Any ideas /g/? (Also if anybody knows how to get to the advanced section in BIOS on an X220 I’d appreciate it.

>> No.66857733

How do i search the void package repository?

xbps-query -s only seem to search packages I allready installed.

>> No.66857822

>>66857582
Install Gentoo.
>>66857571
Yes.
>>66857436
Yes.

>> No.66857854

>>66857666
Search for TPM settings in the bios and disable everything

>> No.66857861

>>66857822
Cool meem. Tahnks 4 teh hlep

>> No.66857897

>>66857666
>>66857854
Just checked, the x220 bios doesn't have anything that says "TPM" in the bios, but the option you want to disable is under Security > Security Chip or something like that.

>> No.66857953
File: 40 KB, 549x413, deepinthought.png [View same] [iqdb] [saucenao] [google] [report]
66857953

what is the closest thing you can get to real unix without actually using unix? like bsd or something? needs to be open source

>> No.66857990

>>66857953
GNU/Linux is not Unix.

>> No.66858003

>>66857953
Busybox, but it's still too good. Unix is compared to GNU pretty much crippled.

There's also a research Unix somewhere on github.

>> No.66858007

>>66857990
Linux is a kernel.

>> No.66858010

>>66858007
Install Gentoo.

>> No.66858012

>>66858003
Can someone explain to me why on Windows 10, with a Ryzen 2700x and 3200mhz RAM and a SSD, with an RX 580, my system feels slow compared to Xubuntu? The only difference is the OS. On Linux, it's lightning fast and instant - everything feels responsive and great. On Windows 10, it feels like there's this slight lag and delay on everything I mess with. Anyone else get this?

>> No.66858021

>>66857953
Research UNIX

>> No.66858051

>>66847028
Windows 10 runs slow as shit on my thinkpad x220. I'm new to linux. What distro would you recommend that would run faster? I've heard manjaro is good.

>> No.66858060

>>66857953
https://www.reddit.com/r/linux/comments/621efd/research_unix_v8_v9_and_v10_are_now_downloadable/

>> No.66858097

>been using Ubuntu for couple of years
>18.04 comes out
>no more Unity

So, if I am really just wanting something that just works, but don't want the horrendous Gnome DE, what do?

Is Kubuntu any more resource intensive than unity? What is this KDE Neon I am reading about in the comments of a 18.04 KDE release review video on youtube?

I did install unity over 18.04 on a trial install, but I don't want to keep prolonging what is familiar if my switching over is inevitable.

Mind you I am not a developer or gamer or anything of that sort, I just hate the route windows has gone

>> No.66858103

>>66858051
install ubunut

>> No.66858112

Is Ubuntu still the No.1 beginner distro?

>> No.66858197

I just want a Linux sysadmin job what do I need to do to get one? What do I need to learn? What buzzwords do I need to put on my resume? What do I put up on my github? My city seems to be Windows only because there are only a few search results with the word linux and they have extremely ridiculous requirements including TS with Poly so wheres a good city to move to for lots of entry level linux sysadmin opportunities?

>> No.66858207

>>66858112
I think a lot of beginners are going to Linux Mint.

>> No.66858256

How would you make a function that would allow you to use a command and then select an image and then google reverse image search from the command line?

>> No.66858272

>>66858097
Honestly, you'll have to try.
I've been using plain wm lately, but I enjoy xfce, lxde is okay too.
I never really liked KDE, gnome went to shit since version 3 and I'm honestly indifferent towards cinnamon.
But then again, you'll have to give 'em a try.
You could just install the DEs you want in Ubuntu without making a full reinstall, rice/play with them a little and once you made your decision either remove all of the others or make a clean install with the one you want.

>> No.66858278 [DELETED] 
File: 11 KB, 480x360, 0.jpg [View same] [iqdb] [saucenao] [google] [report]
66858278

>>66858197
>buzzwords
>no actual job experience
>the absolute state of millennials

>> No.66858295 [DELETED] 

>>66858278
30yo boomer, already have few years helpdesk experience, but getting tired of windows and want to break into the linux side.

>> No.66858321

Why can't I get the size of Googles homepage?
[email protected]:~$ wget --spider google.com
Spider mode enabled. Check if remote file exists.
--2018-07-23 17:53:16-- http://google.com/
Resolving google.com (google.com)... 172.217.3.174, 2607:f8b0:400a:808::200e
Connecting to google.com (google.com)|172.217.3.174|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://www.google.com/ [following]
Spider mode enabled. Check if remote file exists.
--2018-07-23 17:53:16-- http://www.google.com/
Resolving www.google.com (www.google.com)... 172.217.3.164, 2607:f8b0:400a:808::2004
Connecting to www.google.com (www.google.com)|172.217.3.164|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Remote file exists and could contain further links,
but recursion is disabled -- not retrieving.

>> No.66858366

>>66858197
CCNA is a good start

>> No.66858399

>>66858366
Nice integer. But why? Isn't memorizing a bunch about IOS, which is not Linux, a detour on the path to becoming a Linux system administrator?

>> No.66858406

>>66858321
because like the multivac in the last question, it has grown beyond the dimensions and metrics we humans can conceive of

>> No.66858413

>>66858399
No.
Having a ccna will get you in any door, then they train you the specialties they need for the company.

>> No.66858437

>>66857097
Different Anon but I found that people in the Arch community often fail to maintain packages properly. I used to rely on it to easily get roguelikes another gaming-related packages but I found that some of them were out of date or wouldn't work without manual intervention. now I'm just compiling stuff from source I'm going to use lutris as a unified launcher on Opensuse since it's a stable work distro and I like to write literature as a hobby and delude myself into thinking it's a productive job.

Working on recreating my own I3 rice for once instead of copying others. Everything's in place except for the status bar. I'm not sure if I want to use bumble bee status or try to use the one from lxde.

>> No.66858442

>>66858321
$ wget --spider -S google.com 2>&1 | grep Content-Length
Content-Length: 219

>> No.66858446

>>66858406
I just want the front page, though. That should be finite, and not that big. There's not much there when you just go to google.com

>> No.66858460

>>66858442
Very nice, thank you.

>> No.66858559
File: 24 KB, 1610x115, useless.png [View same] [iqdb] [saucenao] [google] [report]
66858559

How can I remove the title bar that's above the tabs where it's essentially just showing the tab title again

>> No.66858580

>>66858559
Its part of gtk3 settings. Your wm should have a "decorations" toggle that should get ride of it

>> No.66858597

>>66847028
>King nigger's admin currently in the midst of a FISA court scandal
this didnt age well

>> No.66858643

>>66858580
>wm
?
looked everywhere anyways nothing about decorations and went through all the options with no luck, even with the gnome tweak tool
I'm new

>> No.66858680

>>66852212
do you format the flash to FAT32? also use rufus and format to 32

>> No.66858996

Is it possible to have one session launch a full DE, complete with all the bullshit daemons and stuff, and another session that just starts i3? I mostly use my laptop for simple text editing on the road, so I don't need any auto-usb mounters or fancy daemons or whatever running and sucking up my battery, but sometimes I want to plug in my TV with an HDMI cable and just have the audio fucking work without fucking around with pulseaudio shit, and where things "just werk" in general.

I've been dual booting manjaro i3 and linux mint to solve this for a while, but if I can just have two sessions so I can switch between bloated just-werking and 16 hours of battery life text editing autism, that would be great. I don't need a step by step guide, just tell me what to google or link me to the right page on archwiki please.

>> No.66859007

>>66858272
Tbf, KDE looks great if you're a recent Windows convert. Panel's on the bottom, clock & notification center in bottom right, application menu in bottom left.

Once you're well into Linux, it's hard not to enjoy XFCE. Kali and Tails use some form of it. And you save RAM!

>> No.66859030

>>66858996
> I mostly use my laptop for simple text editing on the road
So open a tty session and use nano or vi. It's all you need.
>16 hours of battery life text editing autism
What do you do in a text editor for 16 hours?

>> No.66859038

>>66853413
and also *buntu

i just finished installing debian with lxde and xfce to replace my lubuntu install. my ram on lubuntu, all 4gb of it, would constantly get filled to the brim.

LONG LIVE DEBIAN

>> No.66859045

>>66853608
mv *.flac lossless/

>> No.66859047

>>66857897
Thanks, managed to resolve both issues with your advice

>> No.66859058

>>66855462
its like you've never installed linux in your life

>> No.66859068

>>66856255
pcmafm

>>66856295
fuck thunar. i mean, if it supported dual-pane, then it would be good. but it doesnt so its shit

>> No.66859069

>>66859007
>Tbf, KDE looks great if you're a recent Windows convert. Panel's on the bottom, clock & notification center in bottom right, application menu in bottom left.

Like basically any DE that isn't gnome?

>> No.66859073

>>66856640
another file manager i like a lot is xfe

>> No.66859100

I want to go full (kind of) Linux and setup GPU pass through so I can have a windows VM and run my games off of that. I have a 1070ti that I will be passing through to the VM, but need a second gpu for the host.
What is a good cheap card to buy that will work easily without much configuration on Linux while I am passing my 1070ti through to windows?

>> No.66859104

>>66859069
>Panel's on the bottom
>any DE that isn't gnome
>XFCE
Not really.

>> No.66859106

>>66858012
sure I can explain. so basically, windows is garbage. any questions?

>> No.66859122 [DELETED] 

>>66858295
>30yo
>boomer
you're a millennial faggot

>> No.66859125

>>66858996
Search for starting a second xsession. It's pretty easy. Then you can CTRL+Alt+F1-7 to switch between the sessions.

>> No.66859157

>>66859058
AFAIK Linux comes preinstalled.

>> No.66859168

>>66859157
no, it depends on the distro

>> No.66859185 [DELETED] 

>>66859122
That's the joke, senpai. Welcome to 4chan.

>> No.66859247

>>66858437
By the way I don't really know what I'm doing when i'm trying to compile these programs.
I get error messages like
fatal error: QException: No such file or directory
it's always something I don't find in Opensuse's repos. Is there some build tool I'm missing?

>> No.66859254 [DELETED] 
File: 172 KB, 640x360, moo2.png [View same] [iqdb] [saucenao] [google] [report]
66859254

>>66859185
it's a terrible joke and you should feel bad

>> No.66859329

>>66859068
aren't multiple panes in a file manager kinda useless when you can open two windows?

>> No.66859354

>>66859329
no you idiot

>> No.66859375

any bsd anons know how to check disks from a mountroot prompt? or do i literally just
ufs:/dev/***** each one from ? until i hit it?

>> No.66859525

Can someone please give me some resources on fonts and font configuration? I'm having a really hard time setting system fonts and having them be consistent. Can I do this with just the ~/.config/fontconfig/fonts.conf XML file? Do I need to use something like LXappearance for some things? Would really rather not install that though.

The arch wiki has been a big help but their articles on fonts and font configuration aren't doing anything for me, I can't seem to find much help on this topic anywhere at all.

>> No.66859580
File: 57 KB, 768x512, gettyimages-826121550-master-1506462298.jpg [View same] [iqdb] [saucenao] [google] [report]
66859580

>>66859525
dunno gnome handles it just fin for me

>> No.66859603

Looks like Lunduke is back on youtube again with delayed content. Thoughts?

>> No.66859635

>>66859603
unsubbed after that political rant he did awhile ago on freebsd

>> No.66859657

>>66859603
Who?

>> No.66859664

>"#10: Use a hack with Debian

If you're using Debian, there is a simple hack you can use to switch your startup scripts to run in parallel. If you look at the /etc/init.d/rc script, you will see: CONCURRENCY=none around line 24. Change this line to CONCURRENCY=shell and you should see a reduction in boot times.

That's about it. Of course there are always more and better hacks out there. But the above should mostly cover everything. The good news is that you're most likely already running Linux, so the burden of boot times is generally eased by the infrequency of reboots."

I just saw this on a tech website and I'm was wondering if I could do it on my system. Unfortunately when I tried to go to /etc/init.d/rc in my file system is wasn't there. Did they change the name of the file or was it removed completely?

>> No.66859680

>>66859664
Hacking is illegal. Don't do that.

>> No.66859722
File: 59 KB, 480x557, image.jpg [View same] [iqdb] [saucenao] [google] [report]
66859722

>>66847750
First time I see this shit. Too sad seeing old people lose their head, incoherently spouting nonsense like that

>> No.66859739

>>66859722
>image.jpg
You need to go back.

>> No.66859750
File: 157 KB, 900x660, 2.jpg [View same] [iqdb] [saucenao] [google] [report]
66859750

>>66859525
There's several layers to how fonts work, so listen up:

Fontconfig handles associations. It doesn't determine what fonts any applications will request, it only determines what font they receive based on their requests.
Fontconfig lets you do things like remap fonts. For instance one common mapping is Arial -> Liberation Sans because GNU/Linux doesn't have Arial (it's not a free font, but you can steal it from winshit if you want it)
So in short, the purpose of fontconfig is to set sane global preferences. Once you have that set how you like it then you should only change fonts using your applications.

Now, on the application side there's 2 more potential layers.
Applications can just let GUI toolkits like GTK or Qt can handle their font rendering, so those toolkits give the user a way to tell them what they want to use because the application was too lazy to do it. Meaning there are GTK config files on your machine where you can set a default.
So the full chain looks like this:
>GTK reads your GTK font preference from a config file -> GTK takes that string and sends it as a request to fontconfig -> Fontconfig checks how that string gets mapped to an actual font file.
Then the final layer to be aware of is of course just applications that will handle their own font settings. So they may tell GTK to use a different font than your GTK font setting. (or for less well behaved applications they'll just go hunt your machine for the font files themselves and completely ignore any toolkits or fontconfig).

The role of lxappearance is to set the values of your GTK preferences for you in the config files.

>> No.66859756

>>66859722
When you remove the /pol/ crap, Terry is pretty much redpilled.

>> No.66859766

>>66847028
I hacked into your mainframe server. I installed Mint on all your machines.

>> No.66859777

>>66859756
>remove the /pol/ crap
>redpilled
considering /pol/ popularized redpilling...

>> No.66859778

>>66859756
oh the irony

>> No.66859806

>>66859777
If by "popularized" you mean take an already well known 4chan meme used on every board and spread it around social media sites like reddit, just like they do with everything else, then sure. They popularized it.

Also I have no idea what you guys are talking about, I only read your post.

>> No.66859854

>>66859603
Watch these instead:
wget -qO- p.teknik.io/Raw/wJ9Zy | sed -n 188,232p

>> No.66859933

>>66859854
Pasta file needs updates/more content. Maybe a FAQ with answers to common questins like screen tearing, best beginner distro, whatever.
Website needs SSL cert and should eat the pasta file.
OP is too bloated.

*issue*

>> No.66859975

I played around with zsh and discovered zmv and it's so awesome. Make me not switching to zsh.

>> No.66859996

>>66859806
I guess you weren't on pol when redpilling was new

>> No.66860024

>>66859996
>browsing /pol/
Isshydiggy

>> No.66860146

>>66859778
AFAIK the redpill is an old 4chan matrix meme
>le truth
/pol/ turned it into
>le jews

I could be wrong.

>> No.66860158

>>66859996
Of course I wasn't. Why would I concern myself with a board full of normalfag refugees from social media shitholes?

Redpill was used as a casual meme all over 4chan long before you ever saw it on /pol/. People would ask to be given a "redpill" on something just as a way to request information. For instance today I might as for someone to
>redpill me on GuixSD
Of course I wouldn't say that because newfags think it's a politically charged meme now.

>> No.66860270
File: 5 KB, 184x184, 1489212463552.jpg [View same] [iqdb] [saucenao] [google] [report]
66860270

Stable, testing or unstable?

>> No.66860299

>>66860270
not unstable

>> No.66860399

>>66860270
I like my distros like I like my women
unstable

>> No.66860482

>>66860270
stable.

if you need newest version of some software, just compile from source.
if the project needs too many newer libraries and it would be too much of a hassle to compile them all from source -> use docker

>> No.66860493
File: 713 KB, 941x1032, Screenshot_2018-07-24.png [View same] [iqdb] [saucenao] [google] [report]
66860493

been trying to change the color of that block highlighting the tag, with no success
changing the cursor color in vimrc only changes the underline

>> No.66860513

>>66860399
For u

New thread
>>66860503
>>66860503
>>66860503

>> No.66860845

>>66853036
>"arch based"
he's proabably using manjaro

>> No.66860861

>>66856814
damn that looks comfy

>> No.66862339

Is it bad for root and the only user on the machine to have the same password?

>> No.66862492

>>66862339
doesn't really matter if the user is a sudoer

>> No.66864249
File: 14 KB, 500x357, download.jpg [View same] [iqdb] [saucenao] [google] [report]
66864249

I'm trying to find an image viewer that also supports viewing media clips while fullscreen viewing files in a directory.. Irfanview does this handily, but does not have a Linux version

>> No.66864274

>>66864249
there's nothing stopping you from using irfanview in linux, if that's what suits you

>> No.66864327

>>66864274

In order to get all the media viewable I had to install additional codecs and plugins... Which was wired into Windows. I anticipate possible problems with this on Linux...

It also seems a bit resource intensive...

With these two factors in mind, I was hoping there is a better Linux-native option already existing...

>> No.66864334
File: 24 KB, 550x309, Screenshot-10312012-015434-PM.jpg [View same] [iqdb] [saucenao] [google] [report]
66864334

>>66859104
What grade of retardation do you have?

>> No.66864402

>>66864327
yea, you'd have to install the windows version of codecs, like k-lite or something
this won't cause problems, since it's only applicable to the wine environment
just putting it out there

>> No.66864534

>>66864402

Yep, k-lite is the pack I have here with Irfanview. OK, I guess I'll do it this way then, thank you.

Was hoping for a shiny new alternative! Maybe someone else will chime in with one soon...

>> No.66864564

>>66864534
i personally use geeqie, but it doesn't play video
there's also hydrus, but it's not a direct competitor to irfanview, so i'm not sure that'd be something you'd want

>> No.66864621

>>66864564

Only care if it can view pictures and media clips in a fullscreen mode

>> No.66864680

>>66864621
yea, it can

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action