Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 33 KB, 572x184, 1529488920265.jpg [View same] [iqdb] [saucenao] [google] [report]
66424566 No.66424566 [Reply] [Original] [archived.moe] [rbt]

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: just like in /sqt/ spend at least a minute to check a web search engine with your question.
*Search: qwant, searx, ixquick or startpage.
*Many free software have active mailing lists.
*Many free software has an active bugzilla where you can check and report errors

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux: https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux
>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page
>What are some cool terminal commands?
http://www.commandlinefu.com/
http://cheat.sh/
>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/
>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html
>How to break out of the botnet?
https://prism-break.org/en/categories/gnu-linux

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

Previous thread: >>66403463

>> No.66425593

How can I replace cut with delete when I press shift-delete when editing text?

>> No.66426192

>>66425593
Please be more specific.

>> No.66426286

How the fuck do you play mkv/mp4 files on openSUSE? This is literally the only distro I've had this problem with.
I've already tried installing ffmpeg, gstreamer etc. as well as used the "1-click codec install" and still nothing.

>> No.66426353

>>66426286
install a media player maybe? VLC, smplayer etc.

>> No.66426439

>>66426353
I'm using mpv, it does not play the file and immediately closes.
VLC is complete shit and I'd rather use Windows that it, but I've tried it, and it just gives an error playing h264 files.

>> No.66426452

Install Gentoo.

>> No.66426457

>>66426452
Fuck off, this is the actual help thread.

>> No.66426540

>>66426457
Stop telling people to fuck off, this is the actual friendly thread.

>> No.66426577

>>66426457
But it is.

>> No.66426578

>>66426439
>I'm using mpv, it does not play the file and immediately closes.
Does it output any error message to the terminal/stdout?

>> No.66426695

>>66426578
No, nothing.
I’m trying some other fix and will post update in 10 minutes or so.

>> No.66426730

What do you think about gaming on Linux?

>> No.66426783

>>66426730
Perfectly doable if you, like me, play almost exclusively old ass games that can be easily emulated.
Modern AAA games are of course a whole different story, but that is slowly improving.

>> No.66426788

>>66426730
wine is a hit or miss
native games usually run just fine

The only annoyance I noticed in native games that in Memelands 2 I couldn't bind Ctrl while in Pre-Sequel I could.

>> No.66426843

>>66426286
I reinstalled it, updated it and ran the terminal commands from the guide site for installing ffmpeg etc. and now it won’t boot into KDM.
Nice.

>> No.66426961

What's the easiest way to set up a different wallpaper for each monitor on a dual setup under ubuntu?

>> No.66427009

>>66426730
You should use a complete operating system in order to play games.

>> No.66427116

If I install KDE in Ubuntu, will I be able to switch between gnome and kde?

>> No.66427119

i wish linus could put his babies in me

>> No.66427312

>>66427119
why would you even want this

>> No.66427347

>>66427116
yes

>> No.66427391
File: 107 KB, 639x749, 1524738740401.jpg [View same] [iqdb] [saucenao] [google] [report]
66427391

>emerge -uavND @world
>gcc
>chromium
>tfw

>> No.66427421
File: 94 KB, 1200x628, clorox_collage.jpg [View same] [iqdb] [saucenao] [google] [report]
66427421

>>66427391
>emerge -avDuN world
>gcc
>also gcc 2 other times for various toolchains
>llvm + clang
>qt
>15+ rebuilds because why the fuck not

>> No.66427441
File: 111 KB, 1000x600, 1525176978591.jpg [View same] [iqdb] [saucenao] [google] [report]
66427441

>>66427421

>> No.66428239

I have an old PC with a core 2 duo E7500 and 4GB RAM.

What distro should I install on it to make it zippy, and what should I do with it

I bet installing Gentoo would take ages on the old CPU

>> No.66428254

>>66428239
debian lxde

>> No.66428413

>>66428239
Debian OpenBox

>> No.66429128

>>66428239
Debian Xfce

>> No.66429164

>>66428239
solus

>> No.66429190

>>66429164
Sup Kev

>> No.66429207

>>66428239
Debian i3gaps

>> No.66429331
File: 61 KB, 660x480, Dennis-Ritchie.jpg [View same] [iqdb] [saucenao] [google] [report]
66429331

I just downloaded the current Debian stable netinst and holy fuck it's 300mb. I remember netinst images being a tenth of that when I installed it several years ago. That was a testing netinst though (Wheezy to be more specific). Is my memory failing me, or have they really bloated it so much?

>> No.66429426

>>66429331
Debian netinst is light compared to others.

>> No.66429535

>>66429426
I never said that it wasn't, I just recall that it was much smaller ~6 years ago.

>> No.66429573

>>66428239
I have a machine with similar specs (only 8GB or RAM not 4GB), and MATE runs amazingly on it. So Debian with MATE, I guess.

>> No.66429604

>>66429331
seems the kernel has really grown. current stable kernel is 250mb installed https://packages.debian.org/sid/linux-image-4.16.0-2-amd64
wheezy's kernel from 2013-2016 was about 110 mb https://packages.debian.org/wheezy/linux-image-3.2.0-6-amd64
i can't find similar stats for older releases but i'm guessing they were even smaller http://ftp.de.debian.org/debian-archive/debian/pool/main/l/linux-2.6.24/

>> No.66429647

>>66428239
Debian

>> No.66429666

>>66429604
Thanks Microsoft

>> No.66429781

What are the consequences for me if I break Debian's Social Contract? For example if I discriminate against someone online

>> No.66429803

>>66429781
You're a faggot.

>> No.66429826

>>66429781
Literally nothing

>> No.66429834

>>66429781
i believe Debian's Social Contract is there so you have the freedom to use debian while discriminating against someone online.
Debian will not discriminate against you for this behavior of discrimination.

>> No.66429871

>>66429781
that only refers to licenses not individuals. the licenses cannot discriminate.

>> No.66429962

What is the best distro for gaming???

>> No.66429971

>>66429962
Source Mage GNU/Linux

>> No.66430015

>>66429962
there isn't a best one, but i recommend solus or lubuntu

>> No.66430140

Is broadcom firmware free or proprietary?

>> No.66430179

>>66424566
I need to print something from wine (to a pdf). From ltspice and even though I have cups, cups-libs-32 and cups-pdf installed it still tells me "before you can perform printer-related tasks such as pace setup or printing a document you need to install a printer"

>> No.66430259

are you able to use the cups-pdf printer in non-wine programs?

>> No.66430273

>>66430179
accidentally deleted my backlink >>66430259

>> No.66430307

Which DE is best for anime?

>> No.66430315

>>66430307
i3

>> No.66430335

Linux wireless is a real PAIN IN THE ASS
>with windows:
>go to network adapter website
>download .exe, install, restart

>with linux (not gun/linux (fuck off))
>read pages of documentation
>hunt down wireless drivers
>pray to God it maybe works after hours of tinkering

Fuck this.

>> No.66430380

>>66430335
Are you stupid?

>> No.66430389

>>66430335
GNU/Linux*

>> No.66430409

>>66430335
(You)

>> No.66430430

>>66430335
>search model number + linux + distro in search engine
>be told how to use it on your favorite distro
>install it
Simple

>> No.66430435

>>66430380
Don't insult my intelligence like that asshole. I don't even care if this is a "friendly" thread.

I will defend my honor if I have to

>> No.66430477

>>66430335
good luck anon. if its broadcom you're doomed

>> No.66430558

>>66430259
I can select print to file and generic printer in libreoffice

>> No.66430566

>>66430477
it is Broadcom BCM43231 which is FUCKED

>> No.66430615
File: 321 KB, 600x483, 67243797_p0_master1200.jpg [View same] [iqdb] [saucenao] [google] [report]
66430615

>>66430315
>>66430307
i3 gaps with polybar, rofi, qutebrowser and qbittorrent

>> No.66430621

>>66430335
more like:
>with windows:
>go to network adapter website
>download .exe, install, restart

>with linux (not gun/linux (fuck off))
>oh hey it already works and I dont have to download anything

>> No.66430632

>>66430615
forgot feh, urxvt and mpv

>> No.66430648

>>66430621
I don't understand why winfags are so attached to this system of "hey, lets go download binaries from shady, malware-ridden places like that Cnet download.com, and then run them with administrative privileges! This is a great way to install software!"

>> No.66430761

>>66430648
You have to be pretty retarded to not be able to tell what is from the manufacturer's website and what isn't.

>> No.66430769

>>66430648
No, just go to the manufacturers official webzone

>> No.66430813

>>66429331
Netinst has a few basic packages' .debs so ironically you can install a VERY basic system using the netinst iso without a network connection.

There are those mini.iso install thou which are <30MB and contain only the kernel, network drivers for the kernel and the basic install system.

>> No.66430850

>>66430140
proprietary and I think you cannot even distribute them (that's why b43-fwcutter exists btw).

There is a libre firmware for a few broadcom cards but it only supports non-encrypted wifi.

>> No.66430898

>>66430761
>>66430769
do you really trust all manifacturers?

>> No.66430927

>>66430898
What does my trust of a manufacturer have to do with "downloading from shady malware ridden places?"

>> No.66430930
File: 382 KB, 1600x1064, 15135931.jpg [View same] [iqdb] [saucenao] [google] [report]
66430930

>>66430898

>> No.66430956

>>66430898
i mean i trusted them enough to buy their hardware.Who isnt to say they dont have a keylogger on a eeprom chip o the motherboard?

>> No.66431201

after i install manjaro (gnome & xfce), my desktop does not display correctly. I got a black screen on gnome after signing in, and on xfce i get a mouse cursor and a background, thats it. how to fix this?

>> No.66431761

>>66431201
read var/log/Xorg.log and ~/.xsession-errors to see wath went wrong.

>> No.66431864

i decided to try opensuse as my first distro, do i choose live image (950mb) or dvd iso (3.6gb)

>> No.66431883

>>66431864
Go with live image. it will download any extra data it needs on the fly.

>> No.66431925

>>66431883
forgot to mention, i have no wifi

>> No.66432059

>>66431925
If you don't have ethernet in 20 fucking 18 then hit the good ol' clorox bottle.

>> No.66432076

>>66432059
fucking eurokeks and their small hous- ..apartments

>> No.66432157

>>66430648

If your Windows computer breaks, that's good for the economy because it means you either need a new computer, or get it repaired at some repair shop, or call some support hotline to get walked through fixing it yourself.

Linux, though, is based on free and open source software that is not intended to break. Fixing it if something breaks is free too.

As you can see, Linux is promoting communism and we need to stop it.
We need to bring back good computer repair jobs to da community so poor underprivileged peoples can have dem good computer jobs.
Linux was invented by da evil white man from finland to opress dem poor african americans

>> No.66432186
File: 109 KB, 1202x832, mfw.jpg [View same] [iqdb] [saucenao] [google] [report]
66432186

>>66432157
>Linux, though, is based on free and open source software that is not intended to break.
>Linux
>not intended to break.

>> No.66432218

>>66431761
how can i read it when i cant get into anything, not in the cli via ctrl alt f* combo, cant do anything

>> No.66432224

>>66432157
Hi there!

You seem to have made a bit of an error in your post. Luckily, the users of GNU/Linux are always willing to help you clear this problem right up! You appear to have referred to the GNU/Linux system as "Linux", but Linux is just a part of the system! Whoops! Linux is the kernel: the program in the system that allocates the machine's resources to the other programs that you run. The kernel is an essential part of an operating system, but useless by itself; it can only function in the context of a complete operating system. Linux is normally used in combination with the GNU operating system: the whole system is basically GNU with Linux added, or GNU/Linux. You should always remember to say or write "GNU/Linux", unless you are referring to the kernel "Linux" alone!

Now, there's no need to thank me - I'm just doing my bit to help you get used to your new operating system!

>> No.66432248

How secure is SSH? Can a remote server read any of my stuff if I connect to it?

>> No.66432276

what do you use for mass renaming files?

>> No.66432286

>>66432224
>Linux is normally used in combination with the GNU operating system

GNU is not an operating system, because an operating system has a kernel, which GNU doesn't.

>> No.66432344

>>66432286
But GNU has a kernel, anon (actually two).

>> No.66432470

>>66432286

>i discovered this thread 10 minutes ago: the post

>> No.66432682

>>66432157
>Linux is promoting communism and we need to stop it.
Red Hat says HI!

>> No.66432811

If I install the vim-gtk package would it install a shitty GUI vim and bloat? I just need to use the clipboard plugin.

>> No.66432906

>>66432811
Yes

>> No.66432919

>>66432811
Just set up xclip hotkeys.

>> No.66432961

Why is making an SD card bootable impossible only for me?

>> No.66432964

>>66432811
>vim-gtk
>will it install a GUI
hmm

>> No.66433170

what are the differences between -buntu distros
DE only?

>> No.66433255

So every fucking day the application color changes in Mumble at 7:30PM. I'm using Manjaro+bspwm+Mate and I can't figure out what's causing it. Googling doesn't help.

Mumble is the only application effected and it uses QSS. Anyone have any pointers to find the shitty setting causing this? I searched dconf to no avail. I don't have or use f.lux either. Nothing in Kvantum or Qt5 settings either.

>> No.66433277

what managed switch should I buy used for my home servers

>> No.66433289

What are some good/decent terminals for KDE?
Konsole looks like piss

>> No.66433292

>>66425593
Try not pressing shift

>> No.66433293

>>66432248
>How secure is SSH? Can a remote server read any of my stuff if I connect to it?
well yeah a remote server better be able to read what you type, otherwise how does it know how to interpret your commands?

The secure part relates to how the data is sent over the network

>> No.66433294

>run htop
>see processes running, all good.
>run program
>gets D status
>whatdo.tiff
>mfw

I know processes that get the "D" status are Zombie processes, but what can be done about it? Or how does the problem happen to begin with?

>> No.66433300

>>66433289
gnome-terminal

>> No.66433308

>>66432961
You dont know how to use dd?

>> No.66433310

>>66432961
because you don't use dd

>> No.66433402

>>66432248
man ssh

>> No.66433428

Can we get rid of systemd already?

>> No.66433437

>upgrade from 10 year old core 2 duo to skylake i3
>be long time awesome wm user
>screen tearing with the default driver (no xorg.conf)
>internet tells me that i need a compositor
>install compton
>still getting tearing in firefox
>spend an hour trying out compton settings to get something that works for me
>suddenly tome4, dcss and vs code have random freezes
>google around and find that the solution is just giving up on compton
>give up on this compositor bullshit and google for tearing solutions for the modeset driver
>find https://bugs.freedesktop.org/show_bug.cgi?id=98876
>"Doubt I'll be working on this, so a friendly advice would be to give it a stab yourself. "
>immediately give up on modeset driver and the "intel" driver since "modeset" aint working for me and enable "TearFree"
>no tearing but now for some reason my terminals have huge latency as if i was running a remote shell

I wish the old computer was still around.

>> No.66433449

>>66433437
>and the "intel" driver
meant to say: and install the "intel" driver

>> No.66433495
File: 531 KB, 2674x1636, imgur-2018_06_21-03:10:33.png [View same] [iqdb] [saucenao] [google] [report]
66433495

Hi guys. Is there any way to use dark themes but left browser inputs white? This looks kinda ugly...

>> No.66433509

>>66433289
simple fact is none of them look good without tweaking. set up the color theme, add a nice font with powerline support (i like Hack) and use oh-my-zsh or rice your own .bashrc

>> No.66433558

"Linux from Scratch"

Is this an appropriate project for a very new Linux user?

>> No.66433589

>>66433558
probably not. maybe if you run it in a VM so its easy to pick up and put down

>> No.66433643

>>66433495
Which browser?

>> No.66433798

>>66433643
Both chromium and firefox suffers this issue.

>> No.66433886

>>66433798
It's not really an "issue" though because they by design for some widgits they just use standard GTK3 widgits and apply your theme to them.
In Firefox you can fix it with this: https://github.com/lightradius/firefox-dark-theme-fix
Just copy the code block into ~/.mozilla/firefox/*.default/chrome/userContent.css
(You'll most likely have to create the chrome directory, yes the directory is called chrome even though it's firefox)

Not sure how to fix it in chromium.

>> No.66433904

>>66430621
this
buy hardware that works with linux, and it's just plug and play
you wouldn't buy a ps2 to play an xbox game, don't buy hardware you aren't sure will work with your OS!

>> No.66433934

>>66433294
D means it's waiting for IO, zombies are Z (and means killed but not yet reaped by its parent)

>> No.66433943

>>66433934
well, dead, not necessarily killed

>> No.66433972
File: 2.95 MB, 480x270, 1436377334383.gif [View same] [iqdb] [saucenao] [google] [report]
66433972

>Install GuixSD
>replace all my old python scripts with purely functional Guile scripts
Living that functional life

>> No.66434226

>>66433943
>zombies
>daemons
>spectres

Computers are fucking cursed.

>> No.66434472

>>66429535
wow technology gets bigger every year or something, big shock

>> No.66434767
File: 30 KB, 722x475, 2018-06-20-221254_722x475_scrot.png [View same] [iqdb] [saucenao] [google] [report]
66434767

What's the best way to access my media on another server?

samba doesn't work half the time
ssh+fish makes you copy the whole file over before playing anything (bad for hd video)
ssh+sftp gives me:
Your input can't be opened:
VLC is unable to open the MRL 'sftp://[email protected]:22/mnt/media/Movies/Alien (1979)/Alien (1979).mkv'. Check the log for details.
and no log is generated
I don't have webdav or ftp set up

>> No.66434789

>>66434767
Plex or kodi

>> No.66434803

>>66434789
I'm trying to set it up for mpd.

On Windows I can connect to a samba share and after some quick buffering, videos start right up. It's a lot smoother and faster than plex as well.

>> No.66434821

>>66433308
>>66433310
Thanks, now I know the problem is my computer simply being unable to read SD cards at boot.

>> No.66434846

Lockscreen in Debian Xfce is horrible. How do I change its theme?

Someone on google suggested installing gnome-screensaver, but that seems lame, any way to apply current gtk theme to lockscreen?

>> No.66434957

>>66434803
Samba is a disgusting permission nightmare
>smother and faster then plex
Dont buy that, with direct stream plex or kodi just access' the file without any need to transcode.

>> No.66434986

>>66434821
I just realized I was in /fglt/ instead of /sqt/. Searching "sqt" in Clover put /fglt/ above /sqt/.

>> No.66435072

>>66433972
How to learn that stuff? It looks like lisp, scheme or something.
Anyway, nice powerlevel, senpai.

>> No.66435099

>>66434846
>tfw websites aren't websites anymore, just someone at google

>> No.66435112

>>66434846
Look into a more customizable locker if you want to rice. I3lock and its forks is pretty script and ricable.

>> No.66435135

antergos or manjaro? It going to be my first pacman distro

>> No.66435391

>>66434767
http if local, ssh otherwise

>> No.66435453

>>66435072
It is scheme basically. It's like a scripting version of scheme so you can use it like you would bash or python scripts.
I love it and don't think I'll ever go back to python. It seems to be pretty fast too, and at least from my own simple tests seems to be faster than python, at least when it comes to printing a lot of text on the screen.

>> No.66435465

>>66435135
I'd say go with Antergos. It's just an Arch installer that still uses Arch repositories and lets you install what you want. Manjaro is pretty much its own distro with its own stuff.

If you have the time and want to put in the effort though, I'd recommend you to install Arch itself. It's not nearly as complicated as people say it is, and by the end you'll know a lot more about GNU/Linux.

>> No.66435559

>>66435465
the learning is certainly helpful especially for a rolling release (in case it breaks, ill know how to fix it) but i generally dont like to mess with my system too much. the OOTB experience is a big selling point for me

>> No.66435583
File: 39 KB, 850x850, woofer.jpg [View same] [iqdb] [saucenao] [google] [report]
66435583

>found this on some bush in the park
>http://loud-grizzly.ro/produs/woofer/
>take it home
>found an old bluetooth usb
>connect
It sounds beautifuly on windows, but when i boot on linux it sound like shit. How can I fix this?

>> No.66435709

Cool terminal commands:

wget -qO- git.io/burger
wget -qO- git.io/coffee
wget -qO- git.io/ff5boss
wget -qO- git.io/nier2b
wget -qO- git.io/pancakes
wget -qO- git.io/pikachu
wget -qO- git.io/pizzza
wget -qO- git.io/pizzzza
wget -qO- git.io/poptart
wget -qO- git.io/rice
wget -qO- git.io/taco
wget -qO- git.io/unix
wget -qO- git.io/uriel
wget -qO- git.io/v94ea
wget -qO- git.io/vburger
wget -qO- git.io/waffles
wget -qO- ptpb.pw/~goatse
wget -qO- ptpb.pw/~hal
wget -qO- z3bra.org/tits

Why didn't you add your art, yet?

>> No.66435725

>>66435709
inb4 rm -rf --no-preserve-root /

>> No.66435760

>>66435725
how would this even be possible with simple stdout?

>> No.66435803
File: 159 KB, 664x631, Screenshot_2018-06-21_07-21-30.png [View same] [iqdb] [saucenao] [google] [report]
66435803

>>66435709
yea... interesting

>> No.66435951

>>66433972
>You will never be this cool
Time to an-hero...

>> No.66436003

>>66434226
>poisontap
>blueborne
>meltdown
>shellshock
>browncow
>wannacry
>heartbleed
>stagefreight

Computers are fucking cool*
ftfy

>> No.66436004

>>66435709
tits: wget -qO- https://asciipr0n.com/pr0n/anime/anime47.txt
not tits: wget -qO- https://asciipr0n.com/pr0n/anime/anime49.txt

>> No.66436015

>>66436004
>no ass
>>>/trash/

>> No.66436032

I have a weird issue with gnome, I changed my cursor but it only applies to like half the applications I open and switches back to the default breeze one randomly? like right now if I hover over a link it uses default breeze cursor but if I hover over a link in another app it will be the custom cursor?

>> No.66436041

>>66436032
>I have a weird issue with gnome
found your problem

>> No.66436050

>>66436032
You need a gtk2 and gtk3 theme support

>> No.66436108

>>66434767
>samba doesn't work half the time
>uses vlc
Why am I not surprised?

>> No.66436171

>>66436108
I usually use mpv but vlc's error log is a bit more concise.

>> No.66436190

Can someone give me a quick rundown on the common compression formats, i.e. bz2 vs gz vs xz?
Am I correct in thinking that generally speaking xz > gz > bz2?

>> No.66436248

For making connections to devices through console cables (switches, routers, raspi, ect.) would you guys recommend screen over putty? How are the two different from one another? Screen seems to be much more minimal as thus for this task, the better choice but I'd appreciate some insight.

>> No.66436312

>>66434767
minidlna ??

>> No.66436347

>>66433509
>color theme
>powerline
>oh-my-zsh
>>>r/eddit

>> No.66436417

>>66434767
I mean I use sshfs and have never had a problem.

>> No.66436459

>>66436347
using good stuff == redit ???!!!

lol

>> No.66436512

How is solus is for a begginer? Its stable and easy to maintain/install software? And elementary os, its true that's full of bugs?

>> No.66436538

>>66430435
>>I will defend my honor if I have to
>honor
do you know where you are anon? people here dont have that

>> No.66436658

>>66436171
Did you turn on verbose logging?

>> No.66436735

>>66436248
Screen is a terminal multiplexer, putty is a client
They are not the same thing and work on different levels
You run screen after you have connected via your client,it allows you to nest terminal sessions on to one screen and swap between them

>> No.66436898

I happily use Manjaro at the moment, but work requires me to use an Ubuntu-based distro. I tried vanilla 18.04 and it's a flaming mess, even the installer can't work without crashing.
What other options do I have?

>> No.66436936

What's a good program to draw with a Wacom tablet?

I have a Thinkpad x200t with Kubuntu, but never used the pressure sensitivity with Linux, only when I had Windows on it, which detected all the stuff automatically and I never had to set it up.

>> No.66436965

>>66436936
Linux has excellent support for wacom tablets, check the arch wiki for in depth information.
Krita for drawing
Gimp for editing.

>> No.66437020

>>66436898
Are you sure you actually need an ubuntu-based distro and that that requirement isn't just a lazy one?

>> No.66437030

>>66436735
So then if for some unrelated reason I wanted to use screen, I'd still need to use putty to actually connect via console cable?

>> No.66437402

>>66437020
A lazy one, to be honest. All the documentation so far is written for Ubuntu-based distros and I don't want to spend too much time getting the environment setup plus troubleshooting issues when they arise, vs getting work done.

>> No.66437486

>>66437030
Yes.

>> No.66437542

Can I use Menu key as a modifier in KDE?

>> No.66437704

>>66437486
Is there a command line alternative to putty, or perhaps a way for screen to automatically initiate a client process, perhaps when run under a certain shell?
Adafruit seems to suggest that the only thing necessary for making a console connection to a raspberry pi (besides the actual hardware) is the screen command (at least on ubuntu). Is this because the gnome terminal has some sort of client program built in that gets initiated when screen is run? Or perhaps screen got a major update not long ago?

>> No.66437807

I have been trying to install Manjaro, but I can't even boot up the live USB, it keeps freezing at "Started TLP system startup/shutdown". I googled, and apparently it has something to do with the GPU, and the workaround apparently is to remove the Nvidia gpu and only have the intel integrated card. Which really doesn't work for me, because it's a gaming laptop and I'll be dual booting with win10.

Close to giving up on this distro entirely.

>> No.66437843

>>66437704
ssh

>> No.66437918

>>66436032
Restart X.

>> No.66437933

>>66436512
It's gods chosen distro.

>> No.66437960

>change my Nvidia settings to 2 X screens to try get it feeling better
>One screen just goes black
>Restart because it said it might need to
>Log back in
>It just logs in, goes black then right back to login screen
>Try using KDE DE to get back in and change the settings
>It works
>Change Nvidia config back
>Crashes for like 10 seconds
>Then everything is ok..
>1 minute later a full lockup, forced to shutdown by holding power button
>Turn pc back on
>Just stuck in a boot loop forever

Posted from my fucking phone

>> No.66438002

>>66437402
>Ubuntu-based

>> No.66438072

>>66437807
Stop dual booting.

>> No.66438164
File: 245 KB, 1063x1063, 1517169338901.png [View same] [iqdb] [saucenao] [google] [report]
66438164

>>66426961
my brainlet method: change the desktop configuration to spanned with GnomeTweakTool and then merge both pictures into 1 that fits the dimensions of your setup

>> No.66438204

Can I set up claws mail in a way that it saves replies in the folder of the email replied to? How? Thanks

>> No.66438692

how do i "require" the awesome api in a lua script?

>> No.66438708

what is the best linux food?

>> No.66438732

>>66438708
tendies

>> No.66438842

>>66438708
Kernels

>> No.66438905

>>66438708
carrots, cause it's a root

>> No.66438917

>>66438708
fish

>> No.66438996

Am I right in thinking KDE is more demanding than Cinnamon
Using Buster on a real POS laptop

>> No.66439008

>got a new job a year ago as a dev in a small team
>forgot to hide my GNU/Autism power
>end the task I was hired for and be switched to another project, with another team
>I keep seeing my previous dev team often
>they start to use a linux server more and more
>get a message telling me "hey anon, can you help me on a linux thing ? How do you do [insert easy shit] ?"
>Answer anyway since it took me 2 seconds.
>get asked for help every 3 days, sometimes in more complex bash script
>finally decide to end this shit by giving them some education
>start creating a small CLI cheat list with some personalized commands and tricks for them
>wow cool anon, you know what ? you should create a course and teach to the people in the company that wants to know more about linux.
>boss hear about that find its a cool idea and wanted us to share our knowledge anyway and wants to use me as an experiment.

How much per "student" should I make them pay ? Considering I might do 3 or 4 hours of "class". 40€ / hour ? considering I might have 6 persons attending I could ask for 1000€ maybe ?

>> No.66439066

>>66439008
what country / how deep are their pockets?
I think €1000 sounds reasonable

>> No.66439085

>>66438072
And this is what's holding linux back. Thinking that making idiotic trade offs just to have an OS is acceptable.

>> No.66439114

Running Manjaro KDE, I love it.
Two questions:
1. How do I make switching same app instances/windows not take the entire screen? It's a hassle when I need to switch betweeb a browser and several office documents.
2. What's the best dock?

>> No.66439138

>>66439066
France. Salaries aren't that high, but "private" courses are always expensive for companies. A quick search presented me some courses costing 70€/hour (a 35h formation).
>how deep are their pockets
It's a small company, 30 devs at most. They won't go bankrupt for 1000€

>> No.66439186

>>66439085
Linux is a kernel and it already owns the mobile market with Android.

>> No.66439286

should I use XFS or ext4?
> installing on arch

>> No.66439352

What's the deal with M.2 SSDs? I've got a regular 2.5 SSD, so would it be an improvement and by how much? Also where do you actually plug them in?

>> No.66439369

>>66439352
hang on this isn't the sqt thread

>> No.66439525

How do i add a partition with a working OS to grub? it seems to have disappeared

>> No.66439557

>>66439525
run os-prober and rebuild grub

>> No.66439601

>>66439557
thank you anon ily :)

>> No.66439847

>add my whole music collection to a deadbeef playlist
>28k files
>takes a good 20-30 minutes

>run soulseek
>scan my full collection to make it available for upload
>scans the 28k files in about 2 seconds

how. not even foobar can scan the tracks that fast.

>> No.66439866

>>66439847
if you did it one after another, did you drop caches between the two?

>> No.66439909

>>66439866
Yes in that case, but soulseek always scans that fast. Even on a fresh install that I've copied my collection to it scans the entire thing in no more than a couple of seconds.

>> No.66440140

Is there to keep track of new files in a folder? Like and md5 or something?

>> No.66440297
File: 10 KB, 308x240, Capture.png [View same] [iqdb] [saucenao] [google] [report]
66440297

I installed OpenSuse Tumbleweed since I wanted a stable rolling release distro, but I'm unsure which versions of builds to use when installing software. Common sense tells me to download the latest release for whichever the main release is on (Leap in this case), but when I attempt to install either through the command line, or through YaST it says there is nothing to install.

>> No.66440552

>>66438996
Plasma probably is at least.

>> No.66440639

>>66437933
OK thanks

>> No.66440673

>gcc and make need two times more space than a whole working linux installation with busybox

What can be done about this faggotry? I just want a working C compiler and make, not 100mb of useless dependency bloat. Is there a non bloat version of gcc and make? Maybe even g++?

>> No.66440726

>>66440673
Your post is bloat; please delete it.

>> No.66441019

>>66440673
Do you have some precedent for believing a C compiler and make should take up less space?

>> No.66441192

I posted in the previous thread but my problem hasnt been solved.
After my first login on a clean manjaro xfce install I dont see jack. Only the wallpaper and the mouse cursor that i can move. with manjaro gnome my whole desktop is just black.

I tried checking the log files but i cant enter CLI mode, when i press alt+f2 nothing happens or my screen goes black.

pls halp

>> No.66441274

i always hear that fedora is botnet because of red hat. is there any proof?

>> No.66441293

>>66441274
like any neckbeard claim: no. mostly conspiracy and paranoia

>> No.66441300

>>66441293
ok, fedora seems like a really nice distro. Also can you say the same about canonical?

>> No.66441396

what is the best DE for battery power? I just read that ram actually does not use much power and that the big drainers are CPU and GPU. How does one determine a good DE for their laptop based on that?

>> No.66441412

>>66441396
no DE

>> No.66441458

>>66441412
what do you use on your laptop?

>> No.66441485

>>66441396
Debian + OpenBox

>> No.66441497

>>66441396
Arch + i3

>> No.66441516

>>66441485
>>66441497
what is the WM with the lowest learning curve?

>> No.66441561

>>66441516
openbox

>> No.66441638

>>66426439
Perhaps try reading the error message
>>66432276
mv
>>66433558
no. start with something very easy like poobuntu
>>66434767
sshfs is fast and secure
>>66436190
depends on whether you want speed or small file size. check the arch wiki

>> No.66441654

>>66441192
>alt+f2
You mean ctrl+alt+f2?

>> No.66441740

>>66441638
>Perhaps try reading the error message
Error message was literally what I said.

>> No.66441980

Why does Stallman insist on calling GNU/X/systemd/Linux just GNU/Linux?

>> No.66442030

>>66441980
He does most of his job in text interface and there is a good chance he uses a distro with no pötteringd.

>> No.66442063

>>66440673
Go ask sucksmore.org to write a 1,44MB C compiler and C library for (You) because you cannot spare 100MB in 20 fucking 18.

>> No.66442083

>>66441654
yeah also tried that

>> No.66442084

>>66441980
I'd just like to interject for a moment. What you're referring to as GNU/X/systemd/Linux is actually GNU/(Qt|GTK)/(X|Wayland)/systemd/Linux

>> No.66442379

>>66441980
Honestly out of all of those things listed there is only 1 that self professes to actually be making an OS, and that's GNU.
Why do people insist on trying to name an OS after projects that have never even declared their intent to make an OS.

That's like calling a computer "CPU" because the CPU is what does the most work.
>Hey guys, I just built my own CPU, turned it on and installed Gentoo on my CPU. Now I'm browsing 4chan on my CPU.
Sounds dumb right? Because it is.

Calling the OS GNU/Linux is actually just a courtesy from Stallman. Linux never intended to be an OS.

>> No.66442421

>>66441019
Yes, because those 2 don't even make a dent in the actual space usage, most of it is bloat GNU libraries they bring in.

>>66442063
I cannot spare 100MB on a raspberry running alpine linux in RAM, the [current year] doesn't help me with that.

>> No.66442474
File: 78 KB, 440x265, this Naga.png [View same] [iqdb] [saucenao] [google] [report]
66442474

How much of the wine entries for gaymes are bullshit? I refuse to believe most gold and platinums are true. What are gold and platinum to those people?

>> No.66442475

>>66442421
Try TCC.
$ pacman -Qi tcc-git | grep -i size
Installed Size : 883.00 KiB

>> No.66442586

>>66442474
>lying on the internet
now why would anyne do such a thing?

>> No.66442622

>>66442475
Sounds good, I will definitely try that out. Do you also know of any make alternatives?

>> No.66442850

I want to ditch Windows and move to some Linux distro, but out of everything I tested only Linux Mint gets past the boot screen on my system (R9 390 + 4790k).
Everything else (like *buntu, Arch, Fedora, etc) freezes at the boot and the GPU heats up a lot (the fans don't spin) also pressing keys like Ctrl+Alt+F2 or Ctrl+Alt+Delete does absolutely nothing.
The only way I can get to the desktop is with nomodeset and that gives me a beautiful 1024x768 resolution on a 2560x1080 screen.
I tried using nomodeset and installing the amdgpu-pro drivers but nothing changes.

As to why I don't just use Linux Mint, even tho it works, it still has graphical glitches and mpv seems to use the GPU at 100% even with basic config (opengl-hq).

So is there a way I can unfuck this, or should I just stick with Windows?

>> No.66442883

is there a way to stop a full screen game from resizing my desktop resolution when i exit?

>> No.66442954

>>66432276
perl-rename

>> No.66442970

>>66433509
terminal != shell you retard

>> No.66442981

>>66432276
zsh's zmv module

>> No.66443000

>>66442970
dont care

>> No.66443027

>>66442850
Unironically just stick to Windows - its pretty nice if your hardware is supported but otherwise can be a massive pain in the ass and I wouldn't bother.
On another note "opengl-hq" is depreciated, use "gpu-hq" instead on mpv.

>> No.66443031

what are the differences between -buntu distros? DE only?

>> No.66443041

With Kubuntu, how do i create a desktop icon for something that has to be started as root?
Ampps in particular.
Pisses me off starting it from terminal every time

>> No.66443053

>>66443041
Add sudo in front of the icon command?

>> No.66443069

>>66435709
>>66436004
curl git.io/burger
curl git.io/coffee
curl git.io/ff5boss
curl git.io/nier2b
curl git.io/pancakes
curl git.io/pikachu
curl git.io/pizzza
curl git.io/pizzzza
curl git.io/poptart
curl git.io/rice
curl git.io/taco
curl git.io/unix
curl git.io/uriel
curl git.io/v94ea
curl git.io/vburger
curl git.io/waffles
curl ptpb.pw/~goatse
curl ptpb.pw/~hal
curl z3bra.org/tits

what a faggots

>> No.66443085

>>66443053
Let's pretend i have mental retardation and am not quite sure what you mean here

Seriously though, i just switched to Linux a couple of weeks ago

>> No.66443118

>>66435709
info coreutils --index-search 'backup options'

Go straight to any node in the info pages

>> No.66443140

>>66442883
Do you mean restoring the resolution? Why wouldn't you want that? Or are you saying that it just changes your res to some arbitrary and undesired value when you close the game? I'm not sure I understand.

But anyway, I wonder if this is actually a window manager thing. Because ever since I started using i3 I've never once had any application change my resolution. In fact if I press mod+shift+f on a fullscreen application (the i3 hotkey for toggling on/off fullscreen) it takes it out of fullscreen and renders it at the full resolution but scales it down to a small window so it can be tiled.
Changing a games resolution behaves the same. Only the renderd window has a lower res but i3 still scales it up without changing desktop resolution.
It's actually pretty nice because all these operations are instantaneous. There is no alt+tab delay or desktop resolution change or anything.

>> No.66443201

>>66443085
Right click the icon and go into properties (or whatever its called). There is probably something that shows the command that the shortcut does, add in sudo before whatever is already there.

>> No.66443245

>>66443201
The application is in /usr/local/, won't let me change permissions or move it

>> No.66443279

>>66443245
Screenshot?

>> No.66443297

>>66441980
But he's actually fine with that. https://www.gnu.org/gnu/gnu-linux-faq.html#many

>> No.66443325

>>66443069
How about no.

>> No.66443326
File: 629 KB, 1366x768, ampps.png [View same] [iqdb] [saucenao] [google] [report]
66443326

>>66443279

>> No.66443351

>>66443085
there's a command to open the little kde dialog box that prompts you for a password, but I forget the name of it because I haven't used kde for a while.
With gtk, It's gksudo foo to start foo with elevated privileges.

>> No.66443366

>>66443027
Stop recommending malware.

>> No.66443371

>>66443326
Uh, how did you actually create the shortcut?

>> No.66443389

New to void linux, how do I compile 2bwm using xbps-src with my config? Also, why will removing sudo break base-install?

>> No.66443398

>>66443371
I didn't, as i don't know how. That's my issue anon.
This is the default installation folder.

>> No.66443422

>>66443398
Oh, I'm blind for not noticing that.
On the "start menu" (whatever its called) just drag the program to the desktop, it should create a shortcut. If if needs root, it should just come up with a dialog box as >>66443351 said.

>> No.66443473

>>66443422
Just tried, won't let me do that
The only way i can run this thing is
cd /usr/local/ampps
sudo ./Ampps

>> No.66443623

>trying void Linux lxqt iso
>need basic WiFi wpa connection, no other way
>only provided wpa tool is wpa_supplicant
>need to make and edit config file
>just edit lol
>only provided editor is vi
>fire it up, struggle, man vi, man page says beginners will have a hard time even with help of manual, have a friend to help you
>void wiki covers other methods to connect WiFi wpa
>just xbps remote server lol
>enlightenment iso had connman provided but only worked in root session for some reason
I must be wrong. Can I get wpa_supplicant to connect without a config file?

>> No.66443636

>>66443473
Really? I just tested it on a spare machine running KDE and when dragging to the desktop I just click "link here" and it works.
YaST -- which needs root -- then just asks for the password in a dialogue box without having to change any of the properties of it.

>> No.66443719
File: 644 KB, 1366x768, ampps properties.png [View same] [iqdb] [saucenao] [google] [report]
66443719

>>66443636
Didn't work, but i managed to copy it on the desktop, but it still wants me to run it as root somehow.
Pic related, any ideas?

>> No.66443722

>>66443623
Forgot to mention I tried >>66430125 but it fails. Getting "device or resource busy" and "CTRL-EVENT-SCAN-FAILED" shit.

>> No.66443778

>>66443719
On my shortcut there is an "application" tab on the left window that has a command field, that's where I was meaning to put "sudo", but that's not in your picture for whatever reason.
Have you tried looking at the actual .desktop file? Maybe you can add something there?

>> No.66443815

>>66443778
There is no .desktop file. See >>66443326
for the screenshot of the entire folder.
Eh, i give up. Guess i'll start it from the terminal.
Tried this https://gist.github.com/dionysius/2526745612b0b5cc1865 but it just freezes my system when i try and run it

>> No.66443819

>>66443623
>>66443722
I'm not experienced with wpa_supplicant either, but have you considered just temporarily disabling security encryption on your router so it should be easier to connect, performing the install, installing a better wireless management tool, then re-enabling security?

>> No.66443842

so uhhh, all my hardware is amd (cpu and gpu) and i found intel microcode installed so i thought hm, lets remove it. I reboot and K E R N E L P A N I C.

how do i fix this antergos? i can wipe the system if its easier, i have no important data on there

>> No.66444082

>>66443815
Sorry you couldn't get it to work, but if you want a kind of shitty solution that would work just create an .sh file with "sudo ampps" or whatever, put it on the desktop, and then change the icon.

>> No.66444118
File: 1.19 MB, 245x163, check em.gif [View same] [iqdb] [saucenao] [google] [report]
66444118

>>66444444

>> No.66444134

>>66444082
Hey that could work.
How do i actually point it to do
cd /usr/local/ampps
sudo ./Ampps

>> No.66444172

>>66443842
you'll have to boot from a live ISO, chroot into the broken system and get pacman to reinstall the microcode, its probably in the linux-firmware package.
https://wiki.archlinux.org/index.php/Change_root#Using_arch-chroot

>> No.66444199

if i have a hardlink, that points to a file a.txt, then i delete the file a.txt, the link will still work since it points to the same inode (that stores the data location).
but deleting a file means that where the data for this file was stored can now be overwritten. does that mean if i delete a.txt and create a lot of other files, will the data of a.txt be overwritten or will the system prevent it since there's a hard link pointing to the inode?

>> No.66444308

>>66444199
The filesystem knows. It won't be overwritten.

>> No.66444322

>>66444134
If you put those two lines in it might just work actually.

>> No.66444342

>>66444322
Sadly no, it didn't

>> No.66444371

>>66444342
Any error?

>> No.66444388

>>66444308
okay, thanks.

>> No.66444402

>>66444172
ty

>> No.66444415

is ubuntu botnet? asking seriously

>> No.66444428

>>66444415
Is it systemd?

>> No.66444453

>>66444415
if you disable tracking, no. although a bit fucked that it has an amazon app installed by default. and as we all know, amazon is for sure a botnet.

>> No.66444646

>>66444415
Yes, it is. Grab Debian Sid if you want apt and dpkg.

>> No.66444656
File: 504 KB, 1440x900, Screenshot (5).png [View same] [iqdb] [saucenao] [google] [report]
66444656

>>66444428
im not gonna ask why systemd is botnet, this is a whole new thread.
I am trying out different distros before settling on one and never looking back. So far all of my picks have systemd. Recommend one without systemd AND that that is easy enough to use so i can recommend it to people without any linux experience (has to be nice and ready without took much tweaking).
So far my picks are antergos, fedora, mint, elementary.

>> No.66444698

>>66444371
None, just nothing happens

>> No.66444704

>>66444415
Yes. Every opt-out tracking is botnet. However, one click and the botnet is disabled.

>> No.66444738

>>66444415
no in the advertising sense. yes in the sense it submits crash reports, which can be disabled (sudo systemctl disable apport.service)

>> No.66444742

>>66444656
Be a thinking man and start/learn with Ubuntu. Then settle with a well configured Debian netinstall.

>> No.66444788

>>66444742
im thinking of doing this, but the aur seems really attractive.

>> No.66444838

>>66444656
Don't worry about systemd, complaining about it is a meme. At best it's a very useful tool, at worst it's just something in the background you don't have to care about. There's a good reason it's been adopted by every relevant distro.

>> No.66444841

>>66444788
So learn with manjaro and settle with arch.

>> No.66444848

>>66444656
Antergos is Arch so have fun.
Fedora is reliant on systemd, RHEL
Mint is reliant on systemd, ubuntu fork
Elementary is reliant on systemd, ubuntu fork

systemd is just aggressive and invasive. It does its job well, there is just controversy over its overarching power on the system.

>> No.66444852

>>66444841
what about antergos? its just an arch installer which i like

>> No.66444859

debian netinstall was one of the worst contemporary linux experiences i have ever had. if you want to see what dealing with sound drivers and wifi was like in 2009 you should try it, otherwise just use regular debian

>> No.66444870

>>66444656
If you liked Antergos/Arch you can try Artix, which is literally just Arch without systemd. You have the typical Arch installation but with a few different commands, and you also have GUI installers like Antergos.

Parabola is Arch but with fully Free software and it has multiple installers, CLI or GUI, with or without systemd.

I'm not familiar with many others, but you can find a lot of them here:
http://without-systemd.org/wiki/index.php/Linux_distributions_without_systemd

>> No.66444891

>>66444838
systemd is a bloated mess of UNIX philosophy violations made by incompetent developers who don't understand basic GNU/Linux concepts that is slowly but surely becoming a second kernel

>> No.66444921

>>66444870
I hear Artix is good for server but bad for desktop.

>> No.66444925

>>66444848
what can you say about their package managers, pacman, dnf, and apt? My list was mostly made of package managers and convenience.

>>66444870
thanks, i was looking for this link. I didnt know parabola had a gui installer.

Im really looking for easy to use distros without the demand for time sync

>> No.66444980

I installed Ubuntu 18.04 and everything is fucking tiny from text to the GUI itself. I looked at display to increase the scale from 100% to 200% but 200% scale is way too huge and there's no middle ground.

How do I fix this?

I'm using a 4k monitor

>> No.66444985

>>66444698
Are you saving the file properly?
If those commands work to launch that program when typing them in I don't see why they wouldn't work in a script.

>> No.66445005

>>66444698
>>66444985
Also, forgot to add, try substituting in "sudo" for "kdesudo".

>> No.66445097

>>66444985
>>66445005
Still does nothing
#!/bin/bash
cd /usr/local/ampps
sudo ./Ampps

That should work in theory, no?

>> No.66445131

I'm a complete brainlet and don't really understand how to build a network.

I have a raspberry pi in my local WLAN network, and i can SSH into it. that works fine, it's all cool.
But i know that, in offices or in schools, computers are linked and have access to shared files and folders. They don't need to use SSH for that at all. And i don't know how to set that up at all.
I am looking at LDAP right now but i'm not sure if that's what i want. I don't want to go through the hassle of installing and configuring it if it won't do what i want.

>> No.66445147

>>66444921
I haven't had any issues with it. It's Arch without systemd. That's it.

>> No.66445167

>>66445097
I don't know at this point anon.

>> No.66445190
File: 182 KB, 296x381, thumbs.png [View same] [iqdb] [saucenao] [google] [report]
66445190

>>66445167
All good anon, i really appreciate the help in any case

>> No.66445387

Package kernel-headers-4.16.3-301.fc28.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!


Your kernel headers for kernel 4.16.3-301.fc28.x86_64 cannot be found at/lib/modules/4.16.3-301.fc28.x86_64/build or /lib/modules/4.16.3-301.fc28.x86_64/source.

FUCKING HOW

>> No.66445516
File: 53 KB, 336x336, 1512679429193.jpg [View same] [iqdb] [saucenao] [google] [report]
66445516

So I've been using Windows for as long as I've used computers, but I'm starting to get really interested in Linux. I've read countless times that Windows and Linux are supposed to provide different OS "experiences" aimed at "what you want to accomplish" with your computer, but that's annoyingly vague. I only specifically know that Windows is better at games and has annoying bloatware, whereas Linux is cheaper, utilizes the command line more, and allows for greater customization. I'm going to download and mess around with Debian tonight in a VM.

Linux users; what exactly do you spend time doing on your computer that you feel would be hindered/less efficient if you used a Windows OS? Thanks

>> No.66445557

>>66445516
nothing

>> No.66445610

Manjaro KDE vs Kubuntu for a just werks distro?

>> No.66445743

>>66445516

I find it easier to make my Linux machine do what I want.
I occasionally write scripts to automate certain tasks, and I find it very straight-forward and easy to set it up so these tasks are run at certain times of the day.
I'm sure Windows can do this too, but it's more of a hassle.

>> No.66446504

i3 user here.
How can I add Tmux to my start up programs?
I understand I have to exec tmux to run the terminal at start up, but after Tmux runs I want it to run a very specific layout.
aka: start a new session, split the window horizontally and stuff.

What do?

>> No.66446521

Hello, I was experimenting with dual booting, so I install trisquel alongside to windows 10 on a virtual machine, the problem is, it fuck my grub installation. I tried to repair it but my linux installation doesn't show my root partition, how can I find it?

>> No.66446708

>>66446504
That's not an i3 question. You already know how to issue startup commands from i3.
So the real question is just what command(s) do you need to run to get tmux into the setup you want.
Then just run that command in the i3 startup script.

>> No.66446730

>>66446708
Pretty much this.

>> No.66447071

which one do I choose? I'm on Debian testing and printer is a Brother HL-22700W
LPR printer driver (deb package)

CUPSwrapper printer driver (deb package)

Generic LPR printer driver (deb package)

Generic CUPSwrapper printer driver (deb package)

>> No.66447112

Do you think Linus Torvald's last words on his death bed will be that he should have treated Stallman better?

>> No.66447289

>>66447071
I DID IT WITHOUT BREAKING ANYTHING
I wonder how does it feel to install gentoo and make it work smoothly

>> No.66447290

I'm getting a system freeze when I leave my pc idle for a long time, more than 3 hours, power reset seems to be the only solution.
What is the best way to diagnose it?
I'm runing arch w/ systemd, kde plasma, no swap.
The only thing related to it that I remember is that my monitor would not power off after locking (configured at plasma to be 3 min), so I restarded and set dpms:
xset dpms 300 0 0

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action