[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology

View post   

[ Toggle deleted replies ]
File: 95 KB, 430x573, 1529353458537.jpg [View same] [iqdb] [saucenao] [google] [report]
66403463 No.66403463 [Reply] [Original] [archived.moe] [rbt]

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: just like in /sqt/ spend at least a minute to check a web search engine with your question.
*Search: qwant, searx, ixquick or startpage.
*Many free software have active mailing lists.
*Many free software has an active bugzilla where you can check and report errors

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):

/g/'s Wiki on GNU/Linux: https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
>What are some cool programs?
>What are some cool terminal commands?
>Where can I learn the command line?
>Where can I learn more about Free Software?
>How to break out of the botnet?

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

Previous thread: >>66387483

>> No.66403529
File: 227 KB, 1500x743, flt.png [View same] [iqdb] [saucenao] [google] [report]

First for fuck Amazon.

>> No.66403554

Second for go back to /pol/

>> No.66403559

whats some stable linux distro? currently ubuntu, and need something for 18.04 thats lightweight, but not austic rolling distro like arch, as i actually have a job.
is it debian? is gentoo just a meme?

>> No.66403668
File: 14 KB, 400x105, Salixos-logo.png [View same] [iqdb] [saucenao] [google] [report]

What should I expect?

>> No.66403733

Why is linux so shit?
Any time i move data between drives(sdd or hdd) the entire system hard locks for multiple minutes. It could be 2mb, it could be 200gb.
All of the drives pass smart and using the same drives in windows, it has no io lock up.

>> No.66403806

ur a meme

>> No.66403838

because it's a hobby is made by some finnish student
don't expect anything as good as windows

>> No.66403921

lol samefag

>> No.66403926
File: 12 KB, 816x435, 2018-06-18-215653_816x435_scrot.png [View same] [iqdb] [saucenao] [google] [report]

anyone familiar with bitmap fonts? i'm trying to install terminus but can't make mkfontdir detect the fonts in my folders it just writes a 0

>> No.66403935

What's the significance of your screenshot? I have images blocked right now

>> No.66403948
File: 31 KB, 400x320, 1529355951036.png [View same] [iqdb] [saucenao] [google] [report]

What is the best cursor theme and why will it always be DMZ white?

>> No.66403963

>blocking images on an imageboard

>> No.66404015

Debian if you like freedom and respect.

>> No.66404028

basically just a screenshot of mkfontdir just writing a 0 instead of listing the fonts as if should

>> No.66404121

Slackware with a shithuge repository and everything tagged for slapt-get to automagically resolve depends. I've used it, but I used vanilla Slackware before it, so I used it as "I want Slackware but I don't want the ten-million packages in the base install, but I might need to install things later," which worked out okay with only the Slack repos enabled and none of the extra ones, using both Salix and Slackbuilds. I've had more than one update go sideways, though, so I set up regular Slackware again with some slackpkg templates to still get that same trimmed-down feel without the horseshit involved in using Salix.
Basically, it's Slackware with training wheels. There's technically nothing Salix does that you can't do with Slackware itself. Doing the things in Slackware is a one-and-done ordeal, but doing them in Salix is easier. As a long-time Slack user, I'd suggest installing Slack itself and learning the tools, but you're welcome to try out Salix instead. Your mileage may vary with it, is all.

>> No.66404261

>go to /etc/fonts/conf.d/
>delete 70-no-bitmaps.conf
>go to /etc/fonts/conf.avail/
>copy 70-yes-bitmaps.conf to /etc/fonts/conf.d/

>> No.66404281
File: 64 KB, 800x588, 1529357393741.png [View same] [iqdb] [saucenao] [google] [report]


>> No.66404379

already have 70-yes-bitmaps.conf there, changed it with dpkg-reconfigure fontconfig-config. maybe it's just a bug being on debian testing? i can't find much about it on google

>> No.66404393

Try DDG.

>> No.66404466 [DELETED] 

Why is she reading the communist manifesto?

>> No.66404708

Posted on the previous thread, but here we go again:

I have my old Compaq 610 laptop I got like 9 years ago when I was at highschool for about 400 euros (kinda okay for that price I guess but I was not very tech-savvy at that time).
Since some components degraded and I got a desktop I picked up a new laptop for uni, but this thing may be usable with GNU/Linux and a light desktop (I just don't mind the performance drop from just a wm and I don't want to learn shortcuts desu)
Thing is, what should be changed:
-keyboard (missing w because the nipple thingy under that key broke but still detects when you use your finger: ~20 euros
-trackpad: really thinking if it's worth since even not being the best in the world, I would like to have the option. ~15 euros
Battery was bought about 5 months before retiring the laptop and it has a nearly new 500 hdd, but I don't know if it is worth spending that money to fix this spare machine or use the hdd as an external one and just throw it away

>> No.66405020

Why is arch so hard to install?

>> No.66405101

It isnt.

>> No.66405162

it isn't. the install guide is pretty shitty though, if you have never partitioned i hard drive or know which bootloader you want and how to configure it you're probably gonna get lost somewhere cause the guide just sends you off with no default recommendation.

>> No.66405198

it is not, just takes so damn long to install

>> No.66405365

What distro should I choose if I dont care about systemd or runit and I want to become a sys admin

>> No.66405412

Hello, i have a Lenovo laptop with debian on it. it has a ssd and intel 520 graphics card, however when i play videos or music the system shits itself really badly and i get lag when skipping forward in videos even webms any idea what can cause it?

>> No.66405616

What's the best terminal for a wm?

>> No.66405669

Any recommendations for a good book that explains the inner workings of Linux?

Has anyone read "How Linux Works" by Brian Ward?

>> No.66405708

bullshit, i couldn't even get it to boot up successfully because it failed to find a drive that didn't exist after 30 seconds. Also the wiki is shit, it just assumes the iso will work out of the box on all machines and that it won't give you an aneurysm and a thorough butt-fucking.

>> No.66405828

Bought a computer 2013-06.
Haven't booted it since 2017-12. It worked then.
What is the probability of the internal HDD having broken down since then?

>> No.66405848

What video player?
urxvt w/ proper config

>> No.66405859

extremely low.

>> No.66405892

What shouldn't use instead of GRUB in a UEFI system? Should be as minimal as possible and no interaction. Just boots to my distro of choice. No systemd-boot shit.

>> No.66405904

s/shouldn't/should I
I'm a dumb phoneposter

>> No.66406002

You need to add the font to qset or something. I haven't done it in a while, but you need to add a directory to the font path for it.

>> No.66406007

No, your inability to follow a SIMPLE GUIDE is BULLSHIT.
99.999999999999999999% of the time the iso works, it not working is most likely your own fuck up or you're running i386 and didnt know arch ditched it last year.

Install guide is the bare minimum on what is needed to install a bare arch install.
Did you not read the step by step guide on how to partition and the various lists of partitioning guides based on your usage?
Did you not click the bootloader page and read it?

>> No.66406072

amd x86-64, it refuses to boot, throws a bitch fit, and then quits. f u.

>> No.66406089


>> No.66406091

>refuses to boot
Post logs
>throws a bitch fit
Post logs
>then quits
Post logs

Sounds like you dont know how to use dd properly and fucked up the installation medium

>> No.66406092

Alright so i installed ubuntu recently and keep getting into weird shits i don't know how to fix or search about. The newest one being related to trying xfce and later downloading the whole xubuntu-dekstop package, now when i open my session i only see the cursor and wallpaper and have to manually switch to any tty and back to tty7, what exactly is happening here and how can i know?

>> No.66406095


>> No.66406098

>t. archfag

>> No.66406105

umm, that's not a log

>> No.66406115

I am an archfag.Been using it since 2009.
Ive never had these make believe issues shitposters want to bring in this thread

>> No.66406145
File: 2.39 MB, 448x252, arch linux.gif [View same] [iqdb] [saucenao] [google] [report]

Is Kevin lurking in this thread? I'm thinking of abandoning Arch Linux for Solus. I'm tired of lurking / begging for Solutions every time something goes wrong in Orange I'm just tired of dealing with constant little issues. the only thing I really liked arch for was the Aur anyway and that was just because of meh gayems.

I like the pre configurations they make for i3 but I can't seem to find its config file anywhere. Otherwise I think I could get the rest working myself.

>> No.66406214

Love the Arch Wiki! Very detailed, organized and informative. So... is there an app/program to have an offline version of it?
Like, download a copy of the Wiki to your PC for later viewing or whatever.

>> No.66406225

Slackware still doesn't auto-resolve dependencies?

>> No.66406231

See Configuring i3 for details. The rest of this article assumes the i3 configuration file to be in the folder ~/.config.

didnt even try

>> No.66406241

Here you go, jerk:
Probing EDD (edd=ff to disable)... ok
[0.005187] Spectre Vs : Spectre mitigation: LFENCE not serializing, switching to generic retpoline
[2.511092] Initramfs unpacking failed: write error
: : running early hook [udev]
: : running early hook [archiso_pxe_ndb]
: : running hook [udev]
: : Triggering uevents...
: : running hook [memdisk]
: : running hook [archiso]
: : running hook [archiso_loop_mnt]
: : running hook [archiso_pxe_common]
: : running hook [archiso_pxe_nbd]
: : running hook [archiso_pxe_http]
: : running hook [archiso_pxe_nfs]
: : Mounting '/dev/disk/by-label/ARCH_201806' to '/run/archiso/bootmnt'
ERROR: '/dev/disk/by-label/ARCH_201806' device did not show up after 30 seconds...
Falling back to interactive prompt
You can try to fix the problem manually, log out when you are finished
sh: can't access tty; job control turned off
[rootfs ]# _

and then it doesn't let me do anything afterwards.
This is being run in qemuy, my current theory is its supposed to be run from a usb for some reason so i'm currently dd'ing a usb with the iso in order to boot from the usb and (fingers crossed) successfully install to a virtual image.

>> No.66406248


>> No.66406261

use some sort of webrawler to download it all including links then convert to pdf?

that's an easy one dude, you're booting through efi aren't you, select the non efi/legacy usb boot option

>> No.66406270

Your "burning" software didnt work properly and didnt label the device "ARCH_201806".
Very apparent what went wrong.
: : Mounting '/dev/disk/by-label/ARCH_201806' to '/run/archiso/bootmnt'
ERROR: '/dev/disk/by-label/ARCH_201806' device did not show up after 30 seconds...
Falling back to interactive prompt

>> No.66406364

> select the non efi/legacy usb boot option
how do this in qemu?

Currently burning a label right now, haven't done it just yet.

>> No.66406404

no it's your device boot menu, there should be two options listed for booting from the usb, one says efi usblabel the other one should say just usblabel use the second one. I've had this issue often on several different linux isos.

>> No.66406454

is he male or female this week? she always changes her genders now...

>> No.66406487

Emma Watson?

I'm starting to think the whole 'i change genders' thing is about getting a free card to bring up political issues whenever.

>> No.66406496
File: 51 KB, 1016x230, Screenshot at 2018-06-18 18-58-32.png [View same] [iqdb] [saucenao] [google] [report]

What's going on here?

Artix linux, btw. Feel like I have a lot of problems with repos with this distro.

>> No.66406520

You are installing a package that is overriding another packages files.
Did you use pip or similar things since its python?

>> No.66406544

my usb drive is fucked.
I dd'd on /dev/sdc so now every usb drive i put in is arch, regardless of if it is or not.

Also USB burn did not work.

How do i unfuck my usb port? How to i unfuck arch and make it just werk?

>> No.66406568

she's changing genders all the time now. she's mentally ill.

ps: https://www.youtube.com/watch?v=e2Jh4nZhy-8 skip to like 2:40 or something.

>> No.66406571
File: 253 KB, 1920x1080, All_Cursor.png [View same] [iqdb] [saucenao] [google] [report]

Don't mind me, just being better than anything you can throw at it.

>> No.66406621

Oh, that makes sense. So if I just upgrade it via pip, then it'll stop bitching at me? (Or alternatively, just ignore it from pacman?)

Was just a weird error, I did a little python a while back and didn't think pacman would pick up on something like that

>> No.66406636

You're scum.
There's nothing about that in that video at all and Emma Watson has been known to support that side of politics for years now. And you had me actually watch about a minute of that absolute dung.

I advise you reevaluate your sources for anything you've touched if you felt it appropriate to link that anywhere. It's clearly content aimed at the intellectually incapable with a narrator who constantly interrupts to add nothing but poisoning the perspective on the content.
You might aswell be watching those auto-generated kids videos.

>> No.66406651

I would uninstall it from pip and use the repo package instead.
>ignore it
Pacman halts on these type of error, meaning you would always halt on this error and nothing would be done about it.
>pick up on it
Pacman has a list of everything you install and they all are documented, meaning if you use pip to install,outside of pacman, it cant track it, so it finds it in the filesystem and halts asking you to fix it.

>> No.66406660

Ah, that makes sense. I'll go ahead and do that then. Appreciate it anon!

>> No.66406681
File: 38 KB, 362x346, question shoujo.jpg [View same] [iqdb] [saucenao] [google] [report]

Why is manjaro #1 on distro watch? I haven't heard much about it.

>> No.66406682

This seems to be a running theme with arch-fags, first they say its your fault that nothing works, then you try their soultion, it fucks it up more, then they dissapear on you and leave you to try and figure out something there is NO DOCUMENTATION FOR.

Fuck arch, Fuck archfags. eat shit and die.

>> No.66406683

Virtualbox throws this error when launching
The fuck is this?
xcb is installed and reinstalling didnt solve shit
Qt FATAL: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb

>> No.66406689

for some stupid reason mpd starts whenever I login to my session even if I disable autostarting from XFCE's settings
I think it starts before I login because it reads the system wide config file instead of my ~/.config one

>> No.66406697

Havent left. He cant even use dd, nothing i can do at this point.

>> No.66406701

Distrowatch rankings aren't particularly indicative of anything except "what's popular on the distrowatch forums this month".

>> No.66406702

I use it. Based on Arch, which is pretty amazing, just that Manjaro has a few other goodies in there.

Why don't you try for yourself?

>> No.66406706

systemctl --user stop mpd
systemctl --user disable mpd

>> No.66406709
File: 417 KB, 1600x1200, 1509783085933.jpg [View same] [iqdb] [saucenao] [google] [report]

>buttmad white knight who worships some cunt and defends her on boards

you're the most pathetic person I ever came across on /g/.

>> No.66406716

Is pic related the actress that did Hermione?
Damn wtf she did to age this much?

>> No.66406721
File: 25 KB, 467x370, 1513568463246.png [View same] [iqdb] [saucenao] [google] [report]

>What is the best cursor theme
It's this one that I made from various cursors from diff OSes. haven't uploaded it to github just yet.

>> No.66406723

you know that is the first place I looked for it, right?

I had this issue when I tried Sway and it worked normally when I just put a config file where I expected it to be but I like what they did when thay pre-configured it so I want to see what they added.

>> No.66406741

Then look at the system config in /etc/?
Like how is this difficult?

>> No.66406771

Unknown operation mpd.
I've been doing
# this kills the mpd process, that's why I think it's starting before I log in to my user

sudo mpd --kill

# if I do $ mpd after the previous I get can't connect to :6600, address in use (or something like that) so I need to do

sudo systemctl stop mpd.socket

# at this point I can $ mpd and everything works as I want it to work

mpd && ncmpcpp

>> No.66406780

>Unknown operation mpd
You dont have mpd installed

>> No.66406783

>USB broken
>Arch keeps bitching
why is life such pain?

>nothing i can do at this point
that's another thing, its seems rare to find someone who actually knows what they're doing with arch.

>> No.66406810

I just downloaded the june iso and burned it to my usb(dd). Plugged it in my laptop and chose it from the boot menu. I have an arch live usb environment on my laptop.
This isnt an arch issue, this is a USER issue. This user will have the SAME problems with any other iso as they cant do basic commands or follow a wiki.

>> No.66406818

I wouldn't expect you to understand the issues with what you've done.
If you were posting something like that in defense of a political point we shared sides on I'd be just as offended. I bet you're stupid enough to assume I'm for the gender politics stuff. You had to dig up some stupid /pol/ image with just as little substance as the video. As if I even defended Emma Watson. I'm just opposed people who don't know how to use their poor excuse for a brain. Like you and presumably the narrator.

You'd be deemed handicapped if measured.

>> No.66406819

I do have mpd installed

>> No.66406836
File: 42 KB, 562x437, 1497849032239.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.66406840

Then my commands in >>66406706 wouldnt result in "unknown operation mpd"

>> No.66406855

[email protected]:~$ apt list --installed | grep mpd

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libmpdclient-dev/testing,now 2.11-1 amd64 [installed]
libmpdclient2/testing,now 2.11-1 amd64 [installed,automatic]
libmpdec2/testing,now 2.4.2-2 amd64 [installed,automatic]
mpd/testing,now 1:0.20.20-dmo1 amd64 [installed]
rtmpdump/testing,now 2:2.4~20160119.gitfa8646dae-dmo5 amd64 [installed,automatic]

>> No.66406863

kys cuck

>> No.66406868

>Then my commands in >>66406706(You) wouldnt result in "unknown operation mpd"

>> No.66406872

This works, as I said here >>66406771
For some reason mpd is starting before I log in to my user
sudo systemctl stop mpd

>> No.66406875

because it doesn't make sense for me for a configuration file to be in route.

I didn't find it though but I did find the config fire for i3 status which is what I wanted.

>> No.66406879

Can you do me a favor? Tell me if you understood the posts. I'm looking for ways of reaching you people. I'm trying hard to dumb down the speech every post. I'm not sure it helps.
I've read that shorter sentences help.

>> No.66406882

locate i3

>> No.66406919

I'll believe you this time, do more research, and try on an actual computer instead of a virtual machine.

It better work or some niggers gonna need to get lynched.

>> No.66406935

>its a white night
how does ti feel to suck emma's cock?

>> No.66406976
File: 436 KB, 342x342, 1498800858889.gif [View same] [iqdb] [saucenao] [google] [report]

your level of autism is off the charts kiddo. time to take some meds.

>> No.66407005

>you people

>I'm trying hard to dumb down the speech every post.
rude! this is FRIENDLY gnu/linux thread, not ANGERY gnu/linux thread.

>> No.66407052

good news: it was just a minor error of the usb controller so i reset the computer and now things are fine.

>> No.66407069

How long is too long for a sudo session? The default isnt long enough for me to perform maintenance.

>> No.66407429

>tfw you keep using rm when you should be using trash-cli instead, just in case
Why am I such a dumbass guys

>> No.66407533

alias rm='trash-cli'

>> No.66407543

bad idea, because then out of habit he might use rm in another computer forgetting that it's actually rm there

>> No.66407579

alias rm='echo "use trash-cli instead dummy!"'

>> No.66407656

got it working, turns out it was just too little ram :^)

>> No.66407937
File: 659 KB, 1200x800, dc0f37d7ec073391333fd73b8bdfee8c.jpg [View same] [iqdb] [saucenao] [google] [report]

OS: Debian 9.4 stretch
Kernel: x86_64 Linux 4.9.0-6-amd64
(I know this isn't a linux "directly" related question, but I don't find an android general)
I planned to do streams (android vidya gaems) but I can't run QEMU correctly (laptop too old, extremely low fps, but OBS run fine with anothers apps).
This is some cheap "tablet" that can I get from market (3rd world country).
CPU: RK3126 Quad Core, RAM: 1GB, Android 7.1
I want to run scrcpy on it
>The application executes a server on the device. The client and the server communicate via a socket over an adb tunnel.
>The server streams an H.264 video of the device screen. The client decodes the video frames and displays them.
>The client captures input (keyboard and mouse) events, sends them to the server, which injects them to the device.
Is this enough CPU or should I save more money and buy another?

>> No.66408063
File: 260 KB, 1009x767, 03i0ir3.png [View same] [iqdb] [saucenao] [google] [report]

>> No.66408174

Why is the Fedora community so small compared to other distros?

>> No.66408232
File: 613 KB, 1920x1491, sɯɹɹ.jpg [View same] [iqdb] [saucenao] [google] [report]

I am on xubuntu 16.04 using i3. Been using this for a few years and got comfy with it. I do have one gripe, though: dmenu_run. It's nice for launching gui programs, sure, but I wish I could use arrow keys to scroll through my bash history and get autocompletion on more than just the initial command... in other words, what's a good alternative to dmenu_run that gives me full bash functionality, automatically opens in floating mode so my other shit doesn't get resized, and which automatically closes when I hit enter?

pls respond

>> No.66408235

I love Trump, and I ain't even alt right bullshit.

>> No.66408261

Im not going to do RHEL's dirty work and not get paid for it

>> No.66408263

A terminal.

>> No.66408277

But that doesn't open in a floating container and doesn't close automatically. I do not want ALL terminals to be floating, I do not want to have to manually make it floating and I do not want to have to close it by hand.

>> No.66408315

tried rofi?

>> No.66408371


Hey anons, I got really interested in understanding how Linux kernel works, anyone knows books,docs,material,etc where I could learn about it?

>> No.66408689
File: 12 KB, 628x183, DeepinScreenshot_gnome-disks_20180619010623.png [View same] [iqdb] [saucenao] [google] [report]

I'm getting this error when i try to make a new partiton on my 1TB hard drive. I couldn't find any info about this online that helped me. Thanks in advance.

>> No.66409326

My monitor's max resolution isn't showing up in KDE. (2560 x 1440 60hz) the max it's showing is 2560 x 1080.

Looking at xrandr --verbose the maximum resolution being extracted is [email protected]

I followed all the instructions here: https://wiki.archlinux.org/index.php/Xrandr#Adding_undetected_resolutions

but when I do $ xrandr --output HDMI1 --mode 2560x1440_60.00

I get this error xrandr: Configure crtc 0 failed

>> No.66409404

since when has questioning authority been being a cuckold?

>> No.66409498

I just learned about units today and my life is changed.

>> No.66409525

I thought that'd go in a code tag to make it obvious that I mean UNITS(1)

>> No.66409576
File: 13 KB, 331x257, Oxygen-Midnight-Meadow.png [View same] [iqdb] [saucenao] [google] [report]

Oxygen Midnight Meadow

>> No.66409682

But anon, it's green.

>> No.66409765
File: 259 KB, 1600x1200, Emma-Watson-Hot-1.jpg [View same] [iqdb] [saucenao] [google] [report]

Emma watson. She's 28 now
Still cute af

>> No.66409774

literally the first or second option in etc/default/grub is to skip displaying the menu and just boot whatever is the first.

>> No.66409780

>Why is manjaro #1 on distro watch?
i++ is one helluva thing.

>> No.66409792

>got a job at as an embedded devices developer
>1st day on the job
>they show me my desktop computer
>they tell me my first task is to install gentoo by myself

What the fuck I thought this was a fucking meme

>> No.66409806

sudo su you brainlet or open a "root terminal" (there is usually a shortcut for this in your menu if you use a DE)
stop sudoing six gorillion commands in a row like a dumb pajeet in a youtube tutorial video holy shit.

>> No.66409946

>sudo su
>calls others pajeet

>> No.66409986

cam someone please help

>> No.66409998

I thought the screen tear on KDE was a meme but here I am. Using intel graphics how to stop this?

>> No.66410213

>Still cute af
weinsteined and feminist.
.... better become an hero, than live.

>> No.66410254

not him, but what's wrong with that ?

>> No.66410335

Is there a comfy cli image browser with preview, or should I just get dolphin for such tasks?

>> No.66410437


>> No.66410520

sudo -i starts a proper root shell.

>> No.66410526

ranger has image support

>> No.66410572

that doesn't answer my question, what's wrong with sudo su

>> No.66410574

Is dolphin still the only file manager with folder previews?

>> No.66410646
File: 173 KB, 962x1226, 2D328F38000005783264959She_was_working_in_a_trainm1_1444314810214.jpg [View same] [iqdb] [saucenao] [google] [report]

Sorry, I meant file manager in that sense.

Yeah, that's kinda what I'm looking for.

>> No.66410669

How do format my main drive, /lgbt/?

>> No.66410684

mkfs.ext4 <target partition>

>> No.66410907


>> No.66410949

>fresh distro install
>~$ make
>command 'make' not found ...
why is make not a default package holy shit

>> No.66410966

I recently bought a USB interface for connecting a pair of monitor speakers to my Linux machine. Now I'm often getting a loud popping sound when I start to play something. Does anyone here know how I could get rid of that?

>> No.66411054

What's the difference in resources' usage between zsh and bash? Is bash bloated? What do I need to install zsh on Ubuntu 18.04?

>> No.66411236

>Is bash bloated
yes but not nearly as much as zsh
did you know that bash has no interactive capabilities?
completion, keyboard shortcuts, etc all that is done thru readline
unlike zsh that has a fucking tetris game embedded into it
interactive shells are fucking cancer

>> No.66411322

So should I stay with bash?

>> No.66411358

idk, I see no reason to move from bash myself
if you want a "user friendly" interactive shell, you may wanna try fish
it has sensible defaults and works ootb unlike zsh and it's not as bloated
zsh is completely pointless imo

>> No.66411592

Arch is the opposite of hard to install... Like Ubuntu is way worse, it always throws some stupid error... When you're dependent on GUI to install an OS you should stick to windows

>> No.66411600

If you were to go with Debian, good luck managing old libs... It's so fucking shit... They are literally the SJW of the tech world...

>> No.66411667

I want to make the jump from w7 to something else, but I'm not too keen on w10. Is there an "It just worksTM" Linux distro for brainlets? I heard good things about Mint, is there some other user friendly OS or should I try this?

>> No.66411862

Something that just works?

Something that works when you've installed it w/o GUI?

If you want to get better at computers I'd recommend you to get, one of the less straightforward ones. If you don't care just go with the LTS version of *buntu

>> No.66411874

Go for mint
Cinnamon specifically. You'll feel just like in home and won't miss win7

>> No.66411904

He isn't an "authority", he's a manager. An administrator. As a job creator and an entrepreneur, he's a member of the class that is oppressed by the authorities through heavy-handed regulations and extreme taxation (aka theft). You can't oppose the status quo and be against Trump simultaneously.

>> No.66411908
File: 2.27 MB, 1500x878, animecar.png [View same] [iqdb] [saucenao] [google] [report]

I just installed ubuntu 18.04 and I have two monitors connected, and although I have correctly configured the distribution of these, in the login menu continue to go wrong. I tried the command "sudo cp ~ / .config / monitors.xml /var/lib/lightdm/.config/" and then changing the permissions, but it has no effect.
can anybody help me?

>> No.66411930

Any ubuntu. You need to enter as much info at setup as you'd have to for windows.

>> No.66411931

My bad, the second rute is "/var/lib/gdm3/.config/monitors.xml" since i use gdm3, not lightdm.

>> No.66411957

I used Running Linux (5th edition is most recent, still very relevant even if its 10ish years old) from O’Reilly. It’s an absolute unit of a book, but goes through everything with examples as well as why and how you’d configure/be interested in a particular feature.

>> No.66412022

I head mint is a security desaster, not sure if its still

>> No.66412184

Thanks I'll go with Mint, the ui looks great. Do you run any antivirus on this shit or do you go with the "your brain is the best antivirus" meme?

>> No.66412265

There is a very very low incidence of linux malware. Between the low marketshare and package management being managed by repositories there isn't a need for you have any anti-virus software. Don't enter any terminal commands that you don't trust, don't fall for phishing and you're pretty much golden.

>> No.66412298

I am trying to set up a 24/7 Monero miner on a VPS running Ubuntu 16.04. After a period of time, the script is terminated abruptly with the error "CPU time limit exceeded." I ran ulimit and saw that there is no set CPU time limit (unlimited). Any suggestions?

>> No.66412359

have you tried using a real value?

>> No.66412361

anyone use elementary os? is it still buggy?

>> No.66412421
File: 5 KB, 272x102, Screenshot-2018-6-19 FS#59009 [fontconfig] metric-or8.png [View same] [iqdb] [saucenao] [google] [report]

arse linux everyone

>> No.66412448

try it

>>copy 70-yes-bitmaps.conf to /etc/fonts/conf.d/
you're supposed to symlink

the name is xos4 terminus now

>> No.66412451

I fixed it. ulimit -a shows that a CPU time limit was set. I just set it to unlimited. It should be good now.

>> No.66412485

Source of picture please

>> No.66412626

>>66403463 (OP)

I guess its fake src: https://www.google.fr/amp/s/www.vogue.com/article/emma-watson-interviews-marjane-satrapi/amp?source=images

>> No.66412995

ive been trying to install fl studio on ubuntu through wine obviously but since im pirating it i dont know what to do with the keygen, im new as fuck and so far i love it but i miss fl studio, im going to try LMMS today but i really want to keep on working on my old stuff. anyone knows what to do with that shit?

>> No.66413031

The UI doesn't matter as you can change it out with whatever you seem fit. There is no need for antivirus either. Seeing that you're the one that allows code to execute on your computer

>> No.66413392

This thread has become utter shit.
Why do people ITT recommend Mint?

>> No.66413460
File: 38 KB, 660x734, 1507665263131.png [View same] [iqdb] [saucenao] [google] [report]



>> No.66413484

still better than windows

>> No.66413486

I mean for a novice what do you recommend?
I'm preferable to Debian but someone completely new to Linux is going to be confused by non-free repositories that may leave hardware such as wireless broken out of the box.
Plus Mint packages are easily installable from a website repo. Pretty neat.
Everyone has to start somewhere anon.

>> No.66413513

whats wrong with good old ubuntu?

>> No.66413574

I've ran illegal copy of Windows 7 with disabled system updates for so long that the "this copy of windows is not genuine" message had simply given up and disappeared one day. I doubt Mint is less secure than Windows 7: Pirate Bay Edition and the only thing I'm interested in right now is ease of use, maybe when I get accustomed to it I'll try some other distro.

>> No.66413580

This is why nobody likes Arch users.

>> No.66413604

At least it just works. Also the news,are old, the xapps things have been renamed.

>> No.66413671

I just installed slackware, built my wifi driver, and im able to connect to my network...for a second or two. How do i troubleshoot this?

>> No.66413815

you can start by looking at the log of whatever you use to connect to your network

>> No.66413883

Newbie Linux user.
"Redpill" me on your favorite Package Manager.

>> No.66413892

thanks anon, i had to disable ipv6 :)

>> No.66413942


>> No.66413967

The red pills cause brain damage.

>> No.66414010

Helloo, retard here. How do I run .sh file? I marked it executable but I don't see 'Run' in context menu when I right click it and double-click only opens it in text editor


>> No.66414019


>> No.66414032

OK, I got it working.

I needed to "sh xsh" in terminal.
This did not work. It said, 'not found'.

>> No.66414041

Then you cant type properly

>> No.66414120

Try opening a terminal and dragging the file onto it (to fill out the path), then press enter.

>> No.66414132

Linux SUCKS. Why? Because:

1)Command lines/Lack of GUI's

Why the fvck would I want to use a command line? I have a modern computer, capable of displaying color and icons. Why should their be a command line? And further, why doesn't everything have a gui? Gui's are good, and easy, and don't require me to learn commands. Yey for Gui's.

2)Root/sudo is stupid.

Why on earth should I have to deal with either using sudo or running as root to actually use my programs? I still can't get a lot of programs to run because they keep whining about permissions. What ever happened to good old admin accounts? Why does sudo break everything?


Now this is just plane stupid. Why is it so damn hard to install anything? I have a desktop, why not do it the way it should be done? I get the installer icon, click on it, press forward a few times, wait, and have a nice icon on my desktop. Why isn't it done this way?


Again, stupid. Just give me a fvcking installer program. None of this compiling sh1t.

Come on Linux. The rest of the world has moved beyond 1990. It's time for you to do so also. I'm giving up and installing windows.

>> No.66414159

>giving up
Never gonna make it.

>> No.66414227

What's the sane minimum CPU for Gentoo? I want to install it on my laptop with 2C/4T 3.5GHz 3rd gen i5, but I don't want to wait forever for shit to compile.

>> No.66414259

He's obviously trolling anon.

>> No.66414260

1.I can type faster then looking through 5 pages of checkboxes on a gui
2.No one has access to what they dont need, including my user.If by chance i do get compromised, congradulations you have acces to my home folder and thats it.Wreck any havoc you want, i have hourly backups.You cant touch the system. Windows has this but you just spam press the uad button till it stops popping up.AKA no security at all
3.I agree, apt based distros are shit. Use arch and pacman
4.99% of all programs you need are offered as binaries in your distro's repo. Just waiting for you to install.You only need to compile if you use unpopular or experimental features that arent added to the main program due to stability or performance issues.

Come on Windows.

>> No.66414278

And I'm just memeing. Sorry.

>> No.66414291

Imagine being too stupid to apt

>> No.66414302

When was the last time you saw a dep hell on pacman? You havent
When was the last time you saw a dep hell on apt? Every day in every thread.

>> No.66414343

that's noobs installing random ppas that conflict with system packages
I can't remember any dep hell that happened simply 'because apt'.

>> No.66414359

Dont have to install separate repos with arch.

>> No.66414381

you say that like it's a feature
>official packages
>git clone; make

>official packages
>git clone; make

>> No.66414391

Have you heard of AUR, anon?

>> No.66414396

I wish your post was ironic but I've never seen a shill this passionate, you should ask for a raise I'll vouch for you

>> No.66414397

It is a feature, arch dosent have political reasons for disallowing software in their repos. Unlike literally every other distro in the world,that prevent you from easily installing sofware with your package manager..

>> No.66414401

Do you know what the AUR is?
Right: git clone; make.

>> No.66414411


>> No.66414413

This is why nobody likes Arch users.

>> No.66414430

go read a pkgbuild faggot
it's literally downloading source code from literally who and compiling it

>> No.66414437

People envy arch users and the simplicity of pacman and aur.
No need to add random sketchy repos from third party geocities webpages just to get basic functionality.Everything is maintained on the offical website.

>> No.66414438
File: 476 KB, 1600x1300, 1353945581571.jpg [View same] [iqdb] [saucenao] [google] [report]

>takes long to install

>> No.66414460

>lying in a friendly thread

>> No.66414466

if it was just git clone;make, you wouldnt get a pkg.tar.xz that is compatible with pacman :^)

>> No.66414483

Boom thats all you need sweetie

>> No.66414512

Tell me what happens here.

>> No.66414524

do i need intel-microcode on an amd cpu? is it something to do with 32 bit? i see ive also got iucode-tool

>> No.66414532

he's obviously trolling

>> No.66414536

whats the best way to set up a remote desktop (so that i can access my linux desktop on my android phone)<

>> No.66414542

>do i need intel-microcode on an amd cpu?
reread this question and do it slowly

>> No.66414548

No. Intel microcode is intel processor specific. AMD processors (much less models than intel) have their own microcodes in a separate package.

>> No.66414554

microcode is botnet

>> No.66414559
File: 36 KB, 640x640, 1504133430860.jpg [View same] [iqdb] [saucenao] [google] [report]

pls response

>> No.66414561

Tell me what happens here.

>> No.66414590

Literally the same procedure.

I guess so.

>> No.66414596


>> No.66414600

they could be shared, its a valid question

>> No.66414606


>> No.66414614

>they could be shared
why didn't they name it intel-amd-ucode then?

>> No.66414616

same reason its not called amd-intel64?

>> No.66414621

Both download github code and compile it.
You're fucking stupid.

>> No.66414629

exactly, why would they package both intel and amd's microcode in one?

>> No.66414634

git clone;make
Does not produce a pacman installable file

>> No.66414691

This. Just updates CPU backdoor engines.

>> No.66414767

That should be fine. Except really big shit like llvm, gcc and qt take still a long time thou.

>> No.66414825

>1)Command lines/Lack of GUI's
I see you haven't actually used Linux for at least 10 years.

>> No.66415094

Low quality bait, here is your (You) for wasting time that you'll never get back just to write that post.

>> No.66415133

>usb ports not working under kubuntu 18.04

>> No.66415167

>plug in device
>unplug device

>> No.66415225

I don't see any changes in the output. Charging still works but the usb stick is not recognized via lsusb and I don't see any messages that confirm an attached usb stick when using dmesg. It's actually really frustrating and I don't know where the issue is. I mean its a latitude so not some weird acer consumer laptop.

>> No.66415376

So, I have a VirtualBox VM with Arch.

It has bspwm and polybar installed with default configs. And it looks and feels pretty good, but for some reason polybar loves stealing all mouse events at some point.

What I mean is after some time has passed (probably after clicking/scrolling on polybar, but not 100% sure) it eats all mouse events on the screen - for example, if I click somewhere below the workspace switch widget (even in the bottom of the screen while the bar is on top) the click goes right to the widget. Even if I try to click on any window (be it a browser or a terminal emulator), everything goes only to the bar. Switching workspaces, moving windows around, changing window modes do not help at all, but restarting polybar fixes it. Not for a long time though.

There is also a problem with Chromium titlebar. Yet again after some time tabs and omnibox become unclickable (buttons for closing/creating tabs still work), while everything else works.

What do I have to do to make it all work?

>> No.66415771

The touchpad "tap to click" sensitivity is not high enough and it is absolutely infuritating to use. How to increase it? Ubutu 18.04

>> No.66416058

The options you want are FingerLow and FingerHigh.

Or for a more easy way to change it on the fly without editing a config just install "synclient" and run
>synclient FingerLow=<some_value>
>synclient FingerHigh=<some_value>
The values are supposedly pressures and you want to keep the low value smaller than the high value.

>> No.66416275

I want to dual boot but my factory partitioning consists of 9 fucking partitions, several sharing the same label and nearly all with no clear description for the usage. Fucking Windows.

>> No.66416314
File: 77 KB, 797x630, cpu.png [View same] [iqdb] [saucenao] [google] [report]

is it normal for the cpu to spike like that?

>> No.66416327
File: 127 KB, 531x400, gentoo.jpg [View same] [iqdb] [saucenao] [google] [report]

i went back to arch after a month with gentoo

i found that it takes a bit too much time and effort to install programs in gentoo: compiling with my slow cpu, and managing use flags to minimize unneeded features and compile times

but i realized i never really found it useful or thought it was worth it

and even though gentoo can use -march=native systemwide it's not necessarily faster than arch because arch has more up-to-date packages

>> No.66416379

I'm personally tempted to install Gentoo some time if I ever upgrade to a mobo which allows passthrough.
Running a riced, super stable Gentoo base system and sandboxing everything sounds comfy to me.

>> No.66416380

reddit spacing

>> No.66416412

found your problem

>> No.66416421

What keyboard shortcut do you use to open a terminal, /lgbt/?

>> No.66416426
File: 5 KB, 211x239, 92d.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.66416452

So? Fucking delete winshit and make a sensible partitioning scheme. Leave a free partition for windows if you need it.

>> No.66416464

Isn't OEM magical?

>> No.66416469

unironically this >>66416412
try out bare openbox and see if it still spikes

>> No.66416479

I want to keep my factory Windows with pre-installed Office.

>> No.66416514

im sure itll be better but id rather use a DE.

>> No.66416568
File: 1.36 MB, 1440x810, 1529214348851-g.png [View same] [iqdb] [saucenao] [google] [report]

>you're using ressource intensive DE

>> No.66416588

i was only pretending hahah thanks for the (you)s fagot

>> No.66416619

Ok I was used to windows since thats all I knew. I installed arch linux on virtualbox with kde plasma. Is it the same process if I want to install it on my PC and do you recommend KDE or something else?

Also is it hard to customize it like you guys do.


>> No.66416620


Actually it was updated from W8 to W10 so perhaps that added some partitions that weren't from the factory. Also one of the factory partitions seems to contain drivers that might be used for recovery.

>> No.66416638

arch as first distro? more power to you anon

>> No.66416714

It is when you are using the cpu.
Check your network activity, something came in from the network

>> No.66416846

Well I guess its the best way to learn about linux. Right off the bat I entered a problem with makepkg. Didnt let me run it as root.

>> No.66416853

i see a correlation, the cpu averaged ~20% when watching a youtube video. Is that something to be worried about?

>> No.66416879

>Is that something to be worried about?
Worrying that your system is responding to the things you are telling it to do?

>> No.66416951

I installed pulseaudio with apt install pulseaudio and nothing happened and I still don't hear sound.

No DE, just i3 on a fresh network install of Ubuntu 18.04.

Any quick start guides on making audio work? I must have missed a step somewhere.

>> No.66416960

alsactl init

>> No.66417001

CPU Usagae is such a uselesss metric. CPUs scale up and down their frequencies on load. When going from idle to doing something, cpu usage % will seem higher than if it had been on the saem freqneucy all the time

>> No.66417036

I'm using ranger in urxvt and trying to open .mkv video files in mpv and only some of them properly open in mpv, the rest launch chromium for some reason I can't figure out. Can you guys please help?

>> No.66417077
File: 1.09 MB, 1920x1080, Big.City.Greens.S01E02.Cricket.Versus-Blue.Tater.1080p.DSNY.WEB-DL.AAC2.0.x264-Dulus.mkv_snapshot_15.20_[2018.06.20_01.26.18].png [View same] [iqdb] [saucenao] [google] [report]

Explain this, linuxtards
>Just installed Manjaro
>opened Firefox
>downloaded file
>pressed icon "open containing folder"
>instead, music player opens, and says no file
>default install, i changed nothing
you can't make this shit up

>> No.66417133
File: 9 KB, 273x200, 1469139193854.jpg [View same] [iqdb] [saucenao] [google] [report]


Explain this one ^

>> No.66417194

>Just installed Manjaro
stopped reading here
Manjaro retards should fuck off back to reddo.

>> No.66417209

Every distro i try has some glitches in the first several minutes.

>> No.66417222

Is it easy to install more up to date software on debian? I'm on xubuntu, but want more security (for no real reason, though, so I can stick with it).
With MX Linux it was a hassle to install some packages or add some repositories (need to type them in manually, use a tool to validate, did not work from terminal).
The main drawback with debian seems to be older software, is it easy to overcome?

>> No.66417226

There is nothing in the arch install process that a competent gnu+linux user shouldn't learn anyways.
Actually, the steps are simplified with scripts such as arch-chroot and pacstrap.

>> No.66417348
File: 56 KB, 452x604, 1392496727279.jpg [View same] [iqdb] [saucenao] [google] [report]

I'm trying to install Gentoo on my UEFI laptop. The minimal installation CD doesn't work with UEFI so I had to create a bootable USB drive with the hybrid live DVD. The problem is that the installation guide on the Gentoo handbook is for the live CD and a lot of that stuff doesn't work on the live DVD, for example I can't change the keyboard layout. Also I can't connect to my WPA2 protected network because apparently net-setup only works with unencrypted and WEP protected wireless networks. How do I do this and where do I find an installation guide for the live DVD?

>> No.66417539

dude just boot up ANY live distro that can boot simply on UEFI from a usb and install gentoo from that. Yes you can install it from ubuntu/debian/anything.
Only one thing to keep an eye on: most binary distros have extended ext4 features like ACLs enabled thus mke2fs will create ext4 using those. When configuring your kernel don't forget to enabled them.

>> No.66417660

might be a problem with your system.
google it, you'll probably find a solution.

>> No.66417680

It's simple. If we want Microsoft-like or Apple-like levels of synergy between our software then we need a small group that is in charge of making those kind of decisions.

This is one reason I think it's pretty stupid to say that "Linux" is the name of our operating system when neither The Linux Foundation nor Torvalds will EVER be interested in helping out with issues such as that. No matter how much money you throw at them they will never give you a full featured operating system because that's not their job. They are in the kernel business and nothing more.

So who is out there that will give us what we need? Well there is GNU, Redhat, and Canonical off the top of my head. Those are the guys who would actually improve your all-encompasing experience on the GNU/Linux desktop.
But we don't rally behind them because we still have a bunch of n00bs who actually think Linux is their desktop operating system.
GNU is the one we should rally behind but we don't, so what do you expect?

Don't expect things to always cooperate as tightly as they should, we're basically operating on an anarchy system here. Some software might use Convention #1 to accomplish things and other pairs of software might want to use Convention #2.
Sometimes developers of software A might refuse to adopt a convention forcing developers of software B to either do things their way or just not build in support for A at all.

>> No.66417870

You have to start pulse
You also have to create an asoundrc to tell alsa to use pulse

>> No.66417956

Decided instead to install W7 and download Office and use my OEM product key. Oh, I probably should backup that partition with OEM drivers too. Hopefully it will work.

Dual boot procedure:
1A. Boot Linux installer.
1B. Wipe all partitions.
2A. Boot W7 installer.
2B. Let it create its recommended partitions but discontinue installation.
3A. Boot Linux installer.
3B. Shrink W7 OS partition.
3C. Create Linux partition(s).
And from there install either OS in any order. Right?

>> No.66417998

It's still correct... I get that you don't like it, but it's still correct...

>> No.66418177

Is it any good. I use Linux Mint, which I dual boot with my windows, and I plan on removing it and replacing it with another distro.

Reason is that Linux Mint is... broken for lack of a better word.

>> No.66418200

I've been using Ubuntu for the past few months now. I feel really comfortable with it but I want to work up to be able to use Arch. How to I transition to arch from ubuntu smoothly?

>> No.66418248

Start with Manjaro

>> No.66418291

Instead of providing help or useful comments you deliver laughs at beginners and recommend Windows - in a friendly thread.

>> No.66418500

how is it working up? if anything it's just moving changing the package manager, so more like to the side.
moving up would be something like gen2 or lfs

>> No.66419000

The only real hurdle is the installation, which is still relatively easy if you have a minimum of reading comprehension and a few hours.
After that I'd say that Arch is easier and more comfortable to use than Ubuntu.

>> No.66419362

>few hours
Even an elementary reading pace you could install it within an hour

>> No.66419806

ur so clever senpai

>> No.66419822


>> No.66419891

I need help, /g/...
I just got my ASUS notebook back from their repair service. Previously, I was running Arch and everything was OK (the screen had broken pixels, that's why I had to send it in). Today, I got it back with Windows 10 being installed again. I immediately wiped the disk and installed Arch. However, the KDE settings app didn't recognize the touchpad (could not load shared library) and I had to use the default touchpad config. This was weird, but not the main issue. The main issue is that the keyboard backlight isn't working at all. The hotkeys for dimming it are not working and KDE doesn't even see a supported keyboard with backlit keys. I already tested an Ubuntu live stick and it didn't work either. Not even in the EFI I'm able to get the lights to work. Unfortunately, I didn't check it in Windows when I got the notebook back, so I'm not 100% sure if this is a software or hardware failure. Their repair service also fucked up some other things, so this might be an issue caused by them. Should I install Windows 10 and possibly waste 2 hours of my time checking it? I have to call their support tomorrow morning and will probably have to send it back again. Btw, the X logs don't say anything useful, but I don't know what else I can do.

>> No.66419892


>> No.66420045


>> No.66420846
File: 33 KB, 181x222, 1460359321842.gif [View same] [iqdb] [saucenao] [google] [report]

What's the current recommended setup for a KVM with GPU passthrough?

I'm trying to decide on which distro and software suite. I'm guessing it's going to look something like Debian with some qemu frontend, Anyone have any specifics I should look for? Anything that's cutting edge and worth using but not worth migrating too for existing users, etc.

>> No.66421696

Is it possible to change the kernel that will be used when installing a distro? Basically, I want to know if I can get the ISO/files of my distro, change what kernel will be used, and then use the resulting changed ISO/files to burn to disc and install.

>> No.66421706

>run some random crap that spawns a subshell and uses sudo

>> No.66421788
File: 28 KB, 400x562, 1418213517360.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.66421810

Newer kernel versions make my very (18 year) old laptop shit itself into a kernel panic, whereas some distros using older kernels seem to do fine. I just wanted to have up-to-date software with an older kernel to support a gen 2 mobile intel celery.

>> No.66421859

So what does it matter if you hack together some installation disk to use an older kernel on a distro that's just going to break eventually anyway because it'll stop (or already has stopped) supporting it?

Get a source based distro to reduce the chance of breakage. On some of them you don't even need to use their own installation disk, like Gentoo. Use a liveCD from a different distro with an older kernel to install Gentoo with your desired kernel.

You could also configure the kernel yourself which will likely solve your kernel panics and still allow using a newer kernel.

>> No.66421918

Would you recommend any resources for learning kernel configuration? I honestly have no idea where to start and what is causing the kernel panic. Is there documentation somewhere listing what modules would be needed to support what hardware, etc.?

I need spoonfeeding, yes, otherwise I'll give up on having an 18 year old linux meme machine and just use Windows 2k.

>> No.66422004

The Gentoo Handbook has a section on it.
Also this is pretty decent although a bit outdated (which might be even better for your old machine anyway): http://kernel-seeds.bloodnoc.org/settings/3.2.x/settings-01.html

>> No.66422099

might as well use root account, dum dum

>> No.66422131

Oh and I guess some of the pages were never completed for the 3.x kernel, but you could just use the 2.x pages for those instead

I don't know, maybe I'm not the best person to listen to on this, it's been years since I configured a kernel.
But at any rate, this page will _definitely_ be helpful if you do want to do it:
It explains in general how to figure out what to enable from your hardware.

But at any rate, all of this is just assuming you're trying to swap out kernels on modern distros that don't support the older kernel. Since that's what your original question sounded like. If that's really the case then all I was trying to say is you'd have more luck doing that with a source based distro. You can still auto-build the kernel, even on Gentoo, so you don't have to mess with configuration if you don't want.

But instead of just blindly answering your question I should also just mention that there are actually distros that are still using older kernels. Have you considered just installing one of those? Like Debian? That would probably just be the easiest route and would "just work".

>> No.66422149


>> No.66422715
File: 40 KB, 540x327, benis.jpg [View same] [iqdb] [saucenao] [google] [report]

Good audio audio player with multiple library support? I like Clementine for its ease of use but I own a fuckton of audiobooks and don't like it when they get mixed with my music.

>> No.66422736

>instructions tell you to curl/wget then pipe to sudo command to install a program
still did it though, rip in piss me

>> No.66422968


>> No.66423059


>> No.66423144

How do i include/require/import the awesome api in a lua script?

>> No.66423687

if that's male i'm 100% gay

>> No.66423958

>see History
this is why you have crap fonts

>> No.66424572

Memes: >>66424566

Name (leave empty)
Comment (leave empty)
Password [?]Password used for file deletion.