Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 93 KB, 1200x794, linus_torvalds_with_toy_penguins.jpg [View same] [iqdb] [saucenao] [google] [report]
66371202 No.66371202 [Reply] [Original] [archived.moe] [rbt]

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: just like in /sqt/ spend at least a minute to check a web search engine with your question.
*Search: qwant, searx, ixquick or startpage.
*Many free software have active mailing lists.
*Many free software has an active bugzilla where you can check and report errors

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux: https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux
>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page
>What are some cool terminal commands?
http://www.commandlinefu.com/
http://cheat.sh/
>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/
>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html
>How to break out of the botnet?
https://prism-break.org/en/categories/gnu-linux

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

Previous thread: >>66354081

>> No.66371232
File: 25 KB, 730x430, 1526556368357.jpg [View same] [iqdb] [saucenao] [google] [report]
66371232

First for devuan

>> No.66371284
File: 1.08 MB, 279x219, 1466955840650.gif [View same] [iqdb] [saucenao] [google] [report]
66371284

>opensuse developers spammed my twitter timeline with PRIDE messages
time to find a new distro for my servers

dont say Centos

>> No.66371322

>>66371284
FreeBSD faggot

>> No.66371328

Do people actually exist that thinks no software anywhere exists that depends on systemd?

>> No.66371356
File: 1.95 MB, 320x180, 1446961890809.gif [View same] [iqdb] [saucenao] [google] [report]
66371356

>>66371322
https://www.freebsd.org/internal/code-of-conduct.html

AHAHAHAHAHAHAHA

>> No.66371381

>>66371328

They exist until you prove that such software exists (outside of the systemd affiliated software).

>> No.66371393

>>66371356
Solaris faggot

>> No.66371396

>>66371328
Nice strawman.

>> No.66371412

>>66371284
Maybe they are trying to tell you something, because the official openSUSE and SUSE twitters don't have anything PRIDE related.

>> No.66371418
File: 16 KB, 180x180, gentoo-g.png [View same] [iqdb] [saucenao] [google] [report]
66371418

>>66371412
honestly thought it over and im just gonna install gentoo. they seem apolitical.

>> No.66371433

So uhh maybe this is the wrong place to ask this but-
I have two routers acting as switches/dumb aps behind my main router (which I cannot change, due to the way FiOS works) running LEDE/openwrt, latest version, all that fun stuff.

Both are working perfectly fine as APs, both through wired and wireless, but I cannot pull the software package list, either through LuCI or by ssh through the opkg command.

My first thought was "Oh, maybe since they re-merged into the OpenWRT project maybe the url is wrong" or something but nope, through my desktop I can still download the packages. Where I get really confused is that I cannot ping google (ping -c 3 www.google.com) from the routers, but I can ping a local address (192.168.1.1, just for shits and giggles).

So every device connected to these routers can access the internet perfectly fine, but I cannot ping any external site from them. Does anyone have any idea what the fuck I need to configure to let them communicate with stuff outside of my network? I'll admit I'm not the brightest with networking stuff

>> No.66371438

>>66371328
systemctl depends on systemd

>> No.66371443

>>66371328
What is your reasoning for why you would expect that nothing does? What's the point in software if nothing depends on it?
$ egrep "Depends: .* systemd" /var/lib/apt/lists/* | wc -l
129

>> No.66371454

>>66371443
Meant for >>66371381

>> No.66371458

>>66371396
How so?

>> No.66371466

>>66371418
>...I would like to see more fun in Gentoo, and a lot less politics, and in my apparent role as President of the Gentoo Foundation.....
>Daniel Robbins founder of gentoo

>> No.66371485

>>66371454

List the name of the specific piece of software and then point to its source where it mentions systemd as a specific, hard dependency. You still can't, because you're still a retard as in the last thread.

This is a simple request which you cannot fulfil, yet you still continue making these claims. You are as retarded as the flat Earth people or similar.

>> No.66371491

What's the best distro to learn if I actually want a job later?

I'm thinking the most popular Linux choices for corporations are Debian, Red Hat, and SUSE.

So I want to learn Debian.

Is that a good choice?

>> No.66371508

I fucked up.

I had some problems with nvidia 390 drivers on Ubuntu, something about unmet dependencies, tried to purge the install and updating it.

Now I get a black screen on startup and I can't do shit. Tried to boot on recovery mode, went with the update repository option, same, error related to nvidia.

Send help.

>> No.66371524

>>66371433
Means you faggots are too busy arguing some bullshit over systemd, I figured out my issue, and I'll post it in case it helps someone else.
For some reason my DNS wasn't specified, pointing it to my pihole instance fixed it.

>> No.66371525

>>66371491
Debian is good for small companies, big corporation use RPM based distros and love their GUI's.

>>66371508
chroot from live cd.

>> No.66371541

>>66371525
>and love their GUI's.
b-but /g/ told me i have to become a command line wizard... wtf.. all this time spent learning commands by heart.. for nothing?

>> No.66371551

>>66371541
It was all for nothing, but only if it doesn't matter to you whether or not you know how to use your computer.

>> No.66371559

>>66371541
You have to, however but rajesh wont be so diligent, that is why RedHat has a GUI for almost every system configuration.

>> No.66371561

>>66371458
Nobody's saying that nothing depends on systemd, the systemd haters love saying everything does though and that's the actual issue here, the fact that they confuse package dependencies with actual dependencies is hilarious though.

>> No.66371570

>>66371466
he seemed pretty good desu, also seems fairly right wing in recent years which is rare in the freetard community.

plus gentoo isnt using poettering crapware. ill give it a shot next week.

>> No.66371595

>>66371561
Challenging people to name software that depends on systemd implies that you think none exists, going on to quibble about what depends means is pointless autism and wildly missing the point.

>> No.66371607

>>66371232
Based

>> No.66371610

>>66371595
Stop trying to worm yourself out, you like saying everything depends on systemd yet you still can't point to one such program, now you can either start backing up your claim or shut the fuck up.

>> No.66371614

>>66371485
What does specific hard dependancy mean and why is it relevant to me as a user? If I try to install a thing and it tries to bring down systemd how is that not a dependancy? I'm not trying to be facetious, I'm trying to understand what your objection is.

>> No.66371628

>>66371610
>saying everything depends on systemd
No one said that.

>> No.66371635

>>66371524
This wouldn't had happened with systemd-resolved because it defaults to 8.8.8.8 :^).

>> No.66371639

>>66371610
>you still can't point to one such program
Going off the previous thread it looks like KDE. Now can you morons go away!

>> No.66371649

>>66371614
Daemons in general work just fine no matter what init systems you use, if a daemon package pulls systemd as a dependency that just means that the package maintainer ships it with a systemd unit but this still doesn't mean it actually depends on systemd, on a distro that ships with sysvinit the same daemon probably ships with an initscript instead and won't pull systemd as a dependency.

>> No.66371664

>>66371628
This retard did: >>66354455

>> No.66371694

>>66371508
>>66371525
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libglx0:i386 : Depends: libglx-mesa0:i386 but it is not going to be installed or
libglx-vendor:i386
libnvidia-ifr1-390 : Depends: libnvidia-gl-390 but it is not going to be installed
libnvidia-ifr1-390:i386 : Depends: libnvidia-gl-390:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


This is the problem, I removed the card, using an ATI 5670 right now.

How can I get rid of this shit, then move to ATI drivers?

Tried the suggested command and it did nothing.

>> No.66371701
File: 53 KB, 187x208, 1409123255150.png [View same] [iqdb] [saucenao] [google] [report]
66371701

I dislike KDE but it's the only viable, or only, option for Manjaro that uses QT. Convince me to use KDE over XFCE.

>> No.66371708

>>66371701
why would you ever use xfeces

>> No.66371712

>>66371491
Yes.

>> No.66371731

>>66371649
>doesn't mean it actually depends on systemd
What does it matter who is responsible?

>> No.66371744

>>66371708
Lighterweight DE but when I look at how much KDE uses it's really not much more. I assume it adds on if I cover my damn desktop with widgets. Still I'm familiar with XFCE because I use Xubuntu on my Thinkpad. It just doesn't feel the same on Manjaro XFCE.

>> No.66371745

>>66371551
>>66371559
it cannot be..
but i'll still get to use the command line when working with Red Hat, right? the GUI is j-just optional, right?

>> No.66371782

>>66371731
What?

>> No.66371816

>>66371614

Because you cannot claim things that are objectively wrong.

If you don't like something about a package, package it yourself. That way you can remove optional dependencies and your package manager won't install dependencies that you don't want.

>> No.66371832

>>66371639

KDE is an organisation. You don't even know what KDE or KDE Plasma are. Not even going to mention that you still didn't provide proof that KDE Plasma and its components hard depend on systemd.

Why are you still posting? You are lacking basic knowledge required to participate in these threads. Stop wasting everyone's bandwidth on your retardation, retardo.

>> No.66371860

>>66371614
>If I try to install a thing and it tries to bring down systemd how is that not a dependancy?
There's actually not just dependencies (necessary for the program to work), but also recommendations (install these unless you know why you shouldn't), suggestions (don't install these unless you know why you should) and enhancements but i forgot what those do

>> No.66371920

Im having this issue where my computer completely freezes up. Running debian and it seems to happen with deluge. Im not sure whats causing it but it will happen every few days and cause me to restart it (pc is on 24/7). Any ideas?

>> No.66371980
File: 17 KB, 450x370, 1464886780713.jpg [View same] [iqdb] [saucenao] [google] [report]
66371980

After reading about many people having issues with nvidia I'm finally done with this shit. It gave me problems from the very beginning and now my package manager is broken.

Reinstalling Ubuntu and going with ATI. I don't play video games anymore so I don't really give a fuck.

>> No.66371983

>>66371920
bad disks?

>> No.66372014

>>66371980

If you don't play videogames, use the free drivers for Nvidia. They are equally problem free if your hardware supports them.

>> No.66372066
File: 518 KB, 1366x768, nicekde.webm [View same] [iqdb] [saucenao] [google] [report]
66372066

Any fellow KDE user in here? I've always had this issue in KDE but i thought it was a Kubuntu bug. However, it also happens in my Antergos install so this bug is not related to that.
Even though the numpad is not set to move the cursor, until you update the option, it still does and resets on startup.
Do you know where coul I notify the development team about this issue?

>> No.66372148

>>66367361
>I just found out there's a command called "whatis" and i'm loving it
>>66367385
>I love it too. Made a script that displays a random result when the shell starts.

I read this and wanted to make my own "script" for that.
I added the following two lines to .bashrc
randomcommand=$(compgen -c | shuf -n 1)
whatis $randomcommand


I'm too much of a noob to do it in one line though

>> No.66372161

>>66371920
Have you made sure that it's the computer and not just the GUI? Try leaving an SSH server running and logging in over the network when the computer is "frozen".

>> No.66372180

>>66372148
That's clever. Saved.
>one line
whatis $(compgen -c | shuf -n 1)

>> No.66372240

Is it a good idea to get a chromebook and put a linux distro on it?

>> No.66372267

>>66372148
My solution. It works around the "whatis: nothing appropriate" problem by looping until a valid results shows up.

rndwhatis() {
genwhatis() {
whatis $(compgen -c | shuf -n 1) 2>/dev/null \
|| genwhatis
}; genwhatis
}; rndwhatis

>> No.66372428

I like using tmux but I hate that I can't copy and paste to and from it. How do I do it? I tried this https://unix.stackexchange.com/questions/67673/copy-paste-text-selections-between-tmux-and-the-clipboard but it doesn't work.

>> No.66372503

If I install a program by cloning the git and qmake, make, make install how do I uninstall the program?

>> No.66372589

>>66372503
You can't. Create a package if you want a proper solution. There are helpers like checkinstall on Debian based distros.
That said, makefiles indeed support "make uninstall", but people rarly implement it.

>> No.66372607

>>66372503
Open the makefile and check where it copies files to, delete.

>> No.66372640

>Ubuntu 18.04
>Discover keeps not working (goes right to installer without any options to update)
>Muon fails to update as well (no error details)
>try to use sudo apt-get update

>Err:8 http://ppa.launchpad.net/kirillshkrogalev/ffmpeg-next/ubuntu bionic Release
>404 Not Found [IP: 91.189.95.83 80]
>Reading package lists... Done
>E: The repository 'http://ppa.launchpad.net/kirillshkrogalev/ffmpeg-next/ubuntu bionic Release' does not have a Release file.
>N: Updating from such a repository can't be done securely, and is therefore disabled by default.
>N: See apt-secure(8) manpage for repository creation and user configuration details.

How do i resolve this. the apt-secure page doesnt give me any meaningful information

>> No.66372666

>>66372428
Didn't bother to read the link

^B[ then nagivate around and press space to select
press enter to copy and exit select mode
^B] to paste

>> No.66372738

When it comes to python scripts, should I be making them executable? Or should I always invoke them by typing python scriptname.py instead of ./scriptname.py?

Is there any "risk" in making them executable rather than invoking the interpreter?

If it's okay to make them executable, should I restrict the execute permissions to only the script that actually gets run? For example, if I have other scripts that get imported to the main script, they don't need to be executable? I should just leave them without execute permissions?

>> No.66372805

I am using manjaro. Why the hell are some software and packages installed back during an update when I explicitely deleted them before? Wtf is this shit? I dont want bloat that I deleted

>> No.66372833

>>66372589
>There are helpers like checkinstall on Debian based distros.
Checkinstall apparently supports Slackware and RPM too.
http://asic-linux.com.mx/~izto/checkinstall/

>> No.66372838

I'm reading that ATI/AMD graphics drivers are installed by default in Ubuntu, but I'm experiencing some noticeable screen tearing, I also don't have any kind of software like Nvidia Servers to edit my preferences.

How should I proceed to install the correct drivers?

>> No.66372839

What's a working man's DE?

>> No.66372850

>>66372640
that ppa doesn't provide any package for 18.04, what are you trying to get?

>> No.66372862

>>66372838
post your xorg log, it should be in /var/log

>> No.66372863

>>66372839
Plasma

>> No.66372900

>>66372863
I said working man's.

>> No.66372920

>>66372900
Oh I thought actual serious work for money.
In your case for ricing and watching gay anime I recommend not using DE at all

>> No.66372935

http://www.unixguide.net/unix/faq/1.3.shtml

>> No.66373027

>>66372589
what about arch?

>> No.66373031

>>66372920
I did. Isn't KDE for ricing?

>> No.66373034

>>66372738
>should I be making them executable? Or should I always invoke them by typing python scriptname.py instead of ./scriptname.py?
Personal preference.
However, making them executable has one advantage: you may have two separate Python versions installed on your system side-by-side: python2 and python3.
If you have a lot of Python scripts, you may have to think "is this a python2 script or a python3 script?"
By adding the Shebang to the script and making it executable, it will "just work" and you don't have to think about that.
You can even drop the .py ending in the filename.

>Is there any "risk" in making them executable rather than invoking the interpreter?
Not that I'm aware of.

>If it's okay to make them executable, should I restrict the execute permissions to only the script that actually gets run? For example, if I have other scripts that get imported to the main script, they don't need to be executable? I should just leave them without execute permissions?
Just try it

>> No.66373065

>>66372862
I don't have such file.

>> No.66373103

>>66372838
If you are using the radeon kernel module, you can add a config to /usr/share/X11/xorg.conf.d/ with these contents:

Section "Device"
Identifier "Radeon"
Driver "radeon"
Option "AccelMethod" "glamor"
Option "DRI" "3"
Option "TearFree" "on"
Option "ColorTiling" "on"
Option "ColorTiling2D" "on"
EndSection


Don't know about amdgpu or whatever alternatives there are

>> No.66373151

I just realized that systemd is called systemd because it's a system daemon

>> No.66373183

>>66373151
really activates my almonds

>> No.66373250

>man pyreverse

>-s <ass_level>, --show-associated=<associated>
show <ass_level> associated classes. <ass_level>=1 will only take classes directly related to the
classes in the project, while <ass_level>=2 will also take all classes related to those fetched
by<depth>=1.

>> No.66373428
File: 58 KB, 600x286, 002.jpg [View same] [iqdb] [saucenao] [google] [report]
66373428

>>66371202
which one will he choose?

>> No.66373449

>>66372850
OBS (yes I'm that guy from the last thread)
I went to the Website and checked the section on how to install it and added the kirillshkrogalev/ffmpeg-next package like an idiot. now When trying to remove it, the console says the package doesnt exist.

>> No.66373551

How do I even edit my display settings if using nouveau drivers for Nvidia?

I tried using the display settings interface, I tried editing monitors.xml and nothing works, my changes still resetting on reboot.

>> No.66373617

What is the best distro?

>> No.66373637
File: 136 KB, 960x1280, 1464391181079.jpg [View same] [iqdb] [saucenao] [google] [report]
66373637

So, can't seem to get my nvidia card to pass properly through to my VM. This is the script I've tweaked from an anon in the thread.
#!/bin/bash
cp /usr/share/ovmf/x64/OVMF_VARS.fd /tmp/my_vars.fd

qemu-system-x86_64 -enable-kvm -m 10024 -cpu host,kvm=off \
-smp 4,sockets=1,cores=2,threads=2 \
-drive file=/media/ssd2/VM/win.img,id=disk,format=qcow2,if=none \
-device ide-hd,bus=ide.1,drive=disk \
-device vfio-pci,host=01:00.0,x-vga=on -device vfio-pci,host=01:00.1 \
-boot order=cd \
-drive file=/home/toucan/W10.2016.LTSB.X64.en-US.iso,index=1,media=cdrom \
if=pflash,format=raw,readonly,file=/usr/share/ovmf/x64/OVMF_CODE.fd \
-drive if=pflash,format=raw,file=/tmp/my_vars.fd \
-vga none -nographic

Issue though is that switching to the monitors I have hooked up to it has no input. There's no display. Do I need to install the OS and the drivers first, and THEN add the PCI device?

Fucking novideo man, this is advanced jewery.

>> No.66373640

>>66373617
Whichever one I like more than you.

Just try out a bunch a pick one you like. Most are pretty similar anyway.

>> No.66373657

>>66372148
$ whatis compgen
compgen: nothing appropriate.

>> No.66373689

>>66371284
hardened gentoo
go big or go home

>> No.66373811

Hi anons, looking for help getting a wireless logitech mouse to work on my Manjaro laptop. I've never had any problem using mine at home but I'm travelling and haven't used one in a month or so. An anon was trying to help me out last night but I had to pass out before the issue was fixed so hopefully they'll see this here. Anyway this is the last few lines from running
dmesg | tail -n 100
[ 6050.621947] usb 1-1.2: new full-speed USB device number 6 using ehci-pci
[ 6064.774137] usb 1-1.2: USB disconnect, device number 6
[ 6066.752104] usb 1-1.2: new full-speed USB device number 7 using ehci-pci
[ 6070.662149] usb 1-1.2: USB disconnect, device number 7
[ 6073.302191] usb 3-2: new full-speed USB device number 2 using xhci_hcd
[ 6172.165405] usb 3-2: USB disconnect, device number 2
[ 6180.926529] usb 1-1.2: new full-speed USB device number 8 using ehci-pci
[ 6689.159914] usb 1-1.2: USB disconnect, device number 8
[ 6693.586305] usb 3-2: new full-speed USB device number 3 using xhci_hcd
[ 6796.862924] usb 3-2: USB disconnect, device number 3
[ 6830.801419] usb 3-2: new full-speed USB device number 4 using xhci_hcd
[ 7014.300895] lomoco[10980]: segfault at 0 ip 00007f86cb916fa5 sp 00007fffde6f5b10 error 4 in libusb-0.1.so.4.4.4[7f86cb914000+4000]
[ 7023.693701] usb 3-2: USB disconnect, device number 4
[ 7028.800348] usb 3-1: new full-speed USB device number 5 using xhci_hcd
[ 7031.205400] lomoco[11013]: segfault at 0 ip 00007f5545193fa5 sp 00007fffeba6e7d0 error 4 in libusb-0.1.so.4.4.4[7f5545191000+4000]
[ 7050.532929] lomoco[11028]: segfault at 0 ip 00007f6b13c82fa5 sp 00007ffeddffd1b0 error 4 in libusb-0.1.so.4.4.4[7f6b13c80000+4000]
[ 7306.393609] usb 3-1: USB disconnect, device number 5
[ 7313.833249] usb 3-2: new full-speed USB device number 6 using xhci_hcd
[20354.726632] usb 3-2: USB disconnect, device number 6
[20361.201193] usb 3-2: new full-speed USB device number 7 using xhci_hcd

>> No.66373869

>>66371284
Debian

>> No.66374208

>>66373449
>the console says the package doesnt exist.
you're not trying to remove a package, you're trying to remove a ppa, look up how to do that

>> No.66374233
File: 633 KB, 1200x750, 1471753392188.png [View same] [iqdb] [saucenao] [google] [report]
66374233

>>66371202

>> No.66374299

>>66373103
amdgpu has fewer options, but DRI and TearFree are there. You probably don't need any other options than those two.

>> No.66374316

>>66373027
pacman has makepkg

>> No.66374435

Hello, I just transferred from Kubuntu to Xubuntu. I use atom as my text editor and I used to run it from the Kubuntu terminal as:

>atom hello.c

but now that I'm using Xubuntu, it shows "permission denied. no protocol selected". what should i do?

>> No.66374456

>>66374435
also, i downloaded atom from packet manager instead of their website (if that changes anything) it also kinda looks different than the atom that i downloaded in Kubuntu (which I downloaded online)

>> No.66374500

>>66374435
are u running as root?

>> No.66374582

>>66374500
i made my account admin, how is root different and like how do i change it? (sorry for asking)

>> No.66374633

>>66374582
well a root prompt probably starts with a #
while a normal prompt starts with a $

>> No.66374653 [DELETED] 
File: 333 KB, 600x600, 1475442937506.jpg [View same] [iqdb] [saucenao] [google] [report]
66374653

How the FUCK do I set up MPC-HC and madVR?
I've been asking for weeks and have looked at various guides but they are either out of date or give conflicting information.

>> No.66374664

>>66374653
I don't think they work on Linux anon

>> No.66374670
File: 802 KB, 1098x766, 1513455948700.png [View same] [iqdb] [saucenao] [google] [report]
66374670

>>66374664
I-I posted in the wrong help thread.

>> No.66374717

Any of you use Matlab on Ubuntu? Why the fuck is it so fucking bugged on Linux?

>> No.66374840

I'm on a machine where the admin is a dumb fuck who doesn't give permissions to /dev/null

what should I use instead to swallow output?

>> No.66375201

>>66374717
Guess they had to invent the wheel as they couldn't use a lot of GPL'd tools and the hacks they wrote were buggy and subpar.

>> No.66375218

ubuntu kubuntu lubuntu xubuntu

>> No.66375226

>>66374840
Make it not output garbage.

>> No.66375239

>>66374717
Ask Torvalds.

>> No.66375281

>>66374840
cat file > deletethis
rm deletethis

>> No.66375323

>>66374840
2>&1

>> No.66375738

>>66375281
>>66375323
It's a machine with a space quota, this won't do

>>66375226
I don't care about the output (which isn't garbage), I just care about the speed at which it is generated

>> No.66375804

>>66375738
jus dereet de fires.

>> No.66375815

>>66374208
I tried doing that, but Discover still wotn start into browsing or Updating mode, have to do updates via konsole.

>> No.66375841

>>66375738
Create a named pipe/FIFO and use that as a sink?

>> No.66375866

I'm so tired of distro hopping.
It should, ordered by importance,
1- Have stable repositories with packages that just werk
2- Have recent packages, not too outdated
3- Have a default KDE option.

Due to the fact that backports exist, which I didn't know until recently, all my hopping was for naught

Any ideas for which one to go for?
Easy for automatic install and configuration by script is also a +, however KDE doesn't properly support this due to dozens of config files afaik
However

>> No.66375895

>>66375866
Debian

>> No.66375917

>>66375866
Devuan

>> No.66375928

>>66375866
use Fedora anon, it just werks https://spins.fedoraproject.org/kde/

>> No.66376012

>>66375866
Ubahntu

>> No.66376041

rsync is putting single quotes around filenames with spaces in them. How do I get it to stop?

>> No.66376139

>>66376041
If you need to transfer a filename that contains whitespace, you can either specify the --protect-args (-s)
option, or you’ll need to escape the whitespace in a way that the remote shell will understand. For instance:

rsync -av host:'file\ name\ with\ spaces' /dest

>> No.66376174

>>66376139
I've used the -s option (saw that in stackexchange too)
rsync -azsP

And rsyncing a single file is tupid, i'd use scp in that situation.
Any other ideas?

>> No.66376232

>>66373811
bump

>> No.66376270

What is the best distro with KDE?

>> No.66376280

>>66376270
OpenPePE.

>> No.66376353

>>66375866
OpenSUSE Leap
probably the best KDE distro

>> No.66376660

>>66371202
Is there a way to bind a key and a command to a key. I know I can rebind a key with xmodmap and I can replace a key with a command using xbindkeys but I want to do both at the same time. I have tried setting up an xmodmap and an xbindkeys for the same key but then only the xbindkeys command gets executed. I also tried xdotool key [key] ; command in xbindkeys and that works sometimes. It works roughly twice every 15 times I press the key. I am using i3 wm on arch.

>> No.66376883

Why Arch users must point out that they're using Arch?

>> No.66376903

>>66376883
because they need validation
Posted From My ArchBookPro

>> No.66376941

>>66376883
>>66376903

and I guess some problems could be distro specific

>> No.66376969

>>66376660
Give it a sleep of 0.1 or even 0.01 before you invoke xdotool.

>> No.66376995

>>66376969
that actually worked. tnx

>> No.66377079

I'm using Debian - how can I learn more about the way my system starts up? Whenever it boots, it goes like this:

>grub as normal
>fully tty1 for ~90 seconds
>suddenly sddm starts

I can't figure out what is causing this stupid delay and no idea what to even search for to learn more.

>> No.66377118

>>66377079
Poke around in journalctl

>> No.66377164

>>66377079
You want systemd-analyze
systemd-analyze blame # find the slowest services to init.
systemd-analyze critical-chain # find the bottleneck

>> No.66377297

>>66376174
Bump.
Even tried sshfs and mounting locally.
rsync -azsP still surrounds files with single quotes.
Rsync 3.1.2 and 3.1.3 on local and remote machine respectively.

Why does free software do such surprising shit?

>> No.66377340

>>66377118
>>66377164
Looking at blame, no service takes longer than 1.900s to init, and systemd-analyze on its own gives this:

Startup finished in 2.911s (kernel) + 2.712s (userspace) = 5.623s
graphical.target reached after 2.700s in userspace


Looking at journalctl, I noticed some interesting stuff:

Jun 16 12:28:20 callisto systemd[1]: Started Getty on tty2.
...
(me logging into tty1 to try and get it to start faster)
...
Jun 16 12:28:40 callisto kernel: random: crng init done
Jun 16 12:28:40 callisto kernel: random: 7 urandom warning(s) missed due to ratelimiting


Then it finally started sddm. So I'm thinking it took ~20s for "crng init" to finish and the system could not move on to start sddm till then. After looking into it, it seems this is a bug with the kernel introduced around the time I installed Debian, and installing rng-tools might fix it. Going to give that a shot, thank you for your help.

>> No.66377447

Just installed Manjaro i3.
How do I install polybar? Haven't done anything yet aside from getting it from Arch repo. Do I still need to compile it or something?

>> No.66377567

>>66377447
when you git clone it from the aur, just go into the folder and type makepkg -si

>> No.66377584
File: 56 KB, 840x959, fox tail you dork.png [View same] [iqdb] [saucenao] [google] [report]
66377584

>>66371202
I'm a little confused regarding TRIM with full disk encryption.
Do I have to add the discard tag to use fsrim.service?
If so, do I need to add it to both my crypttab and fstab or just the former?

>> No.66377598

>>66377447
https://wiki.archlinux.org/index.php/Arch_User_Repository

>> No.66377606

>>66371284
No one likes virtue signaling, but switching distro over it is a retarded overreaction. Just unfollow them.

>> No.66377645
File: 22 KB, 545x250, rms-FSF-is a poltical cause.png [View same] [iqdb] [saucenao] [google] [report]
66377645

>>66377606
free software *is* virtue signaling.

>> No.66377652

>>66377340
Nope, just restarted and didn't touch it - took 15 whole minutes from power on to sddm. 50% of journalctl takes place over one second, 81% takes place over 3 seconds, 19% takes place over 15 minutes!

Jun 16 14:12:57 callisto systemd-timesyncd[425]: Synchronized to time server [2600:3c01::f03c:91ff:febc:67d4]:123 (2.debian.pool.ntp.org).
Jun 16 14:15:01 callisto CRON[945]: pam_unix(cron:session): session opened for user root by (uid=0)
Jun 16 14:15:01 callisto CRON[946]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
Jun 16 14:15:01 callisto CRON[945]: pam_unix(cron:session): session closed for user root
Jun 16 14:17:01 callisto CRON[948]: pam_unix(cron:session): session opened for user root by (uid=0)
Jun 16 14:17:01 callisto CRON[949]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Jun 16 14:17:01 callisto CRON[948]: pam_unix(cron:session): session closed for user root
Jun 16 14:25:01 callisto CRON[951]: pam_unix(cron:session): session opened for user root by (uid=0)
Jun 16 14:25:01 callisto CRON[952]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
Jun 16 14:25:01 callisto CRON[951]: pam_unix(cron:session): session closed for user root
Jun 16 14:26:49 callisto kernel: random: crng init done
Jun 16 14:26:49 callisto kernel: random: 7 urandom warning(s) missed due to ratelimiting


Then it take ~2s to actually start sddm (I think), then another 5s to recognize my keyboard and mouse. Then this pops up several times:

sddm-greeter[980]: file:///usr/lib/x86_64-linux-gnu/qt5/qml/SddmComponents/LayoutBox.qml:51: TypeError: Cannot read property of null


Then it finally allows me to login to sddm. What the hell is this?

>> No.66377669

>>66371694
install the amd drivers, then install/remove those listed packages by hand.
novideo, not even once.

>> No.66377722

>>66377645
Having a political cause or making a choice because it's more virtues isn't the same as virtue signaling.

>> No.66377751

>>66377652
OK, so rng-tools didn't work. I purged that and installed haveged instead. This fixed the problem and I now boot in less than a two minutes, no tty1 whatsoever! Must have been an entropy problem after all.

The only thing holding me up now is it takes an entire minute to synchronize time to 2.debian.pool.ntp.org IPv6 address. Anyone else have this problem?

>> No.66377767

Newfag here. I finally managed to get one of the "Windows-only" programs required for my studies (ChemBioOffice) running on my Linux PC. Feels fucking good guys, I'm making good progress with de-microsoft-ing my everyday life. In the next months, I'll probably buy a new smartphone and I'll try installing lineageOS so I don't feed the botnet. What's your experience with that, is it possible to run regular Android apps on it? Spotify and Strava are invaluable apps for me in my everyday life and I don't want to miss them when I'm switching.

>> No.66377773

>>66377645
>free software is about software freedom
WTF I hate free software now

>> No.66377784
File: 16 KB, 141x109, 1up back.png [View same] [iqdb] [saucenao] [google] [report]
66377784

NEXON BETTER MAKE EVERYTHING COMPLIANT WITH LINUX I HATE WINDOWS AAAAAAAAAA

>> No.66377789

>>66377773
>bout software freedom
..and not about anything technical, which explains why it's buggy and slow.

>> No.66377828

>>66377767
There's no point in switching systems when you're going to use the same spyware apps as before.

>> No.66377851
File: 506 KB, 267x339, 1528105971260.gif [View same] [iqdb] [saucenao] [google] [report]
66377851

>>66377789
Don't like freedom?
Go sucking your botnet then, FAGGOT

>> No.66377876

>>66377851
>Go sucking your botnet then, FAGGOT
He thinks Solaris has a botnet. How cute.

>> No.66377917

>>66377828
I see your point, but even though there's no getting around a handful of apps for me, it would be a good start to try and minimize whatever data the big companies get, no?

>> No.66377938

>>66377851
>In some ways, Linux was the project that really made the split clear between what the FSF is pushing which is very different from what open source and Linux has always been about which is more of a technical superiority instead of a — this religious belief in freedom.
>Linus

>> No.66377951

>>66377938
Who?

>> No.66377964

>>66377951
The creator of the Linux OS.

>> No.66377970
File: 11 KB, 300x168, techtips.jpg [View same] [iqdb] [saucenao] [google] [report]
66377970

>>66377951
The youtube guy.

>> No.66377982
File: 76 KB, 625x626, 1529183626334.jpg [View same] [iqdb] [saucenao] [google] [report]
66377982

>>66377964

>> No.66378016

>>66376232
you should get the drivers binaries from thw website.
try to compile them and restart the usb service. check if it's working.

had an issue similar with a dongle. just compiled binaries that particular dongle had in their website. it worked.

>> No.66378046

>>66377297
use a pipe and remove the quotes using sed.
dont forget putting backslash before the quotes though

>> No.66378075

>>66377938
So what does this say:

Linus:
>that proprietary addon may spy on the users and may not allow them to change it, fix it, share it or share modifications of it, but it's technically superior so we'll use it, and hell, you can look at the code on github, open source ftw

RMS:
>that proprietary addon is no option, we use the best available free solution til a better option is available while leaving our users uncucked

>> No.66378082

>>66378046
>use a pipe and remove the quotes using sed.
You mean after I rsync? So I have to clean up after the backup utility for surprisingly renaming files?

>> No.66378086

>>66378075
RMS is based af. linux is a poser ffs.

>> No.66378110

>>66378086
linus*

>> No.66378112

>>66378075
>that proprietary addon is no option
lol FREEDUMBS is all about options!

>> No.66378129

>>66378082
from what you posted, yeah.

>> No.66378144

>>66378129
So there is no way to make rsync not automagically rename files?

>> No.66378162

>>66378112
Found the burger.
>you're only free when you're allowed to own guns and enslave niggers

>> No.66378174

Please stop baiting guys. I'll give you (You)'s gratis.

>> No.66378175

>>66378162
Found the EU.
You're only free when we limit your options to what we say.

>> No.66378218

>>66378144
checkd and im speaking from my knowledge of usage man. if there is , you have to get dirty and go through obscure git projects and forums.
like so for example
askubuntu.com/questions/37483/check-the-correctness-of-copied-files

>> No.66378228
File: 171 KB, 374x347, 1454620145046.png [View same] [iqdb] [saucenao] [google] [report]
66378228

>>66371202
Why is it so hard for some Linux users to accept that not every distro needs or intends to support every desktop environment?
>Autist ask for DE derivative.
>Head developer says "No", because they have more important shit to do.
>Autism intensifies. A thesis is given on why snowflake DE should be officially supported.

>> No.66378257

>>66378218
no, i'm not talking hash shit. I'm just asking
"why is rsync renaming files without notice"
This is surprising behavior in software used for copying.

>> No.66378279

>>66377938
love the literal jews that are hell bent on diluting the FSF's purpose.
Freedom above all else faggots.
If you'll take it any other way you're a fucking cuck

>> No.66378282

>>66378257
to obviously restore the original mate.
did you just try googling what you asked me dude.
https://superuser.com/questions/579001/rsync-does-it-create-a-temp-file-during-transfer

>> No.66378299

>install linux to try it out
>wow this sucks
>go to reinstall windows
>the bootable usb goes right to bios
>try and make partition in linux
>sector already used
>sector already used
>sector already used
>value out of range
>value out of range
>value out of range
>fuck it I'll wipe the whole drive
>order drive to wipe itself
>bootable usb still goes right to bios
>regular boot up takes me to grub

Don't know what to do next.

>> No.66378314

>>66378228
Truth but some people are just not good enough at dev shit so they throw money at something and hope it improves by someone who can work as a slave for him.

luckily this only gets you so far in linux, which after a certain limit, meritocracy comes into picture and you have to do shit yourself and that is when devs say fuck off and do it yourself if you want it that much. pretty simple

>> No.66378322

>>66378282
>temporary files
It is persistent. After rsync is finished I have renamed files in the destdir

>> No.66378326

>>66378075
when did this ever happen?

>> No.66378330

>>66378299
Install Gentoo

>> No.66378336

>>66371284
>using twitter
use microsoft server.

>> No.66378341

>>66371782
He means looking at it from the end-user perspective, broken packages, etc etc

>> No.66378358

>>66378336
does twatter spy on me?

>> No.66378364

>>66378322
how are you replying with dubs time and again jeez. it's enough bateman.

and that's what i'm saying, it's doing sanity checks after a period of time. i dont know if you can stop this though, check if there is a seperate rsync instance running by grepping it and try stopping it and then see if it still persists.

>> No.66378421
File: 968 KB, 3231x2424, 1503077702497.jpg [View same] [iqdb] [saucenao] [google] [report]
66378421

Which program do you use to optimize your meme png's? I'm using optipng and I'm wondering if it's still the best.

>> No.66378465

>>66378421
have you tried this

ls *.png | cut -d . -f 1 | xargs -L1 -i convert -strip -interlace Plane -quality 80 {}.png {}.jpg

>> No.66378489

>>66377917
Yes that is correct.
It's almost impossible to completely get away from big companies anyway.
E.g. There's a good chance you use Google's DNS servers without even knowing it.
But it is good to minimize what data the big companies get

>> No.66378573

why is font rendering so hard to nail down, i don't want to have to buy a hidpi display.

>> No.66378620

>>66378465
Lossless pls.

>> No.66378646

>>66378465
>parsing ls
>cutting
>xargs
>not simply giving all options to convert
REEEEEEEEEEEEE

>> No.66378972

how is setting up and installing audio/music production stuff on linux?
for example on windows you can just download/install daw and asio4all and have a basic setup ready to go.
since bitwig is on linux i'm curious to try it but don't know what distro would be best to use, if audio is simple as installing something like asio, and cracking stuff.

>> No.66379142
File: 152 KB, 466x492, 1508965386591.png [View same] [iqdb] [saucenao] [google] [report]
66379142

>arch wiki still hasn't been updated to document new cryptsetup luks2 features, such as argon2
Everything on there is outdated and insecure advice. What happened to the autists who kept up with this stuff? Is Arch dead?

>> No.66379174

>>66379142
The userbase changed from Arch users to users who use Arch.

>> No.66379177

Weird fucking problem with Ubuntu 17.10.1 (default DE).

In applications like Telegram, Okular and Calibre the OS thinks I'm *holding left mouse button down* and as a result glues/selects everything OR starts moving the window instantly after I click it (doesn't stop until I *right click the window* at which moment you can't interact with the said window until you left click at which point the process repeats)

wtf

>> No.66379188

>>66379177
Tried a different mouse?

>> No.66379198

>>66379177
You get what you pay for

>> No.66379202

>>66379188
If it was a mouse problem wouldn't it appear in other programs too?

Firefox, GIMP, Skype, Ubuntu Software, Libre Office work without such issue.

and restart seems to fix it for a while until it comes back..

>> No.66379216

>>66379174
But Arch users use Arch.

>> No.66379231

>>66379216
Arch uses Arch users, users who use Arch use Arch

>> No.66379244

Is there a way to inject a window to another window?
Let's say I have window X and Y. I want to Make a window Z that has window X and Y inside it. Is this possible?

>> No.66379414

>>66379231
What if users who use arch use arch users? Do arch users still use arch or arch users?

>> No.66379832

>>66379142
Since you know so much about it, why dont you document the new features on the wiki?

>> No.66380032

>>66379177
WHAT TEH FUCK IS THI SISSUE

ITS MAKING SOME APPLICATIONS FUCKING UNUSABLE

TRIED THREE MOUSES NO CHANGE
ONLY RESTART FIX

>> No.66380172

>>66375815
>I tried doing that
what did you do exactly? you have to do these according to askubuntu:
$ sudo apt-add-repository --remove ppa:kirillshkrogalev/ffmpeg-next
$ sudo apt-get update

>> No.66380187

How do I make a Debian Live USB? The live images aren't working ("Failure to authenticate"). I'm using Windows.

>> No.66380226

>>66380187
Use Rufus' dd method.

>> No.66380269

>>66380226
dd?

>> No.66380288
File: 80 KB, 1919x401, Screenshot_2018-06-16_13-50-50.png [View same] [iqdb] [saucenao] [google] [report]
66380288

This popped up today, which one should I pick if I have nvidia?

>> No.66380331

>>66380288
Looked a bit further into it, looks like they just added these extra requirements, though I don't know why. I'd rather not have to set one if possible
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6c41530ba8a4f5523f890a88f911b32a0870fdd4

>> No.66380337

>>66372161
Its the computer, monitoring my torrents shows them all as inactive.

>> No.66380397

>>66371920
>Running debian and it seems to happen with deluge.
>>66380337
>monitoring my torrents shows them all as inactive.
What does "it seems to happen with deluge" mean? Does it only happen when you're running deluge? If so, the fact that deluge is also freezing should not be taken as evidence that the whole operating system is frozen, rather than just part of it.

>> No.66380435

>>66380397
Pc is on 24/7 and ive only had the freezing issues while deluge is running. Its freezing up the cursor and entire gui. I dont think its a cinnamon issue as again, only deluge seems to be causing it.

>> No.66380542

>>66371701
>lxqt

>> No.66380548

>>66380435
My first step, in your situation, would be to try to figure out whether or not the whole operating system was unresponsive. You say you've done that, but it doesn't sound like you've done that. If you don't want to do that, then I think you've got two options. Try to dig through your logs for an error message that you can google, or start rolling back, uninstalling, or replacing programs that you think might be at fault until it stops happening.

>> No.66380591

>>66372839
>Cinnamon
>lxde/lxqt

>> No.66380601

>>66377297
Bumparoo

>> No.66380691

>>66379244
tried to look at some X manpages but still can't find anything, any help?

>> No.66380714

>>66380542
>it's shit
there's tons of native qt programs that are great but as a de framework the people who work on qt just can't seem to get it right

>> No.66380886

distros used to detected my proprietary wifi adapter pretty easy but for some reason they stopped. Now instead they use the built in one which i dont want to use but had its drivers in the kernel.

Why is that the case? Even ubutnu with 3rd party option checked doesnt give me the option to install through dkms in the driver manager thing

>> No.66380934

>>66380886
if the wi-fi adapter needed some kind of proprietary driver its likely that it broke somewhere along the line and nobody can fix it, because, y'know, proprietary. This is also the reason why so many android phones run such ancient kernels and never get them upgraded, some proprietary driver for the SoC works against 3.16 LTS and nothing else, and the company that makes it no longer does, so they don't bother updating it.

So your wi-fi adapter is probably just useless now. I hope you learned your lesson.

>> No.66380950

>>66379177
17.10 is buggy as shit. Get 18.04

>> No.66380979
File: 234 KB, 1440x900, Screenshot from 2018-06-16 22-21-46.png [View same] [iqdb] [saucenao] [google] [report]
66380979

>>66380934
what do you mean it broke somewhere? I can still download it from github and install it with dkms or make. Im just puzzled that distros with proprietary hardware managers (pic related) dont detect it anymore. Or do you mean that they dont care about these drivers anymore and hence dont include them?

>> No.66381150

>>66380934
hohohoooooooo never mind, turns out dkms wasnt installed by default (i guess the same thing happened with the other distros). why wouldnt they include dkms by default? its the year 2018.04

>> No.66381230

Void Linux, all packages up to date.

All GTK3 applications are crashing including the Firefox "Save Image As..." and the file picker.

Anyone else?

>> No.66381273

>>66380691
So, figured out I could use Xephyr.
Ran openbox inside a Xephyr window and my whole session was fucked up. I guess I won't use openbox and open the programs directly.
Is there a way to make the programs I launch inside the Xephyr display resize when I resize the Xephyr window?

>> No.66381298

>>66381230
so not sure how this happened but installing gsettings-desktop-schemas fixed the issue.

>> No.66381311

>>66380601
Nvm, installed X and copy n' pasted in the GUI. what a shit OS.

>> No.66381328

just made lunix my main os. i already miss paint.net. GIMP just isn't the same

>> No.66381362

>>66381328
Apparently pinta is a good substitute although development is slow as a new group is developing it, not the original person.

>> No.66381386

>>66378228
what are you referring to? (not doubting you, i'm just curious)

>> No.66381440 [DELETED] 

I'm trying to do input validation in a shell script using grep. Let's say I want to make sure that a command line argument is a seven digit hexidecimal number with only upper case letters. I can do this:
echo $1 | grep -q '^[A-F0-9]\{7\}$' || exit 1
What I can't figure out is the best way to print a message and then exit. I thought that maybe I could do this:
echo $1 | grep -q '^[A-F0-9]\{7\}$' || echo "Error!" & exit 1
It works sort of, but forking "echo" and exiting causes the message to print at the command prompt, requiring the user to press enter to get a new one. I'd like to print the message first, THEN exit. If you use ";" or "&&" instead of "&", the script exits no matter what. If you use parentheses to run echo and exit in a subshell, "exit" just exists the subshell. The only way I've figured out to do this is to run "echo | grep ||" twice in a row, with the consequence of failure being the message the first time and the exit the second time.

Is there a better way to do it?

>> No.66381498

hello friends i want to change distro, what do you faggots use and why

>> No.66381529

>>66381498
ur not my fren if you call me faggot

>> No.66381543

>>66381529
im sorry!! it just slipped out this board has changed me
i love u

>> No.66381643
File: 426 KB, 372x260, 1491183962139.gif [View same] [iqdb] [saucenao] [google] [report]
66381643

What IDE should I use for java? netbeans or eclipse? or is there something better?
inb4
eclimd + emacs

>> No.66381872

>>66381386
Solus choosing not to officially support some desktop environments (at the moment), because their dev-team is still comparably small to others and somewhat stretched thin working on other aspects of the project.

>> No.66382341

>>66381872
i see
i haven't looked into solus specifically, but i can imagine why a distro might want to hold off on adding a DE, namely because many distros have a particular purpose/look/feel they're going for, as well as distro-specific features which may need work to suit a new DE, this requires more work than simply taking upstream and turning it into a package, like most software
looking at their wikipedia entry, they even have their own DE, i'm sure they'd much rather focus on that than any third party ones, users who prefer others should be glad any other DE is supported
and of course, there's nothing stopping literally anyone from customising and packaging their preferred DE for it themselves, heck, do it and talk to them to see if your work can be upstreamed into solus. people work on foss because they want to, not because they have to, complaining gets you nowhere

>> No.66382801

Any settings GUI that allows me to set the default applications for stuff?
Like a GUI over xdg-settings?

>> No.66382845

Is there a command for middle-click paste (from xclip) for tmux?

>> No.66382981

Is Kubuntu 18.04 any less buggy

>> No.66383029 [DELETED] 
File: 13 KB, 200x186, FreeBSD_Fsck_Linux.jpg [View same] [iqdb] [saucenao] [google] [report]
66383029

Hi there, friendly gay-lesbian-transgender thread. Would you like to use an open-source operating system that isn't so gay that you can't even use its code in a commercial product? What is that meant to be, like, "nearly"-open source?? >>66327917

>> No.66383030

>>66371570
Who gives a shit, you stupid fuck. You use whatever works, not the OS that aligns with your borrowed political views.
It's baffling seeing retards like you polluting the board, and bringing other idiots with you, all trying to fit in by pushing their political horseshit on boards which have nothing to do with it.
Get a fucking brain, you bloated sacks of cottage cheese.

>> No.66383060

Any ideas when PulseAudio 12.0 is coming?
https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/12.0/
Some of these changes really interest me

>> No.66383064
File: 53 KB, 329x225, 1238198171272.jpg [View same] [iqdb] [saucenao] [google] [report]
66383064

What's the easiest way I can emulate android? I would like to play my shitty games on my computer rather than my tablet.

>> No.66383102

>>66383064
android x86 in any VM. RIP if you need hardware accelerated graphics.

>> No.66383263
File: 52 KB, 397x484, calendar.png [View same] [iqdb] [saucenao] [google] [report]
66383263

Why does my KDE calendar widget show June 16 even though it's June 17 and shows that in eg the date command? Time zone seems to be set correctly.

>> No.66383457
File: 80 KB, 435x746, 1527930831972.jpg [View same] [iqdb] [saucenao] [google] [report]
66383457

>>66377584
bump for this

>> No.66383514

>>66383457
Dont use the discard option in fstab.Just setup fstrim service and timer. once a week is fine

>> No.66383520

>>66383514
Does this also apply to encrypted disks?

>> No.66383521

>>66383520
Yes, why wouldn't it?

>> No.66383620

>>66383102
I found and tried Anbox but it just crashes when I try to start the game. Oh well.

>> No.66383630
File: 2.08 MB, 4128x2322, 20180617_105714.jpg [View same] [iqdb] [saucenao] [google] [report]
66383630

so I'm kinda new to Linux,even then I never had so many problems with this distro void linux, I honestly dunno what to do here. I used Linux,I reinstalled win 7 and used rufus. nothing seems to work.i tried searching on the Internet nothing.
or I'm retarded or its juts void Linux hard to install.
cpu is 64 bit,and I can use both win 7 and xubuntu.

>> No.66383650
File: 2.27 MB, 4128x2322, 20180617_110426.jpg [View same] [iqdb] [saucenao] [google] [report]
66383650

>>66383630
also this
don't laugh at my monitor got it at the scrapyard for 5 bucks

>> No.66383705

>>66382845
'Middle click paste' is the primary clipboard.

>> No.66383719

>>66383029
https://www.gnu.org/philosophy/selling.html
Retard.

>> No.66383743

>>66383630
>>66383650
install gentoo

>> No.66383781

>>66383719
Selling copies makes no sense when users are free to just send copies to others.

>> No.66383783 [DELETED] 
File: 306 KB, 1366x768, whatiwant.png [View same] [iqdb] [saucenao] [google] [report]
66383783

I'm using Xubuntu, is there a way to setup browsing the internet like pic related? Is it just styling?

>> No.66383821 [DELETED] 

Is a ~5 year old T420 good enough to run KDE Plasma?

>> No.66383840

>>66383783
That's tiling WM, lots of theme work and plugins.

>> No.66383853

>>66383840
Thanks, I was just interested in the internet browser but I figured I just needed to style it.

>> No.66383862

>>66383853
Yeah I don't think mere theme switching of Firefox will achieve that.

Wallpaper board (or /g/ when mods are sleep) should have Desktop threads with guides and helpful anons if you wanna continue.

>> No.66383882

>>66383862
Thanks, I'll go and check

>> No.66383948

>>66383743
gee thanks

>> No.66383959
File: 225 KB, 1582x997, Screenshot_20180617_115009.png [View same] [iqdb] [saucenao] [google] [report]
66383959

>>66380172
Yes. those I did.
OBS still install as 0.0.1
Muon gives me this.

>> No.66384212

>>66382845
shift+insert

>> No.66384347

>>66383030
>pushing their political horseshit
you mean what many devs are doing? yet youre fine when they do it. get a brain.

>> No.66384385

Looks like I narrowed down my dual display problem in Ubuntu.

My secondary monitor appears as 'Unknown', that's why the resolution keeps changing to 1024x768, read many people complaining about this with old monitors via VGA as well. I'm gonna get a new one this week so no big deal.

Also, I'm getting started with GNU/Linux, went with Ubuntu as it seems the mos beginner friendly. Did the minimal install and got my W7 software replaced more or less. Any software, ricing, whatever I should try?

>> No.66384491

>>66383263
What distro are you using?

>> No.66384503

Should I get a Linux Foundation Certified Engineer certification?

Or is it wasted money to get a cert like that?

>> No.66384582

>>66384503
How many sheckles do they want?

>> No.66384584

>>66383959
I'm not sure why you have elementary's ppa and those error messages aren't helpful at all.

>> No.66384594

what is the best linux distro for gaming?

>> No.66384600

>>66384582
$300 (not sure if that includes taxes) and it's valid for 2 years

>> No.66384612

>>66384594
Android

>> No.66384661

>>66371202
I'm trying to get Linux to run on my machine and am having issues with UEFI I think, I want to dual boot it with the already installed Windows 10, I've tried ubuntu too see if it would work but haven't been able to even get to live-cd mode, It shows the splash screen and then drops back to busybox and gives me an inframs shell and and radeon ve init errors.
My motherboard is a GA-970A-D3P (rev. 1.0) and my graphics cad is an AMD Radeon R7 200 Series, any help is most appreciated

>> No.66384728

>>66384661
Reminder that if you dualboot, you're still a windows user.

>> No.66384872

>>66384728
You know what anon, I'm not a fucking sheep like you. I don't feel guilty for doing what I want to.
I am 100% better than you for this very reason.

>> No.66384887

>>66378326
Probably referring to binary blobs in the Linux kernal. They are usually needed to get things like wifi working on all cards. That's why the approved gnu.org distros use a blob free version of the kernal that get with a script to filter it out or they used the linux-libre kernal that does that for them.
Some other things like libreboot do similar stuff too.

>> No.66384902

>>66384584
I wanted to give different DEs a try and tried to get Pantheon running.

So can I just remove launchpad?

>> No.66384960

Is there a true equivalent to the us-intl layout of Winders? The US altgr-intl is okay but quite inferior

>> No.66384985

>>66384902
remove those two ppas, see if that fixes anything

>> No.66385212

>>66384661
You know what it was? Fucking usb 3 Linux don't use that shit bois

>> No.66385288

>>66385212
Linux sucks

>> No.66385317

What fedora based distro can run decent enough on a t61?

>> No.66385327

>>66385212
Never happened to me and I've been booting install media with USB3 for years.

>> No.66386021
File: 464 KB, 400x302, 15268498863180.gif [View same] [iqdb] [saucenao] [google] [report]
66386021

>> No.66386148
File: 18 KB, 483x442, *high-pitched necrophilia sounds*.jpg [View same] [iqdb] [saucenao] [google] [report]
66386148

>>66371202
>Install debian netinst
>install XFCE
>try to mount drive
>FAILED TO MOUNT "350GB VOLUME - NOT AUTHORIZED TO PERFORM OPERATION"
>FAILED TO MOUNT "350GB VOLUME - NOT AUTHORIZED TO PERFORM OPERATION"
>FAILED TO MOUNT "350GB VOLUME - NOT AUTHORIZED TO PERFORM OPERATION"
>FAILED TO MOUNT "350GB VOLUME - NOT AUTHORIZED TO PERFORM OPERATION"
RRRRREEEEEEEE

>> No.66386269

>>66386148
>abusing REEE for general anger

>> No.66386300

>>66386269
It's not general anger, I've been fucking with this niggerlicious piece of shit faggotry for a day now

>> No.66386323

>>66386148
have you tried sudo mount yet?

>> No.66386404

>>66386323
yes, but that way I might as well just use i3, I want XFCE to automatically mount shit, weird thing is that pendrives do mount automatically, hard drives don't

>> No.66386412

>>66386148
>>66386323
sudo is bothersome to use with a GUI. just follow the guides at https://wiki.debian.org/SystemGroups with cdrom and plugdev groups. or add yourself to disk if you don't care about security

>> No.66386433

>>66386404
just add all your hard drives to your fstab?

>> No.66386441

>>66386300
REEE is the noise frogs are making when they discover normalfags or normalfaggotry.

>> No.66386454

>>66386441
[citation needed]

>> No.66386467

>>66386441
What's normalfaggotry?

>> No.66386551

>>66386467
e.g. you

>> No.66386557

>>66386412
>usermod mark -G disk
>
>...
>
>mark is not in the sudoers file. This incident will be reported.
what a retard I am holy fuck

>> No.66386589

>>66386557
No presents this Christmas.

>> No.66386611

>>66386589
;_;

>> No.66386618

I use Linux on my servers and laptop, but people like this in the community are why I don't tell anyone: https://www.amazon.com/gp/aw/review/B0042X8NT6/R3NHGWXW6CB96O/

>> No.66386625

>>66386557
1.) su root
2.) add your user to the sudoers group
3.) log out
4.) log in
5.) use sudo

>> No.66386670

>>66386625
>su: authentication failure
ehh, just gonna install normal bloated Debian XFCE

>> No.66386688

>>66386670
put in the right password or log out of X and relog there

>> No.66386712

>>66386688
The thing is I don't have a root password

>> No.66386736
File: 156 KB, 330x368, 1529127310347.png [View same] [iqdb] [saucenao] [google] [report]
66386736

>>66386712
>The thing is I don't have a root password

>> No.66386783

>>66386736
the debian install program suggests to not set a root password

>> No.66386849

>>66384661
Preinstalled Windows boot loader won't boot Linux, at all. Gotta install a EUFI capable Linux distro, install GRUB and boot Windows or Linux with that.

>> No.66386985
File: 33 KB, 500x285, woohoo.jpg [View same] [iqdb] [saucenao] [google] [report]
66386985

>plasma 5.13

>> No.66387094

Is Compton unreliable?

Sometimes scrolling on 4chan works fine, sometimes the tearing is noticeable.

>> No.66387138

>>66384491
KDE neon

>> No.66387464

I've been using Ubuntu for a couple of weeks and it seems more sluggish than W7 in every single way.

Have I been memed?

>> No.66387490
File: 251 KB, 1629x1043, Screenshot_20180617_183443.png [View same] [iqdb] [saucenao] [google] [report]
66387490

>>66384985
fix one hole, 2 new break

>> No.66387492

GNU thread: >>66387483

>> No.66387518

>>66387464
what exactly do you notice

>> No.66387546

>>66387094
compton --backend glx --paint-on-overlay --vsync opengl-swc

>> No.66387652

>>66371232
I tried the liveCD and it did not come with an audio mixer in the tray, I had to open the pulseaudio thing and change the volume from there. Sad!

>> No.66388715

>>66371284
Void linux

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action