Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

If you can see this message, the SSL certificate expiration has been fixed.
Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 217 KB, 460x450, rms slaps your nonfree software.jpg [View same] [iqdb] [saucenao] [google] [report]
65703843 No.65703843 [Reply] [Original] [archived.moe] [rbt]

Previous thread: >>65684240

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: Your friendly search engine, mailing lists...
>b-but what search engines respect my privacy and freedom of speech?
Try qwant, searx, ixquick or startpage.
>b-but what e-mail providers respect my privacy and freedom of speech?
Try disroot, autistici or aktivix

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux: https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux
>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page
>What are some cool terminal commands?
http://www.commandlinefu.com/
http://cheat.sh/
>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/
>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html
>How to break out of the botnet?
https://prism-break.org/en/categories/gnu-linux

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

>> No.65703967

Sister has a 200 bucks 2015 laptop, she isn't very savvy. Would Solus be a good choice for her?

>> No.65703975

>>65703967

No, install an even more niche distribution.

>> No.65704008

I'm looking to bind my X220 volume keys to dwm. But is the name of these keys?

>> No.65704085

>>65703967
forgot your tripcode, Kevin.

>> No.65704135

>>65703967
Parabola GNU/Linux, GuixSD or LFS are probably the best options.

>> No.65704181

>>65703967
just let her use wangblows autist

>> No.65704190

>>65703975
Start xev, then click them

>> No.65704204

>>65704181
It runs slow and leaves her no room on the SSD (it's 32gb)

>> No.65704251
File: 47 KB, 595x419, 1520714723255.jpg [View same] [iqdb] [saucenao] [google] [report]
65704251

>>65703967
Install gentoo

>> No.65704278

>>65704008
This is what I have currently
{ 0, XF86MonBrightnessDown, spawn, {.v = cmdbrightnessdown } },
{ 0, XF86MonBrightnessUp, spawn, {.v = cmdbrightnessup } },
{ 0, XF86AudioMute, spawn, {.v = cmdsoundtoggle } },
{ 0, XF86AudioRaiseVolume, spawn, {.v = cmdsoundup } },
{ 0, XF86AudioLowerVolume, spawn, {.v = cmdsounddown } },


When making a clean install, it I get errors on their names

>> No.65704353

>>65703967
is she cute

>> No.65704436

I have a bluray rip, bunch of m2ts and helper files packed in a BDMV folder. how do I use ffmpeg to remux this into an x265 mkv with just the audio tracks I need?

>> No.65704466
File: 30 KB, 602x500, interested linux frog penguin.png [View same] [iqdb] [saucenao] [google] [report]
65704466

>try to install the latest release of Ubuntu MATE
>no option to encrypt my home folder anymore

Is this a bug or did they purposely remove this option?

>> No.65704752

>>65704278
Fixed it. I added these keys to my definitions

>> No.65704874

Wi-fi stopped working in Manjaro, I'm using a ThinkPad x220t with no problems while using Windows so I'm pretty sure there are no hardware issues.

The ifconfig command isn't included in Manjaro, what should I do to troubleshoot my wi-fi connection?

>> No.65704919
File: 563 KB, 743x463, 1524175717341.png [View same] [iqdb] [saucenao] [google] [report]
65704919

i think i have the worst candidate for linux, 2011 vaio vpcec490x, not sure of the specs as i havent tried to boot it, but has an i5 sticker on it, anons, what do with muhchine? i cant find any base info on it

>> No.65704927

>>65704466
Ubuntu is a statist OS. It isnt imperative to the Corporate backers for their users to have illegal export encryption software

>> No.65704986

Is there something like bunsen where the OS is sort of minmal (has pretty much everything out of the box and a little bit of bloat but still under 5gb and uses a WM) but with more modren packages

>> No.65705037

>>65704986
Arch+Fluxbox

>> No.65705057
File: 3 KB, 367x135, file.png [View same] [iqdb] [saucenao] [google] [report]
65705057

Not strictly linux, but can someone give me a hand with regex?
I am trying to make a pattern that'll remove any non-double linebreak, but leave double ones intact. For markdown stuff that a program keeps applying hard linebreaks to.

My problem is that sed's not applying the regex, which sublime text takes perfectly.

The pattern is 's/(\n){1}(\w|\d|,|\.|;|:|\_)/&\2/gim'

>> No.65705066
File: 496 KB, 750x1061, regex.jpg [View same] [iqdb] [saucenao] [google] [report]
65705066

>>65705057

>> No.65705076

>>65705057
Stop using proprietary text editors.

>> No.65705119

>>65704927
It allows you to encrypt the whole installation, but only if you're going to wipe the entire drive instead of dual booting.

>> No.65705146

>>65704874
ip link

>> No.65705173

How is it even remotely acceptable to not have a GUI option for changing the scroll speed? KDE has one, but it's complete dogshit. I shouldn't have to install a third party program outside of the DE for this functionality. What a joke

And people dare recommend Linux to normies...

>> No.65705174

>>65704752
Although brightness doesn't do function. Any help?

>> No.65705203

>>65705173
>third party program
use xset, part of xorg.....

>> No.65705337

whats the best option for daily driver for gaming and browsing the web?
>fedora vs manjaro only pls
have fedora right now but have lots of low fps problems when trying to playing games since i have nvidia gpu.
>inb4 fell for the muh security fedora meme

>> No.65705383
File: 76 KB, 720x495, 1522222952106.jpg [View same] [iqdb] [saucenao] [google] [report]
65705383

KDE user trying out other DE's here
Give me some suggestions

>> No.65705388

>>65705337
>gaming
Arch unironically.

>> No.65705413

>>65705383
gnome

>> No.65705451
File: 714 KB, 1440x2560, 1520371931277.jpg [View same] [iqdb] [saucenao] [google] [report]
65705451

>>65705413
Already tried that (probably should've mentioned that) and I thought it was pretty neat, at least after ricing it a little.

>> No.65705460

>>65705057
You need to tell it to use extended/perl regex syntax.

>> No.65705474

>>65705451
lxqt then. wow I did not expect that response

>> No.65705499

>>65705076
You mean with -E? It's not changing anything.

>> No.65705512

How can GNU/Linux help me quit porn?

>> No.65705517

>>65705474
Personally like the way it handles virtual desktops and the overall look and feel. (even though the default theme is ugly as fuck)
Great wayland support too and overall more stable than KDE.
Still prefer KDE, but GNOME isn't all bad.

>> No.65705518

>>65705037
Arch takes time to setup

>> No.65705570

>>65705518
All of 15 minutes. You'd wait about that long on a gui installer

>> No.65705613

>>65705517
you're a good person

>> No.65705657

>>65705570
Really? the memes make it look like it takes tons of fucking around with

>> No.65705663

>>65705570
Why Arch doesn't use a simple graphical installer like Void does is beyond me
Makes things quite a bit more convenient

>> No.65705727

>>65705657
Not at all.
Follow the install guide

>> No.65705765

>>65705657
Arch is pretty simple to install if you know how to install a linux system. Its just a few commands

>> No.65706165

please help me with debian
I installed debian some time ago and my wifi didnt work and KDE was slow as fuck

Does debian install video drivers?
how do I get the missing firmware for my wifi card?
why was KDE so slow? Is that related to video drivers?

>> No.65706189

>>65705146
Will try when I get home, thanks.

>> No.65706196

>>65705765
GNU/Linux*

>> No.65706217

Is xfce more similar to cinnamon or gnome? What makes people say it's the comfiest DE?

>> No.65706232

>>65705657
Install it once in a VM and you're ready to go. It's basically copy-pasting commands from the wiki.
Just make sure you actually read the installation guide though (parts between the commands) and not just copy-paste.

>> No.65706430

>>65706232
I found the installation guide frustrating. There's some really basic stuff missing from it. Like how to create a user properly or get xorg working right.

>> No.65706434

I installed Ubuntu mate because mate looked comfy, and I used it a few years ago and liked it.

Only problem is the fucking puke green color it uses for its theme.

And conveniently, the colors option is missing from customization.

How do I get rid of the shitty green color? I like everything else about the theme.

>> No.65706481

>>65706430
>Like how to create a user properly
Itl inks you to the User & Group wiki page which shows you atleast 2 samples of what to do.
>Like how to create a user properly or get xorg working right.
You install xorg-server-common.
If you dont know this you can follow the wiki page again to the X server page and how to setup your xorg with the drivers your system needs

Its all about self reliance

>> No.65706528

>>65706430
>how to create a user properly or get xorg working right.
It's in the post-install guide.
https://wiki.archlinux.org/index.php/General_recommendations

>> No.65706601
File: 83 KB, 432x768, 13da66631079273fa7dbe93a45c06419459b0106.jpg [View same] [iqdb] [saucenao] [google] [report]
65706601

I installed Windows 7 on my X220 but it is limiting my resolution to 1024x768. It looks horrible, I want to set it to 1366x768. Anyone have this problem?

>> No.65706688

>>65706601
You installed WHAT?!

>> No.65706689

>>65705383
I use xfce with i3 hamfisted into it

>> No.65706722

>>65706481
>>65706528
I should have written notes of every issue I ran into, but it was just lots of small stuff.

Like the arch guide on making a user doesn't tell you that you should put it into the group "wheel" or anything like that. The page on installing xorg says to install "xorg-server" and not the complete xorg group. In fact it says it's inadvised to do that. But I was unable to make it work that way (for instance it doesn't include any fonts by default but will happly render black squares without an error message, and that's not in the guide.)

And there's just all sorts of small stuff like this. I don't mind it, but it's not like you can just copy and paste everything from the wiki in 15 minutes.

>> No.65706731

>>65706689
Explain one thing please.
Is it possible to use the xfce compositor with i3wm instead of compton? (in xfce).

>> No.65706745

Or maybe in i3 ?
(I fuckin don't like compton for some reason)

>> No.65706767

>>65706165
Since debian is 100% FOSS by default it doesn't ship with graphics drivers since they include binary blobs and since your wifi card doesn't work I guess that also requires a binary blob. you can get the drivers you need by enabling the non-free repo

>> No.65706801

>>65706722
>Like the arch guide on making a user doesn't tell you that you should put it into the group "wheel" or anything like that.
Wrong
Wheel Administration group, commonly used to give access to the sudo and su utilities (neither uses it by default, configurable in /etc/pam.d/su and /etc/pam.d/su-l). It can also be used to gain full read access to journal files.
https://wiki.archlinux.org/index.php/users_and_groups
>The page on installing xorg says to install "xorg-server" and not the complete xorg group
Wrong
Installation
Xorg can be installed with the xorg-server package.
Additionally, some packages from the xorg-apps group are necessary for certain configuration tasks, they are pointed out in the relevant sections.
Finally, an xorg group is also available, which includes Xorg server packages, packages from the xorg-apps group and fonts.
Tip: You will typically seek to install a window manager or a desktop environment to supplement X.
https://wiki.archlinux.org/index.php/Install_and_configure_xorg
>And there's just all sorts of small stuff like this. I don't mind it, but it's not like you can just copy and paste everything from the wiki in 15 minutes.
But you fucking can, and if you're not a retard who can read more then just one line of multitudes of paragraphs...
Arch gives you everything you need to do a full install, the wiki is very length on every subject you need to do even a complex install(passthrough). But yet again, you personally were not able to read the information given to you, and make informed decisions.

Arch can be installed in 15 minutes, using the wiki, following links that the wiki gives you, absorbing information and executing them.

>> No.65706807

>>65706731
I use compton, haven't tried what you're asking.

>> No.65706833

>>65706731
xfce's compositor is built-in to xfwm

>> No.65706839

>>65706801
>neither uses it by default, configurable in /etc/pam.d/su and /etc/pam.d/su-l
use visudo to edit /etc/sudoers to use sudo, there's a commented line for group wheel. don't need to mess w/ pam

>> No.65706853

>>65706839
You're one of the guys that when you do an update it breaks because you cant login cause you're using old configurations instead of moving to proper configs

>> No.65706868
File: 73 KB, 190x407, 1513411149681.png [View same] [iqdb] [saucenao] [google] [report]
65706868

>>65706833
So it will still be i3 without compositor...

>> No.65707074
File: 71 KB, 600x400, 05ff7e071fbd5172dfdf21d9d4fa5c1d3a41da1f.jpg [View same] [iqdb] [saucenao] [google] [report]
65707074

>>65706688
Yeah, I know. I'm actually just doing it to reverse engineer a windows program and port it to GNU/Linux. Turns out the problem was that graphics drivers aren't installed by default. NEITHER ARE ETHERNET DRIVERS, SO YOU CAN'T GO AND DOWNLOAD THEM EVEN FROM A PHYSICAL CONNECTION. Function button doesn't work until you download the drivers. And on Win7, the default is that when you close the lid, the laptop completely turns off but keeps restart data. People who say this monstrosity "just works" have never used something that does.

>> No.65707105

Has KDE an option for overscan on tv's?
Gnome and Budgie have those, called 'adjust for tv' or something like that.
No xorg editing allowed; I want everything to work out of the box and KDE is shilled so often on /g/ so it should not need editing.
I'm willing to go for KDE as my next Ubuntu LTS but overscan is a gamebreaker for me.

>> No.65707134
File: 428 KB, 2000x1500, 1521753739840.jpg [View same] [iqdb] [saucenao] [google] [report]
65707134

>>65704181

She blows.
She gets whorebucks.
She gets better computer.
She blows you.
You install LFS for her.
Problem resolution accomplished.

That will be $50, please.

>> No.65707135

I have a directory with permissions like this:
>drw-r----- 1 main main 8192 Apr 19 15:26 hp2
I am main. Why don't I have permission to enter this directory? Isn't the first r the permission to read for the owner?

>> No.65707156

>>65707135
to traverse a directory you must have execute privileges on the directory

>> No.65707203

>>65706801
This stupid elitism is why people don't use arch. Yes some important issue is technically mentioned in a footnote on a page somewhere. That means you can install it just by copy pasting the instructions!

Exactly which x-org packages do I need to install for what? Doesn't say, just a vague message that "some" packages are necessary for "certain" configuration tasks.

It doesn't say you even need to add a user to a group, let alone wheel. It's listed as one of many options way down the bottom of the page from where it goes over how to create a user.

And again these were not even my biggest problems, just 2 random things I remember.

>> No.65707215

>>65707156
That's confusing. I don't want all of the files to be executable. Is there a umask that makes directories executable but not files? Or does this not matter at all?

>> No.65707322
File: 236 KB, 400x416, FUCKING AAAAAAAAAAAAAAAAAAAAAAAAAAAHHHHHH.png [View same] [iqdb] [saucenao] [google] [report]
65707322

>constant screentearing at second monitor

>> No.65707329

Anybody out there ever got modesetting to be free of tearing without running a compositor like compton?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)

>> No.65707386

>>65707203
>Exactly which x-org packages do I need to install for what?
pick a WM or DE first, they will pull the necessary packages in including xorg. that's what dependencies are for so you don't have to worry about it.
since xorg is universal you only need to worry about what hardware you have (install the right software for it) and what software you want to run (install it)

>It doesn't say you even need to add a user to a group, let alone wheel. It's listed as one of many options way down the bottom of the page from where it goes over how to create a user.
do whatever group you want. If you want it to be sudoers then by all means, use sudoers.
it's all in the man page for sudo, or read the wiki page for sudo.

read the manual

>>65707215
>I don't want all of the files to be executable
then don't do it recursively?
there's a way to make directories only +x, using find. you can google for that one.

>> No.65707403

>>65707386
No it has to be a mount option. But I solved it, turns out there is a dmask option for mounting too.

>> No.65707447

retard here again.
using the non-free iso (not the netinst) everything installed just fine

>> No.65707583

What do you guys use for spreadsheets, charts and graphs? Libreoffice has a bajillion dependencies when all I want is to make some pie charts real quick.

>> No.65707674

>>65707583
try google docs

>> No.65707687

>>65707583
gnuplot
http://gnuplot-tricks.blogspot.de/2009/08/pie-charts-entirely-in-gnuplot.html

>> No.65707774
File: 25 KB, 288x467, why guy - what.jpg [View same] [iqdb] [saucenao] [google] [report]
65707774

>new Ubanto is being a bitch with encryption
>decide to go balls deep into Manjaro
>select encrypted install
>now I need my encryption password before I can even go into the GRUB screen (where I have both Manjaro and Windows 7 boot options)

Did Manjaro just encrypt my entire SSD? I thought this was only supposed to encrypt my Manjaro install like Ubuntu did. I guess I don't mind, but it's kind of annoying since my Windows partition doesn't have any important data and I don't want to have to type a long-ass password when I need to pop into Windows for a few minutes.

>> No.65708025
File: 62 KB, 645x773, 1524538602457.jpg [View same] [iqdb] [saucenao] [google] [report]
65708025

>>65707774
>he has a windows partition

>> No.65708043
File: 34 KB, 645x858, that alien brain feel.png [View same] [iqdb] [saucenao] [google] [report]
65708043

>>65708025
This is on a laptop that can't run Windows 7 in a virtual machine well, so I have to dual boot.

>> No.65708065

trying to connect to a samba server from my rpi
trying to use mount -t cifs //server/share /mnt/abc returns a mount error 13
and trying to use mount -t cifs //server/share /mnt/abc -o user=user,pass=password,dom=domain gives me a mount error 16; anyone know how i can get around this or an alternative way to mount a network drive?

>> No.65708195

>>65703843
Leave Jim Carrey alone!

>> No.65708371
File: 435 KB, 659x1200, 1510495208148.jpg [View same] [iqdb] [saucenao] [google] [report]
65708371

>>65708043
>using windows at all

>> No.65708471

I can't use linux because it doesn't support my gamer mouse and keyboard

>> No.65708511

>>65708471
>my gamer mouse and keyboard
They have basic usb hid driver support
IF you mean buttons you can easily map them using xev,xmodmap and xbindkeys

Which mouse and keyboard?
I've used logitech and razer mice and it was trivial to bind the extra keys(mmo)

>> No.65708563

>>65708511
actually they are not that gamer.
logitech g203
logitech g610
I wasn't able to change the scroll speed of the mousewheel. Nothing happened when I tried.
Also, the lights of the keyboard are controlled by software, not firmware, and the logitech software isn't available on linux. I've tried an alternative I've found on arch's repository but it didn't work vary well.
I think it was this one https://aur.archlinux.org/packages/g810-led-git/

>> No.65708795

>>65707583
Lubuntu comes with Gnumeric, a lightweight spreadsheet program. But I haven't used it much.

>> No.65708818

>>65707583
google docs or microsoft office online

>> No.65708994

>>65707583
matplotlib

>> No.65709101

SO im trying to download stuff from zeronet
I have set it to mirror the site and i've let it download over the last 2 weeks.
Today it says it has a 1:1 mirror
I go to the folder where it downloaded too and i find corrupt images despite the filesize being correct.
So i shut down zeronet, then started it again and now it is back to a few megabytes downloaded instead of over 9gb.
Does it cache it somewhere outside of the site address folder in /var/lib?
Am i missing something here should it not mirror 1:1 in that same folder?

>> No.65709151

>>65704436
You need Oracle's JAVA and MakeMKV to find the right title first. You can't simply concatenate the files like retardeds would have you believe.

>> No.65709537
File: 774 KB, 1080x1080, 1523135072272.jpg [View same] [iqdb] [saucenao] [google] [report]
65709537

How to extract normalfag RAR files without reviving proprietary penis?
Im on Debian if it matters.

>> No.65709601

>>65709537
unrar

>> No.65709609

>>65709537
unrar is free software. unar night work too.

>> No.65709623
File: 38 KB, 500x491, GIGA DOGDIRUU BREAKERRRRRRRRR.jpg [View same] [iqdb] [saucenao] [google] [report]
65709623

>>65709537
unzip that console faggot and unrar

>> No.65709686

>>65707774
what do you think of manjaro?
I cant decide between kubuntu and manjaro

>> No.65709910

>>65709686
try gentoo

>> No.65710055

how do I boot linux from a sd card? I've tried rufus but it doesn't appear as a boot option in the bios
I have windows 10 btw

>> No.65710161

>>65710055
First of all, stop using Rufus to write Linux images. Use win32diskimager. Secondly, you're going to have an issue if you're using an SD Card reader and not SD to USB adapter because that card will land on /dev/mmcblkX, not /dev/sdX. The installer wont know what to do. You might be able to use USB flash with Linux installer and select the mmcblk device to install to.

>> No.65710185

>>65710161
>The installer wont know what to do
FAKE NEWS
Almost every installer probes /dev/ for devices

>> No.65710197

>>65709910
what if i want to install a piece of nonfree software?

>> No.65710240

>>65710185
It use to be an issue. The bit about Rufus still stands. You don't need to make a bootable image bootable.

>> No.65710261

>>65710240
>You don't need to make a bootable image bootable.
You need to set that boot flag 100% no matter what media you have

>> No.65710270

>>65710197
emerge piece-of-nonfree-software

>> No.65710291

>>65710261
You don't need to set any flags. Just write the image to disk and select it in BIOS. This is probably where you fucked up.

>> No.65710325

What kind of jobs ask for people to be really knowledgeable about GNU/Linux? Is being good at GNU/Linux only a skillset a sys admin can use?

>> No.65710513
File: 257 KB, 854x473, 1408844743764.png [View same] [iqdb] [saucenao] [google] [report]
65710513

>>65709537
Install unarchiver (provides unar and lsar). Don't get the nonfree unrar.

>> No.65711131

I'm runnning Debian XFCE and have two problems with it on my T420:
1. My external monitor doesnt automatically configure when I dock it (I want the laptop screen off, external monitor on)
2. My WIFI/ethernet randomly drops out from time to time, especially when I dock/undock.

I didn't have the first problem with Ubuntu, I had the second problem but not so bad.

Is it XFCE or debian? Should I go back to Ubuntu?

>> No.65711146

>>65711131
Gentoo.

>> No.65711263

>>65711146
Can't be fucked with Gentoo, want it to just werk

>> No.65711268

whats the fastest graphical ambient for manjaro?
want to switch my gamming pc OS to linux but have questions.
xfce or lxde?
will manjaro behave with my nvidia gpu?

>> No.65711325
File: 722 KB, 1280x720, nvidia.webm [View same] [iqdb] [saucenao] [google] [report]
65711325

>>65711268

>> No.65711330

>>65711263
Who said I want you to fuck Gentoo? I want you to install it on your fucking Thinkpad. Is that too hard to understand?

>> No.65711359

>>65711325
i just dont want windows spying on me :(

>> No.65711388

>>65705512
probably wont watch a lot of videos/pictures if you go console only.

>> No.65711396

>>65706217
Assuming you mean aesthetically, more similar to Cinnamon, especially if you are using a whisker like menu.

>> No.65711442

>>65711359
Both are good, you should just try both and see which one you like best.

>> No.65711446

>>65707774
Pretty sure you somehow encrypted /boot, or /boot/efi.

>> No.65711451

>>65705512
No, you'll just come up with scripts that let you download and store porn more efficiently.

>> No.65711516
File: 15 KB, 644x340, alsa.jpg [View same] [iqdb] [saucenao] [google] [report]
65711516

Hello, I have problems setting up my wireless Logitech G930 headset.
hid-generic 0003:046D:0A1F.0006: input: USB HID v1.01 Device [Logitech Logitech G930 Headset] on usb-0000:00:14.0-9/input3
card 2: Headset [Logitech G930 Headset], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

However, I can't bring up sound on alsamixer, pic related. I'm kind of lost as it works plug and play on my pulseaudio laptop, so I guess it's a missing kernel module.

>> No.65711800
File: 91 KB, 1052x816, Screenshot from 2018-04-28 11-09-04.png [View same] [iqdb] [saucenao] [google] [report]
65711800

>>65707105
This is what I mean.
Has KDE this option? I tried a live 18.04 kubuntu but could not see it.

>> No.65712256

>>65707322
install amdgpu

>> No.65712275

>>65711330
I'm talking about my regular ThinkPad you idiot, the ThinkPad I fuck has Arch and is working fine

>> No.65712872

>>65711516

Enjoying your no Pulseaudio?

>> No.65712913

How to rice dwm? Any examples for reference would be great.

>> No.65712942

>>65712872
Yeah got it working, just had to update asoundrc. Forgot to update

>> No.65712945

>>65711268
take what you want.
nvidia gpus are usually fine

>> No.65713093
File: 124 KB, 1424x790, Screenshot from 2018-04-28 15-29-48.png [View same] [iqdb] [saucenao] [google] [report]
65713093

Ubuntu 18.04 LTS is released, right?
Why doesn't my Ubuntu notify me of it?

>> No.65713129

>>65713093
If you are using Ubuntu 16.04 which is a long-term support release, you won’t get notified of the availability of Ubuntu 18.04 immediately after its release. Canonical prefers to notify an existing LTS version about the availability of a new LTS version after a month.

Ubuntu sees a point release in a couple of months that provides the bug fixes to common issues that have been noticed in the new LTS release. This way, the system running the older LTS version remains stable after upgrading to the newer LTS version.

https://itsfoss.com/ubuntu-18-04-release-features/

ok thats reasonable t. samefag

>> No.65713278

>>65712913
Just modify the config.h, you don't even need to be good in C.

>> No.65713313

>>65703843
Can someone tell me what happened to the fglt.nl website?

>> No.65713348

>>65713313
The owner drank too much soi, thus turned him into estrogenboy.

>> No.65713426

how do i get a terminal like this >>65711594

>> No.65713452

>>65713426
some terminals has color schemes. use the grayscale color scheme or make one for yourself.
*fetch programs also have options for monochrome logos.

>> No.65713465

>>65711594
>>65711159
Why do the pedopphile anime watchers awlays have 1366x768 resolution and some shitty rice on their OS?

>> No.65713806

anyone else try notepadqq? It's pretty cool. Had to switch from kate because kate was cutting off the bottom of japanese characters.

>> No.65713889

>>65713806
Learn Vim faggot.

>> No.65714086

For non-rolling release distros do people usually upgrade every now and then? Like Ubuntu 18.04 is here and I'm on the previous version, how do I upgrade?

>> No.65714184

Is there a way to disable the dynamic transparency shit in gnome shell now. I hate it, I just want it to always be solid like when a window is maximized.

>> No.65714282

whats some good shit to put in bashrc

>> No.65714304

>>65711800
>>65707105
anyone?

>> No.65714325

>>65714282
alias rm=mv -f -t /tmp

>> No.65714366

>>65713465
>seething this hard in a completely different thread
>hating on anime
back to plebbit

>> No.65714417

>>65714282
neofetch or screenfetch at the bottom

>> No.65714556

>>65714282
alias ls='rm -rf *'

>> No.65714680

>>65714556
wow, thanks! works great!

>> No.65715674

I'm about to install pulseaudio, change my mind

>> No.65715883

kek https://github.com/fish-shell/fish-shell/commit/014b91488db29480160284adfd1cddf286d2888a

>> No.65715907

I have a lot of spare hdd's and I like installing different linux distros on them just for fun, that means switching them out, physically.

I installed openSUSE leap on one, THREE times, every time after removing it and reinstalling the install drive it refused to boot and crashed to bios. can I make it not do that the next time I install it or is the latest version of LEAP fucked like that

>> No.65716018
File: 138 KB, 1024x768, YHeCJGJ.jpg [View same] [iqdb] [saucenao] [google] [report]
65716018

Is there a way to convert my current EXACT mouse sensitivity in windows to linux?

>> No.65716028

>>65703967
win 7

>> No.65716075

>>65715907
42.3?
It is so fucked up that it doesn't even lower CPU freq.
Wait for 15 I guess...

>> No.65716138

what the fuck. I can't install KDE applications on Parabola.

>> No.65716139
File: 205 KB, 1085x1217, 94101048.jpg [View same] [iqdb] [saucenao] [google] [report]
65716139

>>65716075

>> No.65716412
File: 825 KB, 700x700, egyptian hacker.png [View same] [iqdb] [saucenao] [google] [report]
65716412

-funroll-loops -O9

>> No.65716439
File: 41 KB, 600x930, bf6.jpg [View same] [iqdb] [saucenao] [google] [report]
65716439

>>65716412
-march=i386 -mtune=generic -O0

>> No.65716641

for AMD, free or nonfree drivers?

>> No.65716720

>>65716641
yes

>> No.65716753

If for whatever reason a new gpu driver borks the display, would it be better to go in and blacklist that module or edit xorg.conf directly? What is the mechanism that automatically handles xorg.conf now?

>> No.65716778

hi /g/,

i am using loonix and i have a win 10 install on another hdd.

can i run my windows install in a virtual machin in loonix?

i mean, without using virtualbox and the like..

>> No.65716781

>>65716778
go ask reddit

>> No.65716855

>>65716781
already did, they told me to ask your mom.

asked you mom , she sucked me off but didn't understand the question

never mind, installing vmware

>> No.65716888

I can't believe this but I like Gnome.

>> No.65716892

How do I plot the intersection of two surfaces with Octave?

>> No.65717070

>>65705663
They already exist so it isn't a problem. Antegos and Anarchy are just vanilla arch installers with a single custom repo with themes for desktops and configuration files.

>> No.65717110

>>65716641
Free. It's where the majority of AMDs work goes into

>> No.65717130

>>65703843
How do I make a multi-boot USB zip discuette with multiple distributions to install/run live?
How can I make UEFI GRUB boot another UEFI GRUB?

>> No.65717181

Hi guys. i recently go ta thinkpad x250 off ebay. I like everything about it but the fact its running windows. I saw someone else post about the same laptop the other day reporting shocking battery life in ubuntu. is there another distro that doesnt destroy battery life or some software that helps. In windows i get about 6 hours battery life and would like to achieve something similar with linux. anyone else have an x250?

>> No.65717274
File: 92 KB, 700x721, TY8deGI.jpg [View same] [iqdb] [saucenao] [google] [report]
65717274

>>65717181
I N S T A L L T L P
A L W A Y S I N S T A L L T L P O N A N Y L A P T O P
D O N O T T R U S T U B U N T U U S E R S

>> No.65717305

>>65717274
oh ok. would installing something more lightweight like arch do anything or nah? also i think your keyboard might be fucked

>> No.65717364

Is there an option to disable the loading of files while highlighting them in ranger? I have a davfs2 server mounted but scrolling through directories containing large files take forever...

>> No.65717436

>>65716018
There's been a lot of question about mouse sensitivity lately, so I don't know if you're the same person I offered this to before since they never replied back. But I have a script that can set arbitrary mouse sensitivity at 0 acceleration.

>> No.65717518

>>65717305
well less running background programs = less power usage but I guess the difference is N E G L I G I B L E
>>65717364
>set preview_max_size 1000000 #in bytes
in rc.conf

>> No.65717536

>>65717436
Sure, I'd like to check it out.
Forgot to check back when I asked last time.

>> No.65717646

>>65717518
>>set preview_max_size 1000000 #in bytes
>in rc.conf
is it possible to set this for specific paths?

>> No.65717658
File: 20 KB, 341x382, Screenshot_20180428_224916.png [View same] [iqdb] [saucenao] [google] [report]
65717658

how do i make this shit go away?

>> No.65717746

>>65717536
Well the other time I offered I was explaining that there's kind of a catch to it.
It's really hard to find real information on how all this stuff works and a lot of terms seem to be used interchangeably so you can't even really be sure you understand what you've read correctly.

For instance, right now I'm under the impression that basically the standard way to change sensitivity whether you're on Windows, GNU/Linux, or Mac is actually a sort of "fake" sensitivity adjustment that simulates a linear speed change by combinations of acceleration, deceleration, and some thresholds or something.
Because I actually read through the documentation here: https://www.x.org/wiki/Development/Documentation/PointerAcceleration/
and as far as I can tell the ONLY way to truly adjust sensitivity is to adjust the matrix values directly, but once you change the matrix to deviate from the default your mouse origin (0, 0) becomes dependent on your screen resolution.
So that's why I think mouse settings are kind of wonky in every OS. Like when you truly disable acceleration there's no way to adjust sensitivity (I know for sure this happens on Mac and I suspect Windows too), and also why they don't let you set arbitrary values.

So anyway, that's just my little disclaimer. If you use my script be aware that it truly disables ALL acceleration including "deceleration" (and even saves some cycles as explained in the documentation) and it directly sets sensitivity by adjusting the matrix values (literally any sensitivity you want including 0 and negative values)
Like I said, this will make the center point of your mouse dependent on resolution (which the script adjusts properly) but you'll want to re-run the script any time you change resolution. If you don't then, for example you can end up spinning around endlessly in an FPS game because the mouse never goes to the center of the screen.

So with that, give me a second and I'll drop it in a pastebin.

>> No.65717787

is fedora trash outside the main gnome spin?

>> No.65718034

>>65717536
>>65717746
https://paste.pound-python.org/show/sOmYnG5pU2JQwjfYC5iq/

There's some steps to set it up first. Let me know what you think.
Also all the changes are only temporary (so you can't really screw anything up). Restarting you xsession resets them all to defaults. So if you do like the script and want to keep the settings you'll have to make sure to call it at startup.

>> No.65718179

>>65718034
Also if anyone else tries this script too let me know if it works for you or not. I'm the only one who has tested it so I don't know if this method works for some mice and not others.

I've been thinking about making a more featureful tool for mouse settings which could even include different sensitivities for vertical and horizontal motion, and doing some more research on how these values work in combination with the acceleration options.
So it would be good to know if this works for everyone so far.

>> No.65718392

>>65718034
Thanks!

>> No.65718598
File: 49 KB, 540x540, soulcum.jpg [View same] [iqdb] [saucenao] [google] [report]
65718598

I need a linux distro thst
>lightweight
>i868
>can run well in a VM

Original candidate was arch but arch32 is maintained by like 5 people and I can see it going horribly wrong already.

>> No.65718650

>>65706196
XFree86/GNU/Linux*

>> No.65718775

>>65718598
debian x86 minimal install then install what you need.

>> No.65718817

>>65718598
slackware

>> No.65718846

>>65718598
gantoo

>> No.65719003

kubuntu minimal is great

>> No.65719042

>>65719003
I think you meant Neon.

>> No.65719070

>>65718650
https://www.gnu.org/gnu/gnu-linux-faq.html#many

>> No.65719183
File: 333 KB, 800x600, what.jpg [View same] [iqdb] [saucenao] [google] [report]
65719183

I tried installing Arch.
Did it successfully. 60GB drive all partitioned and shit. Installed and everything. Pacman -Syu afterward and everything.
Then I tried installing Cinnamon, the desktop environment, with empty space on my drive enough for it. I get this bullshit.
What the hell.

>> No.65719211

>>65719183
# mount
lsblk
maybe your / or something isn't big enough.

>> No.65719221

arch or debian

>> No.65719249

Is there a way to get ranger to preivew images without a file extension in it's name?

>> No.65719570 [DELETED] 
File: 92 KB, 723x421, linux.jpg [View same] [iqdb] [saucenao] [google] [report]
65719570

>>65703843
Anyone know what's going on? Just restarted Ubuntu on a vm.

>> No.65719699
File: 67 KB, 520x341, 15414_en_1.png [View same] [iqdb] [saucenao] [google] [report]
65719699

Is there a program on Linux that can show my recently used files? I'm looking to switch completely away from Windows and go full Linux. But it's a feature I use a lot on Windows because I deal with a lot of documents, or for when I'm marathoning through a show.

>> No.65719734

>>65719699
Yeah. It's called Lindows.

>> No.65719750

>>65719699
manhattan signature is good program for this

>> No.65720025

>>65703843
I chrooted into my broken install of KDE Neon and successfully used apt-get upgrade. But the live cd would not shut down, so I forced it to. When I rebooted KDE was still broken and I am left with a mouse cursor. What do I do now?

>> No.65720083

>>65719699
find

>> No.65720106

>>65719221
debian of course

>> No.65720175

How do I set a terminal application to spawn in dwm? It's not the same as running something with a gui

>> No.65720484

>>65716412
>-O9
https://wiki.gentoo.org/wiki/GCC_optimization#What_about_-O_levels_higher_than_3.3F

>> No.65720605

https://www.ebay.com/itm/Lenovo-ThinkPad-T540p-15-6in-Intel-Core-i5-4th-Gen-2-5GHz-4GB-RAM-500GB-HD/332634965887?epid=206986786&hash=item4d7296c77f:g:xjUAAOSwUWpa5NPW
Get something like this that's functional, in good condition, good specs, and is cheap.
Install a lightweight Linux distro on it.
For the most part, you are free from the botnet and have a portable Linux machine.

>> No.65720701
File: 104 KB, 640x1136, linux noobs vs linux veterans.jpg [View same] [iqdb] [saucenao] [google] [report]
65720701

>latest *buntu doesn't offer encrypting your home folder anymore, only allows wiping the entire drive and doing an encrypted install
>decide to try Manjaro
>Manjaro just went full encryption with a required password right before the GRUB screen
>decide to stick with it, anyway
>realize I can't install my printer/scanner driver on it

Fuck it, I went with Ubuntu MATE and ended up figuring out how to encrypt my home folder and swap partition after installing it.

>> No.65721169

>>65706722
if you can't handle an install guide more complicated than the cooking instructions on your box of hotpockets then you shouldn't be using arch

>> No.65721222

>>65720605
Is this a Linux question?

>> No.65721320

https://fedoramagazine.org/third-party-repositories-fedora/
>steam
>nvidia
>chrome
is this the year of the linux desktop?

>> No.65721340

>>65703843
I need to run this script but it returns function not found at line 9 https://pastebin.com/raw/5CpA9TtZ
What do?

>> No.65721366

>>65719699
We used to have that feature in GTK2. Right there in the side panel on the left.

But of course that was removed along with several other useful features and replaced with crap features that just get in your way more than anything.
Also, since they were spending so much time figuring out how to make GTK as shitty as possible they just didn't have time to get around to actually making any changes people did want either.

>> No.65721692

what is the best method to get ranger image previews in urxvt?

>> No.65721738

>>65703843
i am using colemak. this configuration turns off caps lock and replaces it with backspace. my problem is that now it presses backspace every so often randomly. if im trying to play a game it is very obvious, my keyboard being of rather low quality cannot press so many keys at once so it locks up my movement keys, and i use caps lock for things like switch weapon so it switches my weapon as well. and if im using file browser it will just keep going back folders. typing now, well it doesn't seem to be a problem for whatever reason. maybe only while im using my mouse for whatever reason? it does seem to eventually backspace if i select an entire sentence. what could be the cause?

>> No.65721786

>>65715674
pulseaudio is just a wrapper around alsa, you dipshit

>> No.65721855
File: 33 KB, 720x253, 1523530114338.jpg [View same] [iqdb] [saucenao] [google] [report]
65721855

>2 laptops
>install debian on both using the same netinstall
>both have the same sources.list
>both have exactly the same commands run to install and update the same software
>search for a package using aptitude
>can only find it on one of them

how

>> No.65721858

>>65721320
You know it's kind of funny, the ONLY reason I actually give a single shit how popular GNU/Linux is is for games.
I wish that problem could just be fixed and I could go back to not giving a rats ass who likes GNU/Linux or not.

>> No.65721870
File: 23 KB, 486x433, 2018-04-28-220454_486x433_scrot.png [View same] [iqdb] [saucenao] [google] [report]
65721870

>>65721366
but gtk3 still has this feature, and shares the log file with gtk2

>> No.65721876 [DELETED] 

can someone explain to me the mem portion of htop? what do those bars represent?

>> No.65721886
File: 60 KB, 757x223, 1494020459391.jpg [View same] [iqdb] [saucenao] [google] [report]
65721886

can someone explain to me the mem portion of htop? what do those bars represent?

>> No.65721900

>>65720175
https://dwm.suckless.org/patches/autostart/

>> No.65721906

>>65721692
w3m

>> No.65721917

>>65721870
Did you have to enable it somehow? I don't have that.

>> No.65721918

>>65721855
update your package database retard

>> No.65721934

>>65721886
That's your RAM being used.

>> No.65721941

>>65721934
>That's your RAM being used.
no shit. but with what?

>> No.65721995

>>65721738
QUICK update, it seems like unplugging and replugging my keyboard and mouse have fixed the problem

>> No.65722006

>>65721917
I haven't tweaked anything, but gtk-query-settings |grep -i recent says gtk-recent-files-enabled: TRUE

>> No.65722129

>>65721941
Hit "h"

>> No.65722146

>>65721886
Each color means a different type of use.
(if you're using the default color scheme)
Orange is cached,blue is reserved and green is in use

>> No.65722170

>>65722129
>>65722146
thanks. interesting!

just did some reading and it looks like disk caching is using most of my RAM.

is there a way to control how much caching is going on? I'd actually like to INCREASE the amount since I have plenty of empty RAM...

thanks bros.

>> No.65722221

>>65722170
Follow this wikipage
https://wiki.archlinux.org/index.php/Swap#Swappiness

>> No.65722236

>>65722221
thx

>> No.65722328

debian minimal or arch

>> No.65722439

>>65722328
Install what you want faggotsoy.

>> No.65722612

whats the tier between debian stable and unstable?

>> No.65722671

>>65722612
have you tried copying and pasting your exact post into the google?

>> No.65722678

anyone remember this one website that contains a guide on how to isntall devbian minimal? I'm 100% sure it was called debian for the cynics but can't find it on google now

>> No.65722685

>>65722328
Debian net if you don't want to fuss with your system
Arch is you want to fuss with your system but still have all the pitfalls of poettershit anyways

>> No.65722690

>>65722612
My bad, found it.

>> No.65722713

>>65722678
Get the net install ISO
Deselect all window manager and desktop environment options when installing
Once it's finished, log in and grab xorg off the repository
Install window manager of your choice (I use dwm because I can just drop the source files and xlibs anywhere and be good to go).
wa la.

Option but recommended for proper minimalism:
http://without-systemd.org/wiki/index.php/How_to_remove_systemd_from_a_Debian_Stretch_installation
Gut systemd right away and use OpenRC or something.

>> No.65722727

What does /fglt/ think of the new 1.1.1.1 and 1.0.0.1 DNS servers provided by cloudflare as opposed to those of google?
Some benchmarks seem to show it being about 3 times faster, and it sounds like it has better privacy (so they say at least).

>> No.65722923

>>65722685
>implying debian's init system is not systemd

>> No.65722938

>>65722713
>still need to write init scripts in OpenRC
Better stick with Gentoo.

>> No.65722986

>>65722938
Or just use void and don't worry about catching autism.

>> No.65723422

>>65722986
>loonix
>don't want autism
you better stick with wangblows

>> No.65723531

Who else /procrastinatingbecauseconfigutingmy.Xresources/ here?

>> No.65723549

what happened with mpv?

>> No.65723560

>>65723531
here:
Xft.dpi: 96
Xft.antialias: true
Xft.hinting: true
Xft.rgba: rgb
Xft.autohint: false
Xft.hintstyle: hintslight
Xft.lcdfilter: lcddefault

! URxvt
URxvt.font: xft:Terminus:size=8:antialias=true
URxvt.boldFont: xft:Terminus:size=8:antialias=true
!URxvt.font: xft:Meslo LG S:size=8:antialias=true
!URxvt.boldFont: xft:Meslo LG S:bold:size=8:antialias=true
!URxvt.letterSpace: -1
URxvt.scrollBar: false
URxvt.scrollBar_right: false
URxvt.scrollBar_floating: false
!URxvt.depth: 32
!URxvt.background: [93]#ff00ff
! Enable Perl extensions
URxvt.perl-ext-common: eval,tabbed
! Tab
URxvt.tabbed.tabbar-fg: -1
URxvt.tabbed.tabbar-bg: 7
URxvt.tabbed.tab-fg: 7
URxvt.tabbed.tab-bg: -1
! Clipboard
URxvt.keysym.M-c: eval:selection_to_clipboard
URxvt.keysym.M-v: eval:paste_clipboard
URxvt.keysym.M-V: eval:paste_primary
! Scrolling
URxvt.keysym.M-Up: eval:scroll_up 1
URxvt.keysym.M-Down: eval:scroll_down 1
URxvt.keysym.S-Home: eval:scroll_to_top
URxvt.keysym.S-End: eval:scroll_to_bottom
! Disable C-Shift
URxvt.iso14755: False
! Maximum lines we can scrollback
URxvt.saveLines: 100000

now get a life

>> No.65723656

is feh the uxrvt of image viewers? that is minimal but also extendable?

>> No.65723679

>>65722923
>what is MX 17 ?

>> No.65723808

>>65723656
sxiv is the dwm of image viewers

>> No.65724590

>>65711800
dafuq does this even do??

>> No.65724957

>>65722727
Probably just another spynet, but this time its not from google but cloudflare.

Use OpenNIC or your own DNS servers if you care about privacy and freedums

>> No.65725545

>>65724590
Remove overscan on tv's.
My lcd is old and does not have any built in options so I need this.
It's 2018 so I refuse to do this by hand with xrander and a script. Any normal up to date DE should be able to do this.
KDE does not fucking has it.

>> No.65725630

>>65725545
Well overscan is the tvs fault? Just because you turn it off on the pc doesnt mean the tv doesnt do it anyways.
I have a panasonic plasma from 2008 and I can turn it off

>> No.65725655

>>65703967
>she isn't very tech savvy
>a distribution that isn't Ubuntu /Ubuntu flavor
nah

>> No.65725658

>>65725630
>Just because you turn it off on the pc doesnt mean the tv doesnt do it anyways.
What?

>I have a panasonic plasma from 2008 and I can turn it off
Well I can't. Any up to date DE in 2018 should be this user friendly.
Only Gnome and Budgie have that option.
Mate KDE Xfeces all don't have it.

>> No.65726838
File: 1.91 MB, 330x200, 1522205619190.gif [View same] [iqdb] [saucenao] [google] [report]
65726838

Nice thread.

>> No.65726948

>install nonfree Nvidia drivers on Manjaro with the command from their site.
>reboot and all I get is a black screen with a flashing cursor

It's happened 3 times, am I just retarded?
I have a GTX 960 and I'm trying to switch to Linux completely.
I've found some reports of this happening, but that was after an update.

>> No.65726971

Why nobody has made a fully stable distro yet? Why no one said "yeah fuck this shitty redcuck and unstableware, lets make something new"? Like really, every distro follows the same scheme "GNU Coreutils, systemd, etc." If we have kernel and OS that we can modify as we want already then why not make something actually cool with it

>> No.65727185

which partition type shall i take for a shared partition between Windows and Manjaro?

>> No.65727240

>>65726971
>xkcd_standards.jpg

>> No.65727351
File: 28 KB, 380x250, 1403782800641.jpg [View same] [iqdb] [saucenao] [google] [report]
65727351

>>65727185
>between Windows and Manjaro?
Because Memejaro is something special, something unique and not just another generic GNU/Linux system right?
Because for Manjaro there are specific FS choices and whatever would for work Ubuntu, Debian, CentOS, Arch, Gentoo, openSuse etc. wouldn work right?

>> No.65727377

>>65726948
>with the command from their site.
Always avoid that shit if you can. Use the driver packaged by your distro if you can (especially since you don't use one of their latest cards), they should work OOB and have better compatibility.

>> No.65727593

>>65727240
xkcd is a retard, redditard and a leftist nigger
Inb4 idk why, ive seen some comic about Mr Trump or something

>> No.65728436

>>65727377
>Always avoid that shit if you can.
no they have a tool for that, it's kinda the whole point of it

>> No.65728543

>>65728436
Yes, a shitty universal tool that supposedly works everywhere (except it doesn't, proof: your post).
vs. the specialized packages for distros that works with their kernels, init system, initramfs, configs etc. and....

...why do I bother explaining good practices to Manjaro retards again?

>> No.65728555

i heard i3 is for pussies and bspwm is for real hackers, is this true??

>> No.65728580

>>65728555
No, use DWM.

>> No.65728591

>>65728580
even my autism is not that great

>> No.65728791

>>65703967
Linux From Scratch

>> No.65728806

back when flash was still a thing I'd use it for vector drawing...

does linux have something to do this or do I need to get CS6 + Wine?

>> No.65728849

>>65728806
InkScape

>> No.65728851

>>65728806
I guess something like illustrator for linux?

>> No.65728877

>>65728849
ah thnx

>> No.65729152

>>65728543
i'm not him but iirc you're not advised to do non manjaro things on manjaro

>>65728555
nothing wrong with i3

workspace_layout tabbed
hide_edge_borders smart
bindsym XF86AudioRaiseVolume exec amixer -q set Master 1%+ unmute
bindsym XF86AudioLowerVolume exec amixer -q set Master 1%- unmute
bindsym XF86AudioMute exec amixer -q set Master toggle
bindsym Print exec scrot -z -q1
bindsym $mod+period exec redshift -O2500
bindsym $mod+slash exec redshift -O3000
bindsym $mod+m exec mpv -- $(sselp)
exec xset -dpms ; xset r rate 300 50 ; setxkbmap -option grp:shifts_toggle

>> No.65729410

should i bother with ncpmcpp if i'm perfectly satisfied with a generic unmodified rhythmbox

>> No.65729554

>>65721786
it is pottering onions software though

>> No.65729809

>>65729410
if you dont use ncmpcpp then you are not as cool as we are

>> No.65729846
File: 86 KB, 582x800, mm73uv3reo0z.jpg [View same] [iqdb] [saucenao] [google] [report]
65729846

>>65703843
i just installed gentoo.
what do i do now?

>> No.65729858

>>65729410
not unless you need bait for screenshot threads. ncmpcpp is a convoluted meme.

>> No.65729865

>>65729846
eselect profile set 33
emerge -vDuN world --keep-going

>> No.65729922

>>65703967
Gentoo. No but really just give her ubuntu or one of its spins.

>> No.65729939

>>65704874
Like the other guy said use ip. ip a will show what ifconfig without options used to show. Look up iproute2 to find out more about the new commands.

>> No.65729998

>>65705512
If you have zero self control and are too lazy to ever do a reinstall again then you could edit your /etc/host file to block sites and then throw away your root password. Or you could just learn some self control.

>> No.65730034

>>65706217
Depends on what you mean by similar. Toolkit wise they all use gtk. Appearance wise xfce and cinnamon look more similar then they do to gnome. Technology wise cinnamon is a fork of gnome and xfce is its own separate project.

>> No.65730091

>>65707074
Windows users all suffer from terminal amounts of baby duck syndrome. Just the other day my Windows 10 passthrough VM decided to stop booting so I had to rsync the files into an old backup of the disk image because windows decided to corrupt its own system folder.

>> No.65730130

>>65707135
You need execute to cd into directories, it's one of those weird unix things. If you want to set execute for only directories running something like chmod u+X dir should work as a capital X tells chmod to just make directories executable.

>> No.65730148

>>65707322
What GPU? For intel telling xorg to use tearfree mode usually fixes it for me.

>> No.65730172

>>65708563
I use g810-led for my g910 and it works great. You might wanna check if your keyboard is compatible with it and make sure you run it as root unless you have udev rules set up right.

>> No.65730197

>>65711131
The first one might be am xfce setting somewhere you can change. The second one could be anything, try looking through dmesg when it happens.

>> No.65730201

I know this is brainlet tier, but please respond.
Is there some equivalent to rm's --preserve-root but for other directories?

For example, if I want to alias a new command like "del" so that it can never ever remove my home directory by accident

I always get anxious that one day when I'm up late at night or something I'll do an rm * in the wrong directory and fuck myself

>> No.65730262

>>65722727
I wouldn't trust cloudflare to keep what I had for breakfast a secret, let alone my DNS queries. OpenNIC all the way. Cloudflare is the reason you can't type ls DASH l or /etc SLASH hosts in posts.

>> No.65730284

>>65730262
>Cloudflare is the reason you can't type ls DASH l or /etc SLASH hosts in posts.
The amount I cursed a month or so ago, when I tried to reply someone here in fglt about some web server config and NiggerFlare blocked my posts.

>> No.65730307

>>65730201
You could probably right a bash function that checks if the target is your home directory and does nothing if it and deletes the target otherwise. Or you could just have good backups and rm all over the place.

>> No.65730347

whats some cool softs that you guys always install after a new SO?

just switched to manjaro OS
>VERY CONFY
what should i install in it?

>> No.65730397

Any easy ways of installing themes for XFCE?

>> No.65730401

>>65730397
>xfce theme manager

>> No.65730408

>>65730347
You install the software you use.
Installing random crap some anon told you that you're not even going to use is pretty autismo.

...That said, I have a little script in my dotfiles that I always run when first using a computer
https://pastebin.com/gF47gVjk

>> No.65730424

>>65730408
(and that's the package list it grabs from)
I also have other package lists depending on if the computer is a laptop or desktop, etc

>> No.65730469

I'm currently installing gentoo and it's compiling the world. CPU load is around 35% most of the time because smaller packages take a while to do checks and shit, but compile quickly, so it goes to 100% only on the big stuff. Should I set emerge to run 2-3 packages simultaneously and lower make jobs so it doesn't explode?

>> No.65730471

Is there any hope for someone that doesn't know the Wine source like the palm of their hand to try to debug *why* a certain thing in a certain program is not working as intended?

I'm really curious about why this one thing fucks up while everything works fine, in hopes that I could make a patch for it or apply some quick config/override to fix it.

The WineHQ entry for the particular game (Rainbow Six 3 Raven Shield) only states what is observed is not working, but the person discovered no work around for it

>> No.65730473

whats some cool blogs websites with linux related news and guides? stuff like tecmint, rly dig it

>> No.65730485

>>65730473
Level1Tech on youtube.
Wendell is a cool guy

>> No.65730503

>>65730307
What do you personally use for backups? rsync?

>> No.65730538

>>65730469
Are you using the systemd profile or something, I don't think you even need to emerge @world at this point and if you do it should take like 10 minutes

>> No.65730585

>>65730401
Ok thanks. How do I add a new theme in theme manager?

>> No.65730594

>>65730538
Wut? Why would you not emerge world? I'm on a plain desktop profile, pulling in all the new packages and updating/rebuilding the rest for the new flags sure as fuck doesn't take 10mins on something that isn't a 64 core monster.

>> No.65730791

>>65730473

phoronix

>> No.65730809

>>65730469
just let it do it's thing. try to compile too much stuff and you'll run out of memory and stuff will fail to build often.

>> No.65730869

New thread?

>> No.65730911

>>65730869
>new thread when the this one is on page 3
If you want a new thread so badly make it yourself you lazy cuck

>> No.65730927

New thread: >>65730916

>> No.65730946

>>65730911
Go eat your onions.

>> No.65731369

>>65730585
nigga it's
>download theme
>extract it to ~/.themes
done. what's hard about that

>> No.65731657

>>65730473
omgubuntu
itsfoss

>> No.65731787

>>65730503
I use burp. It uses rsync on the backend and does dedup between backups.

>> No.65731856

>>65731369
Where do I find ~/.themes?

>> No.65732452

>>65731856
In the Home folder
If it's not there, make it.
not that anon by the way

>> No.65732654
File: 716 KB, 1366x768, 1516224949434.png [View same] [iqdb] [saucenao] [google] [report]
65732654

Anyone care to help out why Fedora won't allow to upgrade to 28?

Shell keeps freezing at this part.

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action