[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology

View post   

[ Toggle deleted replies ]
File: 56 KB, 300x360, im done.jpg [View same] [iqdb] [saucenao] [google] [report]
60533667 No.60533667 [Reply] [Original] [archived.moe] [rbt]

>pacman -Syu
>can immediately tell something is wrong because browser doesn't want to launch anymore
>system doesn't want to reboot, have to go into another tty as root and reboot
>xorg is now apparently broken
>downgrading Nvidia package doesn't work
>trying to fix X.org conf files doesn't
>reinstalling seems to be least hassle filled option at this point

I seriously thought this was a meme of the past. I can't believe in 2017 a pacman -Syu can still fuck up your install.

>> No.60533696

We tried to warn you against the Arch trolls anon. It's your fault.

>> No.60533699
File: 393 KB, 462x497, [HorribleSubs] Kobayashi-san Chi no Maid Dragon - 10 [720p].mkv_snapshot_03.26_[2017.03.15_14.21.42].png [View same] [iqdb] [saucenao] [google] [report]

>fell for the meme

>> No.60533714
File: 24 KB, 500x455, arch-linux.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.60533735

I just did pacman -Syu on my machine and nothing happened. You're lying.

>> No.60533771

I wish i was

>> No.60533815

nigger you don't even need an xorg.conf file anymore unless you use shit hardware, you fucked up when you installed you shit

>> No.60533833
File: 91 KB, 530x488, 1485678335945.jpg [View same] [iqdb] [saucenao] [google] [report]

>> No.60533869
File: 371 KB, 2000x1000, girls_laughing.jpg [View same] [iqdb] [saucenao] [google] [report]

>haha this nerd still uses arch

>> No.60534016

werks on my machine ®

>> No.60534065

worked for OP too until now

>> No.60534084

Install a non-meme distro like Gentoo

>> No.60534167

Stop reading there.

>> No.60534876

OP here, as far as I can tell, openSSL is borked

>> No.60534969
File: 3.02 MB, 4032x3024, IMG_0538.jpg [View same] [iqdb] [saucenao] [google] [report]

Any ideas boys? I got an error message whining about openSSL after updating when I tried to launch my web browser from the terminal before upgrading. openSSL is installed already and I reinstalled it just to be safe. Should I just wait this out until the package mantainers sort it out?

>> No.60534985

>after upgrading but before rebooting

>> No.60535295

Switch to tty if you can, install this:

>> No.60535340

Literally just tried that, didn't work unfortunately. I think I'm gonna have to mess around with the system lib files manually.

>> No.60535358

you should reinstall anyway. you fucked up royally on the way.

>> No.60535397
File: 45 KB, 409x409, comfy.jpg [View same] [iqdb] [saucenao] [google] [report]

>emerge -avuND @world
>change use flags if necessary
>everything works perfectly

>> No.60535410

my arch up to date and werks like mad

>> No.60535486

>in case it doesn't work
>warns you about errors and doesn't fuck your system, instead asks you to resolve the conflict and try again until successful
>your system is basically unborkable
Master race

>> No.60535545

Install Windows 7

>> No.60535561

>you don't even need an xorg.conf file anymore
how do you specify the positions of your monitors if you don't have an xorg config file ?

>> No.60535564

OP here, got it to work again. It was my fault in the end, don't fuck with packages from testing and then forget to completely uninstall them then do a pacman -Syu.

>> No.60535596

you forgot the pound sign

>> No.60535639
File: 279 KB, 1180x1488, pepesaint.png [View same] [iqdb] [saucenao] [google] [report]

Then you woke up and realized it was a dream then you got to the desktop and your 10 years old ArchLinux installation was fine.

Arch is stable like a rock.

>> No.60535741
File: 135 KB, 1366x749, Screenshot 2017-05-23 07:35:37.png [View same] [iqdb] [saucenao] [google] [report]

lol BTFO, brainlet

>> No.60535742

>his distro doesn't use LibreSSL by default

>> No.60535757

Just install fucking OpenSSL 1.0.1 from your package cache or archive.archlinux.org you fucking retard
Either go back to Windows if you can't figure something like this out or admit you don't know shit from clay and it's 100% your fault you fucked your system throu-
Oh that's interesting I wonder why it wants so many different versions of OpenSSL? Try giving another -Syu a shot and failing that try a rollback to your last successful -Syu date on archive.archlinux.org
I'm sure it's not a difficult one to nut out but if you have to ask/bitch and moan it's probably beyond you
Good luck mate!

>> No.60535764

Take two minutes to have Ubuntu install itself and then use your computer to do things instead of doing nothing all day the hard way.

>> No.60535779

Run an xrandr script in .xinitrc

>> No.60535797

And to clarify, I fixed it by clearing out my cache with a pacman -Scc and then reinstalling the DE

>> No.60535807

I already fixed it boys.

>> No.60535817

you fucked up nigger..

>> No.60535821

What'd it need?

>> No.60535940

Clear out pacman's cache then reinstall DE. Nothing was wrong with Xorg itself, the DE was looking for a version of OpenSSL I didn't have

>> No.60536014


Section "Monitor"
Identifier "DVI-1"
VendorName "Dell"
ModelName "U2311H"
DisplaySize 509 286
Option "Primary" "True"
Option "PreferredMode" "1920x1080"
Option "Position" "1280 0"
Option "DPMS" "true"

Section "Monitor"
Identifier "DVI-0"
VendorName "Siemens"
DisplaySize 338 270
Option "PreferredMode" "1280x1024"
Option "Position" "0 56"
Option "DPMS" "true"

>> No.60536027

pacman is a notorious homophobe, you shouldn't have been so obvious.

>> No.60536038
File: 11 KB, 250x201, 1335125110054.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.60536068

>posts nigger
>calls others nigger
pajeet calm down
having mess of an xorg file is bit different than section configs

>> No.60536091
File: 82 KB, 613x987, conf.jpg [View same] [iqdb] [saucenao] [google] [report]

buying new GPU, either amd or nvidia
been on intel igpu for ages but now ryzen build

which one gives me less problems on arch?
I feel like I read about nvidia having issues far more often

>> No.60536115

Nvidia does work but they're incredibly stubborn when it comes to Wayland. If current trends continue, AMD might actually be better in the long run because it looks like Nvidia users will probably be stuck on X.org.

>> No.60536127
File: 32 KB, 509x549, 1470248677140.jpg [View same] [iqdb] [saucenao] [google] [report]

Living the arch life.

>> No.60536261

>uses antergos
>calls anyone brainlet
arch-anywhere you dumb nigger, that logo and name look like shit

>> No.60536274
File: 261 KB, 799x623, scr.png [View same] [iqdb] [saucenao] [google] [report]

Don't know what you did, but it was retarded.

>> No.60536310

>Thinks antergos and Arch is any different
>Trip shit
True brainlet spotted

>> No.60536367

>uses antergos
>calls people brainlets

>thinks using an installer is any better than the other retard

>> No.60536388

>Using Arch

You get what you deserve while the fun is on Debian

>inb4 "cutting-edge siftware"

Can be compiled on anything of the same architecture

>> No.60536428

Does installing it by command line increase your benis size?

>> No.60536475

I didn't even command line install it you nigger cattle. Antergos does = Arch but my autism hates that shitty logo and name, Arch-Anywhere is a GUI installer for all your meme needs

>> No.60536485

>Thinks installing a from the command line will make him intelligent
Another brainlet

>> No.60536489

You do realize this is an elaborate false flag thread, right?

>> No.60536506

dependency hell debian?
overheating laptops debian?
I need to make it into ubuntu for it to be useful debian?
literally cuckware debian?
Fedora my nigga

>> No.60537903

It wasn't a false flag, I did have a problem earlier but everything is a-okay now.

>> No.60537937
File: 1.24 MB, 1200x1600, smugAnimeGirl.jpg [View same] [iqdb] [saucenao] [google] [report]

Using aptitude on ElementaryOS

It really feels good right now

>> No.60539433
File: 60 KB, 714x649, 1495325491879.jpg [View same] [iqdb] [saucenao] [google] [report]

>he's too dumb to use arch

Name (leave empty)
Comment (leave empty)
Password [?]Password used for file deletion.