Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

/vt/ is now archived.Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 10 KB, 282x265, 1471469479227.png [View same] [iqdb] [saucenao] [google] [report]
56219791 No.56219791 [Reply] [Original] [archived.moe] [rbt]

Previously on: >>56213318

Welcome to /fglt/ - Friendly GNU/Linux Thread.
Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread. ***

Before asking for help, please check our list of resources[*].

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine using VirtualBox or other software made for this puporse for safety purposes.
1) Use the Live ISO (if your distribution of choice has one) to boot directly into the GNU/Linux distribution without installing anything, that way, you can get to experience the GNU/Linux operating system without installing it.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS, this is recommended if you want to know more about the GNU/Linux operating system.
3) Go balls deep and replace everything with GNU/Linux.

Meet the /fglt/ team:

IRC: irc://chat.freenode.net:6667/flt (6697 for SSL)
If you don't have an IRC client, you can use a web client:
https://webchat.freenode.net/?channels=flt
https://kiwiirc.com/client/irc.freenode.net/flt
WEB: http://fglt.nl/

* Resources:
Your friendly neighborhood search engine (searx, ixquick, startpage, whatever.)
$ man <insert command here>
https://wiki.archlinux.org (Most troubleshoots work on all distros.)
https://wiki.gentoo.org (Please see comment above.)
https://wiki.installgentoo.com/index.php/Category:GNU/Linux
https://prism-break.org/en/categories/gnu-linux/
http://linuxcommand.org/tlcl.php
https://www.gnu.org

Friends:
>>>/t/707928 - /t/'s GNU/Linux Games
>>>/t/713097 - /t/'s GNU/Linux Training Videos

Copypasta:
https://ghostbin.com/paste/gxcnp

>> No.56219801

install gentoo

>> No.56219831

so....nouveau is usable now? i can into optimus on my laptop now?

>> No.56219984

>>56219795
>What search engine respects my freedom? searx.me? startpage.com? Which?

searx is the only one I know of which provides source code, doesn't mean that the servers run the same code, but well. there are also TOR services, check their github

>> No.56220040

Remember to try Debian/Hurd. Hurd is the FSF kernel, and there are other GPL kernels like HiStar, which is a security oriented kernel and Muen, proven to have no runtime errors at the source code level.

Other full operative systems exists like FreeVMS, FreeDOS, and ReactOS, all under the GPL. Plan 9 was also re-licensed as GPL.

>> No.56220056

>>56220040
>proven to have no runtime errors at the source code level.
top kek
Do you have any idea what you're saying?
>freetards embarrassing themselves yet again

>> No.56220066

>>56219795
YaCy is the future, is a program you download and run in your own computer, no cloud unless you want to share some common search results with other peers, but that is optional.

Is GPLv2 of course.

>> No.56220075

>>56220040
>>56220056
I'm having a deja-vú.

>> No.56220082

>>56220056
>freetards
This is a friendly thread, leave.

>> No.56220093

>>56220082
Go to plebit if you want a hug

>> No.56220150

>>56219791
Just installed Debian kde on my desktop, I'm still very new to Linux but I know basic commands. I have been struggling with this for hours though, if anyone could help me I would very much appreciate it.

Trying to install the proprietary nvidia drivers for the GTX 980. Everything goes smoothly when I run it from terminal, until I get this error:

ERROR: Unable to find the development tool `cc` in your path; please make sure that you have the package 'gcc' installed. If gcc is installed on your system, then please check that `cc` is in your PATH.

I am sure that gcc is installed, whereis gcc returns /usr/lib/gcc

From searching I found that echo $PATH shows my path, and I'm assuming that cc is supposed to be somewhere in there and that's the problem.

echo $PATH returns: /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

I know this isn't a tech support board, but if someone could just tell me how to get cc in my path I would greatly appreciate it.

>> No.56220170

Trying to install something and i'm getting this error:
libicu not found
tried doing apt-get install libicu and i get nothing.

>> No.56220188

>>56220170
also tried installing icu-devtools-dbgsym and it says unable to locate packages. Same thing for the other icu shit ending with dbgsysm

>> No.56220288

>>56220188
try libicu-dev

>> No.56220309

I tried to install arch 3 times today and failed oh well back to debian

>> No.56220332 [DELETED] 

[email protected]:~$ sudo apt autoremove --purge gnome-core
[sudo] password for user1:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'gnome-core' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 105 not upgraded.
[email protected]:~$ which nautilus
/usr/bin/nautilus
[email protected]:~$ which gnome-
gnome-contacts gnome-session-inhibit
gnome-control-center gnome-session-properties
gnome-file-share-properties gnome-session-quit
gnome-help gnome-settings-daemon
gnome-keyring gnome-shell
gnome-keyring-3 gnome-shell-extension-prefs
gnome-keyring-daemon gnome-shell-extension-tool
gnome-menus-blacklist gnome-shell-perf-tool
gnome-power-statistics gnome-terminal
gnome-screensaver gnome-terminal.real
gnome-screensaver-command gnome-terminal.wrapper
gnome-screenshot gnome-text-editor
gnome-session gnome-www-browser
[code/]

Now how do I go about actually removing gnome-core? I thought APT is superior

>> No.56220366

[email protected]:~$ sudo apt autoremove --purge gnome-core
[sudo] password for user1:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'gnome-core' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 105 not upgraded.
[email protected]:~$ which nautilus
/usr/bin/nautilus
[email protected]:~$ which gnome-
gnome-contacts gnome-session-inhibit
gnome-control-center gnome-session-properties
gnome-file-share-properties gnome-session-quit
gnome-help gnome-settings-daemon
gnome-keyring gnome-shell
gnome-keyring-3 gnome-shell-extension-prefs
gnome-keyring-daemon gnome-shell-extension-tool
gnome-menus-blacklist gnome-shell-perf-tool
gnome-power-statistics gnome-terminal
gnome-screensaver gnome-terminal.real
gnome-screensaver-command gnome-terminal.wrapper
gnome-screenshot gnome-text-editor
gnome-session gnome-www-browser


Now how do I go about actually uninstalling gnome-core? I thought APT is vastly a superior package manager

>> No.56220370

>>56220332
>how do I go about actually removing gnome-core?
You don't have gnom-core installed, it is telling you that in plain English.
>I thought APT is superior
Superior to what? No package manager is going to remove a package you don't have installed...

>> No.56220413

>>56220370
I thought someone will ask me this so here is my bash history
[email protected]:~$ history | tail -n 150 | grep -i gnome-core
149 sudo apt install gnome-core
153 sudo apt install gnome-core
155 sudo apt autoremove --purge -y gnome-core
171 sudo apt autoremove --purge gnome-core
178 history | tail -n 150 | grep -i gnome-core

>> No.56220435

>>56220413
Do you think your package manager is lying to you then?

>> No.56220494

>>56220413
>>56220366
Apt cucks BTFO once again

>> No.56220524

>>56220366
>I thought APT is vastly a superior package manager
lol

>> No.56220549

>>56220366
>>56220413
>debian fags will defend this

>> No.56220578

>>56220549
He's a retard, what do you expect.

>> No.56220583

>>56220549
not really, he's just doing it wrong.

>> No.56220595

>>56220578
>"is your package man lying"
>"lol he retard"
Debibabbies, everyone.
I'll come home and upload a video how to reproduce this. Get ready for ultimate BTFO

>> No.56220610

>>56220595
>hey package manager, remove this package that I don't have installed
>fucking package manager is shit

>> No.56220615

>>56220610
See >>56220413
Dumb fuckwit

>> No.56220626

>>56220615
Yes, you don't have gnome-core installed. Which part of that is confusing you?

>> No.56220700

Using Ubuntu Mate and I'm enjoying it quite a lot, but I have yet to find a screenshot tool that does what I need it to.
On Windows I would just use greenshot which was more than ideal for me, I'd hit PrtSc, then I would just drag over the area I'd like to capture, let go of my mouse, and then choose where to save/upload it. I ended up setting up a keyboard shortcut with the default screenshot tool, but it only takes full desktop shots with no input from me

>> No.56220752

>>56220626
>install gnome-core
>remove gnome-core
>gnome softwares stay back
>"its not installed"

>> No.56220768

>>56220752
Ok, sure thing moron.

>> No.56220785

>>56220768
BTFO, debcuck

>> No.56220792

>>56220785
>I'm a retard, it's all your fault apt

>> No.56220825

>>56220792
>>56220768
>>56220578
>>56220435
Idk what to say, debqueen but you are actually embarrassing yourself

>> No.56220835

>>56220825
>I can't use my package manager

>> No.56220859

>>56220835
Its okay to get rekt, newfag. Close tge tab and pretend it never happened.

>> No.56220873

>>56220859
It's not me that's crying babe.

>> No.56220997

>>56220700
Does shift+PrtScr not allow you to select a region? I've used Ubuntu (Unity and GNOME), and that's worked for me

>> No.56221030

Does the nvidia driver properly support wayland and current compositors or are they still pushing their nonstandard shit? unfortunately I can't use nouveau with my gpu, and I want to attempt writing my own compositor.

>> No.56221415

I like Xubuntu 16.04 but the disparity between Gtk3 titlebars and standard xfwm titlebars is disgusting. Is there a good WM that overrides it? Openbox perhaps?

>> No.56221580

Will reinstalling xubuntu solve my problem?
I can't fuckin install icu.
I've tried apt-get install icu-devtools and other shit and I still get an error saying it wasn't installed.

>> No.56221594

>>56221580
post error

>> No.56221597

>>56221580
Have you tried apt-get purge, then apt-get install?
Have you tried apt-get install --reinstall?
What's your error message?

>> No.56221630

>>56220309
Use the Architect installer.
Arch is a great distro, despite the toxic community telling you you need to go through manual installation as a rite of initiation to become a True Arch User.

>> No.56221644

How do I root?
LIke, when I go in the terminal i can't do certain stuff cuz i'm not root or something. Trying to make install but I need to be root

>> No.56221652

Is there a list of packages in a default Debian install somewhere?
I want to install Sid.
The recommended method is a minimal Stable installation, then point sources to Sid, upgrade, install whatever else you want.
I want the default desktop, so I need to know which packages it has.

>> No.56221686

>>56221644
To become root, type:
Su
Then enter your password.
To become normal user again, type:
Su [your username (no brackets)]

It is usually better to use sudo.
sudo [command you want to do as root (no brackets)]
For this to work, sudo must be installed and your username must be in the sudoers file. This is the default behavior in Ubuntu, Mint, Arch, and a few other distros.

>> No.56221696

>>56221686
su, not Su

>> No.56221910

I'd like to either put:

Ubuntu MATE
Elementary OS
Some red hat OS

Onto an older laptop that I can take with me to school. I've played around with Elementary OS in a VM and I really like it, but there are a couple issues.

One I was able to resolve with this elementary-tweaks program: https://github.com/elementary-tweaks/elementary-tweaks

Another problem is that I cannot put stuff on the desktop, even though there is a desktop folder; I understand the "why" and "why not?" to it, but I want the freedom to use the desktop how I want to.

A dealbreaker for me though is the tabs on the file manager and terminal. It's one thing if the program re-opens but the tabs go back to a default location, it's another/redundant when they re-open where I was looking.

Is it possible, consumer-friendly, to fix the latter two issues?

>> No.56221940

>>56221686
best practice would be to exit from root shell rather than to switch to a user. otherwise any terrorist or program could exit from the other user and they will be dropped back into root

>> No.56221960

trying to edit this .conf
tried saving but it won't let me. how do I get permissions?

>> No.56221964

>>56221910
The whole point of Elementary OS is to have a clean-looking desktop by removing options.
If the way the desktop works isn't what you like, EOS isn't for you.

>> No.56221973

>>56221940
And I learned something today. Thanks.

>> No.56221983

>>56221960
open it as root, or with sudo.

>> No.56222192

I got some .swp that I want to delete, problem is I don't know how.
I entered this:
vim -r /etc/mpv/encoding-profiles.conf
Then it asks me to enter number of swaps I want to use.

>> No.56222237

>List of /fglt/ approved distributions:
>>Funtoo
>>Slackware
>>gNewSense
>>Haiku
>>Alpine
>>Puppy

>If you need systemd:
>>Debian
>>Gentoo

>If you want something out of the box:
>>Calculate Linux
>>Ubuntu
>>Manjaro
>>Linux Lite

>If you're hardcore and want to prove yourself:
>>LFS

>If you want to be an edgelord while simultaneously being the laughing stock of the Linux community:
>>Arch
>>Antergos

>If you want to be a living meme and a lab rat:
>>Fedora

>If you've finally realized that Linux is shit:
>>*BSD

>> No.56222269

I'm trying really hard to stay with linux, but I just keep having problems that take days at the least to fix

>> No.56222298

>>56222269
Thank you for sharing.

>> No.56222320

>>56220150
$PATH Lists directories. If cc is in any of the ones listed, you're fine.

>> No.56222335

>>56220700
xfce4-screenshooter

Install this and bind prtscr to it via your wm/de.

>> No.56222336

>Take a screenshot, without subtitles. (Whether this works depends on VO driver support.)
Just tested this on mpv and it shows the subtitles.
How do I get this VO driver?
apt-get install vo driver? lol

>> No.56222376

>>56222336
just press V to turn off subs,,, take screenshot and turn on subs again.
I couldn't get that shit to work either

>> No.56222556

>>56220040
ReactOS is a cool idea for sure, but it certainly is not ready for primetime right now.

>> No.56222648

>>56222269
What problems? What distro?

>> No.56222681

>>56222648
arch
>audio won't work with vm's
>constant video driver issues
>audio keeps muting itself
>sometimes reboots by itself for no reason

>> No.56222728

>>56222681
>new
>arch
Your fault

>> No.56222746

>>56222681
Do you use proprietary drivers?
Because those really don't mix well with rolling release distros.

>> No.56222767

>>56222746
I use amdgpu

>> No.56223114

I've installed Gentoo in a virtualbox, and everything works okay. I installed the guest additions and using XFCE as my DE, everything was good. Now I wanted to try herbstluftwm and openbox, but with both of them, the virtual machine screen won't adapt to my screen (like when you don't have the guest additions installed). It worked with XFCE though. Does anyone know what to do? Googling didn't help.

>> No.56223241

lvm on luks or luks on lvm?

>> No.56223263
File: 56 KB, 500x474, 1470742768347.gif [View same] [iqdb] [saucenao] [google] [report]
56223263

Any Codeblocks wizards here? Any idea why my codeblocks v.16.01 hides my underscores? Can't find solution anywhere. Thanks in advance.

>> No.56223391

>>56223241
luks on lvm, as is tradition.

>> No.56223679

>>56223114
it's because these WMs doesn't autostart /etc/xdg/autostart entries like Xfce
you have to call VBoxClient manually or make it run in the Xorg startup

command:
VBoxClient --clipboard --draganddrop --seamless --display --checkhostversion

>> No.56224702

>>56220309
Where are you having problems, anon?

>> No.56224728

>>56222681
The first word of your post is responsible for the significant part of your problems.

>> No.56224759

>>56224702
Probably with the fact that the installer is missing.

>> No.56224931

some good music player?

>> No.56225075

>>56224931
Cmus, moc, deadbeef, clementine
Sorted from minimal to not minimal.

>> No.56225371
File: 123 KB, 492x475, 1465870897166.jpg [View same] [iqdb] [saucenao] [google] [report]
56225371

BACK TO KUCKSHED, APTKUCKS
https://youtu.be/NysoCN9RR_c

>> No.56225436

Can anyone help me with this command?
find . -type f -name '*.css' -exec sed -i 's/#FFFFFF/#000000/g; s/#ffffff/#000000/g;' {} +
I am trying to replace all appearances of multiple colors in multiple css files, and I can't get it to work properly (it changes only some colors)

>> No.56225447
File: 302 KB, 1366x768, Screenshot from 2016-08-23 23-49-36.png [View same] [iqdb] [saucenao] [google] [report]
56225447

>>56225371

>> No.56225459
File: 372 KB, 517x773, Selection_026.png [View same] [iqdb] [saucenao] [google] [report]
56225459

How to fix this anons?
>pic
It works only for cyrillic and latin letters, but others like Asian letters no

>> No.56225476

>>56225459
Install your native font

>> No.56225483

>>56225459
You need to install some fonts. Noto fonts should cover all your needs.

>> No.56225513

>>56225459
go away pajeet

>> No.56225523

>>56223679
I gave it a try. For one, the command doesn't seem to work like that, only if you run it with each flag individually. Running "VBoxClient --display" after starting X did it, but putting "exec VBoxClient --display" in my .xinitrc doesn't work.
Also, the DPI seems to be much lower than it was in XFCE.
Do you know what the problem might be?

>> No.56225580

>>56225371
>>56225447
Yeah, I had this problem when switching desktop environments on Debian. There's no good, simple way to remove the entire DE and all its associated apps.
Perhaps the problem is overlapping dependencies? That's just my shitty layman guess. I feel like the Debian devs must be aware of this, and it's probably done how it is for a reason, or there's an open issue somewhere.

>> No.56225587

>>56225436
Why don't you just -
sed -i 'blah' *.css ?

Also post example of the strings that don't change.

>> No.56225597

>>56225513
go away /pol/

>> No.56225598

>>56225447
I don't think nautilus is a part of gnome-core.
>>56225580
Remove the metapackage you installed it with.

>> No.56225608

>>56225598
It wasn't there before installing gnome-core

>> No.56225617

>>56225598
nautilus is part of gnome, other than being a file namager, it manages the gnome desktop

>> No.56225633
File: 26 KB, 500x286, 1470692679594.jpg [View same] [iqdb] [saucenao] [google] [report]
56225633

So I was testing some live ISOs and after I was done USB drives stopped being detected at boot.

What could be the cause? One of them overwrote efivars or something? What do?

>> No.56225640

I'm using Arch Linux and I want to level up. What is the best distro?

>> No.56225644
File: 685 KB, 1196x1024, Selection_027.png [View same] [iqdb] [saucenao] [google] [report]
56225644

>>56225476
>>56225483
and look this, windows tittle is ok but only is fucked in page. this problem started few days ago, dont know why

>> No.56225656

>>56225640
Debian.

>> No.56225663

>>56225640
normie level
ubuntu

ok level
debian

pro level
arch

almost über pro level
gentoo

über pro level
lfs

>> No.56225664

>>56225656
Shit package manger

>> No.56225671

>>56225644
install noto

>> No.56225673

>>56225617
Gnome-core is the minimal version of gnome. Because of this I thought it may not have been part of it.
>>56225608
Did you remove task-gnome-desktop manually?

>> No.56225682

>>56225663
>arch
>pro
topkek

>> No.56225690

>>56225663
>t. Archfag
>>56225640
The one I'm using

>> No.56225692

>>56225673
>Because of this I thought it may not have been part of it.
which nautilus gave no input, literally first thing in the video

>> No.56225699

>>56225587
All of the strings are hex colors (and none of them are the same). I just put #FFFFFF and #ffffff for example, there are maybe ~50 of them
I have to use find because I need to replace it in all subdirectories.
Could it be tha

>> No.56225704

>>56225682
Never understood why people feel superior for pasting 10 wiki commands.

>> No.56225705

>>56225692
output*

>> No.56225714

>>56225699
>>56225587
Could it be that sed can't work with that big word list, or that many files?

>> No.56225725

>>56225692
We still don't know if ypu installed gnome via gnome-core, task-gnome-desktop or some dummy package.

>> No.56225726

>>56225704
Never understood why people fail in pasting 10 wiki commands

>> No.56225735

>>56225714
Nah, if you would sed a 5 tb file, you'd just wait b bit, still without errors.

>> No.56225737

>>56225725
What I did is clear in the video; do I smell chronic denial?

>> No.56225757
File: 28 KB, 730x178, Selection_028.png [View same] [iqdb] [saucenao] [google] [report]
56225757

>>56225671
wtf is this shit anon

>> No.56225764

>>56225704
well they are going to learn from it either way, but dumbfags will still mess something up and then complain when something breaks and blame arch for it

>> No.56225768

How do i save a playlist on ncmpcpp
The cheat sheet i use say say but thats just stop

>> No.56225772

>>56225757
Noto is huge. The project tries to cover up all languages.

>> No.56225797

>>56225772
ok anon,i trust you!
/g/ always helped me

>> No.56225800

>>56225764
Same reason people blame apt for their own failure.

>> No.56225803

>>56225757
retard you are going to mess your shit up,
each time you open up font picker it's going to freeze for A WHILE now

>> No.56225806

>>56225800
What own failure?

>> No.56225809

>>56225633
Anyone?

I can only think that a live ISO overwrote efivars because I didn't change any BIOS option after I was done testing it.

>> No.56225832

>>56225772
? >>56225803

>> No.56225851

Any hints on "Babbies first self compiled kernel"?

>> No.56225862

>>56224759
Where did he find Arch without pacstrap?

>> No.56225879

>>56225726
>fail

Nah, it's just that most people realize tedious shit like partitioning and user setup doesn't have to be done trough cryptic commands. The only reason Arch doesn't have an installer is for the 1337 factor and KISS meme that the devs don't actually care about.

>> No.56225883

>>56225737
I don't use youtube and you didn't bother to make a 4mib vp8 webm that you could post here, why should I watch it?

>> No.56225890

>>56225879
>1337 factor
What's 1337 about pasting 10 wiki commands?

>> No.56225895

I study IT at an online academy, and they've told me that we'll be using Fedora and a debian based distro in the future for learning.

What distros would you recommend?

>> No.56225897

If I want to install the same distro on 4 different machines, is there a way to just install it once and then just copy it to the other machines?

>> No.56225906

>>56225895
Debian or fedora obviously.

>> No.56225928
File: 1.61 MB, 2000x2000, 1468485447823.jpg [View same] [iqdb] [saucenao] [google] [report]
56225928

>>56225883
(To) Cry harder, debqueen

>> No.56225940

>>56225906
"Debian based"

What's the perks of Fedora?

>> No.56225946

apt-cache depends gnome-core | awk '{print "sudo apt-get purge "$NF}' > yolo.sh

>> No.56225957

>>56225851
gentoo wiki

>> No.56225974

>>56222237
>>>Funtoo
What's up with all the Funtoo shills lately? It's awful.

>thinking *BSD is any good
>clearly never actually used *BSD
OpenBSD is the only BSD that isn't a piece of shit, and you still have to endure the fact that it's got no hardware support. FreeBSD is just contrarian garbage.

>Thinking Manjaro is good but Antergos is edgy
>Calling LFS a distro.

You also forgot -
>If you're above the age of 18
>>OpenSUSE

>> No.56225986

>>56225897
You could dd it, yeah.

>> No.56225993
File: 132 KB, 1268x592, 1471560053204.png [View same] [iqdb] [saucenao] [google] [report]
56225993

>>56225974
>OpenBSD is the only BSD that isn't a piece of shit
OpenBSD is the only BSD that is a piece of shit. Come back when you can use qBittorrent in OpenBSD
FTFY

>> No.56225995

>>56225663
lazy level
ubuntu

normal level
debian

waste-of-time level
arch

bigger waste-of-time level
gentoo

no life level
lfs

>> No.56226002
File: 40 KB, 683x255, Selection_029.png [View same] [iqdb] [saucenao] [google] [report]
56226002

what do i do

>> No.56226005

>>56225995
Can you tell that I run Debian?

>> No.56226008

>>56222681
Welcome to Arch, you were warned.
On the other hand: How the fuck do you get issues like those? My only issues on Arch were xorg constantly breaking.

>> No.56226017

Who /frankendebian/ here?

>kali repos
>debian repos
>ubuntu repos
>trisquel repos

It works surprisingly well. I just enable/disable the individual repos when I need them. No problems, since all repos use the same debian version as base.

>> No.56226034

>>56222681
>audio keeps muting itself
this happens when you are for example, watching video on VLC and you start video on youtube. VLC gets muted

>> No.56226035

>>56226017
E D G Y
D
G
Y

>> No.56226048

>>56226017
W-why?

>> No.56226049

>>56225851
Stay away from debugging features. Do not compile your filesystem and sata drivers as modules, better yet do not compile anything as one. Make sure you add the correct firmware for your graphics and network (if needed) and if you use uefi enable the relevant options. Also use nconfig because the arrow key navigation is better.

>> No.56226054

>>56226017
Why would you do that? What was missing from Debian's repos? I'm sure you've read this page: https://wiki.debian.org/DontBreakDebian

>> No.56226060

>>56226048
VM Fun. I just wanted to try how far I can go.

>> No.56226088

>>56226002
Install a better Distro.

>> No.56226090

I'm running Mint and it won't connect to wifi that has a two-step login (ie. username + password). Either that or my wifi is just bad, but my phone connects to it no problem. How do I fix this?

>> No.56226093

>>56225075
deadbeef looks nice, thanks anon

>> No.56226137

Ok guys. I love shell scripting, but when it comes to naming my scripts and functions, I'm always afraid that I overwrite the name of an already existing program.
Usually I use type <program> to find out if a program with the same name already exists on my system, but is there a better, generalized way?

>> No.56226151

>>56226090
see >>56226088

>> No.56226152

>>56226090
Btw, it just loads infinitely, it doesn't say "cannot connect" or anything. I've tried turning my wifi and the computer itself off and on a few times but no dice.

>> No.56226171

>>56226093
WHY ISN'T IT ON WINDOWS?

I just want a music player with these attributes:
- FOSS
- runs on Linux & Windows
- looks/functions well out of the box
- custom keyboard shortcuts

Quod Libet is the closest thing I can find to matching my criteria, but it doesn't have custom shortcuts afaik.

>> No.56226206

>>56226151
t. bitter Arch user

>> No.56226241

>>56219791
Hello there /fglt/,
I need a little help for a rather simple script, but i fail to get it done right.
The goal of the complete script is to scan through /boot, fetch all files and categorize them (vmlinuz, initramfs), pick the highest version available and symlink them as "*-current".
Basicly automate updates, so the first syslinux entry would always pick the latest kernel/initramfs to boot as it refers to *-current.

My problem here is, that i fail to a) distinguish the files per prefix and b) don't know how to determine the highest version string.

I did research a bit and tried to accomplish these simple tasks myself, but i guess i'm simply too new to bash. Any hints?

>> No.56226306

>>56225580
It's done for a reason.
Debian has optional dependencies, i.e. package A depends on either B or C.
If you have A and B installed, then install D, which depends on C, it will pull in C.
If you remove D again, C stays cause it's listed as a dependency of A.

This is expected behaviour and doesn't pose a problem. You can still remove C manually, and if you don't, it doesn't hurt anyone and just fills up a few KB of disk space, which desktops systems have plenty.

>> No.56226318

>>56226241
a little more info on the structure
ls /boot
System.map-4.7.2_1 initramfs-4.6.6_1.img initramfs-4.7.2_1.img syslinux
config-4.7.2_1 initramfs-4.6.7_1.img

>> No.56226326

>>56226241
Not sure how the end result should look like.
I'd start with
find /boot/ -maxdepth 1 | grep vmlinuz | sort -V | sed '$!d'

>> No.56226332

>>56226306
This. gnome-core for example depends on either firefox or chromium, if you have neither installed it will install firefox but if already have chromium installed it won't install firefox.

>> No.56226335

>>56226326
Thanks man

>> No.56226346

>>56226332
>if you have neither installed it will install firefox
Nope

>> No.56226349

>>56225940
Based on usually means shittier than the original, and by usually I mean always.
Fedora is nice, it has a blobbed kernel (which means your hardware will nost likely work without installing anything manually) but comes at the price of having nonfree software on your system. Otherwise the packaging guidelines are very well done. It doesn't have a lot of packages prepacked though.
I prefer debian personally because the community is great.

>> No.56226352

>>56225371
>>56225447

See -> >>56226306
Here's a more in-depth answer and method for removal: https://askubuntu.com/questions/164941/why-removing-gnome-core-does-not-remove-all-of-its-dependencies

>> No.56226353

>>56226346
https://packages.debian.org/sid/gnome-core

>> No.56226384

>>56226002
Looks like you are packaging a truetype font but it fails because their archives are not valid, I would file a bug report if I were you.

>> No.56226396

>>56226171
>Custom shortcuts
if i understand you correctly you want to press a certain key-combination and want quodlibet to react to that e.g. press super+F1 and ql plays the next song.
this can easily be accomplished using xbindkeys

>> No.56226419

>>56226137
You could add something like -own to your own stuff.

>> No.56226420

>>56226002
The package you're trying to install from an unvalidated insecure repo, without knowing its author or reading the source, is broken.

Welcome to the AUR.

>> No.56226432

>>56226326
>>find /boot/ -maxdepth 1 | grep vmlinuz | sort -V | sed '$!d'
no need for grep

find /boot/ -maxdepth 1 -name 'vmlinuz*' | sort -V | sed '$!d'

>> No.56226462

>>56226332
>>56226306
What does GNOME have anything to do with firefox? GNOME even has their own browser

>> No.56226481

>>56226137
On Debian:

apt-cache search <program>

>> No.56226498

>>56226481
That would only check the package name. Some packages include more than one program.

>> No.56226509

>>56226462
The Debian package gnome-core depends on firefox-esr or firefox or chromium. You can see for yourself >>56226353

>> No.56226576

I'm using ffmpeg-git from aur, but can't update libvpx because ffmpeg depends on libvpx.so.3.
Firefox won't work as well, because it needs the updated libvpx.so.4.

How to solve?

>> No.56226593

The real enemys are DEs, not the package managers.
DEs were a mistake. This is how it ends when people try to make a operating system tech illiterate friendly. People blame Linux for DE problems "X doesnt have feature Y, REEE" instead of fixing problems themself and customizing their desktop to their needs. Don't suck DE dick. Boycott the DEs, install your favorite programs and your favorite WM.

>> No.56226608

>>56226509
>Debian package gnome-core
That's where I am interested in. Why does debian require gnome-core to have firefox as a dependency? Why such a massive bloat?

>> No.56226634

>>56226608
>install DE
>complain about bloat
Wew lad.

>> No.56226654

>>56226634
At least on other distros they don't shove a couple of whole fucking browser onto your ass

>two browsers for installing a DE
kek

>> No.56226660

Why are people even using gnome? I mean, users are waiting since 12 years for a simple filepicker bugfix.

>> No.56226669

I have also noticed GNOME/any other DEs in debian installs a login manager.

Why?

>> No.56226682

>>56226660
That's a gtk bug

>> No.56226687

>>56226654
It's not two browsers. Are you illiterate? Firefox OR Chromium, it needs one of those.

>>56226608
Also It's not Debian, it's GNOME, in Fedora for example it also depends on Firefox.

>> No.56226694

>>56226669
I've noticed some DEs install a terminal emulator, why?
>>56226682
gtk is a gnome project

>> No.56226701

>>56226608
Gnome-core is a metapackage.
It is designed to offer the user a standard Gnome Desktop with basic tools. One of the tools pretty much every user expects to find on an installed desktop system is Firefox.

If you want more control over what parts of Gnome you install, you can always do that seperately.

>> No.56226719

>>56226687
Try GNOME browser and either firefox or chromium

>>56226694
Nope, wrong. Probably just debian

>> No.56226722

I've noticed some DEs install a text editor, why?

>> No.56226738

>>56226722
Text editors are part of their respective DEs

Xfce has mousepad
MATE has pluma
GNOME has gedit
KDE has Kate

newfag

>> No.56226740

>>56226719
computer illiterate spotted

>> No.56226758

>>56226740
Fuck off

>> No.56226762
File: 1.05 MB, 1000x1000, 1435117195187.jpg [View same] [iqdb] [saucenao] [google] [report]
56226762

Just got a pi and it's a hassle to use because I need to move my monitor and kb to another room whenever I need to use it (no free outlets where my pc is)
How do I set it up so I can SSH into my pi from my windows pc? What security measures do I take?

>> No.56226796

>>56226762
https://wiki.archlinux.org/index.php/Secure_Shell#Server_usage

>> No.56226851
File: 36 KB, 419x460, file.png [View same] [iqdb] [saucenao] [google] [report]
56226851

P-pls help
http://pastebin.com/raw/wSX9avVW

>> No.56226873

>>56226660
That's not GNOME issue only, all gtk DEs have this problem.

>GNOME is a gtk project
Go complain about file picker to Xfce devs, retard

>> No.56226927

I just got dwm on archlinux but I have a problem. All commands work correctly, except alt+shift+enter doesn't open a terminal. I haven't even edited the config file at all, does anyone know what coud be wrong?

>> No.56226950

>>56226927
Install a DE like a normal person

>> No.56226995

>>56226873
gtk is a gnome project, retard

>> No.56227025

>>56226995
And filepicker issue is not a GNOME Desktop Environment issue only, idiot.
Go back to >>56226660 where you implied so

>> No.56227029
File: 3.87 MB, 3000x3000, 1452878885005.png [View same] [iqdb] [saucenao] [google] [report]
56227029

>>56226950
NORMIES GET OUT

>> No.56227047

>>56227029
Normies don't use Linux

>> No.56227057

>>56226927
Check out the config.h and change the terminal line to your preferred terminal emulator and recompile.

>> No.56227102

>>56226927
>unable to read the wiki or the manpage
typical arch user

>> No.56227162

>>56227102
>lol read manpage XDD
This thread would be extinct a long time ago

Manpages are memes that belongs to history books. No one wants to read hundred pages long man to do the think they want to do

>> No.56227201

>>56227102
The Seven Learning Styles
Visual (spatial):You prefer using pictures, images, and spatial understanding.
Aural (auditory-musical): You prefer using sound and music.
Verbal (linguistic): You prefer using words, both in speech and writing.
Physical (kinesthetic): You prefer using your body, hands and sense of touch.
Logical (mathematical): You prefer using logic, reasoning and systems.
Social (interpersonal): You prefer to learn in groups or with other people.
Solitary (intrapersonal): You prefer to work alone and use self-study.

>> No.56227230

What should I do if I want to install Fedora without a DE, and I want to set up a DM, WM etc. manually?

>> No.56227235

If it weren't for internet browsers, media players, and anything that requires a mouse, I would just live in the terminal.

Is that why OpenBox exists, and should I use it? I've always gone for XFCE because it has the best balance of minimalism and not looking like dogshit.

>> No.56227236

>>56227102
archbabbies btfo!

>> No.56227273

>>56227047
Android runs on Linux.

>> No.56227291

>>56226660
*4chan users that are too retarded to drag and drop from their regular FM are waiting

>> No.56227307

>>56227235
Vimperator, Cmus/Mplayer.
Openbox exists to work as a normal desktop, only with as few resources as possible. True Terminal warriors use i3, awesomewm, or xmonad

>> No.56227308

>>56225995
Not NEET level
Fedora

>> No.56227319

7 decides which distro I use for the next 6 months

>> No.56227342

>>56226306
>This is expected behaviour and doesn't pose a problem
The problem is being unable to easily uninstall loads of unnecessary packages. Let's say that I have none of the dependencies from the metapackage installed. I install the metapackage. I uninstall the metapackage. Why doesn't it remove everything?

In my research, I found that it has less to do with your "optional dependencies" explanation, and more to do with the fact that metapackage dependencies are marked as MANUALLY INSTALLED instead of automatically. This is why they have to be found and removed manually.

Who the fuck designed metapackages and thought this was a good idea? What would break if they were listed as auto-installed? Can someone please explain this bullshit garbage to me? I hope I'm just retarded.

>> No.56227347

>>56226927
You are probably not using st correct? Download the latest version of dwm from suckless via git, cd into the directory, cp config.def.h config.h, nano config.h, change everything to your liking and make sure it uses your default terminal emulator instead of st, if not, make it use it, save, recompile and package (I have no idea how to package in arch, I usually just checkinstall)

>> No.56227352

What's a good beginner distro that isn't Ubuntu?
I'm going to replace my friend's distro with another since Ubuntu's only skin-deep functionality slows down our uni work

>> No.56227362

>>56227162
Dude that answered the question again. Suckless manpages are short, easy to understand and make sense. You should read them sometime and git gud.

>> No.56227373

>>56227352
>Ubuntu's only skin-deep functionality slows down our uni work
What does this mean? Can you be more specific about what was wrong with Ubuntu? It would help to give you a better suggestion.

>> No.56227380

>>56227235
If you love the terminal, play with w3m. It can also display images and you can use scripts to play videos from it with mpv. (Or use a urxvt url opener script).

>> No.56227390

>>56227352
You're either trying to use a modern DE without having the hardware-power or you're fucking up the system

>> No.56227393

>>56227373

shit broke all the time, surprisingly

>> No.56227425

>>56227342
You manually installed the meta-package so it does make sense to mark the actual packages as manually installed.
That you can't uninstall them the same way though is pretty annoying.

>> No.56227426

>>56227102
>>56227162
to be quite honest, manpages are usually unreadable unless you already know how the program works and just need to look up what the options and config files are called.

I refer interested readers to man sudoers

>> No.56227427

>>56227342
And to make it worse literally no -meta flags in ANY meta packages. The fuck is this retarded repo?

>> No.56227456

How come new releases of Fedora always have vm-linuz crashes? It gets fixed with updates but then they never update the iso to include the fix. It looks unprofessional to have an error in the live cd.

>> No.56227486

>>56227236
>Samefagging
Debibabbys are pretty cute when they get cornered

>APT too dumb to remove orphaned packages
>"Who needs GNOME"
>"lol read the man, not like I read them myself :-DDDD"
>"y does DE's text editor come with DE"
>"u can remove them one by one"
Quite hilarious

>> No.56227488

>>56227456
Fedora is unprofessional

>> No.56227516

>>56227373
Oh. Well if that's the case, then Debian is Ubuntu without the extra bullshit. It's well-known for being stable and reliable. It takes a little extra doing to install/set-up, but imo it's worth it for the stability and FOSS-philosophy.

If the extra set-up sounds unappealing, then Fedora, OpenSUSE, or Manjaro are probably what you want.

>> No.56227519

>>56227486
Oh I forgot
>"Extra file manager, contacts manager, window manager, power manager and a control center wouldn't hurt as much :D"

>> No.56227527

>>56227342
The metapackage acts as a placeholder for all packages it depends on.

Telling apt "I want this metapackage" is the same as telling it "I want all these packages".

Setting them all as manually installed has the advantage that you can then remove one of them seperately (which will remove the meta-package as well), without losing them all.

It's just a decision of the Debian team, which assumes people will more often want to easily remove one component of a DE, than uninstalling an entire DE (which you can still do pretty easily. The list of packages it holds is readily available).

>> No.56227529

>>56227516 was meant for >>56227393

>> No.56227535

>>56227486
>>56227519
triggered archbabby in his element.

>> No.56227538

>>56227527
>Telling apt "I want this metapackage" is the same as telling it "I want all these packages".
But why can't you tell apt "I want this software suite removed"?

>> No.56227546

>>56227538
You can

>> No.56227558
File: 232 KB, 1600x1200, 1471968056244.jpg [View same] [iqdb] [saucenao] [google] [report]
56227558

>>56227535
Cry some more, pajeet

>> No.56227573

>>56227546
How can I remove gnome-core suit?

>> No.56227580

>>56227538
It's a limitation of Apt, to be honest.
The fact that Apt is 25 years old shows sometimes.
Metapackages themselves are a crutch designed to make this old software work with huge modern systems.

>> No.56227590

>>56227558
>>>/pol/ go back

>> No.56227646

>>56227558
i live to trigger archkiddies like you m8

>> No.56227648

Do I use apt or apt-get?

>> No.56227650

>>56227352
fedora i guess

>> No.56227659

>>56227646
Shut it down

>> No.56227664

>>56227590
>pajeet is a /pol/ meme
back to reddít you go

>> No.56227668

>>56227573
You don't have it installed.

>> No.56227670

>>56227362
If you type man dwm the only thing it tells you are the commands. It gives no information on how to fix this problem.

>> No.56227675

>>56227648
None. Both are the dumbest package manager I'v seen.

I like Dnf and Pacman. Portage is very good but a bit slow.

>> No.56227682

>>56227668
No, right after I installed the package, how do I remove it?

>> No.56227684
File: 17 KB, 500x334, 1453223695199.jpg [View same] [iqdb] [saucenao] [google] [report]
56227684

>>56222237
>>If you've finally realized that Linux is shit:
You were doing so good until that.

>> No.56227685

>>56227648
apt is the newer tool (it unifies the old apt, apt-get and apt-cache), it has pretty colors and shit but it's still missing some apt-get features I believe. If you're only installing and removing packages it doesn't really matter.

>> No.56227721
File: 236 KB, 1600x1200, 1471953979811.jpg [View same] [iqdb] [saucenao] [google] [report]
56227721

>>56227646
1.5 rupees and a list of male programmers' privilage checklist have been dispatched to your address, rakesh. Murcock is now rolling in his grave

>> No.56227735

Alright I'm done trolling with >>56222237 but the question still stands: should there even be a list similar to that one? I guess that would depend on if you clowns were willing to drop the namecalling for at least one thread so a list can get composed

>> No.56227752

>>56227735
/g/ has had a flowchart for choosing own distro.

But people mostly use Arch and Ubuntu anyway.

>> No.56227763

>>56227735
>I guess that would depend on if you clowns were willing to drop the namecalling for at least one thread so a list can get composed

It seems like half of the people in these threads are only here to try to feel superior to internet strangers like this >>56227721 retard here because they use X distribution or X program.

>> No.56227776
File: 493 KB, 3000x1568, jy1BF.png [View same] [iqdb] [saucenao] [google] [report]
56227776

>>56227752
yea, I guess we do have this

>> No.56227810

>>56227763
>It seems like half of the people in these threads are only here to try to feel superior
Of course I feel superior to subuman trash such as >>56227646

>> No.56227882

>>56227664
If not then tell me how racism is in any way tech related.

>> No.56227891

>>56227648
I prefer aptitude personally

>> No.56227911

>>56227670
That's why I gave you another answer as well. Reading the config file is always a good idea with such minimal programs. Have fun with dwm, it's really nice.

>> No.56227914

>>56227882
>>56227590
this guy gets it.
nice to see not everyone on /g/ is underage

>> No.56227925

>>56227891
Read the manpage of apt. aptitude is useless bloat for people who don't know it better.

>> No.56227929

>>56227914
>i live to trigger archkiddies like you m8
>""grown up""
Must be a manchild then

>> No.56227932

>>56227882
>>56227914
>this meme is racist so it must've come from /pol/
Do you really need an explanation on 'pajeet'

>> No.56227991

>>56227047
We don't live in the 2000's anymore.

>>56227307
Include ratpoison.

>> No.56228005

>>56227932
It's stupid in it's essence. Fist "poo in loo" was referring to "pajeet" windows marketers (for whatever reason), now everyone calls people with other opinions streetshitters. What the hell. Insult the targets. If you hate Debian users, insult Debian users, but don't bring completly unrelated racism with it.

>> No.56228035

>>56228005
never said I support it, just that it's also not correct to tell someone to go to /pol/ if they call others pajeets, something whole /g/ has been spammed with just a few months ago

>> No.56228077

>>56227925
I have been using both of them, I formed my opinion over an extended amount of time. I prefer aptitude because it is better at resolving dependencies, the search is better by default, it is easier to manage bigger amounts of software (thanks ncurses).
If you only use something like stable or some buntu with no need for specialized software apt-get is great and all but if you like to create stuff, use sid and play around with software a lot aptitude will come in handy after some time. Just never ever mix them up on one install.

>> No.56228089
File: 5 KB, 282x265, 1471921620074.png [View same] [iqdb] [saucenao] [google] [report]
56228089

>>56219791
your png is now optimized

>> No.56228090

>This thread
That's it,no more ubuntu/debian. Installing Korora tomorrow

>> No.56228123
File: 8 KB, 217x223, 1448123845068.jpg [View same] [iqdb] [saucenao] [google] [report]
56228123

>>56228090
>gnome

>> No.56228135

>>56228123
https://kororaproject.org/discover/cinnamon

>> No.56228147

>>56226002
>md5sum validation failed

Your computer now has aids anon.
Remember always use condom

>> No.56228201

>>56228090
Compared to the arch people here they seem to be quite helpful and knowledge on average in this thread.

>> No.56228210

>>56228201
/g/ doesn't have distro flags

>> No.56228234

>>56228147
I cant install debian. Installation precess keep failing. Why everyone is recommending it?

>> No.56228244

>>56228210
That is a fucking awesome idea. Does /q/ still work?

>> No.56228265

>>56228244
It's not a good idea

>> No.56228269

>>56228234
Which iso did you use, what is the error, what did you use to put it on your usb mass storage device? Did you read the installation guide.

>> No.56228280

>>56226002
What the hell are you installing?
https://www.archlinux.org/packages/extra/any/noto-fonts/

>> No.56228290

>>56228244
>That is a fucking awesome idea
yea, if this were reddít

>> No.56228292

>>56228265
no not a good idea, it's actually a great idea

>> No.56228319

>>56228292
What's next, usernames so you can identify everyone even better?

>> No.56228328

Just go balls deep and installed devuan,looks great for now and is without systemd

>> No.56228337

>>56228328
Nice blog

>> No.56228444

>>56228292
It's complete cancer. People will reply to the distro icon, not the post itself.

>> No.56228533

>arch
https://www.youtube.com/watch?v=flmX9GYwyiI

>> No.56228534

>>56227682
>right after I installed the package, how do I remove it?
This works with any metapackage:
sudo apt-get remove `apt-cache depends gnome-core | cut -f 2 -d ':' | tr '\n' ' '`
Literally took less than a minute to search "uninstall gnome-core" and find this.

>> No.56228586

>>56228534
What the fuck. Read the manpage faggot.
>what is autoremove

>> No.56228605

okay honestly, is there a point to the AUR other than dependency resolving?
I don't see why you wouldn't just download the source yourself and compile it, it's not like it's hard to do

>> No.56228617

>>56228605
Easier upgrades

>> No.56228622
File: 660 KB, 1280x720, sad.png [View same] [iqdb] [saucenao] [google] [report]
56228622

When I write something in emacs, and then open it up in another editor/IDE the tab spacing doesn't carry over.
Is this normal? Or is there some setting I need to turn on?

>> No.56228626

What's a good lightweight distro for my notebook? I only have 2gb of ram, but my screen is 1080p on 14' so scaling would be good. I'm currently running Xubuntu on it

>> No.56228662

are there any idiot proof tools for extending an existing filesystem?
I'm afraid of fucking up my Linux partition

>> No.56228665

>>56228626
debian

>> No.56228679

>>56228622
Use a monospace font for all editors.

>> No.56228688

>>56219791

I installed Nvidia drivers before using the run file from their website. A few people told me that was a bad way to install the drivers. So I did it the way specified on Debian's website.

But doing it this way doesn't work without setting nomodeset in my grub file. I am using Debian 8 Jessie. Should I just ignore what Debian has on the webpage and do it and manual way again?

>> No.56228689

>>56228622
wake up
spaces > tabs

>> No.56228713

>>56228688
If you think you know better what you do than the Debian maintainers, sure, go ahead.

>> No.56228748

>>56228586
Maybe you should read the thread. We were talking about metapackages like gnome-core (and most DEs), and how you can't uninstall all its dependencies by simply using "apt-get remove gnome-core && apt-get autoremove". What happens is that the metapackage is the only thing removed, because all its dependencies are marked as *manually installed*.

The command I provided will reliably remove all the dependencies of any metapackage.

>>56228689
Tabs have variable width, which can be good and bad. Spaces have a static width, which can be good and bad. Obviously it doesn't matter whether you use tabs or spaces as long as there's consistency within a project.

>> No.56228774

>>56228622
a tab is simply a character in the text file.
it's up to your text editior/viewer to display that tab.
the tab width you set in emacs may differ from the tab width you set in vi or gedit or nano.

I can recommend setting your editor to put some spaces instead of tabs, those will carry over to any other monospace text font very well and lots of projects actually ask of you to use 2, 3 or 4 spaces usually instead of tab characters.

>> No.56228834

>>56228713

Not going to take that chance. Any idea of way it hangs on boot? I do the steps for the driver, reboot and it just hangs on a black screen unless I enable nomodeset in grub.

>> No.56228855

Am I the only one who had never problems with installing and removing packages via apt? I don't get all these "dependencies hell" and "just use aptitude" memes. apt works flawlessly since 4 years on my Debian testing machine.

>> No.56228896

>>56228855
it's just archfags trying hard
>>56228748
you should re-read the manpage

>> No.56228908

>>56228855
I had problems with one particular package, which coincidentally has the same developer of another commonly hated program.

>> No.56228978
File: 49 KB, 1021x577, s.png [View same] [iqdb] [saucenao] [google] [report]
56228978

>>56228679
>>56228774
>>56228689

What is monospace? Also, I don't set the tabs in Emacs, it auto indents everything.
Pic related is what I'm talking about. The default text editor looks sloppy, but perhaps that's because of how my settings are in the default text editor?

>> No.56228992

>>56228855
>Am I the only one who had never problems with installing and removing packages via apt?
No one mentioned anything about apt being dependency hell. The entire controversy was over metapackages and how you can't uninstall all their dependencies automatically. It was pretty much explained/resolved by these posts: >>56226352
>>56227527
>>56228534

>>56228896
>you should re-read the manpage
I reference it often, and just read the part on autoremove. Yes, it "is used to remove packages that were automatically installed" but the problem is that gnome-core installs all its dependencies MANUALLY. So you can't use autoremove to remove them.

>> No.56228998

>>56228855
I guess it's mostly PPA related. If you install something from a PPA that upgrades a lib, and try to install another package that depends on the older version, it results in problems. The difference is that aptitude tells you why it went wrong and apt just tells you that it went wrong. Basically beginner problems (and IMHO not related to a specific distro, AUR can cause simliar problems)

>> No.56229007

>>56228834
Is there a problem with nomodeset?

>> No.56229028

Y'all should install gentoo. Based portage is a package manager y'all are dreaming of.

>> No.56229042

>>56229028
but I'm scared of configuring proprietary firmware

>> No.56229043

>>56228998
does debian even have ppas? isnt that a noobuntu thing?

>> No.56229064

>>56229042
Portage can filter by license, so you make it completly freetard friendly if you want.

>> No.56229076

-----------------------------------------------------------------------------------------------------------------> >>56229044

>> No.56229081

>>56229043
You can add 3rd party repos, which is just like ppas but without being called ppas

>> No.56229089
File: 9 KB, 640x400, 1456458924661.png [View same] [iqdb] [saucenao] [google] [report]
56229089

>>56229028

>> No.56229106

>>56229007
A while back when I was using Ubuntu, a lot of people said it was a bad a way of installing nvidia drivers.

But I figured it out, apparently the nouveau driver wasn't being blacklist and it was conflicting with the Nvidia driver.

>> No.56229107

>>56225895
>debian based
Devuan

>> No.56229117

>>56229089
Where would the problem be?

>> No.56229128

>>56225895
Whatever they want

>> No.56229165

>>56226762
Get a powerbrick

>> No.56229437

Can I include/exclude certain elements with the dnf remove function?

I just want to remove thunar, not xfdesktop!

I suppose I can always install xfdesktop again and heck it could give me a reason to try out i3 within xfce.

>> No.56229564
File: 51 KB, 800x533, 1379139326394.jpg [View same] [iqdb] [saucenao] [google] [report]
56229564

>>56225993
>qbitorrent

>> No.56231109

>>56229564
Grapes are sour

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action