Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 165 KB, 421x389, stallman ugh.jpg [View same] [iqdb] [saucenao] [google] [report]
53925550 No.53925550 [Reply] [Original] [archived.moe] [rbt]

"WHAT DID I JUST DO"-Edition

Previous Thread: >>53918771

Welcome to /fg/lt/, or as I've recently taken to calling it, /fg+lt/. We are always open to users of all levels, including absolute beginners.

There are four ways to try GNU/Linux, you can:

0) Install a GNU/Linux OS on a VM (Virtual Machine/VirtualBox) for "safety purposes"
1) Use the Live ISO directly without installing anything, that way, you can get a "full GNU/Linux experience".
2) Dual-boot GNU/Linux with Windows/Mac (recommended if you want to learn more about GNU/Linux)
3) Go balls deep and overwrite everything with GNU/Linux

Before asking, please search for answers to your questions in resources.

Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread.

Understand that much of your software from Windows will be unavailable, although maybe WINE can make up for it.

IRC connection details:
Server: chat.freenode.net:6667 (no SSL, 6697 for SSL)
Channel: #flt
If you don't have an IRC client (which you should), go to https://webchat.freenode.net/ to join the webchat.
Do not tick "auth to services" (as you probably don't have a freenode account), choose a nickname, and type "#flt" as the channel.
Google captcha, click "connect", all that.

Resources:
man <insert command here>
Your friendly neighborhood search engine (searx.me, ixquick, whatever)
https://wiki.archlinux.org/ (Most of the configurations and troubleshoots will work on various distros, including Debian)
https://wiki.installgentoo.com/index.php/Category:GNU/Linux
http://linuxcommand.org/tlcl.php

>> No.53925678

>>53925649
Try pinging something, like

ping -c 5 google.com

>> No.53925679

>>53925550
What happens when he dies /flt/?

>> No.53925696

>>53925679
The GPL will remain. And Eben Moglen will take over. Or someone else. Stallman is merely a spiritus rector of the FSF, the day to day business is done by others

>> No.53925702

>>53925679
We continue his legacy.

>> No.53925721
File: 68 KB, 700x700, 1432259490310.jpg [View same] [iqdb] [saucenao] [google] [report]
53925721

>>53925678
>Temporary failure in name resolution

I'm fucking crying RN

How the fuck does everything go THIS badly????

>> No.53925746

>>53925721
ping 8.8.8.8

>> No.53925751

>>53925721
Why'd you fall for the debian stability meme.

>> No.53925753

>>53925721
Obviously Debian stable uses a different system-d version and all than Debian Testing. However, at this point the best thing you can do is raze it all and start anew. If you have any data that needs backing up, back it up somewhere, then reinstall your shit.
And learn from your mistakes.

>> No.53925813

>>53925751
This. Debian is garbage, and I used it for a decade.

>> No.53925815

>>53925751
>>>53925721 (You)
>Why'd you fall for the debian stability meme.

No fucking clue.

Debian Stable was working PERFECTLY. I had no complaints at all. But packages were a little old and some trolls were saying how stable is shit and to use testing/unstable.

Fuck.

>>53925753
>Learn from your mistakes

I DONT KNOW WHAT MISTAKES I MADE OTHER THAN CHANGING "JESSIE" TO "STRETCH" IN SOURCES. LIST AND THEN DOING sudo apt-get update && sudo apt-get dist-upgrade

Jesus Christ.

Is there some way to back up a list of the packages I had so I can get my shit back to normal as soon as possible?

>> No.53925826

Why is everyone trying to do this idiotic "I install Debian stable and then switch all my repos to testing". Is there some popular YouTube video / Gawker article that says: "This is the best shit ever!!! xD".

If you go that route anyways just use Arch or some pre-configured installation of Arch: Antergos or whatever it is called. Then you have your testing packages and it seems to be less error-prone.

>> No.53925830

you guys have a local lug you go to?

been thinking of looking for mine after going to a linux expo and having a blast

>> No.53925831

>>53925815
Debian is server software senpai.

>> No.53925859

>>53925826
It was advice from people in /flt/, ffs.

>>53925831
Then what the hell do I use that isn't a meme?

I don't even understand what went wrong. It just all somehow broke over nothing, honestly I'm confused as to how my Ethernet firmware isn't even working right now.

>> No.53925864

>>53925859
>Then what the hell do I use that isn't a meme?
Everything is some kind of meme. But honestly just use Ubuntu without Unity or Arch. I guess Fedora isn't too bad.

>> No.53925872

>>53925859
Sorry man, I don't mean to make a bad situation worse. If I knew a bit more about Debian I could probably tell you, but it seems like the upgrade of the operating system failed somehow -- some upgrading of packages failed majorly and fucked up your system. I assume this would happen to others attempting this too, so I don't think you are alone in this.

Personally I really like Arch Linux, but it's connected with more setting up at the beginning.

>> No.53925886

Fedora has SELINUX enabled.

Is the NSA living in my PC now?

>> No.53925907

>>53925886
https://github.com/torvalds/linux/tree/master/security/selinux

You can read the source included in the kernel if you want.

>> No.53925916

>>53925826
I did that back in the day when I started using Lincucks because I liked to live on the wild side.
Nowadays that I actually have a job, I just use Xubuntu or Ubanto Gnome or most recently Ubuntu Cinnamon.
Just works, has the most software support, you dont have to fear shit breaks unless your computer is too new and there aint drivers out for it yet.
OpenSuSe, Fedora, Ubuntu, PCLinuxOS, Mageia, all good.

>> No.53925917

>>53925864
I just want an explanation as to what happened at least. I don't get it man.

>>53925872
But is it really that easy to fuck up? I was under the impression that I would need some manual input to actually fuck it up this much

Arch seems a little too autistic for me, what other good suggestions are there? Opensuse seems popular desu

>> No.53925944

>>53925907
I guess it would make sense that the NSA would want to make Linux more secure, since they use it for their own computing. Putting a backdoor that could possibly be exploited by black hats or enemy agents would be a bad thing for them too.

>> No.53925947

>>53925916
Jesus.

I was a loyal little Debian cuck all this time, I was enjoying it so much... Then it just all goes to fucking hell.

>> No.53925953

>>53925550
How the fuck do I get Xorg server set up on VirtualBox?
No matter what I do, no matter which drivers I install it or even if I have VB Guest additions installed it always returns error and never allows me to start the X server
Arch Linux first timer here.

>> No.53925960

>>53925917
Fedora is pretty good and up to date, while remaining on a fixed release. Breakage is low while still having pretty new software. They even update the kernel during the release instead of waiting like everyone else does.

>> No.53925968

>>53925917
Debian seems to be this easy to fuck up at least. What happened shouldn't really happen -- you basically just told your system to use newer packages. But the repos are called testing for a reason, so it might be that there was a bad package and your system just vomitted.

>> No.53925970
File: 10 KB, 225x225, 1.jpg [View same] [iqdb] [saucenao] [google] [report]
53925970

>>53925944
That's assuming they haven't made their own Linux kernel derivative. :^)

>> No.53925986
File: 285 KB, 1600x900, 1451116280563.jpg [View same] [iqdb] [saucenao] [google] [report]
53925986

>>53925916
>have a job
I workd 40 hours a week in a shitty retail job,and still manage to do 'pacman -Syyu' once a week

>> No.53925992

>>53925953
Install xorg-server and choose libgl-mesa when it prompts you. After that install linux-headers base-devel and then virtualbox-guest-utils.

Do not enable 3D Acceleration if you plan on using KDE Plasma -- it breaks.

>> No.53926000

What have you installed?
sudo pacman -S xorg-server xorg-xinit

>> No.53926006

>>53925992
I already did all of that, it still breaks.

>> No.53926020

>>53926006
Define break. Are you sure that you installed base-devel and linux-headers FIRST, and then attempted to install virtualbox-guest-utils? Make sure and reinstall virtualbox-guest-utils and virtualbox-guest-dkms.

>> No.53926021

>>53926000 was made for >>53925953.

>> No.53926026

>>53925916
>>53925986
>not having a cronjob set up

what a bunch a cuckoos

>> No.53926039
File: 954 KB, 1296x968, 1458860891936edited.jpg [View same] [iqdb] [saucenao] [google] [report]
53926039

>> No.53926043

>>53926026
>blindly installing packages

>> No.53926057

>>53926043
Yeah I mean, I am all for using yaourt etc. but I still wouldn't blindly run a cronjob that updates all my packages -- that sounds like a recipe for disaster.

>> No.53926060

>>53925947
Debian is good if you know what you are doing. Like: Not upgrading retardedly.

Also there is nothing wrong with any of the *buntus, or Mint. Just use them instead of GNU/Linux: Old and Outdated Version

>>53925986
My job requires me to have working computer 24/7 (I'm a translator). Ubanto LTS fills that need pretty well. My files get rsynced to two separate NAS every hour, and I have a few more thinkpads that serve as backup if my desktop should break somehow so I can access files and go on working.

>>53926026
cronjob for what? breaking your system?

>> No.53926061

>>53926043
yeah that's pretty stupid. that's why i update my installed packages blindly instead.

go back to work wagecuck

>> No.53926071

>>53926020
I'll try that, even though attempting to install linux-headers returns some weird messages but it still installs successfully.
Thanks.

>> No.53926078

>>53925960
>>53925968
So retarded...

I just don't get it. How do people use this shit when it breaks so easily over seemingly nothing?

>>53926060
But how did I do it retardedly?

Please explain for next time guys.

Also I think I'm going to go with Antegros, it looks cool desu

>> No.53926081

>>53926057
>yaourt
God damn disgusting. Why is that derivative even popular.

>> No.53926088

>>53926071
When you reinstall -dkms it should stop for a bit and compile. It should take around 30 seconds to a minute or so -- if that happens, then the thing happened that I wanted to happen. Try the xorg stuff after that.

>> No.53926096

>>53926078
>Also I think I'm going to go with Antegros, it looks cool desu
Imo if you want to use an Arch based distro just use Arch or you're asking for trouble.

>> No.53926100

>>53926081
Because direct installation from AUR. Suggest me something better, and dont fucking link me that Wikipedia page. Tell me what YOU are using and why.

And no I don't want to run wget/curl makepkg -si manually, mam.

>> No.53926128

>>53926100
pacaur

See table for why, https://wiki.archlinux.org/index.php/AUR_helpers#Comparison_table

Don't complain about a wiki link in this case, just look at the table.

>> No.53926129

>>53926096
Tbh I might just reinstall debian stable after backing up my home folder.

It was outdated but worked flawlessly ;-;

I'll just use backports next time I guess.

>> No.53926130

>>53926078
You installed one system and then enabled packages that are marked testing -- UNSTABLE packages. Then you tried to update your whole distribution at once with these unstable packages.

That's what happened, it's just a bad idea. We can't diagnose what exactly went wrong.

>> No.53926146

>>53926128
Alright, thank you. What about bauerbill, did you try that too?

>> No.53926152

>>53926061
douchebag-2.6.2-1
UPDATE
douchebag-2.7.1.0-2

You're still installing

>> No.53926157

>>53926130
The funny part is those unstable packages are way older than all the other distros. Debian is just incompetent.

>> No.53926184

>>53926157
Why is Debian such a meme?

>> No.53926199

>>53926100
>Better
>pacaur<
apacman
packer
cower

>bauerbill
Dont use it.Xyne likes to take long breaks of not updating anything,and when he comes back,he has to completly do a rewrite of everything

>> No.53926204

>>53926078
You just the major version if a whole bunch of packages, they are all dealing with your old config files and crust. Crying and throwing everything out is a very poor response to this. Figure what is wrong and fix it you fucking user

>> No.53926227

>>53925550
What programs should I test out Ubuntu to see if it works for me?

>> No.53926231

>>53926129
If you are reinstalling just go with testing out unstable. It was likely the upgrade from an old system that broke it.

>> No.53926248

>>53926204
I don't know where to get started, I've never dealt with this before.

Why don't you help me then smartypants?

>> No.53926250

I'm trying to install Wallabag.

Composer works for five-ten minutes and then dies with OOM. I have around 300 MB of RAM free. I mean, really? What for does it need 10x times more ram than the whole project?

>> No.53926262

>>53926157
> did something he doesn't understand
> didn't even try to figure out what went wrong
Incompetent

>> No.53926284

>>53926248
Have you even said what is wrong apart from "it broke"?

>> No.53926290

>>53926146
Can't say I did.

>> No.53926304
File: 101 KB, 660x457, Screenshot at 2016-04-07 19:13:44.png [View same] [iqdb] [saucenao] [google] [report]
53926304

Just installed Linux Mint on my T520. How do I get wifi working?

I believe I have the correct driver but nothing shows up in the driver manager or in network connections menu.

>> No.53926308

>>53926146
It's in python and probably isn't pacman-like like pacaur is though.

>> No.53926316

>>53926284
Yes I have.

I tried to update to testing and then rebooted and xserver was broken.

Then I tried to purge my graphics driver because I read it on some website and now my Ethernet firmware is somehow broken

>> No.53926320

>>53926304
it should just werk. what card do you have?

>> No.53926321

>>53926146
see >>53926199

>> No.53926322

>>53926290
I think people are not using pacaur because it makes itself unpopular. "Don't use me if you aren't a makepkg guru!" basically -- while yaourt just tells you "Yeah you can use me to install packages from the AUR directly". Also when I attempted to install the AUR version of pacaur I got GPG signature error.

I'll be honest, I don't immediately know what that is about but I might look into it.

>> No.53926325

I bought this laptop when I was younger and stupider:
http://www.newegg.com/Product/Product.aspx?Item=N82E16834231631

It actually runs Ubuntu pretty well, but I can't get the fans to run properly and it hangs on the desktop when I call shutdown.

Anyone had similar problems and/or been able to solve them?

>> No.53926334

>>53926321
Noted, thanks love.

>> No.53926348

I can't be fucked to do another Arch install and Antergos fails on boot. What's another good arch-based distro that isn't too autistic?

>> No.53926358

how bad/good its solus? its look really nice but i have no idea on the tech side

>> No.53926360

>>53926348
There is none, since you've already done it you should know installing arch takes 5 minutes tops. Especially since your partitioning is already done.

>> No.53926362

>>53926348
Why are you calling every Arch derivate autistic? Maybe try Manjaro.

>> No.53926382

>>53926362
>Maybe try Manjaro.
And have more issues and come here whining about them?

>> No.53926389

>>53926360
Well I did it before over Ethernet but never successfully over WiFi which is what I have to do now.

>>53926362
I just want to avoid going down the obscure distro rabbit hole without giving up the AUR

>> No.53926392

>>53926316
So apt search radeon for installing graphics drivers. It looks like the xserver module has dropped the hd from the end of the name.

>> No.53926408

when i installed kernel 4.6 rc2 on my desktop pc, it wont shut down the computer all the way, or restart it, when i trigger it through CLI or GUI. It gives a DENIED error message of some sort on the command line, at the end of the normal boot messages. wat?

>> No.53926419

>>53926389
Then use Arch ffs.

>> No.53926429

>>53926408
>installing unstable kernels
yeah... how did you think this was a good idea, expecting a worryfree system?

>> No.53926436

>>53926392
I did that but it's useless for me because my Ethernet won't work.

Any ideas on diagnosing and fixing it? Not sure how it broke.

>> No.53926437

>>53926408
Maybe downgrade the kernel again or simply deal with it. At this stage your filesystem probably won't be corrupted when you forcefully shut it off.

>> No.53926453

>>53926316
What are the actuall error messages? If you are still interested in fixing it. There will probably be some info in the /var/log/Xorg.0.log about missing modules or some crap. And for the firmware try searching apt for the nic manufacturer and install firmware-<manufacture> and maybe firmware-linux-nonfree

>> No.53926463

>>53926389
Use arch like the cuck yo uare or install a real man's workstation distro.

>> No.53926467

>>53926320
Uhh. Idk. I just ran lspci -vq but I don't see anything that says wifi card.

>> No.53926470

>>53926348
Why don't you use antegeos?

It's better then manjaro. It's just arch with an installer that makes no sense not to be automated.

>> No.53926482

Is How Linux Works by Brian Ward a good book to read?

>> No.53926483

>>53926470
Antergos is more than just an installer wrapper, that's architect.

>> No.53926486

>>53926467
huh, that shows mine on my t420.

>> No.53926497

>>53926453
On boot it said I'm missing module microcode from modules.dep

But the problem is now I have no internet connectivity. How fix it, familia?

>> No.53926520

>>53926483
In what way? It uses Arch repos, etc

>> No.53926543

>>53926470
I tried it today and it just errors out after installing.

>> No.53926550

>>53926543
It errors out -- well that is helpful.

>> No.53926557

>>53926497
>microcode
Dunno about that module, or if required.

Run ip link and see if eth0 is listed there. If so you do have firmware and just need to set your network up. If not you need to grab the .deb from eg packages.debian.org via some other method and install with dpkg -i

>> No.53926581

>>53926520
>Antergos started life under the name of Cinnarch, combining the Cinnamon desktop with the Arch Linux distribution, but the project has moved on from its original goals and now offers a choice of several desktops, including: KDE, GNOME 3 (default), MATE, Cinnamon, Openbox and Xfce.

>> No.53926607

>>53926581
Yes and?

So it's arch basically with easier installation and setup.

>> No.53926621

>>53926557
Thanks bro. I really do want to fix this I just didnt know where to start so I needed a familia to help me.

>> No.53926653

>>53926550
It tells me there may be a boot loader installer problem after the installation finishes. Then after rebooting, it just gives me a blank CLI

>> No.53926673

>>53926557
Eth0 is listed.

But it is not werk

>> No.53926743

>>53926673
Well you probably have network manager or whatever new systemd hawtness installed and I don't know about them. But try sudo ip link set eth0 up and sudo dhclient -v eth0 and see what that spits out at you.

>> No.53926748

Why are debianfags such flamboyant SJWs?

https://www.youtube.com/watch?v=ILLHVCHN4f8

>> No.53926800

>>53926743
Werkes now.

Ok now what for the problem at hand?

>> No.53926849

>>53926743
I opened xorg.0.log

I see it says fglrx module not found, no drivers available and no screens found

>> No.53926858

>>53926800
What does /var/log/Xorg.0.log complain about?

>> No.53926872

>>53926858
Above.

But when I try to install fglrx it says the package is not available BUT is referred yo by another package.

>> No.53926890

>>53926872
FGLRX is no longe rbeing developed, besides it was shit anyway and inferior to the free drivers.

>> No.53926919

>>53926890
Then wut do? It worked much better for me than the free memedrivers.

It's what that log file complains about, anyway.

And I'm guessing I need to somehow fix the reference to it

>> No.53926940

>>53926250
i know that feeling.

had it awhile back but nuked the server.

after i tried to set it up again, didn't manage to get it done. i'll try again and see if it works then.

>> No.53926972

>>53926872
Make sure you have the non-free and contrib components (along side main) installed in /etc/apt/sources.list and run apt update then apt install linux-headers-`uname -r` fglrx-driver

>> No.53927037

>>53926972
Package fglrx-driver is not available but is referred to by an other package.

This may mean that the package is missing, has been obsoleted or is only available from another source.

E: Package fglrx-driver has no installation candidate

>> No.53927052

>>53926748
because they majored in computer information systems, which requires no real skill or intelligence

>> No.53927071

>>53927037
can't you just apt search it?

why are you just pasting this shit on your terminal

>> No.53927107

>>53927071
What do you mean? It's not letting me install it.

>> No.53927177

>>53927107
i'm saying search for the fucking term and get the right name so your fucking machine can fucking install it instead of it saying X is not available.

but chances are you did it wrong and didn't even add the 'non-free' to your repos. do a cat /etc/apt/sources.list

>> No.53927180

>>53927037
>>53927037
You need to open up /etc/apt/sources.list and add contrib and non-free on the line that starts with deb and ends with main then apt update.

>> No.53927212

>>53927177
>>53927180
Nope I have those added.

I did apt search but it says (none) under it, not sure what that means.

>> No.53927262

>>53927212
Oh my bad, mine was pointing to an old snapshot repo. Err, don't really know about non nvidia stuff but https://wiki.debian.org/AtiHowTo says to apt-get install firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati then reboot *shrugs*

>> No.53927294

>>53927262
>>53927262
I already have those...

>> No.53927305

>>53927262
odviously there should be a i at the end of that code block for *-ati

>> No.53927329

>>53927294
Well then your /etc/X11/xorg.conf is wrong and still pointing to the old fglrx drivers. Try ... renaming it and see if Xorg can autodetect

>> No.53927378

>>53927329
Ok did that, no dice desu.

>> No.53927390

I'm taking a TestOut course teaching Linux for beginners and decided to record their videos for later use. When I'm done, would they be useful for these generals?

>> No.53927421

Earlier I had friends over and we watched movies on my computer, so I unplugged my headset and plugged in my speakers. Now when I go to plug my headphones in, the sound works, but the microphone isn't capturing anything.

What am I doing wrong?

Arch, Cinnamon and Alsa aren't reporting anything wrong and the microphone was working earlier today, so I doubt it's a hardware problem, what do?

>> No.53927433

>>53927390
Where are you going to post them?

>> No.53927478

>>53927329
Please reply... What is the next step

>> No.53927488

>>53927433
YouTube channel is off limits, I know for a fact it'll go down harder than a sack of rocks. DropBox also may be taken down. MEGA? Though people don't like to download videos anymore right? Any suggestions where I can upload them to, without much worry about them being taken down any time soon?

>> No.53927526

>>53927478
You're hopeless, just install ubuntu.

>> No.53927538

>>53927526
;-; don't give up on me family

>> No.53927545

>>53927478
Is it still giving the same error about no fglrx driver? Because I don't know why it would be looking for that except from xorg.conf

>> No.53927547

>>53927488
I'd definitely be interested in taking a look at these if and when you provide them. I don't think MegaUpload is exactly out of the question, but who knows?

>> No.53927561

>>53927547
>>53927488
Also, I meant Mega.nz, not MegaUpload.

>> No.53927656

>>53927545
Yep. Same shit.

This time though it's saying the same thing but with xserver-xorg-video-ati which I changed it to.

>> No.53927685

>>53927656
I meant rename the whole file, as in move it away, so that it isn't there when Xorg starts up and it has to figure shit out on its own. Also the driver isn't called xserver-... that package apparantly install the right one for you. Maybe radeon?

>> No.53927735

>>53927685
Now it's complaining it's not matching the config file(I deleted it)

>> No.53927774

Why can't I play something with an audio on two things at the same time on arch. For example I can't have sound from two different videos on two different browser tabs, or play from URL on mpv and watch video from browser. With Windows I can watch and have sound on all videos simultaneously.

>> No.53927817

>>53927774
if you using arch then you should easily be able to find a solution for this.

>> No.53927835

>>53927735
What's not matching the config file? What is the actual error message?

>> No.53927839

>>53927774
Pulseaudio.

>> No.53927842

>>53927774
This happens if you are not using pulse and alsa is pointing at the hardware device with dmix...

>> No.53927853

>>53927839
lol no, that's in not the answer
Alsa can do it perfectly well with that shite.

>> No.53927860

I've tried twice now to reinstall Xubuntu and start fresh, and yet both times have preserved my original installation. Both times I've specifically directed the installer to format the space where the old root partition is, and it it doesn't seem to work. (I always double check it's just that partition and I'm not formatting what is to remain /home.) What's going on here? (The second time I fucked up grub and sda4, the root partition, is now sda6, so that's cool I guess.)

(I'm dual-booting on this computer, and wish to keep all that the same.)

>> No.53928139

>>53927835
A whole ton of shit and basically says it's not matching the config file(paraphrased).

Missing shit like vesa, and some other junk too.

>> No.53928165

Is it possible to start a service only once, after boot is finished/on login? I normally just enable services using systemd but that slows things down a lot when your init hangs on that one service starting.

>> No.53928212

>>53928165
I'm not exactly sure how to myself, but I'm pretty sure some services do start at boot and then commit sudoku as soon as they're done with whatever.

>> No.53928322

>>53925550
okay I just installed ubuntu what now?

>> No.53928333

>>53928322
No, that's not how it works. You have to ask a question that can be answered, like, "I want to do X, how do I do it?".

>> No.53928380

>>53928165
What?

You mean other than 'systemctl enable $service'?

>> No.53928385

Give me 5 reasons NOT to install Antegros.

>> No.53928387

why does my ubuntu gnome have so much trouble with jewtube videos? everything is unresponsive, framerates are trash, and fullscreening is a death sentence. wat do?

>> No.53928397

>>53928380
Yep. That will run it during init, so when you have a service that takes some 20 seconds to start you hang right before you're dropped into a login shell waiting for the service to start.

>> No.53928398
File: 55 KB, 640x489, 1460087108362.jpg [View same] [iqdb] [saucenao] [google] [report]
53928398

>>53928333
okay, what sort of things did you enjoy learning to do and helped your general experience with using computers that you were only able to do with linux?

>> No.53928399

>>53928387
what video card/video card drivers are you using?

>> No.53928417

>>53928139
Should I give up on this shit or does anyone still want to bear with me?

>> No.53928427

what's the best torrent program?

I used qbittorent on jewndows.

>> No.53928465

>>53928399

I have an R9 280 and I'm using the fglrx-updates driver. The open source driver was having the same issues, possibly more so.

>> No.53928468

>>53928427
rt-ps

>> No.53928486

>>53928139
Fucks sake man, not paraphrased. Do you think I have seen every possible error message and can figure out what they say from vague references? I'm not a magician. run nc termbin.com 9999 < /var/log/Xorg.0.log and post the output of that.

>> No.53928504

ubungu 16.04 when?

>> No.53928511

>>53927835
Ok so basically in the log file everything seems to go well then LoadModule: fbdev fails, same with vesa,

Then screen 0 deleted because of no matching config section


Anyone got a clue?

>> No.53928533

I tried installing kubuntu. Big mistake. Settings don't save (global shortcuts, account login password request), display settings keep getting reset randomly, applications keep opening on secondary monitor, and wine graphics are broken while the window is on the primary screen.
And this is just the first day of use. I should not have betrayed our Lord and Savior xubuntu.
16.04 when? If I install the development version now can I switch back to stable once released?

>> No.53928595

>>53928397
At login, most shells execute a login script, which you can use to execute your custom script. The login script the shell executes depends, of course, upon the shell:

bash: .bash_profile, .bash_login, .profile (for backwards compabitibility)
sh: .profile
tcsh and csh: .login
zsh: .zshrc

You can probably find out what shell you're using by doing

echo $SHELL

from the prompt.

>5 seconds of search engine

>> No.53928604

>>53928486
K

Termbin.com/06j0

It's long AF

>> No.53928635

>>53928595
That's not even close to what I meant, your shell rc gets sourced _every_ login instance of it. I figured it out though.

>> No.53928638

>>53928604
>Termbin.com/06j0
Ok so that is basically saying there is no working driver. What video card do you have? Maybe someone has the same or similar and can tell you what setup is required, because I have only dealt with nvidia before. (Also try sudo modprobe radeon)

>> No.53928653

>>53928638
Ati 5770

Modprobe radeon made my native resolution but then I wrote startx and it's frozen and I need to reboot.

>> No.53928701
File: 49 KB, 524x700, 1445960900251.jpg [View same] [iqdb] [saucenao] [google] [report]
53928701

So I'm ready to remove Windows and install Linux, but there are so many Linuxes.

I hope /flt/ can help me: What it the BEST linux?

>> No.53928709

>>53928653
> Modprobe radeon made my native resolution
You meen the tty resized? I guess that means the driver works.
> it's frozen and I need to reboot
Well the xorg log should still be there after you reboot and could give you some insight

>> No.53928714

>>53928427
Transmission and Deluge are easy and effective with fancy web-gui. rTorrent is good but it lacks my convenience whoring drag-and-drop magnet link capabilities

>>53928465
try libgl1-mesa-dri and xserver-xorg-video-ati
This is what worked with debian, I see the same packages exist in ubongo repos so i'd say its worth a try

>> No.53928718
File: 1.30 MB, 1000x1400, 1454848594603.png [View same] [iqdb] [saucenao] [google] [report]
53928718

>>53928701
I'd just like to interject for a moment. What you're proclaiming to be Linux, is in fact, GNU/Linux, or as I've recently taken to calling it, GNU plus Linux. Linux is not an operating system unto itself, but rather another free piece of a fully working GNU system made useful by the GNU corelibs, shell utilities and essential system components comprising a full OS as defined by POSIX.

Many computer users run a modified version of the GNU system every day, without realizing it. Through a peculiar turn of events, the version of GNU which is widely used today is often called Linux, and many of its users are not aware that it is basically the GNU system, developed by the GNU Project.

There really is a Linux, and these people are using it, but it is just a part of the system they use. Linux is the kernel: the program in the system that allocates the machine's resources to the other programs that you run. The kernel is an essential part of an operating system, but useless by itself; it can only function in the context of a complete operating system. Linux is normally used in combination with the GNU operating system: the whole system is basically GNU with Linux added, or GNU/Linux. All the so-called Linux distributions are really distributions of GNU/Linux.

>> No.53928725

>>53928701
They're all the same except their package manager and what they come prepackaged with nigga.

I like Arch though.

>> No.53928738

>>53928701
4.5

>> No.53928758

>>53928709
Yes the tty resized.

The new log is even more FUCKED than the previous. Do you want to see it?

>>53928701
Whatever you do... DO NOT INSTALL DEBIAN.

I REPEAT, DO <<<NOT>>> INSTALL DEBIAN. UNDER ANY CIRCUMSTANCES. DONT GET TROLLED INTO FUCKING YOUR LIFE UP

>> No.53928784

>>53928758
>Whatever you do... DO NOT INSTALL DEBIAN.
>
>I REPEAT, DO <<<NOT>>> INSTALL DEBIAN. UNDER ANY CIRCUMSTANCES. DONT GET TROLLED INTO FUCKING YOUR LIFE UP
lmfao, I mean I wouldn't have recommended it either but your bad experience cos u fucked up isn't a reason to act this way

>> No.53928787

>>53928758
>The new log is even more FUCKED than the previous. Do you want to see it?
Sure, why not.

>> No.53928797

>>53928701
Whatever you do... DO NOT INSTALL ARCH LINUX.

I REPEAT, DO <<<NOT>>> INSTALL ARCH LINUX. UNDER ANY CIRCUMSTANCES. DONT GET TROLLED INTO FUCKING YOUR LIFE UP

>> No.53928801

>>53926060
there are many things wrong with mint

>> No.53928811

>>53928784
For a new user, fucking your shit up beyond any recognition Just by trying to upgrade to packages not from the 90's is a ****bit***** of a dealbreaker.

>> No.53928815

>>53928701
Whatever you do... DO NOT INSTALL OPEN SUSE.

I REPEAT, DO <<<NOT>>> INSTALL OPEN SUSE. UNDER ANY CIRCUMSTANCES. DONT GET TROLLED INTO FUCKING YOUR LIFE UP

>> No.53928821
File: 141 KB, 1000x750, 1456382280509.jpg [View same] [iqdb] [saucenao] [google] [report]
53928821

>>53928701
The one I'm using.

>> No.53928843

>>53928801
Does Mint even have a reason to exist next to "not using Unity"?

>> No.53928863

>>53928843
There are many distros existing without any reason/not filling any missing gap, like, basically everything RH ever released.

>> No.53928873

>>53928787
Ok termbin.com/qt2q

>> No.53928875
File: 57 KB, 832x690, 12936487.jpg [View same] [iqdb] [saucenao] [google] [report]
53928875

>>53928701
Grsec kernel is ok but can lead into complications with various programs.

I am using Linux-zen atm.

>> No.53928885

I have an important question!

People say it's recommended to use not the default Ubuntu, but other *buntus since they aren not Canonicalbuntus. But they all get the same stufff from the same Canonical sources, so what's the whole point, except not using Unity?

>> No.53928887

>>53928875
>tfw using linux-vfio

>> No.53928889

Should I wait for 16.04?

>> No.53928906
File: 58 KB, 360x200, 1435849261942.png [View same] [iqdb] [saucenao] [google] [report]
53928906

>>53928701
>What it the BEST linux?
The best Linux is GNU Linux-libre.
http://www.fsfla.org/ikiwiki/selibre/linux-libre/index.en.html

>> No.53928907

>>53928701
Ubuntu is nice if you hate learning and freedom
Mint - ubuntu with a better DE
Debian is the only major distro that seems to care about free software
Arch is nice for AUR porting every program ever over and a robust wiki
Gentoo if you're a CS major I guess
Fedora is a good workstation
CentOS is for servers.
openSUSE - see fedora
slackware - I don't know. someone with experience please tell me.
Contribute more memes to this list

I use Arch on my laptop and CentOS on my server. Best = best for circumstances. No objectively best exists.

>> No.53928918

>>53928907
I-is antegros any good

>> No.53928921

>>53928907
>>Fedora is a good workstation
lel
>implying you can't install libre office and offer shit on literally every other disto
>implying fedora has any value
>openSuse
literally the same shit in green

>> No.53928924

>>53928887
How is it so far?
Zen somehow feels faster here, have no idea why

>> No.53928930

>>53928924
I just use it for muh passthrough.

>> No.53928934

>>53928907
Pretty good listing anon. Agree do everything (except fedora being useful).

>> No.53928945

>>53928918
root distros + ubuntu only desu

>> No.53928960

>>53928787
>>53928873
Any idea fampai?

I read through it but it makes no sense.

Really close to giving up but we've put so much effort into this...

>> No.53928964

>>53928873
>termbin.com/qt2q
HAHAHA You're right thats fucked. Segfault on in input device, wireless headset added as multitouch keyboard and mouse? What kind of sweet future tech do you have! I didn't see any errors there actually relating to graphics, try unplugging all you shit apart from keyboard and mouse and trying modprobe radeon and startx again. If shit freezes up try switching to a different vt (ctl+alt+F2) and see if you still get a login prompt, just to confirm that it is just a userspace problem.

>> No.53928966

>>53928918
IDK man, it's always somehow broken ootb with cinnamon and KDE plasma

>> No.53928969

>>53928907
Yeah desu I don't understand Fedeora's place exactly. I mean I'm SORT of new so I don't have all the distros down yet but it's just kind of ...been there, but no one seems to ever say what it does that's special over something else.

>> No.53928973

Why are there people out there, who think it's a good idea to use Fedora?

>> No.53928984

>>53928966
Tbh I've NEVER had a good experience with any DE except xfce

>> No.53928989

>>53928984
Tried mate? I haven't I'm curious.

>> No.53929002

>>53928934
>>53928921
>>53928969
fair enough, it seemed like an option for those who would like to be familiar with RHEL environment that has updated packages. Quite a few companies use RHEL, Its not necessarily a bad idea to learn if you were to work in a sysadmin or IT position in the near future.
That is literally the only reason you would want to use it, though.

>> No.53929012

>>53928964
Ok I unplugged headset thing

It froze again.

Jesus Christ all over testing packages...

>> No.53929024

>>53929002
>Quite a few companies use RHEL
That's a wrong measure of actual quality.

There are, for example, many companies who buy Helvetica fonts, just becaue they think "expensive = must be good".

>> No.53929031
File: 85 KB, 2064x448, 1.png [View same] [iqdb] [saucenao] [google] [report]
53929031

>>53929024
Holy shit.

>> No.53929033
File: 13 KB, 736x547, 1457915242348.png [View same] [iqdb] [saucenao] [google] [report]
53929033

Why did canonical do this?
Was it not possible to install Bash in wangblows earlier?

Enjoy more security vulnerabilities not that Bash is in wangblows

>> No.53929041

>>53929033
Time to migrate to zsh

>> No.53929046

>>53929024
>not using the many companies use Windows argument

>> No.53929055

>>53929033
Basically Canonical has nothing to do with Bash since Bash is a GNU utility. It's just PR.

>>53929041
ayy, implying we don't have enough zsh users who don't even know how to configure a PS1.

>> No.53929057

>>53928989
No I haven't.

KDE was an epic fail for me. On several machines randomly plasma just breaks, I look for help from devs on forums, they just say "try xyz, if it doesn't work idk bye". None of it worked lol

>> No.53929064

Should I wait for 16.04 or just go with 15.10?

>> No.53929065

>>53929024
Oh of course, companies use RHEL because of the 'full stack' buzzwords, technical support, and how far they are up Cisco's butt. It's a prepackaged product to implement specific things quickly. There are server variants and a desktop edition to 'seamlessly integrate'.
None of those are reasons for individuals to use it. I hope you can see why businesses would use it, however.

>> No.53929066

>>53929055
>zsh does nothing more than configure PS1

>> No.53929070

>>53928964
>>53929012
Ok are we calling it quits on this or you got anymore ideas?

>> No.53929076

>>53929057
KDE is just windows with source code. It's fucked.

>> No.53929078

>>53929064
wait

>> No.53929095

>>53929076
Looks nice but maaan does it randomly fuck up.

>> No.53929099

>>53929046
Only the ones who haven't figured out that poo goes in loo

>> No.53929100

You're all wrong. The programs I'm using are only right way to use GNU/Linux in general.

>> No.53929108

>>53929095
>Looks nice
eh

>> No.53929111

>>53929100
What programs?

>> No.53929112

>>53925550
I once created a bootable linux usb drive with dd, to then discover that it didn't dd to the USB..

>> No.53929121

>>53929111
The best programs ofc.

>> No.53929125

>>53929121
What are "the best programs"?

>> No.53929132

>>53929121
I, too, use the best programs.

>> No.53929137
File: 39 KB, 389x96, Screenshot at 2016-04-08 02:17:40.png [View same] [iqdb] [saucenao] [google] [report]
53929137

if I want to have a bottom panel (in MATE) and also want to keep plank on the bottom, how do I make plank sit on top of the panel and not at the bottom of the screen, clashing with the panel?

>> No.53929138

>>53925815
>he fell for the "use stretch" meme
It's not stretch it's testing btw
You should have expected this to happen.
Let this be a lesson to you to either use jessie-backports or live with your older (although stabler) packages.

>> No.53929161

Is Antegros from cucks or not?

>> No.53929178

>>53925864
Honestly just use Windows 10 with Linux subsystem, best of both world desu

>> No.53929190
File: 35 KB, 633x309, idDCrpS.png [View same] [iqdb] [saucenao] [google] [report]
53929190

>use arch and Ubuntu regularly (both MATE)
>Pamac and pacman/yaourt is a godsend compared to synaptic and aptitude/apt
>AUR is fucking divine
>app development is still Ubuntu centric; updates to Mate and other tools like Mate-Tweak actually are released on Ubuntu before Arch
>Many features working in Ubuntu Mate natively dont work in Arch (such as the Marco-Compton option in Mate-Tweak, Plank Config not launching if no config file is manually made prior, certain programs not registering in the programs list and won't launch through synapse

literally what le fug. I want to drop Ubuntu and Canonical and go full freedom fries but the support Ubuntu gets makes it just werk
>>53929161
Most arch users will tell you it is because it essentially packages an arch installer with a bunch of bloat but it does work and it actually is arch

>> No.53929195

>>53929178
Spyware

>> No.53929208

>>53929161
just use whatever. what's with the preoccupation with what others think?

all the distros are all basically the same anyway.

>> No.53929221

>>53929190
What bloat though? Doesn't it just automate installation desu? Doesn't seem unreasonable and it BTFOs manjaro

>> No.53929224

>>53929070
Dude put some effort into it on your end. You have the logs and google. Look for any errors in the xorg log, dmesg, syslog, google for those errors and/or symptoms. You have havn't looked into what actualy froze up, are the other vtys still functional. Sit and think for a while instead of just jumping on the first copy/paste opportunity you see. You must be a terrible problem solver.

in that old log there is AIGLX error: dlopen of /usr/lib/x86_64-linux-gnu/dri/r600_dri.so failed (/usr/lib/x86_64-linux-gnu/dri/r600_dri.so: undefined symbol: _glapi_tls_Dispatch)
Do you have a file '/usr/lib/x86_64-linux-gnu/libGL.so'? If not mayb try installing libgl1-mesa-dev:amd64

>> No.53929236

>somehow these gnufags manage to break their system without knowing how

should try and actually break mine and see how it goes. still don't get how they manage to do it

>> No.53929245

>>53929221
It's better than manjaro for sure. It forces you to pick a DE and installs a whole lot of other shit as well though. I mean you can always uninstall it afterwards but, ugh.

>> No.53929253

>>53929221
it comes with a lot, like Ubuntu-tier, of preinstalled applications.
the real "it's just an arch installer" is architect

I like antergos for its simplicity and functionality and for the fact that they have a lot of useful packages in their repository. Its not perfect though

>> No.53929279

>>53929224
Ok I installed that desu, startx still freezes.

The other vtys are functional, yes.

There's some more aiglx errors, gonna try to resolve them too desu

>> No.53929321

>>53929253
>their repository

>> No.53929343

>>53929224
>>53929279
Yeah nah. Googling this shit isn't really helping either since I'm first of all not sure what to look for exscrlu and then when I do they have some other issue only slightly related but different solution...

>> No.53929349

>>53929321
well yeah, they literally run an independent repository. on arch you normally have
>core
>extra
>community
and with antergos you have
>antergos
but you're probably going to yell at me for something anyway

>> No.53929353

>>53929245
>implying there's not a net install of manjaro

>> No.53929370

>>53929353
Manjaro holds back updates

>> No.53929381

>>53925550
So uh, I've been running into 2 issues randomly on my antergos install recently.
Didn't happen with a pacman -Syu or any other updates, just randomly started happening.
On an x230t with the i5. DE is xfce with compton.

First issue: After locking the screen (lightdm), sometimes, when unlocking, the mouse pointer is invisible (Still works, just invisible). I can workaround by going to a terminal login (ctrlalt f1) then switching back to my session (ctrlalt f7) . Makes it reappear again.

Other issue: In mpv, and only mpv, I suddenly started experiencing heavy stuttering - as in, frame plays, previous frame plays, next frame plays, previous frame plays, and so on.
VLC works flawlessly, but I'd prefer to use mpv.

Any idea what the issues are?
I'm clueless as I didn't update or install anything and it all worked great before.

>> No.53929382

>>53929349
Oh? I was under the impression they used arch repos. That's even worse.

>> No.53929383

>>53929370
yeah for stability

>> No.53929402

>>53929381
I forgot to mention, the mpv stuttering only happens in full screen. Windowed it plays fine.

>> No.53929404

>>53929343
Let me have a look at the latest xorg log then. Also is there anything interested in syslog after xorg freeze? Could maybe also be your xinitrc or something if you have one of them hanging around from stable.

>> No.53929405

Currently have CentOS and Lubuntu dual booted on my ThinkPad. Interested in playing around with Gentoo.

Is it just a matter of installing it using minimal install/Hybrid ISO, then downloading stage 3?

How do I do this without wiping my current MBR? Just not play with the MBR in my install and then run an update on grub later?

Just concerned that it may be quite easy to wipe everything in the install, not that anything would be lost.

>> No.53929408

>>53929383
>Stability
>Causes more problems for people than antegros by far

>Stability
>Holds back SECURITY updates

>> No.53929433

>>53929408
>Stability
>spends time backporting SECURITY updates to ancient packages left to die by upstream developers.

>> No.53929445

>>53929404
I powered off. Going to sleep. I'll try one last time tomorrow with newly recouped strength, if not then I'll just reinstall.

One thing I don't get is that it was saying some shit about the driver files, as you said. Which belong to libgl1-mesa but I have it installed already... Up to date

>> No.53929449

>>53929402
>I forgot to mention, the mpv stuttering only happens in full screen. Windowed it plays fine.
That's weird. mpv doesn't take exclusive mode or anything, it's just a bigger window really.

>> No.53929455

>>53929190
What do you like more about pacman than aptitude?

>> No.53929459

>>53929402
>>53929449
Oh right, try killing compton and seeing if it goes away. I have had stutter issues caused by compton before, I don't run it any more. Happened to me regardless of fullscreen though.

>> No.53929469

>>53929449
I personally assume the culprit is either xfce or compton.
Oh, i remember - I DID install compiz-fusion for ccsm before that happened, to try to resolve the disappearing mouse cursor

>> No.53929471

good distro for the pi zero?

managed to finally snag one, and now just waiting for it to ship.

>> No.53929480

>>53929195
Get out of here with those memes man, if you have nothing to hide there isn't anything to fear

>> No.53929491

Is debian actually bad for desktops?

I hear its server software, but i want to be running a home server, a dns server and a desktop environment. Is debian the right choice?

>> No.53929535

>>53929459
hmm, do you use anything else to prevent tearing then? I can't deal with the tearing that xfce normally has

>> No.53929542

>>53929535
I fix it with nvidia drivers in my xorg config.

>> No.53929549

>>53929542
>tfw using intel graphics
can I do that shit too?

>> No.53929560

>>53929535
First verify compton is the issue.

>>53929549
Er maybe? I can't tell you, I can give you the information about fixing it with nvidia but it will NOT work for you. Might set you on the right path.

Read both these:
https://github.com/chjj/compton/issues/227
https://github.com/chjj/compton/issues/227#issuecomment-60490130

>> No.53929564

>>53929491
I use it on my work laptop.
It's okay for work, no problems.
It is a very good work distro, love it.
But I could never use Debian on my home desktop, at home I want to new and fun packages.

>> No.53929578

>>53929560
yup, pkill compton fixed it.

>> No.53929581

>>53925721
That is a dns problem senpai

See how far a traceroute gets or try dig -c IN -t ANY +short google.com

If the traceroute fails it is a routing issue , most likely your local network/ISP

If it fails to resolve try a different dns resolver and if that also fails then it is definitely a routing issue.

>> No.53929587

>>53929578
though weirdly, if I restart it, it still works.

>> No.53929608

>>53929564
Main think im looking for is resource efficiency. I dont want my computer using a lot of energy since its on most of the time

>> No.53929635

>>53929587
Yeah, I know what you mean. Compton seems to have a leak and start to lag over time.

>> No.53929676

Last time I tried to install xubuntu alongside with w10 it didn't work, didn't give me the option to choose what to boot

I just followed the install menu. What did I do wrong? I would like to try again

>> No.53929782

>>53929676
You should get rid of Windows 10. Seriously.

>> No.53929797

>>53929608
To fix your problem you need to install a wind turbine, battery pack and a DC TO AC converter.
Then your computer can use as much energy as you want, unless you don't have any wind.

>> No.53929890

>>53929782
Well that was the plan, slowly adapting to Linux, while having w10 for stuff I can't do in Linux yet

That's why I'm asking the question

>> No.53930014

>>53929676
I'm part happy I don't have a modern EFI machine that has to deal with this shit, part sad I can't confidently help people like you due to having next-to-no experience with it.

It's not difficult, though, I know that much but I can see how it would trip people up. Assuming the Xubuntu installer is similar-to/same-as the standard Ubuntu installer (which I reckon it should be) then https://help.ubuntu.com/community/UEFI should help you get things going without issue.

>> No.53930143

I do wonder what desktop environment provides the best out-of-the-box experience. Reasonably, whatever this is should be the default recommendation unless one is sure the referral is willing to mess with stuff post-install.

It's not the oft-recommended Xfce, what with screen tearing and all.
It's not my personal choice of Gnome, with its - ah, how to put it mildly - questionable defaults.
It's probably not KDE what with people constantly clamouring over it being buggy as hell.
Maybe I'm wrong, with my own experience of it being very limited, but I doubt it's LXDE. It felt rather lacking.
I suspect the answer is Cinnamon even though I really don't like it myself. It evidently caters to people used to Windows which isn't inherently a bad thing. Just makes me feel queasy.
Mate? Budgie? What about Enlightenment?

Remember that it's not about your own preference, people. Out-of-the-box experience with the average user in mind.

>> No.53930216

>>53929405
Anyone?

>> No.53930265

>>53925831
False, Debian stable is a pretty good desktop distro, probably the best. But it doesn't work if you have attention-deficit disorder and you think having constant updates that can break your workflow with newly introduced bugs (i.e. you're NEET) is a good thing.

>> No.53930331

>just realized i can hotkey super+[5,6,7,8] to super+shift+[1,2,3,4]
life changing how didn't i think of this earlier revelations general

>> No.53930355

>>53930143
I'd agree with Mint Cinnamon honestly, it just werks without being a complete overhaul for the new user (Gnome3, Unity)
Xfce has retarded shit like not having super bound to opening the menu by default and just.. feels dated I duno

>> No.53930381

I bought my sister a 200€ laptop with a celeron N3050, she doesn't need it for anything more than web browsing and it doesn't come with an OS so I'll be throwing some linux flavour there.
I haven't been distrohopping for years myself as I have been good with Fedora on my desktop and Arch on my laptop for the past 4 years.

What's a decent lightweight distro I should throw on her laptop?

>> No.53930496

when I open tetris with M- x tetris I cant close it
how the fuck do I close this fucking game how do I even close anything

>> No.53930510

>>53930496
Oh and now C- x k is working the fuck is wrong with emacs

>> No.53930562

>>53930355
>it just werks without being a complete overhaul for the new user
I've thought a lot like this, that it's important to keep to an experience that is similar to what the user is used to, but I also wonder if that's not doing them a disservice. People don't seem to have a lot of trouble switching from Windows to OS X which is a lot different, so maybe we're giving them less credit than they're due? On the other hand, perhaps the notion that everything Apple is easy to use and "just works" is so settled in the collective mindset that a user is more likely to stick around until they grow used to it, lest they brand themselves as unable to use something "objectively better".

I'm just speculating, obviously. Could be I'm way off the mark on all counts; I won't pretend to understand how people tick.

>> No.53930571

>>53930510
Everything is wrong with fucking emacs.

>> No.53930615

>>53930571
But what else I thought emacs would be best 100% free editor the fuck tetris please dont start tetris dont M- x tetris

>> No.53930621

>>53930615
I mean, it's free, but it's not the best. vim is the best editor.

>> No.53930635

>>53930621
I'll check out vim later hope I dont get confused when I want to switch back to emacs
or rather IF

>> No.53930643

>>53930635
The keybinds might weird you out at first. Run I advise running vimtutor.

>> No.53930663

I'd just like to interject for a moment. What you’re referring to as GNU/Linux, is in fact, linux-libre/GNU, or as I’ve recently taken to calling it, linux-libre + GNU. GNU is not an operating system unto itself, but rather another free component slapped onto a fork of the useful Linux kernel, called linux-libre. The GNU project didn't manage to finish a working kernel replacement for Linux, which they tried with HURD after 20 years of developement. Many computer users run a modified version of the Linux kernel every day, without realizing it. Through a peculiar turn of events, the version of Linux, which is widely used today is often called "GNU/Linux", and many its users are not aware that it is basically the Linux kernel, developed by volunteers all over the world, maybe with a few userland packages added. There really is a GNU, and these people are using it, but it is just a part of the system they use. GNU is a collection of a few packages.

>> No.53930670

>>53930635
Don't worry, you won't get confused. Vim has tetris too.

http://www.vim.org/scripts/script.php?script_id=172

>> No.53930674

>>53930670
kek

>> No.53930689

>>53930670
FUCKING TETRIS

>> No.53930700

>>53930689
https://github.com/uuner/sedtris/blob/master/sedtris.sed

>> No.53930724

What is the difference between ubuntu/kubuntu/debian if you use KDE as the manager on all three?

Like it'll look the same and packages will install the same?

>> No.53930726

>>53930700
I might cry

>> No.53930757

>>53930724
ubuntus use ubuntu repo
debian uses debian repo

>> No.53930773

>>53930757

Ok but what does that mean in terms of difference? Will programs be different in terms of features/versions will there be more packages for some and not others?

>> No.53930779

Hi Ubuntu friends!

Is there a way to get cgred service working on xubuntu 15.10. To my surprise there is no such a service in regular repos.

>> No.53930783

>>53930663
4chan is 18+, please leave.

>> No.53930788

>>53930773
yeah ubuntu repos are a bit more up to date depending on the release you have.

but they all get the important stuff, security updates.

>> No.53930814

>>53930779
>Hi Ubuntu friends!
I feel insulted.

>> No.53930832
File: 27 KB, 1367x705, tetris.png [View same] [iqdb] [saucenao] [google] [report]
53930832

Tetrisss

>> No.53930838

>>53930832
fucking tetris

>> No.53930850

>>53930832
Tetris is a shit game. Srsly. Fuck tetris.

>> No.53930863

>>53930850
This.

Even snake is better than fucking tetris,

>> No.53930880

>>53930832
>>>/v/

>> No.53930913

So I wiped Windows from my system but my volume control is gone. For some reason I can't add it to the panel. Any help?

>> No.53930926

Is there a way to make the area near the window borders where the cursor resizes them larger in Xubuntu? I like my mouse to move pretty fast but being pixel-perfect to resize windows is hard with that mouse speed.

>> No.53930930

>>53930913
from what little i gleamed off your post, you wiped windows and volume control is gone.

could you be any more vague? would help for you to do that.

>> No.53930933
File: 23 KB, 1367x705, snake.png [View same] [iqdb] [saucenao] [google] [report]
53930933

>>53930863
Fucking snake fucking tetris

>> No.53930946

>>53930930
Sorry. Installed Lubuntu (its a slow laptop) and the panel taskbar thingy at the bottom lacks a volume control button and it cannot be added for some reason

>> No.53930978

>>53930946
from a quick ddg search.

>I figured it out. The panel menu was confusing me a little... I thought the Panel Applets tab was showing me what was available to add--but it's showing what's already on the panel..

>Just to remind me (or anyone in the future that might have the same question:

>Right-click panel
>Add/Remove Panel Items
>Panel Applets Tab
>Click on "Add"
>Select available plugin

was from 09, so might or might not work anymore.

>> No.53931016

>>53930978
I tried that, apparently doesn't want to add it.

>> No.53931097

>>53930381
install gentoo

>> No.53931110

Hey guys anyone care to help with a small problem?

Recently got an additional monitor, and now the right border shadow of a fullscreen window on left screen is visible on right screen.
Anyone know how to fix? Thanks

>> No.53931139

>>53930926
Raises eyebrows ... not sure if that would be a good thing

>> No.53931159

>>53931139
Eh, wha..?
As it is the tip of the pointer needs to be EXACTLY on the window edge, I just want a 2-3 pixel margin in which that works.

>> No.53931291

>>53930926
Can't you just set your window manager to resize on alt+right click?

>> No.53931316
File: 198 KB, 566x333, Keanu-Reeves-Whoa-09.jpg [View same] [iqdb] [saucenao] [google] [report]
53931316

>>53931291

>> No.53931432

I'm trying to test out a reverse SSH tunnel on a local connection.

At first I got Connection Refused. Opened the SSH port on the router, now the connection just times out.

I'm using this command to open up the tunnel:
ssh -fNR 5000:localhost:22 [email protected]

What have I missed?

>> No.53931476

>>53931432
Why -R? Isn't tunnel -L?

>> No.53931483

>>53931476
Ignore, I'm retarded, you said reverse.

>> No.53931485

>>53929480
Just because you don't have any thing to say it doesn't mean you for need your freedom of speech
get out

>> No.53931695

So, I've got a CentOS install. Being a Xubuntu babby, yum is a mysterious and irritating layer of voodoo magic. I'm trying to install some other packages, but for some reason I'm getting a dependency error for a package I tried installing earlier and gave up trying to install. How can I clear this issue so I can get back to installing stuff?

>> No.53931782

/g/ halp

how to fix alsa

ALSA lib pcm_direct.c:1685:(snd1_pcm_direct_parse_open_conf) The field ipc_gid must be a valid group (create group audio)
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed


i added and removed some groups - audio video disk storage optical and a few more
now systemd

>> No.53931825

>>53923572

>sudo su

You w0t m8?

>> No.53931850

>>53929549

Nigga, with Intel graphics all you need is the TearFree option turned on. Look up how to do that. There's no need to run a compositor just for screen tearing.

>> No.53931889

>>53927860
Did your partitions change? Maybe you don't see the difference because of the config files in /home.

>> No.53931924

>>53931850
holy shit brochacho, you're the master.

>> No.53932355

>>53931782
it might have something to do with udev

>> No.53932412

>>53931782
Your user needs to be in the audio and possibly realtime groups, I think just audio though.

http://jackaudio.org/faq/linux_rt_config.html
http://wiki.linuxaudio.org/wiki/system_configuration
For this second link the stuff after the kernel config is probably the parts relevant to you.

>> No.53932608
File: 78 KB, 426x266, 1434776529259.jpg [View same] [iqdb] [saucenao] [google] [report]
53932608

>>53925944
>>53926000
>>53926088
>>53926100
>>53926199
>>53926322
>>53926800
>>53927177
>>53927433
>>53927488
>>53928322
>>53928333
>>53928399
>>53928511
>>53928533
>>53928811
>>53928966
>>53929033
>>53929055
>>53929066
>>53929099
>>53929100
>>53929111
>>53929433
>>53929455
>>53930355
>>53930700
>>53930788
>>53930933
>>53932355

GNU/Thread: >>53932581

>> No.53932713

>>53931432
Anybody?

>> No.53932738

>>53932713
Are you blind?

>> No.53932745

>>53925550
why stallman so sad?

>> No.53932755

>>53932745
People still use windows and even linux users still use cancerous things.

>> No.53932788

>>53932738
Please elaborate?

>> No.53932804

>>53932788
You're posting in a dead thread, already on page 10.

>> No.53932827
File: 57 KB, 500x375, 1403082795589.jpg [View same] [iqdb] [saucenao] [google] [report]
53932827

>>53932804
Was the first thread up at the time, had it open all day. I'll take my shit to the new thread then, thanks.

>> No.53932829

>>53931825
On some systems, root has no password. This means that you can't become root through standard mean.

>> No.53932848

>>53932755
like systemd? :^)

>> No.53932852
File: 14 KB, 646x720, 1460108447647.png [View same] [iqdb] [saucenao] [google] [report]
53932852

>>53932804
not if i can help it

>> No.53932911

>>53932852
litreally impossible

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action