Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

If you can see this message, the SSL certificate expiration has been fixed.
Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 419 KB, 599x769, 1453862396824.png [View same] [iqdb] [saucenao] [google] [report]
53552219 No.53552219 [Reply] [Original] [archived.moe] [rbt]

Previously on >>53535938

Welcome to /flt/, we are always open to users of all levels, including absolute beginners.

There are four ways to try GNU/Linux, you can:

0) Install a GNU/Linux OS on a VM (Virtual Machine/VirtualBox) for "safety purposes"
1) Use the Live ISO directly without installing anything, that way, you can get a "full GNU/Linux experience".
2) Dual-boot GNU/Linux with Windows/Mac (recommended if you want to learn more about GNU/Linux)
3) Go balls deep and overwrite everything with GNU/Linux

Before asking, please search for answers to your questions in resources.

Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread.

Understand that much of your software from Windows will be unavailable, although maybe WINE can make up for it.

Resources:
man <insert command here>
Your friendly neighborhood search engine (searx.me, ixquick, whatever)
https://wiki.archlinux.org/ (Most of the configurations and troubleshoots will literally work on various distros, including Debian)
https://wiki.installgentoo.com/index.php/Category:GNU/Linux
http://linuxcommand.org/tlcl.php

>> No.53552258
File: 234 KB, 605x6812, 1442751260474.png [View same] [iqdb] [saucenao] [google] [report]
53552258

> Shell pasta:

The based GNU Bourne Again SHell:
https://www.gnu.org/software/bash/

The community driven BASH wiki:
http://wiki.bash-hackers.org/

The Grymoire - home for UNIX wizards:
http://www.grymoire.com/Unix/index.html

Greg's (also known as GreyCat's) wiki:
http://mywiki.wooledge.org/BashFAQ
http://mywiki.wooledge.org/BashGuide
http://mywiki.wooledge.org/BashPitfalls

SED and AWK; your new best friends:
http://www.pement.org/sed/sed1line.txt
http://www.pement.org/awk/awk1line.txt

Google's Shell Style Guide:
https://google.github.io/styleguide/shell.xml

The Linux Command Line - A Book By William Shotts:
http://linuxcommand.org/tlcl.php

Interesting, useful and dangerous one-liners:
http://www.commandlinefu.com/

Great online (and offline) linting tool:
http://www.shellcheck.net/

Know what you are doing:
http://explainshell.com/

>> No.53552269

Having problems with bumblebee and nvidia.
When executing install nvidia-current it wants to replace my latest nvidia driver 352 with old 304. I dont know if thats good or not. Also in bumblebee config when I change Driver= to Driver=nvidia i get the error that bumblee daemon cannot start, when i change that back to Driver= that it says it cannot access the GPU.
modprobe nvidia tells me that it can find module named 'nvidia' .

So does the new nvidia patch has different name now? Other than nvidia-current? What to add to bumblebee config to Drive= amd KernelDriver?
I am on Xubuntu 15.10 .
If my kernel and nvidia are out of sync how do I fix that with the newest 352 patch?

>> No.53552271
File: 154 KB, 556x5537, 1440369307033.png [View same] [iqdb] [saucenao] [google] [report]
53552271

> Filepicker meme:

Tippers:
https://copr.fedoraproject.org/coprs/jkisielewicz/gtk2-filepicker-iconview/

Amazuntu:
https://launchpad.net/~helkaluin/+archive/ubuntu/gtk2-filechooser-iconview

Arsch Linux:
https://aur.archlinux.org/packages/gtk2-patched-filechooser-icon-view/

Absolute Madmen:
https://gist.github.com/ahodesuka/01213036b58e510dc074
https://gist.github.com/ahodesuka/49c1d0eea4b64f24c4c7

>> No.53552305

>>53552258
No mention on alternative shells in this pasta? Astoundingly enough, in all my years of fucking around I've never given zsh a try, but I'm thinking of doing so soon.

>> No.53552333

>>53552219
>>53552219

Can you anons help me with advice on customising my Ubuntu system?

I wanna change the theme (icons, colour scheme, animations etc.) -- is there any crash course or resources for learning about DE and OS customisation?

Thanks.

>> No.53552342

>>53552305
zsh is nice, but only after using bash to it's limits, otherwise there's no point, especially for new users. fish has some pretty nice features too, but sadly not POSIX compatible. Feel free to try them both, but please don't install that oh-my-sh bullshit.

>> No.53552353

>>53552342
>oh-my-sh
oh-my-zsh, ofc

>> No.53552388

>using GNU shit instead of superior alternatives
CVE-2014-6271, aka Shellshock, allowed complete compromise of systems running GANOO BASH. After looking at the 20 year old, shit spaghetti code researchers discovered CVE-2014-6277, CVE-2014-6278, CVE-2014-7169, CVE-2014-7186, and CVE-2014-7187. More secure/faster/better alternatives include csh, tcsh, and pdksh.
CVE-2015-7547, a glibc getaddrinfo() vulnerability that allows anyone able to send UDP packets to your computer to compromise it, affects basically EVERY PIECE OF SOFTWARE that uses GANOO glibc. More secure/faster/smaller/better alternatives include musl and uClibc.

>> No.53552389

>>53552333
Usually you just search the web for themes for your DE. (GTK for Ubuntu). You place the extracted archives into /usr/share/themes (dont forget to use sudo) and select them either via cli (gsettings) or via gnome-tweak-tool.

>> No.53552394

>>53552353
grml is better desu.

>> No.53552400

>>53552342
Auto complete isn't useful for new users?

>> No.53552414

>>53552342
I definitely agree new users probably shouldn't delve into zsh or likely any alternative shell at all. Huh, I guess that's the point; the pasta is aimed at new or inexperienced users and therefore does not mention alternative shells. Point taken.

And don't worry, while I enjoy tools designed for convenience, I've never quite liked tools designed for hand-holding.

>> No.53552495
File: 47 KB, 500x495, 1453373329883.jpg [View same] [iqdb] [saucenao] [google] [report]
53552495

>>53552342
>>53552414
you are morons :(
its like saying you dont need browser that got extensions and customizations unless you used internet explorer 6.0 for a half a year and meets its limits

>> No.53552546

>>53552495
>morons
It'll work out fine, Anon. Don't you worry.

It's possible I'm mistaken, but with most people using Bash and most resources foremost assuming Bash, it seems to me a lot easier for the inexperienced user to get help with whatever they want to do if they are using Bash.

>> No.53552547

>>53552495
At the point you start scripting in the terminal directly, you know why compatibiliy > yet another shell scriping language.

>> No.53552583

>>53552547
>I dont want to level up.
Wait 2-3 years, then zsh will be the standard since every newfag is installing it as seen on screenfetchTV. Then you may ask yourself why you're incompatible to zsh.

>> No.53552597

>>53552546
Tbh I don't see the problem with letting a noob's first experience be zsh over bash. Can you list some?

>> No.53552602

Anyone else using plasma 5.5? Seems like the TouchPad scroll speed is too fast compared to it's predecessor, 5.4

I've attempt adjustment but I'm not seeing a change. Looks like some changes were made to the input settings dialogs.

>inb4 kdecrash||bloat||shit

>> No.53552607

>>53552583
>screenfetchTV
wat is this

>> No.53552609

>>53552597
>"Anon, just run this command."
>"Doesn't work, I'm using zsh."

>> No.53552610

>>53552389
What's the general command for placing a theme file in that directory?

Also, do you place the entire .zip file in themes?

>> No.53552616
File: 44 KB, 638x479, zsh.jpg [View same] [iqdb] [saucenao] [google] [report]
53552616

>>53552546
Why do you even talk about zsh when you obviously never tried it?
Do come up with a problem that has different solution in bash vs zsh

>>53552547
theres only tiny number of differences zsh vs bash that could come out during scripting
and you dont script in terminal, you script in an editor, making your script file with shebang at the top to identify in what shell it will be run

>> No.53552618

>>53552609
>just run this command
Such as?

>> No.53552620

>>53552610
7z x theme.zip
sudo mv muh-theme/ /usr/share/themes

>> No.53552633

>>53552597
Can't really say more than I already did. If zsh has complete compatibility with Bash, then I'll concede the point, but otherwise it stands.

>> No.53552638

>>53552583
They only install it because they are too retarded to set PS1 by themselves and because other retards in a Desktop threads used it because they are too retarded as well.

>> No.53552639

What's the best way (if there's even a way) to have decent 2D acceleration and a decent amount of VRAM in a VM with Windows host + Linux guest?

I mean, I use Virtual Box in my Win desktop to test distros and stuff before doing something stupid in my linux netbook, but even with like 75% of my CPU (i5 3570k), 4GB RAM and all possible virtualization capabilities enabled (also, both host and guest are 64 bits) the performance in stuff like Gnome 3 is miserable. Even my POS netbook (N2930 Celeron) can run it much better and with proper animations and stuff.

>> No.53552645

>>53552633
It's been my experience it does except for some escapes. I can't think of any command I've tried to run that no longer worked because I was using zsh.

>> No.53552654

>>53552639
Here

If it helps, I have my iGPU completely disabled on BIOS and running exclusively on a dedicated one. Would it help to enable it?

>> No.53552657

>>53552616
>you dont script in terminal, you script in an editor, making your script file with shebang at the top
And this is what I'm talking about. There is literally no point in using zsh for people who use the terminal only to cd, ls and rm -rf /, and once in a blue, call a script via ./.

First learn the standard shell, then you can level up to zsh or other things.

>> No.53552669

>>53552639
It's easier the other way, especially if you want help from us, i don't think anyone here would run windows as a host if he could use KVM or Xen on GNU/Linux.

>> No.53552694

>mfw BASH vs zsh is the new "what are you hacking with" meme

>> No.53552706
File: 278 KB, 1024x683, 1427271854494.jpg [View same] [iqdb] [saucenao] [google] [report]
53552706

>>53552694
>mfw no face

>> No.53552714

>>53552620
Cool. Thanks.

Then I'm assuming that it'll appear in the gnome-tweak-tool. Does the tweak tool have a UI?

>> No.53552716

>>53552706
This is now a shoop, sorry, gimp template. Post results.

>> No.53552726

>>53552669
But muh gaming! Well yeah, I know, gb2 /v/, yadda yadda. My desktop is just for games and media, anything remotely productive is done in my Linux netbook so I don't see a point on having a Linux partition and stuff in the desktop for basically testing if a new distro or feature I want to try is broken beyond repair. I just wondered if there's something to "fix" the particular scenario I have.

>> No.53552731

>>53552714
Yes. It's GUI only.

>> No.53552736

Man you zsh/bash faggots are still fighting`? Thought you had it settled back in the fucking 80s when your shitty shells came out

>> No.53552741

>>53552645
It's unclear how vast your experience is and how intricately you use the shell, so I suppose we're not reaching a conclusion.

>>53552616
I'm talking about zsh because I was the one who brought it up. Congratulations on figuring out I haven't tried it, friend.
I take it you claim that zsh has complete compatibility with Bash, then? My apologies, but your statement "you don't script in terminal" will make me doubt the validity of your answer.

>> No.53552745
File: 210 KB, 796x928, 1299314902203.jpg [View same] [iqdb] [saucenao] [google] [report]
53552745

>>53552657
seriously have you ever used zsh for any amount of time?
The idea I would go back to shit tier autocomplete of bash, or lose the smart history of zsh.. fuck that noise

those things noobs will use automaticly without knowing they are there because they will use tab or arrow up keys soon enough
and exactly for those small things its the best, for simple navigating, for simple running and listing whats in the place and noobs will definitly likeit same as they like adblockier, downthemall or imagus in their browsers

theres like 99.99% compatibility between bash and zsh
so I repeat, you are morons to oppose the idea of zsh for everyone, be it noob or guru
its just plain better

you should really try zsh out, with ohmyzsh you dont even need any tinkering with it, it just works

>> No.53552753

>>53552726
do this anon: https://wiki.archlinux.org/index.php/PCI_passthrough_via_OVMF

>> No.53552757

>>53552741
>It's unclear how vast your experience is and how intricately you use the shell, so I suppose we're not reaching a conclusion.
True, but even if I had only basic experience that's all a noob will have anyway, so there's not going to be a problem. If anything only the higher level shit will be impacted and by then the user isn't a noob.

>> No.53552770
File: 196 KB, 661x768, 1296488025328.jpg [View same] [iqdb] [saucenao] [google] [report]
53552770

>>53552741
>I take it you claim that zsh has complete compatibility with Bash, then? My apologies, but your statement "you don't script in terminal" will make me doubt the validity of your answer.
please go through your ~/.bash_history and post your last "script" that you done in terminal

I am really interesting in it, but I think you dont even realize WHY you sound absolutely retarded with claims of "scripting in terminal"

>> No.53552802

>>53552745
>99.99% compatibility between bash
ksh. You mean ksh, not bash. There is no compaibility to bash (yep I know there is "emulate".

Also 99% of zsh features are possible using bash. Name them, I tell you how, the only thing bash is "missing" is the autocomplet bloat.
Implying the advanced terminal users who is ready for zsh, doesn't already know what command he needs to type, but well, even here BASH has >complete.

man <program> > installing other software for fixing things.

>> No.53552827

>>53552745
>those things noobs will use automaticly without knowing
We're not at Windows where you need to install superior alternatives to get shit done. BASH is based.

>> No.53552855

le wild gnu+linux user appears
:D
whats up dudes?

>> No.53552860

>>53552802
zsh has nicer PS1s and comfy autocomple, fuck your outdated shit.

>> No.53552872

>>53552855
MISSING GNO

>> No.53552894

>>53552757
Well, the issue is it might turn into a problem if the noob looks to do something more advanced all of the sudden. You don't become an advanced user overnight.

I'll not try to stop anyone from switching, mind you. I just feel it might be a disservice to thrust it onto people, hence my agreement that it perhaps should not be in the pasta that Anon posts.

>>53552770
I have a few in one of my tmux windows that I don't even need to scroll back in the buffer to see. Not any too advanced stuff right there, and I'm confident not something I'd have any problems replicating in zsh even in case some syntax is different (which is basically what I'm asking here). Point is, one-off things you don't see yourself repeating is nice to just type out straight.

>absolutely retarded
Also, you should probably calm down. You seem inexplicably upset. Go get yourself a cup of tea or coffee before responding, and avoid language that prompts people into unconstructive shit-flinging.

>> No.53552907

>>53552802
>autocomplete bloat
Ok nigga.

>> No.53552923
File: 157 KB, 683x1024, 1443850193894.jpg [View same] [iqdb] [saucenao] [google] [report]
53552923

>>53552860
https://github.com/robbyrussell/oh-my-zsh/blob/master/plugins/lol/lol.plugin.zsh

export PS1="\[\033[34m\]╭|╮\n╰|╮\n╰|╯ \[\033[m\]"
man bash, / complete

>>53552907
10/10 arguments you got there

>> No.53552925

>>53552731
Thanks for the help, anon.

>> No.53552939
File: 5 KB, 933x527, Screenshot_2016-03-18_14-34-59.png [View same] [iqdb] [saucenao] [google] [report]
53552939

>>53552923
>PS1="\[\033[34m\]╭|╮\n╰|╮\n╰|╯ \[\033[m\]"

>> No.53552941

>>53552925
np buddy, feel free to ask more questions, so we don't need to diarrhea about shells.

>> No.53552946
File: 179 KB, 589x564, 1304001596731.jpg [View same] [iqdb] [saucenao] [google] [report]
53552946

>>53552802
>ksh. You mean ksh, not bash.
no I dont
I mean /bin/fucking/bash

>Also 99% of zsh features are possible using bash. Name them, I tell you how, the only thing bash is "missing" is the autocomplet bloat.
autocomplete is huge, if its missing you mean to tell me its only 0.01%
thats like half the things you do in terminal
you opening something somewhere, you navigating someplace, you are giving git some parameters... jesus fucking christ AUTOCOMPLETE IS ESSENTIAL
only absolute retard would call it bloat

but lets go for history

>pressing arrow up multiple times
previous commands like just bash

>write ffmpeg, then press arrow arrow up multiple times
lists only commands in history that contain the ffmpeg string
this makes history actually usable, not just for fixing forgotten sudo

which brings me to ZLE and ease of customizing keybinds and doing stuff to content of terminal

>ctrl+F will append sudo at the begining of current line and return cursor to the end
all done in few lines in zsh

here have some fun
http://www.slideshare.net/jaguardesignstudio/why-zsh-is-cooler-than-your-shell-16194692

>> No.53552958

>>53552946
tl;dr

>> No.53552992

>>53552946
All these things are possible using bash. Read the fucking manual. You don't even list actual reasons why advanced users want to use zsh, eg. scripting shortcuts, ext-globbing, etc.

>> No.53553001
File: 16 KB, 534x285, 2016-03-18-134033_534x285_scrot.png [View same] [iqdb] [saucenao] [google] [report]
53553001

I installed gentoo, whats now? Learn bash scripting?

>> No.53553015

>>53553001
>he fell for the gentoo meme
Uninstall that macfag developed bullshit and install a real distro like debian or arch.

>> No.53553019

Freshly installed kubuntu and updated everything.

It keeps fucking crashing and making odd visual glitches - I tried to maximize the terminal lots of spooky shit started to show up.

Browsed files and suddenly screen turned red.

Wtf is all this, how can I stop it?

My hardware is pretty good, and it works - there are no hardware problems.

>> No.53553020

>>53552946
>>ctrl+F will append sudo at the begining of current line and return cursor to the end
How please.

>> No.53553021

>>53553001
fix your font rendering

>> No.53553026

>>53552946
>>write ffmpeg, then press arrow arrow up multiple times
>lists only commands in history that contain the ffmpeg string
Bash has the same thing, only you hit PgUp and PgDn. Or if you mean ffmpeg anywhere, not just in the beginning of the line, Ctrl+r.

Different Anon here, just wanted to point that out. We would probably do well not to assume that an alternative does not have a particular feature.

>> No.53553029
File: 36 KB, 400x460, 1453686124777.jpg [View same] [iqdb] [saucenao] [google] [report]
53553029

>>53552992
>All these things are possible using bash.
no they are not
or link to how-to

why would people use zsh, why would it even exists, if bash would have the features?

>> No.53553030

>>53553015
This desu.

>> No.53553031

>>53553015
>real distro
>like debian or arch
kekkers

>> No.53553035

>>53553001
>allowing bold fonts at the terminal

>> No.53553047

>>53553020
put this in to your .zshrc

add_sudo (){
prefix="sudo"
BUFFER="$prefix $BUFFER"
CURSOR=$(($CURSOR + $#prefix + 1))
}
zle -N add_sudo
bindkey "^f" add_sudo

>> No.53553053

As the Anon who initially brought up the subject of zsh:

I'm so terribly, terribly sorry for the shitfest I spawned.

>> No.53553061

>>53553019
post output of inxi -Fx

>> No.53553066

>>53553053
like 2nd time you mention you are the one who brough up zsh
this was the biggest impact you had on your surrounding thins month
wasnt it?

>> No.53553071
File: 91 KB, 1207x587, 1433106827089.png [View same] [iqdb] [saucenao] [google] [report]
53553071

>>53553029
>>why would people use zsh
Because people are retarded and install what they see on plebbit, eg. Fist babby distro: Arch via Architekt, zsh, powerline and then they run rm -rf /*

>> No.53553078

>>53553053
This is nothing. The faggots haven't even started discussing fish yet.

>> No.53553079

>>53553015
Gentoo is real flexible and very fast distro, I love it, but still not understand a lot, I want to read some books Linux Sea, and something about bash scripting///

>> No.53553089

>>53552946
>http://www.slideshare.net/jaguardesignstudio/why-zsh-is-cooler-than-your-shell-16194692
>completing this task using a bunch of pipes and programs took less lines than writing it from scratch
>it also ran like fucking shit compared to it and depended on all those programs
I'm all for using scripts and chaining programs together, but comparing an actual program to a chain of process calls is fucking retarded.

>> No.53553090

>>53553021
how? rendering looking good on my real display/

>> No.53553098

>>53553078
found the POSIX hater

>> No.53553102

>>53553071
it was actually:
>why would it even exists, if bash would have the features?

answer is: because bahs dont have those features
and you are now so frustrated by it that you outright lie

>> No.53553107

>>53553047
Very nice.

>> No.53553115

>>53553061
I have to install inxi wait take me slow new to this shit.

>> No.53553121

>>53553066
Don't be silly. I said it the first time because it was relevant to what was pointed out. This time because I would really rather not have had this happen and wanted to apologise. Is that so strange?

>> No.53553125

>>53553089
not sure how pascal works
but what exactly do you think would happen if you would make it in python
there would be some calls to standard library that makes the tasks you write there do their thing

>> No.53553129

>>53553078
Because fish is so shit no one gives a fuck.

>> No.53553133

>>53553115
sudo apt install inxi
wait till it finishes
type inxi -Fx
post a screenshot or something. you can make that with scrot.

>> No.53553135

Made a suckless version of vrms (debian only)

vrms() {
dpkg-query -W -f '${Section}/${Package}\n' | grep --color=auto -E '^(contrib|multiverse|non-free|partner|restricted)/' | sort
}

r8 h8 masterb8

>> No.53553139
File: 247 KB, 1920x1080, snapshot1.png [View same] [iqdb] [saucenao] [google] [report]
53553139

>>53553061

>> No.53553148
File: 101 KB, 1920x1080, 2016-03-18-123832_1920x1080_scrot.png [View same] [iqdb] [saucenao] [google] [report]
53553148

>>53553035
Oh, how disallow it? I use ST, it configuring thru source editing, how recompile it after editing?

>> No.53553161
File: 179 KB, 1920x1080, snapshot2.png [View same] [iqdb] [saucenao] [google] [report]
53553161

>>53553139

Holy fuck no, wait it's ok now.

>> No.53553163

I want to try GNOME with that new settings interface and network manager. I've never actually used this DE, and was wondering which distro implements the newest stuff so I can try it in a VM. I assume Fedora gets this stuff?

>> No.53553165
File: 33 KB, 456x342, 1450894690953.jpg [View same] [iqdb] [saucenao] [google] [report]
53553165

>>53553135
contrib/otherosfs/vice
contrib/utils/conky-all
non-free/libdevel/libfaac-dev
non-free/libs/libfaac0
non-free/sound/faac
partner/web/adobe-flashplugin
partner/web/adobe-flash-properties-gtk


Do I need to feel bad?

>> No.53553172

>>53552941
That's genuinely all I wanted to know. A general Ubuntu cheat sheet would be great, so I can just quickly refer to that for any little queries. So if you have any links that resemble anything like that, it would be much appreciated.

>> No.53553175

>>53553125
Yeah. And it would be in that program. It wouldn't have the overhead of creating processes and moving output to other programs.

>> No.53553177
File: 20 KB, 355x235, snapshot3.png [View same] [iqdb] [saucenao] [google] [report]
53553177

Lmao

>> No.53553182

>>53553161
your issue could be related to you using noveau. have you tried it with proprietary NVIDIA drivers?

>> No.53553186
File: 6 KB, 419x282, 1428368757512.gif [View same] [iqdb] [saucenao] [google] [report]
53553186

>>53553177

>> No.53553197

>>53553163
I can confirm that Fedora 23 is great for using Gnome 3. It's probably the newest and best.

>> No.53553200

Hi does anyone have that pretty arch installation guide summed up in a picture? My head fucking hurts from reading all the shit on wiki, thanks

>> No.53553207

>>53553182
It is my greatest wish that nvidia wouldn't be shit on linux.

>> No.53553209

>>53553197
Fuck off rh-chan.

>> No.53553217

>>53553200
Bait or new, if new, don't follow the image.

If you're shitty info graph guy, fuck off.

>> No.53553219
File: 623 KB, 1880x1634, 1441793156703.jpg [View same] [iqdb] [saucenao] [google] [report]
53553219

>>53553207
I'd just like to interject for a moment. What you're referring to as Linux,
is in fact, GNU/Linux, or as I've recently taken to calling it, GNU plus Linux.
Linux is not an operating system unto itself, but rather another free component
of a fully functioning GNU system made useful by the GNU corelibs, shell
utilities and vital system components comprising a full OS as defined by POSIX.

Many computer users run a modified version of the GNU system every day,
without realizing it. Through a peculiar turn of events, the version of GNU
which is widely used today is often called "Linux", and many of its users are
not aware that it is basically the GNU system, developed by the GNU Project.

There really is a Linux, and these people are using it, but it is just a
part of the system they use. Linux is the kernel: the program in the system
that allocates the machine's resources to the other programs that you run.
The kernel is an essential part of an operating system, but useless by itself;
it can only function in the context of a complete operating system. Linux is
normally used in combination with the GNU operating system: the whole system
is basically GNU with Linux added, or GNU/Linux. All the so-called "Linux"
distributions are really distributions of GNU/Linux.

>> No.53553220

>>53553207
unfortunately for nvidia you need to use proprietary drivers for it to not suck. nvidia are massive assholes when it comes to opening documentation and working with FOSS.

>> No.53553224

>>53553219
It's not though.

>> No.53553229

>>53553200
https://wiki.gentoo.org/wiki/Handbook:AMD64/Full/Installation
screenshot in and glue in gimp

>> No.53553233

>>53553200
either you use the beginner guide or you don't use arch at all. it's not for you.
>>53553224
yes it is.

>> No.53553235

>>53553220
>unfortunately for nvidia you need to use proprietary drivers for it to not suck
No no, I mean that even then they still really fucking suck. Or if it's not the drivers themselves the ability to customise them, set settings etc, is.

>> No.53553237

>>53553229
Kindly /r/equesting you to stop namefagging like retard.

>> No.53553240

>>53553219
Happy Birthday RMS!

>> No.53553242

Installed nvidia driver, but not sure if it fixed anything - the stuttering is the same when I move windows around.

What settings should I apply now to debloat kde?

>> No.53553244

how do i prevent screen tearing in kubuntu using skylakes iGPU, i cant use the option Re-use screen content because its buggy af, so is there another way?

>> No.53553258

>>53553200
If you need a fucking pictogram to install Arch for you, you have no business installing Arch. Just install Debian and switch your sources to the unstable repos so you can enjoy a system which breaks without warning just as frequently as Arch

>> No.53553260

>>53553235
the proprietary drivers for them are not perfect at all but they actually have similar features to their windows drivers.

>> No.53553261

>>53553237
OK bro

>> No.53553264

>>53552219
MORPHEUS CHECK YOUR FUCKING EMAIL.

>> No.53553269

my f1 to f12 have funcions like volume down or mute, and they don't work for things like fullscreen. How do I disable that?

>> No.53553275

>>53553219
>fmt -w 80
<3

>> No.53553276

>>53553244
https://wiki.archlinux.org/index.php/intel_graphics#Tear-free_video

>> No.53553278

>>53553242
Use Vsync

>> No.53553289
File: 519 KB, 2170x1070, 1458166051741.jpg [View same] [iqdb] [saucenao] [google] [report]
53553289

>>53553200
here it is
but seriously theres hundreds of youtube videos
and theres articles
the picture is nothing special and will be outdated pretty soon
maybe it already is

>> No.53553292

>>53553258
>without warning
that's extremely rare

>> No.53553300

>>53553260
They don't even let me rearrange my monitors properly. I can set a default but I can't set monitors after that to the identifier I want. Only my shitty VGA monitor actually works in the virtual terminals, and I can't actually switch to any beyond the first. Wasn't a problem before I actually installed the drivers.

>> No.53553301

>>53553269
If it's a laptop keyboard where you can get to the F#-keys by holding the Fn key, there's usually a switch in BIOS that you can flip.

>> No.53553304

>>53553001
You could start modding your kernel. Personally I've never done this before. /flt/, any hints? I'm interested.

>> No.53553307

>>53553289
>30.12.15
definitely is outdated

>> No.53553317
File: 500 KB, 500x494, 1451872298019.gif [View same] [iqdb] [saucenao] [google] [report]
53553317

>>53551622
I actually had this done already for each concurrent display, but it still had tearing. I don't know if it's how Debian or GNOME does things with the xorg conf or just nvidia drivers being uncooperative.

>> No.53553324

>>53553200
>>53553289
[shitty apps guy intensifies]

>> No.53553326

>>53553317
>or just nvidia drivers being uncooperative
I'd put money on it.

>> No.53553330

>>53553292
Only if you count "running apt-get upgrade" as a warning

>> No.53553334

>>53553242
>>53553304
>/flt/, any hints? I'm interested.
I did configured my kernel good, it very small 8Mb and fast, efi stub kernel.

>> No.53553340

Is Plan9 alien technology?

>> No.53553347
File: 58 KB, 640x478, install_arch.png [View same] [iqdb] [saucenao] [google] [report]
53553347

>>53553289
why not using GRUB for uefi installation instead of systemd boot?
it would be more consistent, but beginners guide goes for systemd as well
https://wiki.archlinux.org/index.php/Beginners'_guide#UEFI_mode

Does grub has some problems on uefi?
or if it just about not needing the package, then what about systemd being able to boot non-uefi mobos?

>> No.53553354

>>53553330
>upgrade
on testing and unstable you should always install apt-listbugs and apt-listchanges and use dist-upgrade instead of just upgrade.
it's not debians fault that you are to lazy to read the wiki. https://wiki.debian.org/DebianUnstable

>> No.53553388

>>53553276

do i have to creeate the config file myself because theres no 20-intel.conf file ?

>> No.53553399

I installed Debian on a laptop about three years ago. I recall needing to use the nonfree iwlwifi firmware package. I recently nuked and reinstalled on the same laptop and apparently don't need that package anymore. Has anything changed in Debian in the last couple of years or was I just a retard for installing it the previous time?

>> No.53553406

>>53553090
>how? rendering looking good on my real display/
Set up your USE flags (you can check them on a per package basis with the equery uses <package> command) and then install the latest (~amd64) version of freetype, cairo, poppler, pango, fribidi, harfbuzz, fontconfig-ultimate, and infinality-ultimate-meta.

package.use
*/* infinality harfbuzz adobe-cff xft system-cairo cairo fontconfig graphite icu


Then you apply these patches to your poppler and you're golden: https://github.com/giddie/poppler-qt4-cairo-backend

Run the following commands to enable fontconfig-ultimate:
eselect fontconfig (disable all of them, enable '[33] 52-infinality.conf')
eselect lcdfilter set 14
eselect infinality set 7


There you go, you now have the best possible font rendering of ANY operating system.

>> No.53553407

>>53553388
yes

>> No.53553411

I'm looking to switch from one distro to another (keeping it vague to not start a distro war) how do I delete already existing partitions from this distro to freshly install the other?

>> No.53553414

>>53553347
Why would anyone voluntarily use uefi?
https://github.com/systemd/systemd/issues/2402
Seriously, bios boots just fine.

>> No.53553416

>>53553399
>Has anything changed in Debian in the last couple of years
>3 years
of course not

>> No.53553421

>>53553399
it could be that someone made the generic driver compatible with your wifi chip.

>> No.53553430

>>53553411
just do it during the installation of the new one

>> No.53553439

>>53552645
I haven't used zsh in years but I think it uses escapes like 'it\'s\n', where the bourne shell(and ksh, bash, other derivatives) doesn't. This could be incompatible with some sed '...', awk '...', whatever commands.

Also on glob match failure I think zsh throws an error, where the bourne shell returns the glob as a string.

It's a bunch of little things like that, in some cases they might be improvements but it makes it incompatible with the bourne shell.

>> No.53553442

>>53553407
sorry for being retarded but do i just put Option "TearFree" "true" in t or do i have to add something else?

>> No.53553467
File: 29 KB, 640x424, Linus-Nvidia fuck you.jpg [View same] [iqdb] [saucenao] [google] [report]
53553467

>>53553326
I really hope these Polaris cards can best the 970. Even then, I don't think they'll be getting the love Tonga has gotten with AMDGPU. I don't want to wait until Vega, I really just want to get rid of this card.

>> No.53553492

>>53553354
But I did do those things, anon. I suspect it had more to do with my package and supplemental repository choices them anything else (i.e I made a FrankenDebian because at the time the version of Xbmc in the Debian repo was fucking old)

>> No.53553497

Reminder to use \e for escape sequeces to make your shell scripts incompatible to lurking OS X fags.

>> No.53553524

>>53553497
'no'

>> No.53553540

>>53553416
I clearly meant "has anything changed in Debian which might affect the need to have the iwlwifi package installed" you shit-breathed cumstain which should never have been wiped off your mother's dress and rubbed inside her gaping vagina in a vain effort to relieve the burning portion of her syphilitic sores.

>> No.53553542
File: 9 KB, 193x224, 1438010451306.jpg [View same] [iqdb] [saucenao] [google] [report]
53553542

>>53553467
>posting Linus
filtered

>> No.53553570

>>53553497
Explain.

>> No.53553586

>>53553467
Why nVidia not open source code of drivers?

>> No.53553591
File: 56 KB, 453x294, large_TorvaldsOregon.jpg [View same] [iqdb] [saucenao] [google] [report]
53553591

>>53553542
are you making fun of gnuguys comparing them to thumblerinas feminazies?

>> No.53553595

OK someone suggested to activate vsync and I went to search for the option... but nowhere to be found.

Also considering I installed nvidia proprietary driver - do i need to disable x server or delete other shit?

>> No.53553597

>>53553416
ebin distro war faggotry
>>53553586
they hate freedom.

>> No.53553610

>>53553595
Has to be enabled in xorg config. See >>53551622

>> No.53553623

>>53553597
Why?

>> No.53553639

>>53553570
Simple example.

printf "\e[31mRed Test\e[m\n" will work on common posix shells, exept OS X since the shipped shell is too old.

Full compatible would be either
printf "\033[31mRed Test\033[m\n"
or
printf "\x1b[31mRed Test\x1b[m\n"

>> No.53553642

>>53553623
because freedom doesn't bring as many shekels as they would like to see.

>> No.53553648

>>53553586
I can't run the dolphin-emulator and mpv stutters like hell. I can deal with no AAA bullshit gaymes, but I like to have emulation and video playback.

>>53553597
>they hate freedom.
I really want to get rid of it though. I would love to have a 380 and be done with it, but I'd rather wait for Polaris.

>> No.53553668

>>53553591
You got me. ;_;

>> No.53553682

>>53553639
Wtf even IS \e. Documentation has 'escape'. Does it mean the escape key as an input?

>> No.53553697

>>53553682
Terminal escape sequences.

http://www.termsys.demon.co.uk/vtansi.htm

>> No.53553708

>>53553682
http://wiki.bash-hackers.org/scripting/terminalcodes

>> No.53553737

>>53553639
- old + crippled
well, macfags can still update their shell

>> No.53553757

>>53553682
Have some toys.

printf "\033[?47h" # Save screen.
printf "\033[?47l" # Restore screen.

printf "\033]0;%s\007" "$_title" # Set title.
printf "\033]50;%s\007" "$_font" # Set regular font.
printf "\033]51;%s\007" "$_font" # Set bold font.
printf "\033]52;%s\007" "$_font" # Set italic font.
printf "\033]53;%s\007" "$_font" # Set bold italic font.
printf "\033]10;%s\007" "$_color" # Set foreground color.
printf "\033]11;%s\007" "$_color" # Set background color.
printf "\033]12;%s\007" "$_color" # Set underline color.
printf "\033]4;0;%s\007" "$_color" # Set black color.
printf "\033]4;1;%s\007" "$_color" # Set red color.
printf "\033]4;2;%s\007" "$_color" # Set green color.
printf "\033]4;3;%s\007" "$_color" # Set yellow color.
printf "\033]4;4;%s\007" "$_color" # Set blue color.
printf "\033]4;5;%s\007" "$_color" # Set magenta color.
printf "\033]4;6;%s\007" "$_color" # Set cyan color.
printf "\033]4;7;%s\007" "$_color" # Set white color.
printf "\033]4;8;%s\007" "$_color" # Set bold black color.
printf "\033]4;9;%s\007" "$_color" # Set bold red color.
printf "\033]4;10;%s\007" "$_color" # Set bold green color.
printf "\033]4;11;%s\007" "$_color" # Set bold yellow color.
printf "\033]4;12;%s\007" "$_color" # Set bold blue color.
printf "\033]4;13;%s\007" "$_color" # Set bold magenta color.
printf "\033]4;14;%s\007" "$_color" # Set bold cyan color.
printf "\033]4;15;%s\007" "$_color" # Set bold white color.

>> No.53553769

I don't have audio from my speakers but headphones are fine

how fix? Xubuntu

>> No.53553779

>>53553757
This is, btw, pretty useful for setting dynamic colors/themes in urxvt.

>> No.53553787

>>53553769
alsamixer

Unmute speakers.

>> No.53553820

I'm a but confused...
why does my Ubuntu come with alsa AND pulse running at the same time? I don't even know if I should use alsamixer or the pulse gui to set up my audio shit.

>> No.53553825

>>53553769
in the same jack hole?
turn your speakers ON

>> No.53553830
File: 1.36 MB, 1216x9822, guide.png [View same] [iqdb] [saucenao] [google] [report]
53553830

>>53553200

Got you covered senpai.

>> No.53553832

>>53553820
delete pulseaudio and only use alsa. it's easier that way.

>> No.53553838

>>53553820
Pulse mixes the audio tracks.

>> No.53553842

>>53553830
Outstanding post.

>> No.53553848

>>53553830
real fucking funny dude

>> No.53553853

>>53553820
pulseaudio does not do the same thing, its above alsa to do some special tasks
like separate volume control for applications

>> No.53553854

>>53553820
pulse is a layer on top of ALSA. use alsamixer, it should be fine.

>> No.53553857

>>53553832
Don't fuck with newbies.

>> No.53553859

>>53553830
How do you guis save full webpages? Is there a comfy cli tool?

>> No.53553862

>>53553820

Pavucontrol, the Pulseaudio control GUI. Opening alsamixer will only show 1 volume control if you have pulseaudio (and the alsa plugin) installed.

>> No.53553870

>>53553857
It IS easier that way. no idea what you mean.

>> No.53553872
File: 136 KB, 873x1063, Pulseaudio-diagram.png [View same] [iqdb] [saucenao] [google] [report]
53553872

>>53553820

>> No.53553874

>>53553859

Firefox: hit F2, type screenshot name.png --fullpage true

>> No.53553877
File: 162 KB, 457x450, weaaboo.png [View same] [iqdb] [saucenao] [google] [report]
53553877

>>53553830
I saw it too many times to be funny
and the word senpai just made me sad that everyone on /g/ is a disgusting weaboo

>> No.53553882

>>53553832
>>53553838
>>53553853
>>53553854
>>53553862
Thank you, can I uninstall pulse without issues and keep alsa? Like sudo apt-get purge pulse?

>> No.53553884

>>53552305
I like zsh's features, but I get this obnoxious problem with the default settings where it tries and fails to parse URLs for me unless I wrap them in quotes.
On the upside, it gives auto-complete for apt, which is very useful when hunting for dependency libraries to compile something.

>> No.53553895

Alsa vs OSS?

>> No.53553899

>>53553877

The slightly black and shortened version of family gets autofiltered to senpai.

>> No.53553900

>>53553882
sudo aptitude remove --purge pulseaudio

>> No.53553907
File: 69 KB, 303x350, 1449249355627.jpg [View same] [iqdb] [saucenao] [google] [report]
53553907

>>53553874
Holy fuck man, there's literally a small cli hidden inside my Firecuck. WTF

>> No.53553911

>>53553882

Name one reason why you do not need Pulseaudio. Remove it and then come complaining when some of your stuff stops working as you're used to.

>> No.53553915

>>53553825
laptop
>>53553787
they were muted in alsa and I fixed it, bumped their levels as well, restarted but still no sound

speakers show as (unavailable) in the volume control

>> No.53553917

>>53553882
Pulseaudio is useful. Keep it.

>> No.53553919

>>53553911
/g/ says the systemd guy is developing it.

>> No.53553930

>>53553907

It's part of the developer tools. Also, I forgot to add shift. It's shift+F2.

>> No.53553937

>>53553917
literally for what? appliation volume? wow, it's fucking nothing compared to fucking around with two running sound systems at the same time.

>> No.53553945

>>53553919

Valid reason. Enjoy your lack of automatic sound redirection on headphone plugging in and per application volume control.

>> No.53553951

>>53553911
it should be the other way around. most people just flat out don't need pulseaudio and it should not be included by default in any distro.

>> No.53553952

>>53553930
I did CTRL+SHIFT+F2, worked too. Any more hidden features?!

>> No.53553965
File: 47 KB, 640x422, wea.jpg [View same] [iqdb] [saucenao] [google] [report]
53553965

>>53553899
just stop

>> No.53553972

>>53553937
>appliation volume?
A good example, yes.

>wow, it's fucking nothing compared to fucking around with two running sound systems at the same time.
There's no reason to ever touch anything but Pulseaudio. Let the other stuff do its work without user interference.

>> No.53553973

>>53553945
I'm not that anon. I don't really know what I'm doing, still learning. So I keep both? Where to set my settings now? Pulse or Alsa?

>> No.53553987

>>53553952
f12

>> No.53553988

>>53553973
I just want to do everything correctly.

>> No.53553998

>>53553951

>and it should not be included by default in any distro

One of the most ignorant things I've read on here. Whatever you say. Everyone is crazy, but you.

>> No.53554002

>>53553915
also I don't know if it matters but my output profile doesn't automatically switch from headphones to speakers when I unplug the headphones. Might be because the speakers are (unavailable) though

>> No.53554005

>>53553952
control + w

>> No.53554012

>>53553998
nice reasoning lennart

>> No.53554013

>>53554005
kek

>> No.53554015

>>53553973

Via Pulseaudio, the top layer.

>> No.53554046

I'm not new in Linux at all, but I didn't know where else to ask this. Is there a way to set a proxy for different networks individually? I have to use my laptop in several places with different proxies, and I really hate to set it each time.

>> No.53554116

>>53554046

If you're using NetworkManger, nm-connection-editor might be of help. It should remember settings for each network.

>> No.53554201
File: 267 KB, 1342x1358, 1444125387688.png [View same] [iqdb] [saucenao] [google] [report]
53554201

>>53554005
Classic.

>> No.53554222

>>53553071
That reddit post looks pretty scripted.
inb4 tinfoils

>> No.53554227

What does your filesystem sound like?

ls -laR / | aplay -r 48000

>> No.53554291

>>53553899
That's even worst, kill yourself.

>> No.53554311

>>53554227
like 10 cable modems next to each other mixed with the sound of a 100 different pokemon screams

>> No.53554408

Tip for a noob to other noobs that want to try Linux/GNU.

Use virtualbox, start with lxde or mate - avoid complicated or demanding desktop environments as they require tweaking or time consumed to learn the de itself...

Get something simple that just works like lubuntu.

And focus on learning the basics, terminal etc... Linux core stuff, go balls deep and fuck everything up - you won't even care - you can alt tab to windows and browse, find shit etc.

>> No.53554755

>>53553899
>not typing senpai directly
I'm glad the nigger speak was filtered, I can't believe that kind of facebook normalfaggotry spread around everywhere.

>> No.53554758 [DELETED] 
File: 1.82 MB, 567x565, 1448242278873.jpg [View same] [iqdb] [saucenao] [google] [report]
53554758

(play me in mpv)

>> No.53554762

>>53554408
Noob here: I've been using Lubuntu on an old netbook (1gb ram) for quite some time now and the main issue I have with it is that it has a lot of shit I don't need. I like it for how lightweight it seems to be but I really want to try something else.
Is there a distro that let you choose what you want installed? Talking about programs here, not drivers and such

>> No.53554891

The Debian site doesn't have links to choose between stable, testing and unstable.
Do I just have to download it and that choice will be presented to me when I'm installing?
Or is there a button that chooses it and I'm just too retarded to see it?

>> No.53554897

>>53554762
Most distributions offer minimal installs, where you only install the base system, letting you add whatever you want afterwards.

>> No.53554917

>>53554891
it's supposed to be that way. you install stable and then upgrade to testing.

>> No.53554937

>>53554917
Oh, ok. Thanks.

>> No.53554951

>>53554891
Links to testing are there, clear as day. There are no images for unstable.

>>53554917
You're thinking of unstable. You install testing and upgrade to unstable from there.

>> No.53554974

>>53554951
These are beta versions of the installer, it is not recommended to use them. installing stable and upgrading is recommended.

>> No.53554978

>>53554897
Mmh, pretty sure Lubuntu didn't let me do that. Actually, it asked me if I wanted to download even more shit during installation.
I'll try Debian or Arch/Parabola. Are they /g/ approved?
Sorry for all this weak ass questions.

>> No.53554994

>>53554974
If that's the case, they sure do a poor job of communicating it to users. I took a look and saw testing right below stable with no mention of what you're saying.

>> No.53555018

>>53554978

You have to download the mini ISOs for Ubuntu in that case. Maybe there's a way to get to the advanced prompt from the regular installation ISOs too, but why waste 1GB when you can get the 30MB mini ISO?

>> No.53555034

>>53554978
Sorry, I should have been more clear. There's usually separate images for minimal installs. So in this case instead of getting the Lubuntu iso, you'd want the minimal iso from wherever on the main Ubuntu site. It's not always obvious where they keep them.

>> No.53555040

>>53554994
they are indeed not communicating that well. i first read it in the handbook somewhere.

>> No.53555060

>>53555040
Are you sure that recommendation is still in effect? Seems weird they wouldn't state it clearly.

>> No.53555147

>>53555060
Well I guess they think if someone wants to use the beta OS they wouldn't mind using the beta installer aswell.
Looks like they actually do communicate it in https://wiki.debian.org/DebianTesting

>> No.53555163

Is there a way to use a different WM if you are using a DE? I'm using KDE and want to try out some different WMs, mainly Awesome. Is that possible?

>> No.53555194
File: 35 KB, 640x480, 1432377002392.jpg [View same] [iqdb] [saucenao] [google] [report]
53555194

>>53555163
Just install the desired WM, go to a tty (CTRL+ALT+F1) and run a second session (startx awesome -- :1), but usually the login manager should regonize new WMs automatically, so you can select them at login.

>> No.53555207

>>53555147
Guess I learned something new today. Cheers, Anon.

>> No.53555249

>>53555163
Forgot to say, it is also possible to run a WM inside a DE; you can create, as example, an Openbox session within the GNOME shell and similiar combinations, but don't ask me for the single steps, last time I tried it is some time ago.

>> No.53555254
File: 481 KB, 1366x768, Screenshot_20160318_123332.png [View same] [iqdb] [saucenao] [google] [report]
53555254

>>53555194
tried ctrl+alt+f1, nothing happened. tried to start a parallel session, when I hit new session nothing happened.

>> No.53555256

Woot, it only took me two days but I managed to duel boot Arch and Windows 10. Interestingly my problem was with systemdboot, it kept trashing my Windows boot partition for some reason. Used GRUB instead like
>>53553347
said and it worked on the first time, go figure.

>> No.53555283

>>53555163

https://wiki.archlinux.org/index.php/KDE#Using_an_alternative_window_manager

>> No.53555293

>>53555256

Which distribution draws faster in the duel?

>> No.53555305

>>53555194
>>53555254
nvm, just logged out and back in and it works. thanks

>> No.53555319

>>53554762
This guy said, but I have a question.

Is there a way to wipe everything up once I install it?

I mean I still want to have ubuntu packages, fixes and what not.. but I want to pick my own software, there's just too much shit.

>> No.53555349

>>53555319

How do you mean wipe up? You get Ubuntu packages, after all the distribution is Ubuntu.

>> No.53555352

>>53555283
tried that, it's greyed out and wont let me select it

>> No.53555366
File: 255 KB, 1920x1080, 1436515917335.png [View same] [iqdb] [saucenao] [google] [report]
53555366

Fucking around with imagemagick:
dd if=/dev/urandom bs="$((1920*1080/8))" count=1 | convert -size 1920x1080 -depth 1 GRAY:- out.png
Ideas to make this more interesting?

>> No.53555367

>>53555349
Let me ask you the other way around.

If I take the minimal iso of ubuntu which is 40 mb - it will download up every package and be up-to-date - but will it also bloat me with useless software, or software that I not need?

>> No.53555384

I wanna buy a wireless headset for my mom:

http://www.ebay.co.uk/itm/4-0-Stereo-Bluetooth-Wireless-Headset-Headphones-With-Call-Mic-Microphone-Black-/351449697974?hash=item51d408ceb6:g:amwAAOSwT6pVnm5Z

Her PC has ubuntu. How do these headphones operate on a loonix PC? Is it possible to mute the laptop sound when they are turned on? Does the microphone work?

>> No.53555389

>>53555366
Use something with more structure than random data, like /dev/sda, /dev/mem or some binary files.

>> No.53555398

>>53555367
At this point you should just install Debian.

>> No.53555401

Using linux mint and trying to get latest maven version.

doing sudo apt-get install maven, installs the version 3.0.5

but the project I want to package requires mvn 3.2.1

Did I fell into the 'outdated packages' meme or do I just have to install it from the source and without the package manager?

>> No.53555431

>>53555319
>>53555367
If it works the same as the Debian netinstall did last I used it (years ago), then there's a step where you get to choose what extra stuff you want the installer to [download and] install. Pretty sure it's not going to bog you down with full desktop environments unless you tell it to at any rate.

>>53555398
Not if Anon prefers the Ubuntu release cycle.

>> No.53555438
File: 71 KB, 250x250, 1441503868929.png [View same] [iqdb] [saucenao] [google] [report]
53555438

>>53555389
>dd and sda in one command

>> No.53555469

>>53555401
Latest Mint is based on Ubuntu 14.04, so yeah, outdated packages are kind of to be expected.

You might be able to install the latest version, but it's very possible that it depends on package versions newer than those installed on your system, creating a rather vicious cycle.

>> No.53555485
File: 40 KB, 1920x1080, 1437148261358.png [View same] [iqdb] [saucenao] [google] [report]
53555485

>>53555389
Nice ideas.

>> No.53555486

>>53555431
Yea I prefer ubuntu release cycle, I just have every packet out of the box - and must stuff just working.

>> No.53555511

>>53555485
now merge it with an existing image of RMS

>> No.53555527

>emerge git-annex
>gentoo wants to install 200 haskell packages

WHY, this triggers me, I want to keep my installed packages as small as 300

>> No.53555537
File: 134 KB, 1920x1080, out.png [View same] [iqdb] [saucenao] [google] [report]
53555537

>>53555485
Now create a program that uses these image as the initial population of a Conway's game of life.

>> No.53555564

>>53555367

>but will it also bloat me with useless software, or software that I not need?

No, it will not. At one point it will present you a prompt where you can select groups of packages. Not selecting anything will give you a base system. I don't remember exactly, but you should at least select the "core utilities" or however it's called. It will also take you to the aptitude TUI where you can even more fine tune it.

>>53555431

It IS the Debian installer.

>> No.53555578

>>53552219
Trying to install ubuntu on my SSD alongside windows. Ubuntu doesn't recognize windows. No problem - "Do something else" SSD is shown as "free space" even though windows is installed there. I did full shutdown, disabled secureboot and fast boot. I think it's a problem with UEFI vs Legacy. Anyone know how to solve?

>> No.53555579

>>53555527
Reminds me of the horrified reactions of every minimalist ricer when they look to try out xmonad. Good times.

>> No.53555593

/flt/ proudly presents you the animated RAM wallpaper (meh included):

while :; do
sudo dd if=/dev/mem bs="$((1920*1080/8))" count=1 \
| convert -size 1920x1080 -depth 1 GRAY:- png:- \
| feh --no-fehbg --bg-fill -
sleep 1
done

>> No.53555594

>>53555564
lol the irony - I was at that step which you described in virtualbox - but because I was distracted by ( you ) I pressed enter as a mistake and it selected some random stuff.

>> No.53555598

>>53555564
>It IS the Debian installer.
Which I last used years ago.

>> No.53555603

>>53555527

How big is your hard drive? 5GB?

>> No.53555610

>>53555593
cpu would be more funny, but how?

>> No.53555632
File: 154 KB, 713x555, 1458320651.png [View same] [iqdb] [saucenao] [google] [report]
53555632

>>53555593

>> No.53555648

>>53555632
install imagemagick, imagemagick can sudo your mother (TM)

>> No.53555673

>>53555593
>>53555610
What about ps aux? there might not be enough data to fill the image but we could fill a smaller one and scale it up with nearest neighbor.

>> No.53555706

What linux distro will net me the most chicks?

I have arch on my notebook and I'm currently compiling the kernel for my gentoo install.

>> No.53555707
File: 69 KB, 960x897, how_linux_handles_it_1443958325805.jpg [View same] [iqdb] [saucenao] [google] [report]
53555707

Why should I use linux? Why is it better then windows? What is possible with Linux and not with windows.


Got dis meme but it seems like with Linux every thing goes wrong hahha :(

>> No.53555713
File: 132 KB, 1062x814, vid_1458320916.webm [View same] [iqdb] [saucenao] [google] [report]
53555713

>>53555648

>> No.53555726

>>53555707
you should not use it
we should not feed you

its that easy, use windows

>> No.53555746
File: 543 KB, 1200x2416, dont-sigkill.png [View same] [iqdb] [saucenao] [google] [report]
53555746

>>53555726
>>53555707
also forgot pic

>> No.53555750

>>53555603
8GB, my fileserver os is on a usb 3.0

>> No.53555758

>>53555707
With Windows you get:

Microsoft has backdoored its disk encryption.
https://archive.is/2XIvX

In Windows 10, the universal back door is no longer hidden; all “upgrades” will be forcibly and immediately imposed.
https://archive.is/IVzBA

Windows 8 also has a back door for remotely deleting apps.
https://archive.is/KeUmF

Windows 8's back doors are so gaping that the German government has decided it can't be trusted.
https://archive.is/Z8ItN

Microsoft is repeatedly nagging many users to install Windows 10.
https://archive.is/bwzXF

Microsoft informs the NSA of bugs in Windows before fixing them.
https://archive.is/OBGB1

Windows 10 snoops on the users' files, text input, voice input, location info, contacts, calendar records and web browsing history.
https://archive.is/MBdcI
https://archive.is/QnTTA
https://archive.is/Zny36

Windows 10 sends identifiable information to Microsoft, even if a user turns off related settings.
https://archive.is/sz1nt

Microsoft uses Windows 10's “privacy policy” to overtly impose a “right” to look at users' files at any time.
Windows 10's full disk encryption gives Microsoft a key. https://archive.is/qLRZx

Microsoft SkyDrive allows the NSA to directly examine users' data.
https://archive.is/tW6fu

Windows 10 sends screenshots of your desktop to Microsoft.
https://d2.maxfile.ro/rwspylwbwo.webm

With your favorite GNU/Linux distro you get:

Freedom.

>> No.53555784

>>53555707
Use virtual box and program for windows with it - it's like UNIX so in a way it's like a IDE itself, very very productive.

Otherwise don't use it - you waste your time.

>> No.53555789
File: 70 KB, 509x1607, why GNU + Linux.png [View same] [iqdb] [saucenao] [google] [report]
53555789

>>53555707

>> No.53555834

>>53555713
Some DEs use different methods to set the wallpaper. It's possible that feh is setting the wallpaper "below" you actual wallpaper. Common thing around DEs, don't ask me to fix that. Maybe try: display -window root <some pic> just for testing.

>> No.53555845

If I got with ubuntu minimal iso and pick up manual everything - can I only install i3 as my desktop environment?

>> No.53555929

>>53555758
>https://d2.maxfile.ro/rwspylwbwo.webm
creepy

>> No.53555956

Do you guys advice against KDE plasma?

I mean it's cool and all but for me it was an awful experience, full of bugs - too bloated - full of shit I would never use.

It's a great project and all but it does not suit well the linux philosophy - with linux only minimal/simplistic stuff properly work.

From my experience the best I enjoyed were lxde and MATE - so which one you suggest for destkop based on your experience with these two.

I will also us i3 for development and other stuff that require productivity - but right now I want to focus on desktop and making life easier on Linux.

>> No.53555960

>>53555750

I have almost 700 packages installed including a bunch of "big" stuff like LibreOffice and my root partition is 5,3GB. Chances are it will fit without you being that anal about it.

>> No.53555981

>>53555956
Never do what /g/ says, try everything yourself till full wizard mode.

>> No.53556024

>>53555845
It should be said that i3 is a window manager and not a desktop environment, but yeah, you can do that.

>> No.53556025

>>53555845

Define manual everything. Just don't select any of the things during the install. If you go with manual everything (via aptitude and deselecting everything; if that's even possible), chances are you'll forget something important.

>> No.53556034

>>53555960
I installed LibreOffice some moths ago and recently removed it. Literally never used it. Don't laugh, but when I need to print something, I copy paste into GIMP, format it and print it like a faggot.

Thanks for reading my blog.

>> No.53556090
File: 64 KB, 200x213, thunderbird.png [View same] [iqdb] [saucenao] [google] [report]
53556090

probably should go to stupid questions thread
but I am on linux so I ask anyway

thunderbird
mail loads images only when I open the mail
it annoys me
I tried quick google nothing
I did check to load images automaticly from the address
but shit nigger fuck cunt, it only does it when I click the email
instead of having everything fetched way before as it should

>> No.53556093

Is there a better way to list the size of my root partition, but not taking into account /home directories?

du -hcs --exclude=/home/* / 2>/dev/null

>> No.53556096
File: 38 KB, 480x640, 1430621182170.jpg [View same] [iqdb] [saucenao] [google] [report]
53556096

>>53555960
>700 packages
3027 here, get on my level nigga

>> No.53556135
File: 7 KB, 275x275, 1452909336853.png [View same] [iqdb] [saucenao] [google] [report]
53556135

>>53555746
Hit me right in the feels hahah

>>53555758
Thnx I now understand that you get more power using Linux and more freedom. But is it beter to use linux only for work or can i use it for my free time like gaming and watching movies. Because I know most games aren't compatibel with Linux.

>> No.53556139

>>53555706
>girl wants to Netflix and chill
>run VNC on your phone, hook it into the TV with an HDMI adapter
>boot into CLI, start i3,
>run Netflix through Wine
I don't know how any girl could say no at that point

>> No.53556148

kde is autistic as fuck - the moment you start it for the first time you can already start counting useless feature, every time you highlight a button it has to fucking waste resources into presenting your the same button again but trough an animation.

Everytime you zoom a tab, you waste more resources - and there's a constant size indicator rectangle in the center.

The list can go on and on - kde is good if you're autistic as fuck, otherwise you're better off trying anything else.

>> No.53556165

>>53556135
Use linux when you browse child pornography or illegal content, use windows for everything else.

>> No.53556191

>>53556096
BLOAT
L
O
A
T

>> No.53556193
File: 19 KB, 577x397, 1453279544104.jpg [View same] [iqdb] [saucenao] [google] [report]
53556193

>>53556165

>> No.53556200

>>53556165
Not searching for that shit. Btw there is tor for Windows.

>> No.53556217

>>53556191
My excuse: About 2k are literally -dev packages/libs.

>> No.53556223
File: 178 KB, 1920x1080, kde03.jpg [View same] [iqdb] [saucenao] [google] [report]
53556223

>>53556148
KDE is also the most customizable
when I switch to linux and my first try was ubuntu, I was absolutely shocked at how little I can customize the feel and look of my enviroment
I seriously thought that linux users were fucking trolls bating
then came opensuse with KDE4 and for 6 months I learned to prefer linux over windows, now its arch+i3 but I have found memory of KDE

>> No.53556235

>>53556200
But it's about about the surfing itself you can even do it on toaster, Linux is a enclose environment with no access from outside.

Anyway use tails if you even plan to watch stupid shit.
It will store all the history / traces on pendrive which you can just trash away after you got tired of so much infantile pornography.

>> No.53556239

>>53556223
>KDE
>customizable
install gentoo

>> No.53556250

>>53556223
If there was a hit & run wonder script / software to customize my kde to bearable standards I would totally use it again.

>> No.53556253
File: 907 B, 357x123, 1433681766863.png [View same] [iqdb] [saucenao] [google] [report]
53556253

>>53556223

>> No.53556262

>>53556223
It looks like you just installed a theme... what you done so special besides that?

>> No.53556283

The best DE is no DE.

>> No.53556301
File: 412 KB, 1920x1200, kde_2.jpg [View same] [iqdb] [saucenao] [google] [report]
53556301

>>53556239
Why? to waste time compiling?

>>53556250
yeah, I actually talked with one KDE developer on reddit when they had some talk
he did not like my complains of absofucking retarded shit experience out of the box.

>>53556262
not mine, its from /r/unixporn, search for KDE

>> No.53556320

>>53556235
Nah if you surf the Internet you are not in a enclosed environment
>>53556135
But still didn't get a real answer tho. Expect if everybody is using Linux for CP and shit
As dis guy told me >>53556165

>> No.53556326
File: 1.79 MB, 384x216, 1444574728867.gif [View same] [iqdb] [saucenao] [google] [report]
53556326

>>53556283
Everytime when someanon doesn't quote, I imagine a person standing up, saying something, and everybody is looking at him like pic related.

>> No.53556343
File: 18 KB, 152x156, image.jpg [View same] [iqdb] [saucenao] [google] [report]
53556343

>>53556301
>Packages: 4053

>> No.53556348

>>53555485
>posting bits of your memory/disks in a lossless format
sounds like a great idea

>Intel(r)Cantiga Graphics Controller
>LG Display LP156WH3-TLA1
>lemonbar
>terminus
a few strings in that picure

>> No.53556354

I have a luks home partition on Fedora. If I'm moving to arch would I mount this the same as any other home partition or is there an extra step?

>> No.53556360

>>53556326
she ruined it

>>53556343
kill yourself weaboo

>> No.53556363

>>53556326
Because of your autism, don't use imagination it's a thing we got after we fallen from Eden

>> No.53556381

>>53556360
you'll have to learn to ignore weebs if you want to survive here without raging every few seconds on retarded, pointless 2d drawings which weebs think they're part of.

>> No.53556402

>>53555537
and this one is a bit of an mkv file, probably an anime from the fancy subtitles

Input #0, matroska,webm, from '/tmp/out.raw':
Metadata:
encoder : no_variable_data
creation_time : 1970-01-01 00:00:00
Duration: 00:23:40.11, start: 0.000000, bitrate: 1 kb/s
Stream #0:0: Video: h264 (High), yuv420p, 1280x720 [SAR 1:1 DAR 16:9], 23.81 fps, 23.81 tbr, 1k tbn, 47.95 tbc (default)
Stream #0:1(jpn): Audio: aac (LC), 44100 Hz, stereo, fltp (default)
Stream #0:2(eng): Subtitle: ass (default)
Stream #0:3: Attachment: ttf
Metadata:
filename : OpenSans-Semibold.ttf
mimetype : application/x-truetype-font

>> No.53556403
File: 30 KB, 263x378, image.jpg [View same] [iqdb] [saucenao] [google] [report]
53556403

>>53556360
>hating on the official 4chan mascot

Kill yourself reddit

>> No.53556408

>>53556348
No panic buddy, it's actually just the output of /dev/tcp after reloading the /flt/ page.

>> No.53556439

>>53556096

Just for reference, how much space does it occupy?

>>53556191

It's not bloat if he uses all of it.

>> No.53556466
File: 85 KB, 426x266, 1435200903046.jpg [View same] [iqdb] [saucenao] [google] [report]
53556466

>>53552333
>>53552388
>>53552400
>>53552633
>>53552855
>>53553066
>>53553133
>>53553177
>>53553200
>>53553233
>>53553244
>>53553300
>>53553388
>>53553399
>>53553411
>>53553877
>>53553899
>>53553900
>>53553911
>>53553988
>>53554222
>>53554311
>>53554755
>>53555366
>>53555511
>>53556200
Well done, level up to: >>53556449

>> No.53556471

>>53556403
hating you
not a character or a picture
but the weaboo person that lives by it

>> No.53556491

>>53556403
What was her name again? 404 girl?

>> No.53556492

>>53556283

>has a window manager
>has a taskbar
>has a wallpaper setter
>has a file manager
>has a notification daemon
>has a bunch of other utilities

>claims he's not using a desktop environment

>> No.53556511

>>53556348

How did you extract that info from it?

>> No.53556535

>>53556511
convert input.png -depth 1 gray:output.raw

basically the reverse of what he did to make it

>> No.53556611
File: 155 KB, 750x1334, image.jpg [View same] [iqdb] [saucenao] [google] [report]
53556611

>>53556471

>> No.53556648

So I made a mistake installing kde - it was horrible, constant bugs 'n shit.

I decided to go with ubuntu mini iso - and pick MATE minimal then download the software I like.

What would be the correct way of doing so without fucking things up - including dual boot.

Delete the partitions, make them back into unallocated space - then just install over them?

>> No.53556656

>>53556402
Yes, Horriblesubs Konosuba ep 07.

>> No.53556683

>>53552802
show me the oneline equivalent bash command
> zmv -Q "(**/)(* *)(D)" "\$1\${2// /.}"

>> No.53556801

>>53556354
Bump

>> No.53556831

>>53556801
Move it to active thread:
>>53556449

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action