Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Maintenance is complete! We got more disk space.
Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 394 KB, 1024x768, h1OGEnU.jpg [View same] [iqdb] [saucenao] [google] [report]
51056685 No.51056685 [Reply] [Original] [archived.moe] [rbt]

Intended for users of all levels, including absolute beginners.

Although it is recommended to install a Linux OS on a VM (Virtual Machine/VirtualBox), it is better to try the Live ISO directly without installing anything, that way, you can get a full GNU/Linux experience.

If you are serious about switching to Linux and if you have Windows dual-booted (recommended), use it exclusively for 2 weeks, avoid Windows dual booting for that period of time, or it's likely you will start retreating back to windows instead of getting used to Linux as your new home and working on making it feel the way you want it.

https://www.youtube.com/watch?v=R33sFFhgkWk

>Recommended for beginners:
-*buntus except vanilla Ubuntu (Unity)
-openSUSE
-LinuxMint (a.k.a Ubuntu LTS + Cinnamon)

Before asking, please find the answers to your questions in resources.

Please be civil, notice the "Friendly" in every Friendly Linux Thread.

Understand that much of your software from Windows will be unavailable, (although maybe wine can make up for it.)

Resources:
man <insert command here>
your neighborhood search engine
>>>/g/sqt
/r/linux4noobs
/r/linuxquestions
https://www.codecademy.com/en/courses/learn-the-command-line
https://wiki.archlinux.org/
https://wiki.installgentoo.com/

>> No.51056700

>>51056685
Is it possible to pkbuild edit out pocket out of Firefox?

>> No.51056706

What is GNU/Linux?
https://wiki.installgentoo.com/index.php/GNU/Linux

Babby's First Linux (What distro to choose?)
https://wiki.installgentoo.com/index.php/Babbies_First_Linux

What software does /g/ recommend?
https://wiki.installgentoo.com/index.php/List_of_recommended_GNU/Linux_software

Ricing on Linux (Make it good and functional or make it worse like those at desktop threads)
https://wiki.installgentoo.com/index.php/GNU/Linux_ricing

There is also scripts for new users from Windows that are heading straight to Debian.
https://github.com/Chocolate-Chip-Computing/DebianNewbieScript

>> No.51056816

>tfw using a tiling WM with a broken keyboard

random keys are either over-sensitive or under-sensitive and te keys on either side of K don't work so I have to copy paste them

thoughts on my predicament

>> No.51056834

>HE FELL FOR THE X MEME
>USE A REAL DE INSTEAD OF THAT GAY WM
>USE A WM INSTEAD OF THAT BLOATTED PIECE OF SHIT
>NOOBUNTU
>HOW DO I INSTALL X SORRY IM NEW
>CAN I PLAY COD IN LINUX?
>DOES LINUX HAS MOAR FPS THAN WINDOWS?
>MY SOUND DOESN'T WORK HELP

>> No.51056881

>That quote
is it implying that if people where to use those distros, people would start bitching about all of them?

>> No.51056890

will the new fallout game run in linux?

cause if it does, ill ditch windows

>> No.51056900

Coming in from just learning how to use ubuntu a year ago, I don't understand why some people don't like systemd.

It seems like /g/entoo men are purposely trying to make Linux unusable.

>> No.51056928

>>51056834
Its funny to think there are people who actually believe this greentext is a joke

Linux is such a waste of time for home use

>> No.51057193
File: 1.02 MB, 1920x1080, 45629.jpg [View same] [iqdb] [saucenao] [google] [report]
51057193

>>51056928
>Linux is such a waste of time for home use

>> No.51057453
File: 58 KB, 954x549, llll.png [View same] [iqdb] [saucenao] [google] [report]
51057453

Can anyone help me? How do i change the sidebar color to grey?

>> No.51057531

need a linux distro for uni
want to go for debian because I already know the basics
should I go stable or unstable?
usage will be virtualizing other OSs and c/c++, python and java programming

>> No.51057548

>>51057531
also
netinstall and rice it myself or full install?

>> No.51057574

>>51057531
>>51057548
net-install and testing.

>> No.51057643

>>51056890
we'll know when it releases. i sure hope it does but we don't know yet.

>> No.51057703

>>51057574
ok thanks
is it correct that testing has newer packages than stable?

>> No.51057789

>>51057703
yes.

>> No.51057798

>>51057703
Yes, but testing is more stable than unstable.

>> No.51057817

>>51057703
correct.

tho i personally would netinstall stable and just convert to testing. using the testing installtion iso will also use the current alpha version of the installer which has plenty of issues.

>> No.51057896

>>51056685

>pic

Well I guess I'm not a Linux user? WTF?

>use linux
>I don't bitch

Been happier over the past 18 years than if I had used Windows, that's for sure.

>Nana's computer is slow
>look at task list
>Windows Update eating half and more of the CPU

Jesus.

>change update to manual
>fine

Ok... off to the next task, the Windows 10 "upgrade" icon...

>Remove Windows10 kb update to remove icon in system tray
>reboot
>15 minutes later after booting it shows back up

What the fuckin' fuck. Fuck you.

>> No.51058119

>>51057896
thats what windows users call malware. The first malware was windows. Bassically windows is a malware that holds other malwares, like a big piece of shit that holds other pieces of shit.

>> No.51058239
File: 4 KB, 90x67, makulu.png [View same] [iqdb] [saucenao] [google] [report]
51058239

Has anyone tried Makulu Linux?
Is it botnet?

It's boasted as a "just werks" distro. Are there better debian based "just werks" distros or should I risk electronic HIV?

>> No.51058266

>>51057817
>convert to testing
how does that work? just change the repo?

>> No.51058278

Can't find info on this: is the guest session in *buntu network ready? Like if you have UFW installed and on, is it also enabled in the guest session?

>> No.51058293

>>51058278
It is installed and on by default, just with no rules.

>> No.51058377

I want a tiling wm that can do the following

quickly full screen an app and then back to how it was setup before

dynamic gap sizes from no gaps to a few pixels when wanted

easy to resize each apps window/container either with keys or the mouse.

I have seen some good videos on desktops here that do what i want but have no idea what software they are using.

also i only seem to get good video playback when using compiz on ubuntu 15.10. can i use a tiling wm with something like compiz or does that make no sense or is impossible? i dont really understand where a compositor fits in with a tiling wm

>> No.51058406

>>51058377
Awesome WM seems to fit your needs

>> No.51058455

>>51058266
sudo nano /etc/apt/sources.list
replace every mention of "jessie" or "stable" with testing

>> No.51058491

>>51058377
i3 gaps

>> No.51058554

>>51056685
Currently I have Arch Linux installed and I want to install Debian alongside (dual boot).

I tried installing Debian using the same /boot, /home and swap.

When I ran grub-mkconfig it got the kernels and partitions confused and kind of broke everything.

Am I supposed to make two /boot partitions? How else do I fix this?

>not autistic enough to configure grub manually

>> No.51058577

>>51058239
*buntus tbh

>> No.51058641

>>51058239
after watching some videos it looks like debian with a different default desktop background.
also
>http://makululinux.com/
>default wordpress theme
>fat autist in youtube video
>$1 donated so far

>> No.51058645

>command line

Why? Why not have a gui to do that stuff?

>> No.51058649

>>51058239
You could always just, you know, use Debian.

>> No.51058655

>>51056900
http://without-systemd.org/wiki/index.php/Arguments_against_systemd
or to keep it usable. Depends how you see it.

>>51058554
last time I had two distributions on the same hardware, I had grub on my arch partition (didn't had a separate /boot partition), and installed debian normally. he managed everything itself.
In you case can you tell us your partitions ?

>> No.51058657

should i dual-boot GNU/Linux and win10 for gayming and go with an amd fx 8350 or should i try to put windows in a VM and GPU-passthrough with an intel i5 6500? GPU would be a r9 390. i can't decide.

>> No.51058676

>>51058645
because, believe it or not, sometimes the cli is more convenient.

>> No.51058698

>>51058655
>/dev/sda1 is /home
>/dev/sdb1 is /boot
>/dev/sdb5 is Arch /
>/dev/sdb6 is swap

>> No.51058707

>>51058698
you odn't have debian installed yet ? your arch works ?

>> No.51058728

>>51058707
Arch was installed originally.
I got rid of Debian after it broke everything.

>> No.51058750

>>51058655
>Is systemd really an attempt of NSA to corrupt GNU distributions?
Jesus Christ. Get your tin foil hats on

>> No.51058777

>>51058728
but what is the problem?

do you have the grub menu when you boot?

>> No.51058849
File: 138 KB, 1280x710, Airline-Cockpit.jpg [View same] [iqdb] [saucenao] [google] [report]
51058849

>>51058645
a GUI that offers everything the command line offers on one surface would look like pic related
that's why command line is better _sometimes_

>> No.51058860

What terminal do you guys use?
Currently using XTerm, but considering to switch to urxvt.

>> No.51058861

>>51058406
>>51058491
i3 looks pretty good. i am trying to find the video of the desktop i really liked but cant damnit.

>> No.51058883

>>51058860
whats the difference?

>> No.51058890

>>51058728
doing two /boot partitions is not useful since only one will be used. Don't use your /boot partition with debian, just ignore it.
You should be able to use the same swap, but I'm not sure of what would happen if you hibernate one of the system and boot on the other (probably a message saying unable to mount the swap partition and nothing else).
For the same /home partition, you can use the same, but I recommend you using two different user directory. There's config files on your ~ that might make a software not work (like firefox)

>> No.51058924

>>51058860
xfce4 terminal because i use xfce. they don't really make that much of a difference.

>> No.51059073

>>51058750
tin foil hat yeah. That's not an attempt by the NSA that's for sure, but bigger a software is, more chance you have to hide a "bug", fail on the design of the project and have security issues that can be use by people like the NSA. There's a lot of people thinking that heartbleed is a bug made by the NSA. Something that should be easy to spot with debugging tools, used for years by the NSA to spy on people... OpenSSL is a mess and that happen.

>> No.51059102

>take some anons advice, remote MATE and install Xubuntu-desktop instead of removing the entire OS
>close lid, put in backpack like usual
>go to get it an hour or so later
>it's fucking hot
>oh shit it didn't standby
>open it covered in blue every where
>turn it off, let it sit
>turn it on
>login screen is STILL a black background, now with an unthemed looking login
>now there is a thin line of dark on it
>closing the lid and reopening is now handled by something else it looks like, because the login prompt looks straight out of windows 95

T-thanks /g/ ... ;_; Rip x220T screen

What else do I need to install then to get a Xubuntu experience

>> No.51059125

How the heck do I configure ALSA to work with multiple sound cards? Say I want to play audio from my speakers when I turn on my stereo receiver, but by default I should be using headphones whenever my O2+ODAC USB is plugged in.

**** List of PLAYBACK Hardware Devices ****
card 1: DAC [UAC1 DAC], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: DG [Xonar DG], device 0: Multichannel [Multichannel]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: DG [Xonar DG], device 1: Digital [Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 3: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 3: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0


The only thing keeping me on Debian GNU/Linux instead of OpenBSD is the lack of pass utility for password management. PulseAudio sometimes works, sometimes doesn't. It almost seems like there's no solution.

Even better if I could just play audio to both sources at the same time, then I can just control the source with the power button on my stereo receiver.

>> No.51059136

urxvt or xterm?
Neither?

>> No.51059178

>>51059136
rxvt-unicode has less legacy code in it and still works just like xterm. Do note that rxvt-unicode doesn't come with 256-colors support by default, but there's commonly patches and distribution packages for rxvt-unicode-256colors.

From the pesrpective of being pure, st (stterm) is the choice of terminal emulator. It's just a pure terminal emulator, no terminal multiplexing and other features that tmux would do.

Anyway, no reason to use xterm. Use anything else.

>> No.51059209

>>51059102
Are you the same guy as
>>51056527

jfc how can you fuck up that badly?

>> No.51059334
File: 1.61 MB, 320x213, PizzaDay.gif [View same] [iqdb] [saucenao] [google] [report]
51059334

>>51059209
I found a way.

Anyways update: everything is fine, it is just Planck that is making the line and a ghosting issue that made me not realize it was software based.

So now I have two (or 3 i guess) core issues: how do I make the login screen look like shit, and in XFCE what handles things like standby logon and have it resume to a login prompt?

S-sorry for autism

>> No.51059570
File: 69 KB, 960x589, hds.png [View same] [iqdb] [saucenao] [google] [report]
51059570

>pic related

I think I screwed up somewhere. My SSD is missing. That 105gb partition has linux in it but I have this ubuntu/ drive at the top also. I'm worried I might have ended up with two installations - one alongside windows which isnt showing because it's on my ssd and one on the 105gb.. not entirely sure. Any ideas?

>> No.51059825
File: 18 KB, 327x344, 1415834762836.jpg [View same] [iqdb] [saucenao] [google] [report]
51059825

Hello /g/
I'm going to completely remove winshit from my machine and seeking for good notepad++ replacement.
Currently running archlinux.
Any tips?

>> No.51059850

How can I "make" my ftp server http without apache thing? Like many "http://ftp.~" sites.

>> No.51059876

>>51059825
vim

>> No.51059967

>>51059825
for a straight up raplacement, geany

but really, vim

>> No.51060007

>>51059876
works fine,
thanks bro!

>> No.51060053

>>51059570
show me

sudo fdisk -l

>> No.51060101

>install linux because steam OS so year of the linux desktawp!
>only 71 out of my 502 steam games are compatible
>welp
on a less retard note :
why is deluge so slow ? getting like 1/5th of normal speeds with it when changing from 2.2 utorrent, already changed ports but no effect ?

>> No.51060107

>>51059850
You want ftp or http?
For ftp, you can use vsftpd for example.
FTP is deprecated though.
For http I recommend nginx, but you can also use lighthttpd, apache or cherokee for example. Cherokee actually has an advantage of having a nice config panel, so you don't have to edit text files.

>> No.51060133

>>51060101
did you run utorrent on linux?

>> No.51060134

>>51060101
I recommend you transmission-qt


if you have to pick 3 games out of those 502, which would you pick ?

>> No.51060181

>>51060101
Probably you have missconfigured connection settings (number of connections and such) and/or have a smaller DHT client table.

>> No.51060255

>>51060101
>you can't play all the games you wouldn't play anyway

>> No.51060259
File: 384 KB, 1024x768, 1436124784300.png [View same] [iqdb] [saucenao] [google] [report]
51060259

I want to install arch on skylake. I don't have a dvd-drive so I'll use a bootable usb drive.

Will an old version of arch even boot on skylake computer since it is a new architecture?

>> No.51060299

>>51060259
All x86-64 CPUs are compatible. Better question is if the chipset will work.
You can boot with the liveusb and before installing check if there are problems with drivers or so.

>> No.51060334

winbabby here, would Linux Mint XFCE be a good starter distro?

>> No.51060352

>>51060334
Yes, it would be fine.

>> No.51060364

>>51060334
Yes. Maybe xubuntu would be better. I started with mint cinnamon and I don't regret it. Using debian now though.

>> No.51060382

>>51060352
thanks luv

I'll probably set up dual boot tommorow, are there any things I should know before hand (about using Linux)

>> No.51060403

>>51060133
nah, it was on my wangblows 7, apparently you have to run it on wine, but that is no longer that compatible according to WineHQ.
>>51060181
tryed fucking round with connections, the d/l rate gets shitter any time i go either side of 200 connections, how do i change DHT client table ?
>>51060134
new client was next on my hitlist, will definitely give it a go. As for 3 games well they would have to be Grim Dawn, Stronghold II and EvE

>> No.51060416

>>51060134
>implying he's using KDE

>> No.51060422

>>51060403
>apparently you have to run it on wine, but that is no longer that compatible according to WineHQ.
You're considering running utorrent in wine on linux?
Holy shit, I've heard it all now,

>> No.51060432

>>51060299
https://aur.archlinux.org/packages/linux-git/

I just want to install that kernel, could I boot into arch and then install it with that kernel?

is it something like:
pacman 4-3-kernel

or something like that once I get to the command line?

>> No.51060443

>>51060416
>think qt is tied to kde

>> No.51060444

>>51060416
transmission does'nt belong tto KDE

>> No.51060447

>>51060403
You don't, it gets filled up when you download torrents.

>> No.51060452

>>51060432
4.3 isn't released yet.
You could install the rc though.

>> No.51060458

>>51060443
>>51060444
well considering pretty much every other major DE uses gtk, you would think that the standard recommendation would be transmission-gtk

>> No.51060475

>>51060458
Pretty much every distro comes with qt moron.

>> No.51060482

>>51060432
It's yaourt -S linux-git if you have yaourt. Yes, you can install after booting, if it boots properly.

>> No.51060496

>>51060382
It does not work like windows. Don't expect it to be the same.
Have fun and back up your stuff so you don't need to be scared of accidentallying the whole thing.

>> No.51060535

>>51060496
>Have fun and back up your stuff so you don't need to be scared of accidentallying the whole thing.
On Windows I use a program called Acronis True Image to make daily backups

Now, I know there's probably a metric butt load of those, but one feature I like is that it can "inject" itself before Windows, so that right after POST I can click f11 to go into the Recovery Manager

Pretty gud if I don't want to whip out the DVD

do any Linux imaging programs have anything similar?

>> No.51060556

>>51059825
>>51059876
that's the first time I heard someone saying :
"works fine, thx bro" after someone recommending vim.

>> No.51060568
File: 1.38 MB, 386x286, 1443285670722.gif [View same] [iqdb] [saucenao] [google] [report]
51060568

>>51060452
>>51060482
thanks

>> No.51060571

>>51060458
both are good.

I think I just like qt because i worked with it in the past.

>>51060403
Gonna try stronghold 2.
If it is like a age of empires sort of game, you try 0AD . Is free. as freedom.

>> No.51060604

>>51056816
buy keyboard or fix current one

>>51060535
you could boot to recovery mode in grub if you mess up things.

>> No.51060621

>>51060604
>you could boot to recovery mode in grub if you mess up things.
would that allow me to restore an image from any imaging programs?

>> No.51060948
File: 70 KB, 540x720, 1436559230455.jpg [View same] [iqdb] [saucenao] [google] [report]
51060948

I'm this fag >>51060007
>>51060556
I really like linux programs running in terminal.
Vim werks for me.

>> No.51060962

>>51056685
When I look at Stallman`s photos i feel a bit strong desire to masturbate, is it okay?
Sory for my bad Polish

>> No.51060973

>>51060621
pls

>> No.51061153

>>51060621
http://www.acronis.com/en-us/business/backup/linux-server/
but you could also just write an image.

>> No.51061191

>>51060571
this is most distressing for the games.
trying transmission now but so far it seems to be doing well.
Thus far it is not looking good for 2015, maybe 2016 will be the year of the linux desktawp.
I needed a clean out of my old windows OS so it's not a total loss i guess.

>> No.51061198

I have some experience with Linux, but I don't know what distro I should use. A friend told me that Debian is a good one, but completely dislike that left-side menu bar Debian and Ubuntu have by default. Should I install Debian and try ricing it away or am I better off installing another distro? And if that's the case, do you recommend Mint?

>> No.51061260

>>51061191
you have a better attitude than yesterday.

one week more and you will feel the pain of going back to win.

>> No.51061369

>>51060962
yes. that means you love Freedom

>> No.51061421

>>51061198
left-side menu bar? what? are you talking about the unity DE? just do a netinst of debian with xfce or whatever you like. if you want something easier go xubuntu.

>> No.51061439

>>51061198
>. A friend told me that Debian is a good one, but completely dislike that left-side menu bar Debian and Ubuntu have by default
when you install debian, it ask you which desktop environment you want. you confused with ubuntu that have the left bar (the DE is unity).
I think you should install debian in a VM, and select all the DE during the install process. Then when you'll login, you'll be able to choose which DE you want to use for this session. Try them all, modify them, rice them a little see what you can do with them, and once you choose which DE you prefer, you can :
install debian with the DE you want
install a distribution that comes with this DE.

>> No.51061502

>>51061421
>>51061439
Ok, thanks a lot! I'll try that.

>> No.51061517
File: 20 KB, 468x243, Karte_Bundeslaender.gif [View same] [iqdb] [saucenao] [google] [report]
51061517

why should I switch from ubuntu 15.10 to arch?

>> No.51061522

hai /flt/
>>51057531 again

have installed debian now and a bunch of crap via apt-get
for virtualbox I did
apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') virtualbox
and according to the wiki it should set everything up but I get
WARNING: The character device /dev/vboxdrv does not exist.
Please install the virtualbox-dkms package and the appropriate
headers, most likely linux-headers-amd64.

You will not be able to start VMs until this problem is fixed.

virtualbox-dkms and linux-headers-amd64 ARE installed and additionally:
modprobe vboxdrv
modprobe: FATAL: Module vboxdrv not found.


So am I fucked or am I fucked?
I don't see how I did anything wrong but yet nothing works

>> No.51061545

>>51061517
Pacman and AUR

>> No.51061563

>>51061260
t-thanks anon, trying to initialize a dual boot now, w-wish me luck.

>> No.51061564

>>51061517
i don't think you should. try distrohopping for a while if you got the time.

>> No.51061572
File: 5 KB, 198x200, meinneger.jpg [View same] [iqdb] [saucenao] [google] [report]
51061572

>>51061545
Name a major advantage of Pacman over apt
Name three non autism-tier pieces of software you can get through the AUR which aren't available via a PPA or the usual *buntu repos

>> No.51061598

>>51061564
I did, but somehow ubuntu always got me back.
Everything works just flawlessly (except that it could have more performance sometimes, I guess)

I don't know where I had which problem but on some distros my multitouch wouldn't work on other distros suspend wouldnt work out of the box. It was just a pain in the ass.

Ubuntu just does everything for me

>> No.51061624

>>51061598
if you like it and don't see a reason to switch just stay, nothing wrong with it.

>> No.51061644

>>51056685
Why is vanilla Ubuntu excepted in the main thread? I just noticed that. What's so non-beginner friendly about it?

>> No.51061676

>>51057531
>Distro for University
No question, go stable

>> No.51061684

>>51061644
it is beginner friendly but unity had spyware in it and is generally hated among /g/entoomen.

>> No.51061689

>>51061644
"Everyone" hates Unity

>> No.51061696

>>51061522
reinstall vbox, make sure to read the bulld logs

>> No.51061772

>>51061572
the native search feature is actually usable

>> No.51062093

I installed ubuntu on desktop
Should i rice or no....
Reminds me alittle bit of mac
How do i move toolbar from left side to bittom?

>> No.51062150

>>51062093
It's unity, so you don't.
install a different desktop environment, and choose it when you log in.

>> No.51062353

>>51061684
Spyware?

>> No.51062377

How do I start learning iptables?

>> No.51062409

>>51056685
WHat is the best and trustworthy website to be up to date with linux world news? Also generally what are best tech/IT/programming/nsa/etc. news websites?

>> No.51062422

>>51056928
top kek, though this into that meme post next thread fam

>> No.51062437

>>51056928
so how come people get defensive when windows has issues but on GNU/Linux it's some hilarious joke of an OS for it

>> No.51062846

I've been having a weird problem with gdm (and lightdm).

A few days ago gdm randomly started glitching out. It would start up, show the greeter, but without any users displayed for login. When i click on anything in the top status bar, it works fine.
I've googled for hours and it's none of the problems described anywhere. So i just tried lightdm. It worked after installation, but after a reboot, it doesn't work anymore, only if i reinstall it entirely. (gdm always glitches out though)
The only significant thing i've done before it stopped working was compile gnome-shell from source and install it (reinstalled from my systems package though)

Here's the gdm greeter.log if anyone has an idea what might cause this.
http://pastebin.com/v76mZ6Jx

>> No.51062919

>>51056881
Bethesda has a history of not porting any of their games but who knows man

hard to ignore us now that the Steam controller and accompanying devices are out.

>> No.51062987

>>51056685
I'm installing archlinux and I'm trying to pacstrap base base-devel into /mnt as per usual but I get the error: key "XXX" could not be looked up remotely. I can't install archlinux-keyring obviously because I'm on the live cd. I downloaded and burned the cd yesterday. What should I do?

>> No.51063016

>mfw bought a black and gray, with green detail checkered cargo short
>it's a linux mint cargo

Nice Blog™

>> No.51063092

>>51062987
I ran gpg --refresh-keys and It tried to import the missing keys but failed for some reason.

>Import PGP key XXX "name <email>", created date?
>error: key "name <email>" could not be imported
>required key missing from keyring

>> No.51063139

>>51063092
I rebooted the livecd and it failed to start and initialize keyrings or something at the screen where it loads everything. I'm not sure why or what to do to fix it. I can't say the exact error because it's going a bit fast.

>> No.51063146

I'm installing Arch on VM right now. How do I verify the checksum?

>> No.51063327

>>51063146
nvm powershell command is Get-FileHash <filepath> -Algorithm MD5

>> No.51063522

>>51063139
I switched from a disk install to a usb install. It says: failed start initialises pacman-keyring. pacman-keys --init doesn't work, even though it doesn't show any error when I do it. I can't even install the base package on the system right now.

>> No.51063615

>>51063522
it was a time problem, my machine seems to think we're in 2007, so setting the internet time fixed it.

>> No.51063642

I'm planning on replacing my current installation of Windows 7 with GNU/Linux, but I have quite a few large files that I'll need to transfer over. Is there any way to do so without having to upload it onto the Internet and re-download it?

>> No.51063660

>>51063642
I like to make a backup partition but I'm not sure if that's recommended, especially if you've never played with partitions. Let others tell you if it's a good idea.

>> No.51063689

how do I change my ranger theme?
found one I like but I don't know what file I'm replacing

http://dotshare.it/dots/959/

>> No.51063700

Say I would like to run ubuntu but don't care to have a full DE.

Is it reasonable to just install ubuntu minimal and build from there?

>> No.51063827

>>51063642
>>51063660
yeah, just make a backup partition instead. you can read files from ntfs partitions from linux

>>51063700
install lubuntu

>> No.51063830

>>51059334
get xscreensaver and SLiM

>> No.51063882

I'm on a forced -1 channel when I try to use aircrack-ng. How come? Won't let me change to the channel I need

>> No.51063895

>>51061572
the AUR is like having EVERY PPA

pacman doesn't have the ticking timebomb that is apt-get autoremove (marks shit seemingly randomly and sometimes takes away things you want like an icon pack)

>> No.51063911

>>51063689
~/.config/ranger/rc.conf

>> No.51063918

>>51063911
That's what I was thinking, but it didn't work. Are you sure?

>> No.51064012

>>51063918
Oops, replied without looking at the source. Check this:
http://ranger.nongnu.org/pydoc/ranger.gui.colorscheme.html

Seems more awkward than it needs to be...

>> No.51064085

>>51064012
okay.. got the colors to switch, but is that all that file was? the preview image showed it having two columns instead of 3 and it looked a lot better. I was hoping that was part of the config

>> No.51064103

>>51057453
Edit the theme CSS. It's in where you installed the theme.
If you can't do it then ditch the idea or pay someone to do it.

>> No.51064139

>>51058861
Remember to use one of the gaps forks from github/AUR/your choice of unofficial repo, regular i3 doesn't want into gaps

>> No.51064147
File: 5 KB, 696x45, snapshot3.png [View same] [iqdb] [saucenao] [google] [report]
51064147

>>51056685
everytime I open a song, the icon of my music player appears in the taskbar/panel (see pic related). it keeps "working" for like 10 seconds, before disapearing.the song of course plays instantly, and the icon has no impact.
can I remove/disable/do something about it? if I just open several songs in a row, my panel will be full of that shit, like in pic related.

>> No.51064731

Why do ubuntu get so much hate? Just installed it because I found out #! is done. It's not as bad as they make it out to be. I mean it's not anything like Fedora or Arch but it has it's own place in the market.

>> No.51064751

>>51064731
*does

>> No.51064897

>>51064731
>>51064751
Amazon fucking shit up.

>> No.51064906

>>51064731
well, i started with it.

it a bit scaled down my initial shock (i knew nothing back then, and i was very surprised when i saw /dev/sda instead of C:\), so i'm not judging it too harshly. but unity is bad. especially on slower computers. it lagged every time i opened menu. it was unusable until i downloaded xfce.

now i'm using debian and testing solus. and i'm satisfied with my linux distro history.

>> No.51064999

sudo pacman -S kde-meta
erorr: target not found: kde-meta


wat do

>> No.51065013

>>51064999
o shit I got trips

>> No.51065029

>>51064731
>#!
whats that hashtag for?

>> No.51065072

hi /flt/

im new in the linux world, a couple of week got xcfe mint on my thinkpad and xubuntu on my desktop.

the mint instalation its grath for now, i got zero issues and im very happy.

the desktop instalation in the other hand, got the, for what i search on internet, very usual audio problem.

i have a m3n78vm mobo whit Via high def audio and for what i read the via assholes dont share their driver for linux.

any recomendation whit a distro whit nice audio support specialy whit VIA audios?

i really dont want to set everything back again and again.

ty

>> No.51065150

>>51065029
It's the name of the distro. Crunchbang.

>> No.51065161

>>51064999
>erorr

>> No.51065347

>>51065161
I'm trying to install my archlinux's initrc (systemd) with openrc, but after following this guide: http://blog.notfoss.com/posts/openrc-on-arch-linux/ up to the point where he says to reboot into openrc, after rebooting it says INIT: No inittab file found, then under it there's "Enter runlevel:" and no matter what I say (default, boot, shutdown) it asks me again.

What did I do wrong? I can still fix it from the live cd

>> No.51065368

Anyone know how to fix pic related ?
Battle.net launcher asked me my email and passwd and now I just have this white screen. Search a little and going to try one or two stuff, but if anyone knows..
CPU is FX-8350 and GPU a R9-280X with free drivers.

>> No.51065382
File: 7 KB, 1194x747, battle.net.png [View same] [iqdb] [saucenao] [google] [report]
51065382

>>51065368
ans as usual I forgot the pic.

>> No.51065420

>>51065347
also openrc-sysvinit should be installed but when I try to reinstall it it says: init-openrc: /dev/initctl: no such file or directory. I checked and /dev/initctl does exist.

>> No.51065454

>>51057453

Which icon theme is it, please?

>> No.51065486

reminder:
VMware does not respect the GPL:
https://sfconservancy.org/news/2015/oct/28/vmware-update/
https://news.ycombinator.com/item?id=10465435

>> No.51065497

>>51064999
-As kde

>> No.51065528

>>51065497
Or -Ss

Fuck Google keyboard

>> No.51065582

I need to learn about modules, and whether or not certain ones are loading at boot.

My new skylake system isn't working right, and I am wondering if the required modules are loading. I am not even sure what modules it needs.

>> No.51065611

>>51064999
>He fell for the Arch meme
HAHAHAHAHAHA WHAT A FUCKING FAGGOT.

>> No.51065623

>>51065582
$ man modprobe
$ man modprobe.d
$ man insmod
$ man modinfo

these commands aren't in a special order
or just google it

>> No.51065649

I've been using linux for a while now, but none of the environments have really sat well with me.

I just want several terminal windows open and visible at once, no user interface or mouse support. Is there a DE that does this? I namely use irssi, cmus, and vi. I'm an author and I need the no-frills, distraction-free environment on my computer.

>> No.51065699

>>51065649
>I just want several terminal windows open and visible at once, no user interface or mouse support. Is there a DE that does this? I namely use irssi, cmus, and vi. I'm an author and I need the no-frills, distraction-free environment on my computer.
You're looking for a gayass WM, install a gayass WM like the gayass i3, you gayass maggot.

>> No.51065863

>>51065072

sorry for bump but i want some opinions

>> No.51065939

>>51065420
I got it working but how the fuck do I start gdm with openrc?

>> No.51066009

>>51058849
yep

i've yet to see a gui for ffmpeg that isn't either;
- a clusterfuck
- severely limited by comparison
for example

>> No.51066038

hi, /fgt/s!
Just a quick question: I am a funtoo user, and when I first time installed it I used the default debian stable 3.19 kernel. Later, I thought it would be a good idea to try a custom gentoo kernel; So, I made a good config, compiled, make install && make modules_installeh it, generated initramfs and updated boot configuration, adding a new one, where I changed only the kernel and the initramfs. When I try to boot, it goes into a kernel panic, saying that it's unable to find primary boot device.
wtf? I changed only the kernel and the initramfs!
tl; dr: funtoo with new kernel and old boot configs is not booting. wat do?

>> No.51066127

SO something's wrong with my desktop environment in Arch -- it's just giving me a black screen. How do I prevent it from auto launching when I start?

>> No.51066188

>>51066127
>He fell for the arch meme

>> No.51066259

Is there any way I can bind Meta + Arrow keys to moving windows on xfce4? Like windows button arrow keys on windows?

>> No.51066295

>>51065611
The Arch meme is where you pretend it's bad. So, actually, you fell for it. How does it feel?

>> No.51066299

>>51065347
Why don't you just follow Arch's own documentation.

>> No.51066364
File: 1.05 MB, 1196x768, battle.net.png [View same] [iqdb] [saucenao] [google] [report]
51066364

>>51065368
>>51065382
One anon asked me on the previous thread to tell him if I could manage to install heroes of the storm in archlinux.
Pic related. I still have to download the game and try it, but it should be fine.

if there is the white screen issue on the launcher, go on the settings of wine via playonlinux, select windows xp, make sure you use the last version of wine.
What is weird is that wine was set on windows xp, but the nothing happened (launcher didn't appeared). Then I change it for windows 7 and had the white screen issue. Going back to windows xp fixed everything.

>> No.51066372

>>51066295
You seem confuse:
'Arch' itself is not a meme.
'Arch is a meme' is a meme.
My whole post was just that, a joke.

>> No.51066382

>>51066299
I'm pissed off it's not showing any fucking thing about DMs my desktop computer hasn't worked for 2 days and now I'm so close but I can't start fucking gdm and I'm back on systemd because I can't even get the network to work and the archwiki is worthless for openrc and now I'm on systemd but gdm doesn't work yes I installed xorg and yes I installed drivers fuck my life.

>> No.51066424

>>51064999
>kde-meta
That package doesn't exist, anon.

>> No.51066428

>>51066372
sorry I was feeling bullied and reacted inappropriately

>> No.51066447

>>51066127
you think you're going to get a serious answer with that amount of details?

>> No.51066457

>>51065649
openbox is nice and light


I would say use openbox or i3 or awesomewm or just go into a TTY and use tmux

>> No.51066474

>>51066428
You were being bullied, just with memes.

>> No.51066484

>>51066127
can you get into another TTY?
>>51064999
put an asterisk at the end

there are many packages that start with kde-meta

>> No.51066489

>>51066474
I feel like this should be a banner post

>> No.51066512

>>51066382
Why not just install funtoo? You could have done that in half a day and be plain sailing by now.

DEs with openrc are not much different than with systemd. Fuck gdm, it's a buggy pile of shit. If you can't get the network to work then you probably missed something, pretty sure Arch's docs mention this. Depends what you use though, I just have wpa_supplicant and dhcpcd as services and connect to wifi through wpa_gui.

Arch isn't the be all and end all, spend some time with funtoo/gentoo and you will see it is far better.

>> No.51066520

>>51066484
>asterisk
>with pacman

>>51064999
The package you're looking is plasma-meta and kde-applications-meta

Look at the wiki next time: https://wiki.archlinux.org/index.php/KDE#Installation

>> No.51066534

>>51066512
I'm already having trouble installing arch and I'm about to destroy my screen. I feel like installing gentoo would make me throw it out the window

>> No.51066539

>>51066520
>>asterisk
>>with pacman
does that not work? didn't try because I didn't want to install kde

I feel like I have done that with apt before

>> No.51066547

>>51066539
It doesn't, not with pacman, it works with apt-get.

>> No.51066558

i have come to a conclusion after my recent foray into the ganoo/linex-verse:
>freedom is not free
>freedom is struggle
>freedom is effort
>but most of all freedom is pain
So in conclusion i posit that it should not be called freeware but revolution ware.
Thus ends mai blog.

>> No.51066568

>>51066534
Go for funtoo, the install is much easier and quicker than gentoo. Seriously, arch isn't worth the amount of hassle you're getting, especially if you're interested in not using systemd. Look over the funtoo install guide, it will seem long at first but once you read over it you'll see it's literally a few commands and just werks.

>> No.51066589

>>51066547
oh.. that's depressing

>> No.51066607

>>51066558
freeware is gratis stuff, free software is the libre stuff

what is this pain you experienced?

>> No.51066665

>>51066489
>a banner post
Do it

>> No.51066668
File: 387 KB, 1920x1080, 1435040878338.jpg [View same] [iqdb] [saucenao] [google] [report]
51066668

>>51066558
pain cleans your soul.

>> No.51066789

>>51059102
install gentoo tbh

>> No.51066823

>>51060334

>Xfce

another one fell for the meme boys

>> No.51066841

Installing Mint right now. If I want absolutely beautiful rice, which would be the best DE? Very confused on what to pick and the time I used KDE (Kubuntu) I just fucking HATED the taskbar since it acted buggy AF.

>> No.51066852

>>51060334
Ubuntu flavors would be better if you ask me.

>> No.51066876

>>51066841
>If I want absolutely beautiful rice.
Rice is a waste of time.

>> No.51066892

>>51066382
So it think gdm is started. systemctl says that gdm is active and running, but I don't see anything. What can I do?

>> No.51066907

>>51066876
When I have to use my laptop constantly I like to have something nice to look at to make me feel good. I probably shouldn't have said rice.

>> No.51066991

>>51066259
anyone know this? Google hasn't been very helpful

>> No.51067002

>>51066991
yes, set it in the keyboard shortcuts

>> No.51067224

>>51066668
i see you have an affinity for seamen

>> No.51067294

>>51066841
If you want to rice, then no DE for you. WM+bar only. BunsenLabs is meant for minimalism, but is also pretty much ready to rice out of the box. Conky, Openbox, Tint2. Maybe swap Openbox for E or i3.

>> No.51068085

My custom start page has tabs that expand on hover for my desktop, but on my laptop with Linux, I just see the text that identifies the tabs. Am I missing something?

>> No.51068144
File: 1.57 MB, 1944x2592, IMG_20151029_003759.jpg [View same] [iqdb] [saucenao] [google] [report]
51068144

Oh god the decisions. I've been using openbox for years. Is now the time for a change?

>> No.51068160

>>51068144
Honestly... no. I've tried a lot of shit and openbox is still my favorite. I'm trying to learn i3 on the side (got it on one or two machines instead of openbox) and so far it's not as comfy

>> No.51068186

>>51066364
Still didn't downloaded the game completely but I could try and it works fine. Ofc I have to lower the settings compared to windows but it works.

>> No.51068468

I'm this >>51064731 poster from earlier. Anyone go from crunchbang to archbang?

>> No.51068605

>>51068468
I tried it once. Didn't like it much at the time. These days that's basically what I use, though. I have a regular arch install with openbox and tint2 and all that other crap.

>> No.51068750

ok im trying to install debian, using unetbootin

should i go for testing_netinstall or the testing_hdmedia?

also go for the x64 option or no?

>> No.51068797

>>51068750
I used netinstall.
Don't know about the second one though.

>> No.51068859

>>51068750
go with your preference. netinstall will be long as fuck during the install, hdmedia will be long as fuck before the install.

>> No.51069115

How come League of Legends keeps getting stuck in PlayonLinux?

Fucking Riot fix your shit.

>> No.51069221

>>51069115
perhaps they do it on purpose...

>> No.51069242

>>51069115
HoN and dota2 works natively.
Get better friends

>> No.51069299

>>51056685
SSH is suddenly not running on port 22 to my server I rent (Ubuntu 14.04)

I have been googling and have no idea what to do.

Any assistance would be greatly appreciated

>> No.51069439

>>51068750

go for stable ffs

>> No.51069497

>>51069242
I quit for Dota a long time ago. I'm only getting back into because I can win a decent chunk of change if I play for some losers at my college.

>> No.51069698

I have this issue on Arch with Plasma/Openbox: for some reason, no matter the font, in my terminator or Xterm terminal the letter spacing is off, way to close with makes it hard to read. Didn't find a solution online so far. Anybody knows this issue?

>> No.51070077

>>51056685
Is it better to encrypt my install when prompted or my HDD? What's the difference?

>> No.51070307
File: 288 KB, 368x699, 1444222789860.png [View same] [iqdb] [saucenao] [google] [report]
51070307

Can using the physical volume control buttons and mute button in T420 change the active soundcard?

>> No.51070567

>>51069698
that's kerning

perhaps install infanility?

>> No.51070579
File: 398 KB, 600x847, 161.jpg [View same] [iqdb] [saucenao] [google] [report]
51070579

testing

>> No.51070584

>>51070307
are you asking because you think it's causing an issue? that sounds unlikely and oddly specific

>> No.51070638
File: 19 KB, 449x374, Lain_navi.jpg [View same] [iqdb] [saucenao] [google] [report]
51070638

whats more user friendly CrunchBang++ or Arch?

>> No.51070670
File: 445 KB, 1019x257, employment.png [View same] [iqdb] [saucenao] [google] [report]
51070670

>>51070584
Yes, Active sound card for my T420 now is HDA intel PCH.
Which is a fresh install, before that the sound stopped suddenly, and I've hadn't upgraded anything.
The only thing I did was using the mute button, which is an issue under XFCE.
So I've re-installed pavucontrol and everything worked back for a while until it stopped working again.
During that time I noticed the active sound card was dummy output device, and the current sound card isn't visible.

>> No.51070762

sex with xfce!

>> No.51070797
File: 117 KB, 500x158, tumblr_inline_nc9bmbCK911s1od9b.png [View same] [iqdb] [saucenao] [google] [report]
51070797

>>51070762

>> No.51071239 [DELETED] 

I'm having a little trouble setting up a fresh install of Arch on my laptop. Following the wiki I get up to partitioning my hard drive for a EFI system partition.
When I am in (parted) and go:
>mkpart ESP fat32 1MiB 513MiB
I get:
>warning: you requested a partition from 1049kB to 538MB the closest location we can manage is 1048kB to 1048kB is this still acceptable to you?
Any help or advice would be appreciated!

>> No.51071595

>>51070797
I want to impregnate xfce!

>> No.51071733

I not on my laptop, still I want to get it off my chest and ask for assistance.
I do believe that the threas will still be there.

So I managed to make warframe work on the ubuntu 14.04.
Then, I installed the directx 9 with winetricks in order to hear some sounds and fix the actually needless texture issues.
I wish I didn't.

I assume since doing it, I can't play it at all and am stuck on the launcher window with a blank screen where only the useless retry/play button is reacting.


What can i do to get it back working again?

>> No.51071778

>>51071733
Goddamit.
Forgot the name of the game:
Warframe.

Btw:
Excalibur a bro.
A BRO.

And valkyre the best.

>> No.51071807

>>51070567
Will try that, thanks a lot, based anon!

>> No.51071917

>>51056685
Ok, let's give this a shot.
I really want to try openSUSE but every single time I try to install it (either tumbleweed or the other one), when booting from a fresh install I get "Kernel panic: not syncing. No init found.". Tried this up to 4 times in a single day and gave up after not finding a solution.

>> No.51071966

I installed Arch as my first distro, followed beginner's guide and all that. Instalation was successful but I lost my internet after instalation. Can't ping www.google.com nor 8.8.8.8. Changed to other HDD and everything works fine. The hostname was set while instalation took place. Loading the module made no difference either. P-please help...

>> No.51071997

>>51071966
did you enable dhcpcd or sudo dhcpcd?

>> No.51072223

>>51058645

If you know your shortcut keys by heart you can use your system blindly.

>> No.51072234

PSA: Install 4.0.9 from the kernel ppa to enable pci-passthrough on ubuntu wily. However, nouveau will just plain break.

>> No.51072266

>>51060101

>using Linux
>not using glorious rtorrent

what the fuck are you doing niqquh

>> No.51072318

>>51072266
rtorrent is shit though

>> No.51072373

>>51072318

Yes that's why every seedbox company uses it since it handles 5000+ torrents easily.

>> No.51072400

>>51072373
Yeah, it's good for seedboxes. For regular home users it is pretty shit.

>> No.51072501

Some questions, I could google for hours and still not be sure so thought I might ask here

1) If I use a separate /user/ partition, will reinstalling just comprise wiping '/', apt-get install <everything> and then I'm up and running again, or am I missing something?

2) I have only experience with ubuntu. If I install Debian (space/ram reasons) I will need to install things like wifi selector, keyboard language indicator and al that right? Would it be easier to install Ubuntu and strip it (including unity/gnome and all that)? I just need browser, wifi, python and a 'usable' system on the low resources

Thanks

>> No.51072542

How do I install Windows in part with ubuntu? I already have ubuntu 14 LTS on my laptop right now, but no windows. I need windows for some of my classes. Thank you.

>> No.51072631

>>51071997
I did not. Should I?

>> No.51072667

>>51072631
If you're not using something which generates by itself then yes, that is why it was suggested to you. Alternatively, you could do your own research, find out if or why you might need it.

>> No.51072694

>>51072667
fair enough, I'll try to lurk more

>> No.51072807

So I need Ubuntu 14 for an assignment, do I just reformat my shit and get 2 boot partitions, or can I use Ubuntu from a USB stick?

I'm thinking of setting up my laptop again anyways, but I'm kind of still wrapping up the loose ends from my bachelor thesis with it, so I'd rather not wipe it just now.

>> No.51072818
File: 668 B, 41x38, icon.png [View same] [iqdb] [saucenao] [google] [report]
51072818

So for some reason, I have this strange black square on top of the icons on window titlebars. It goes away when I hover over the icons.

Does anyone know how to fix this and remove the silly black square ? It's kinda ugly.

>> No.51072857

>>51072807
>So I need Ubuntu 14 for an assignment
What kind of assignment?
Anyway, I'd probably just use a VM.

>> No.51072930

>>51072857
Mobile Systems Engineering at University.
They're using ROS Indigo Igloo for some robotics programming.

It really feels kind of awkward that I did my bachelor in computer science without ever using Ubuntu, so I really have no idea what I'm doing. Most things I've heard from but never actually used myself.

>> No.51073028

>>51072542
Keep a live image of ubuntu handy, install windows on an empty partition, boot into live image and fix grub.

>> No.51073031

>>51072930
I was in your position 2 years ago:

If I were you I'd just dualboot Ubuntu. The recommended version on the ROS website.
Those ROS package are so fucking fragile they break on any driver/architecture/virtualisation/whatever inconsistency they can find.
The system is okay once you get the hang of it, but the OS support is really shit

>> No.51073041

>>51072930
I would avoid dual-booting unless you know what you are doing and have the time to set it up properly. You can run it live from a flash drive but you won't be able to keep any thing installed. You can install Ubuntu on a flash drive, but that's slow as shit. I'd recommend you set up a VM and install Ubuntu to that.

>> No.51073078

>>51073041
>unless you know what you are doing and have the time to set it up properly
Why would it be difficult?

- write image to usb
- select usb as boot device
- create empty partition from windows
- install ubuntu

It is really that simple and keeps it contained, after the project he can just wipe the partition and merge it into his windows partition

>> No.51073116

>>51073078
can I set up a partition without formatting the entire hard drive, though?

>> No.51073400

>>51073116
Yes if you have unallocated space or you have free space on your last partition you can shrink it and format the created free space.
https://help.ubuntu.com/community/HowtoResizeWindowsPartitions

>> No.51073519

>>51071733
What the terminal told me
http://pastebin.com/BujFjcdi

>> No.51073615

Well, it's been a good run, but I'm slinking back to Windows 7. Linux is really nice to work with, but it seems to be a solution to problems I don't really have.

>> No.51073638

>>51073615
lol ok see you fam

>> No.51073647

>>51073638
bye bb ilu

>> No.51073666

>>51073519
fixed it.

Just delete the gamefiles and re-download the installer.

>> No.51074150
File: 69 KB, 700x394, ubuntu-1510.jpg [View same] [iqdb] [saucenao] [google] [report]
51074150

>upgraded Ubuntu 14.04 to 14.10, then to 15.10 on the Mighty Day of the Werewolf
>everything worked just fine
>then I reinstalled 14.04 a week later (it wasn't the fault of 15.10 - long story)
>ok, then upgrade again, I want new stuff
>the first upgrade dies and fuck my shit up
>whatthefuckjusthappened.png

Now I'm using 14.04 again and fighting the urge not to try the upgrad again...
But I don't want to reinstall everything if the process dies again.

Funny thing is, I have no idea why the upgrade failed.
The terminal just said something like "Well, it failed fam".

>> No.51074156

Yo, I just installed arch linux.

According to the beginner thread, I made the fstab for my primary install drive. How do I make the rest of them automount?

Commands if I were to mount external drives manually:

>mount /dev/sdb /mnt/int
>mount /dev/sdc /mnt/ext

I also have a usb drive connected. Come to think of it, how do I make it so that everything connected automounts?

>> No.51074187
File: 100 KB, 900x500, werewolf_by_srdunko-d5io4w1.jpg [View same] [iqdb] [saucenao] [google] [report]
51074187

>>51074150

Also: is there a safer / easier way to upgrade Ubuntu?

>> No.51074195

>>51074150
>just said something like
Cool story.

>> No.51074208

>>51074156
udevil

>> No.51074210

>>51074195

I was so angry that I just turned off the pc and reinstalled 14.04.

Also I'm obviously a Linux pleb.

>> No.51074227

>>51074150
Ubuntu:15.10
Resto Worgen

>> No.51074255

>>51074210
It's not that you're a pleb but it's pretty hard to give you any kind of help or information with "something like".

>> No.51074282

>>51074255
>It's not that you're a pleb but it's pretty hard to give you any kind of help or information with "something like".

Ok, I absolutely understand, you're right.

What about this: >>51074187
>Also: is there a safer / easier way to upgrade Ubuntu?

>> No.51074691

I just installed a firefox css which omits the search bar. How am I supposed to use the private browse mode? F6 won't get me to the url bar.

>> No.51075051

>>51074691

uninstall the css then?

>> No.51075072

>>51074691
use vimperator, it's probably what your css was made for.

>> No.51075414 [DELETED] 

>brs winning
uhmmmmmmmmmm gotards??????

>> No.51075804

can i have the router dns point to a computer on the network?

trying to setup fancy subdomain redirects for the inhouse server, if i manually setup the DNS server everything works like i want, not asking aobut that, im just not setting up every computer to read the dns like that.

but will the network go fucky since the dns server is on the local network?

or will dhcp issue the IP (well ubuntu asks for a static ip) then ask for the dns info?

>> No.51075865

>>51075804
I dunno, can you?

>> No.51075916

>>51075865
technically i can set it

but will that cause some black hole asking for DNS off a server on the network rather than outside the network

>> No.51075926

>>51075804
You have to setup your DHCP server to distribute the DNS server's address to the clients. That would be the easiest way.

>> No.51076002

Can somebody recommend a good backup program for linux? Doesn't matter if graphical or console interface, but it should be able to do incremental backups. Better yet, it should be effective, only copying as much data as needed to keep the backup up to date. Any suggestions?

>> No.51076009
File: 427 KB, 1280x1024, dmr_screenshot.gif [View same] [iqdb] [saucenao] [google] [report]
51076009

Dennis Ritchie used windows. Why don't you?

>> No.51076036

>>51070638
#!++ is a one-man show. Bunsen is made by the #! community, and thus has more active development. I'd recommend it over arch, whith the note that pretty much everything is done via right-click menu. Also remove libreoffice & autoremove. It'll put you at around or sub 2GB, depending on what all you selected for initial config.

>> No.51076051

>>51076002
rsync -avh --delete /home/faggot /mnt/partitionA/backup/

put it in a script, set crontab to execute the script daily

https://www.linux.com/learn/tutorials/836851-how-to-backup-files-in-linux-with-the-command-line

>> No.51076100

>>51075926
so when i configure a DNS in the router, im not "setting the DNS on the router" but sending that variable to the computer to use?

i dont feel like setting up a secondary dhcp server

>> No.51076109

>>51066823
I tried most DEs in VMs before and XFCE was the one I liked the most

>> No.51076271

>>51076100
Just to be clear: You have a router that connects your network to the internet, but you want it to redirect all queries to local-domain.com to a specific computer? Or did I completely misunderstand you?

>> No.51076309

>>51076051
Okay thanks, I'll look into this.

>> No.51076335

>>51074282

bump

>> No.51076511

>>51076271
yup

basically trying to setup intranet.ourcompany.com without over complicating things

the server box works, i can manually configure the DNS in windows and it works like i want it to.

But i'd rather the router tell everyone the DNS, rather than me do that or setup a hosts on every computer.

trying to make it super easy for the boss to show shit off in the conference room, its obnoxious when he brings me in while im developing (cause local on laptop), and hes really tech illiterate so the eaiser the better.

i just dont want to experiment then hear him bitch the internet was down for an hour, i just want to know its going to work when i do it.

it would be eaiser if i was just fucking around at home but im not.

>> No.51076682

does it matter if when I writing a path in terminal to a folder, if end it with / or just leave it be
like ~/test vs ~/test/

>> No.51076725

>>51076682
Depends on what you try to do

>> No.51076802

>>51076725
whatever, copy, move, rsync

>> No.51076836

>>51076511
Ok, then your router already acts as a DNS server but it just pushes all queries out to the internet. So you have two options:

a) if your router is configurable enough, you add a new rule to forward all queries to intranet.ourcompany.com to the specific machine while pushing all other queries out to the internet. Be aware of rule priorities.

b) you let the machine be the main DNS server in your network, then you have to disable the router's built-in DNS server and tell its built-in DHCP server (which I assume it has) to distribute that new server's IP address to the clients. Make sure though, that your new DNS server redirects all queries it can't answer by itself to some other server on the internet.

>> No.51076845

>>51076802
for move, copy, cd id doenst matter.

Get used to use tab for autocompletion.

>> No.51076873

>>51076802
Doesn't matter:
cp -r ~/test /tmp
cp -r ~/test/ tmp
Does matter:
cp -r ~/test/* /tmp
cp -r ~/test* /tmp

Or if you try to do String-matching with paths, it also matters.

>> No.51076955

Hello friends. Posting this from an Ubuntu 14 live USB as my elementary OS just crashed yesterday and the XServer doesn't start or fails to start or some shit. I just get a black screen when I boot into it and I can tty the terminal and see all my files are there, but no GUI. I spent like 4 hours trying to figure out how to fix it and restore whatever it was but I'm now thinking I'm just gonna nuke it from space and install Ubuntu.

So: how bad is Ubuntu? I know it's very pleb but that's all I really want. I know RMS hates it because of the search bar or something and Canonical are unfreedoms. So far everything looks great and fine.

>> No.51077016

>>51076955
ubuntu is fine if you are fine with it, its very polished and new version came last week, though no real changes

>> No.51077042

>>51074150

I'm >>51076955 and when I booted 15 just before it came up with all the windows fucked up, nothing had any minimise or close buttons and the launcher bar or bar at the top wasn't visible.

>> No.51077060

>>51076955
Ubanto is fine, google how to remove the amazon search thing if you fear muh botnet.

If you dislike unity, try out one of the *buntu derivatives.

>> No.51077099

>>51077060
>google how to remove the amazon search thing if you fear muh botnet.

Yeah I wondered what the fuck that was doing there

>> No.51077121

>>51077060
>if you fear muh botnet.
On top of that it also is a pretty stupid function - when you search for programs or files in your computer, how exactly would amazon help with any of that?

>> No.51077166

>>51077060
I thought its no longer implemented in unity

>> No.51077179

>>51076836
alright thanks ill look into it

and yup the box already loads googles dns for other queries

>> No.51077191

new thread >>51077177
new thread >>51077177
new thread >>51077177

>> No.51077216

>>51076009
Ritchie used Windows as a dumb terminal to connect to a Plan9 system.

All Windows is good for is a dumb terminal heh

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
reCAPTCHA
Action